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Hierarchical Data Transformation Guide

Hierarchical data transformation
Use the Hierarchical Data stage to create powerful hierarchical transformations,
parse and compose JSON/XML data, and invoke REST web services with high
performance and scalability.
Many industries have standardized on Extensible Markup Language (XML) as the
mechanism to use to exchange information between organizations. With the
broader acceptance and use of these standards, companies have increasingly
looked to XML to also satisfy requirements for the exchange of information
between different IT units within their organization. The business projects for
which XML has been adopted have generated specific requirements for IT. In some
cases, the data volume that is represented in an XML document is minimal. For
example, the data might represent a single transaction, but it might have many
layers of hierarchical complexity. Other projects require that multi-gigabyte files
with relatively simple XML schemas be transformed into a new format that
prescribes to an industry standard. When the data volume and complex hierarchy
requirements meet, they often present their own challenges to traditional IT tools.
The Hierarchical Data stage includes capabilities that easily manage the design and
processing requirements presented by the most challenging XML sources. The IT
developer can leverage the schema library manager to register the XML metadata
in its native form. This metadata forms the basis which guide the design activities.
The Hierarchical Data stage uses an integrated user interface component called the
assembly editor to facilitate the transformation of XML data from hierarchical to
relational or other hierarchical formats, or from relational to hierarchical formats.
After the logic is constructed, the job runtime leverages unique components that
provide various forms of parallelism that are built specifically for hierarchical data
formats, such XML. With these mechanisms IBM® InfoSphere® DataStage® scales to
meet very high volumes and manage system resources efficiently.

Choosing an XML solution
InfoSphere DataStage provides two XML solutions: the XML pack and the
Hierarchical Data stage. The XML pack, which includes the XML Input, XML
Output, and XML Transformer stages, is useful if you have already made an
investment in using this technology or if you want to perform only very simple
transformations that do not involve a large amount of data. The Hierarchical Data
stage the best choice if you have not yet created an XML solution and want
perform complex transformations on large amounts of data.

Schema management
Use the Schema Library Manager to import schemas into the metadata repository
and to organize them into libraries that can be shared across all DataStage projects.
Before you can use the Hierarchical Data stage to produce or consume data, you
must import the XML schemas that describe the data into the metadata repository.
To import the schemas, you use the Schema Library Manager, which is available
from the IBM InfoSphere DataStage and QualityStage® Designer via the menu
choice Import > Schema Library Manager.
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After you import a schema, you can browse the type structure that the schema
defines. You use these types to define the processing in the Hierarchical Data stage.
The schemas that you import are available for use with any data. To use a schema
with specific data, you bind the physical location of the data to the schema. For
example, to read an XML file, you provide a path to the XML file and select the
schema for the data that the file contains. When you work with XML data, you
perform the binding when you configure the XML Parser or XML Composer step
in an assembly.
You can add related schemas to the same library. Schemas that are in the same
library can refer to each other. For example, one XML schema can use an XML
include element or an import element to refer to another schema that is in the
same library. Schemas that are in one library cannot refer to external schemas or to
schemas that are in another library.
When you create a library, you specify a unique name for the library and an
optional category name. Library names must be unique across all categories.
Organizing libraries into categories ensures that you can later locate a specific
library.
After you add schemas to a library, the library is automatically validated to
determine if the schemas contain any errors. If the validation is successful, the
library contains all of the element and type definitions from the schemas. If the
library is invalid, you are notified that there are errors. To view the list of errors,
click Validate. Whenever you modify a schema, delete a schema from the library,
or add a new schema to the library the library is automatically re-validated.
Schemas are used only at design time, not at runtime. Therefore, modifying a
schema or deleting a schema from a library has no effect on existing jobs that use
the schema.
If you modify a schema that is already being used by a job, the schema
modifications are not automatically passed on to the job. If you want to apply a
modified schema to an Hierarchical Data stage, you must edit the Hierarchical
Data stage to retrieve the modified schema.
Within a library, you cannot repeat the same type definition; however, two
different libraries can have the same type definition. Having the same type
definition in two different libraries is useful if you want to have two versions of
the same type definition.

Opening the Schema Library Manager
You use the Schema Library Manager to import the schemas to use in jobs that
include the Hierarchical Data stage.

About this task
You can open the Schema Library Manager from IBM InfoSphere DataStage and
QualityStage Designer or from the Libraries tab, which is available from the
Assembly Editor.

Procedure
Do one of the following:
v From the InfoSphere DataStage and QualityStage Designer, choose Import >
Schema Library Manager.
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v From the Assembly Editor, click the Libraries tab.

Working with libraries and resources
Use the Schema Library Manager to import resources, such as XML schemas, and
to create and manage libraries of resources.
Use the istool command line to transfer contract libraries between metadata
repositories of IBM InfoSphere Information Server. Libraries are stored in the
metadata repository and are available for use in any job that uses the Hierarchical
Data stage. In the metadata repository, a contract library is represented by the
library name, followed by the extension .cl. When you work with multiple
installations of InfoSphere Information Server, you might want to transfer a
contract library from one installation to another installation, for example, from a
test environment to a production environment.
For more information about exporting and importing common metadata assets by
using the command line, see http://publib.boulder.ibm.com/infocenter/iisinfsv/
v8r7/topic/com.ibm.swg.im.iis.iisinfsv.assetint.doc/topics/pdrassets.html.
Table 1. Working with libraries
Task

Action

Creating libraries

1. Click New Library.
2. Enter a name.
3. Enter a description and the name of a
new or existing category.

Refreshing library lists

Click the Refresh icon at the top of the
Libraries pane.

Removing libraries

Select a library, and click Remove.

Opening libraries

Select a library, and click Open. You can
open a library only if it has been validated
and has no errors. The Types tab displays a
list of namespaces and the belonging types.
To view the schema for a type, select a type
from the Types tab. To view the facets and
attributes for a node, select the node from
the Schema tab.

Recategorizing libraries

To move a library to a different category,
edit the Category field in the library details.

Table 2. Working with resources
Task

Action

Importing resources

1. Select the name of a library, and click Import new
resource.
2. Select the file to import, and click Open. You can
select a single .xsd file or a .zip file that contains
multiple .xsd files.
3. After importing all of the required resources into the
library, the library is automatically validated. If the
library is valid, a green checkmark displays beside its
name. If it is not valid, a red exclamation point
displays beside its name.
4. If the library is invalid, click Validate to display the
list of errors.
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Table 2. Working with resources (continued)
Task

Action

Displaying the types in schemas

Double-click the name of a library to display the Types
and Schema tabs. On the Types tab, click the plus sign
beside a namespace to display a list of types that belong
to the namespace. Click a type to display the schema for
the type on the Schemas tab. Browsing the types and
their structures is useful for a variety of reasons. You can
determine which type corresponds to a specific
document instance by matching the top-level element
name with the type name. You can determine which
pieces of information are optional but could be included
in similar documents. You can view the characteristics of
the data, so that you can understand how to set
transformation options.

Exporting resources

Select the resource, and then click Export to save a copy
of the resource on the local computer.

Updating resources

If you modify a resource and want to update it in the
library, select the resource, and then click Replace
Selected Resource. The updated resource has no effect
on jobs that used the earlier version of the resource. To
use the updated version in an existing job, you must edit
the assembly.

Deleting resources

Click the Delete icon that displays beside the resource
name. Deleting a resource has no effect on existing jobs
that use the resource.

Displaying the resources in a library

Click the name of a library. For the Hierarchical Data
stage, the Resources view displays a file location and a
namespace for each schema in the library. Click the name
of a schema to display additional details about each
schema.

Editing resource details

Only the File Location and Description fields can be
updated. After you update the file location, the library is
automatically validated.

Related information:
http://publib.boulder.ibm.com/infocenter/iisinfsv/v8r7/topic/
com.ibm.swg.im.iis.iisinfsv.assetint.doc/topics/pdr_cli_export.html
http://publib.boulder.ibm.com/infocenter/iisinfsv/v8r7/topic/
com.ibm.swg.im.iis.iisinfsv.assetint.doc/topics/pdr_cli_import.html

Creating an example schema library
Create an example of a library and import the schemas.

About this task
The library can have more than one schema. The schemas can be interdependent. If
the schemas are interdependent and if you import only one schema, the library
displays an error. To ensure that the library is valid you must import the
dependent schema.
You can download the files, department.xsd and definition.xsd using the link,
http://www.ibm.com/support/docview.wss?uid=swg27019894. Open the xml
examples zip file and select the folder, example_library to download these files.

Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer.
2. Choose Import > Schema Library Manager.
3. On the Libraries tab, click New Library.
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4. In the New Contract Library window, enter Example_library for the name of
the library.
5. Click OK to save the library.
6. Select the library that you created, Example_library, and then click Import
New Resource from the Resource View.
7. Select the schema, department.xsd.
8. The File Upload Complete window is displayed.
9. Click OK.
The library is not valid and the error message, “One or more resources failed
validation. Click Validate to view the errors” is displayed.
10. Click Validate to view the actual error. Following figure shows the error.
The error indicates that the schema department.xsd has a dependency on

another schema, definition.xsd. The schema department.xsd contains an
element named dept_id that has the type dept_id1. Because the type dept_id1
is defined in the schema definition.xsd, you need to import it, too.
11. Import definition.xsd and click Validate. The error still exists because the file
location for definition.xsd is incorrect.
12. Perform the following steps to specify the file location:
a. Open department.xsd in a notepad or a wordpad to get the schema
location. The department.xsd is shown below:
<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns="http://www.ibm.com/departments"
xmlns:xs="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://www.ibm.com/departments">
<xs:include schemaLocation="http://ibm.com/definitions/definition.xsd"/>
<xs:element name="Info">
<xs:complexType>
<xs:sequence>
<xs:element name="dept_id" type="dept_id1"/>
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:schema>

b. Copy the schema location, http://ibm.com/definitions/definition.xsd
from the include statement.
c. In the Resources View, select definition.xsd and paste the schema
location below in the File Location field as shown in the following figure.
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13. Click on any other field to refresh the view. The error gets resolved and the
library becomes valid. The following figure shows the resolved view.

14. Click OK to close the Libraries window.

Using the Hierarchical Data stage
Use the Hierarchical Data stage to parse, compose, and transform XML data.
The Hierarchical Data stage is available in the Real Time section of the palette in
the IBM InfoSphere DataStage and QualityStage Designer. You can use the
Hierarchical Data stage in parallel jobs not in server jobs. In parallel jobs, the
Hierarchical Data stage can have multiple input and output links. You can use the
Hierarchical Data stage as source stage, which has only output links; a middle
stage, which has both input and output links; or a target stage, which has only
input links.
The Hierarchical Data stage page displays a preview window that shows the
Hierarchical Data stage and any input or output links. The page displays a set of
runtime properties that you can configure, and the Edit assembly button. When
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you select the stage in the preview window and then click Edit assembly, the
Assembly Editor opens. You use the Assembly Editor to create the assembly for the
Hierarchical Data stage. When you close the Assembly Editor, the assembly is
saved as part of the stage.
To create the columns on an input or output link, click the link in the preview
window to display the links view. Then click the Columns tab and create the
columns on the link.

Adding a Hierarchical Data stage to a job
Use the InfoSphere DataStage and QualityStage Designer client to add a
Hierarchical Data stage to a job.

Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the Real Time section of the palette, and drag Hierarchical Data stage to
the canvas.
4. Open the File section of the palette, and drag Sequential File stage to the
canvas. Position these stages to the right of the Hierarchical Data stage
5. Create a link from the Hierarchical Data stage to each sequential file stage.
6. Modify the default name of the stage and the link
Note: When designing a DataStage job with Hierarchical Data stage, decide the
name of the DataStage input and output link before configuring the mapping
within the Hierarchical Data stage. If you try to rename the input or output
link, then it invalidates all the configured mapping within the Hierarchical Data
stage. Similarly, when copying an Hierarchical Data stage, you must
reconfigure the mapping for the copied Hierarchical Data stage.
7. Choose File > Save, and name the job.

Configuring runtime properties for the Hierarchical Data stage
To modify how the Hierarchical Data stage runs in the job, configure these
properties.
Heap Size (MB)
Enter the maximum heap size, in MB, for the Java™ Virtual Machine. This
property corresponds to the -Xmx command line option. Specify at least
256 MB. Consider specifying a larger heap size if the assembly includes a
large schema and large documents.
Stack Size (KB)
Enter the size of the stack, in KB, for the Java Virtual Machine. This
property corresponds to the -Xss command line option.
Other Options
Enter additional command line arguments to the Java Virtual Machine. For
example, to set a system property, enter DSystemProperty=Value.
Limit Output Rows
Enter Yes for Limit output rows, and then enter a value for Maximum
output rows. Limiting output rows is useful when you are debugging a job
and do not want to wait for the results of the entire job.

Hierarchical data
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Maximum Output Rows
Enter Yes for Limit output rows, and then enter a value for Maximum
output rows. Output rows are calculated cumulatively across all output
links. The Hierarchical Data stage stops processing after generating the
maximum number of output rows.
Enable logging
Enter Yes to enable logging and set the log level to Warning. By default,
logging is not enabled. Enabling logging affects performance.
Log level
Specify the level of detail to log. Choosing a high level of logging affects
performance.
Assembly Date
The date that the assembly was last saved.

The assembly
To configure the Hierarchical Data stage, you create an assembly.
An assembly is a series of steps that perform enrichments and transformations on
hierarchical data. By default, a new assembly always contains an assembly
Overview, an Input step, and an Output step. Between the Input step and the
Output step, you insert additional steps that parse, compose, or transform the data
from the previous step.
The assembly Overview provides creation and modification information about the
assembly and includes an optional field for the assembly description. This field
documents the purpose of the assembly and is helpful when you or others later
need to modify it.
The Input step transforms the relational structure – the links and columns – into a
hierarchical structure. In the hierarchical data structure, an input link is
transformed into a list item, and each column on the link is transformed into a
child content item of that list. The step Output schema displays the schema tree
that represents this hierarchical data structure. This data structure is passed to the
next step in the assembly, where it becomes the step Input. At each step, the step
Input is modified by the action of the step. For example, if you use an Aggregate
step to perform a calculation, the result of the calculation is added as a branch to
the step Output. Additions to the step Output are highlighted in the schema tree.
The Output step receives the results of all of the previous step transformations. In
the Output step, you map the hierarchical data structure back to a relational data
structure. That is, you map schema items to output links and to the columns on
those links.

Overview
The Overview of an assembly provides creation and modification information
about the assembly and includes an optional description field that you can modify.
On the Overview, you can enter an optional description for the assembly. This field
documents the purpose of the assembly and is helpful when you or others later
need to modify the assembly.
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Input step
The Input step describes how the links and columns of a relational data structure
are represented as a hierarchical data structure.
The Configuration tab of the Input step provides two views: a Links view and a
Tree view.
The Links view displays the same column definition table that you see in on the
Columns tab of a stage. From the Links view, you can edit the column definitions
and then view the result in the step Output. When you save the assembly, the
edited column definitions are saved in the job properties.
The Tree view displays the relational links structure after it has been transformed
into a hierarchical structure. The root element is Top, and it contains the entire
input data. Each input link is transformed into a child list item of the InputLinks
node. Each column is transformed into a content item and assigned a primitive
type. For example, a column that is assigned the SQL Varchar type is transformed
into an a content item that has the String data type.
When waves are used in a job that uses the Hierarchical Data stage, each wave is a
new item in the Top list, and each item contains all of the data that belongs to a
particular wave. When waves are not used, the Top list always contains a single
item that contains all of the data that passed through the stage.
The step Output of the Input step becomes the step Input for the next step in the
assembly. This process of taking the transformed data structure from the previous
step; transforming, parsing, or composing data; and then producing a modified
data structure for the next step continues through each step in the assembly. At
each step, you can look at the step Input, which displays the result of the previous
step, and the step Output, which displays the output results of the current step, to
assess the changes that each step makes to the data structure.
Note that not all assemblies use an Input step. For example, if the Hierarchical
Data stage is used as a source stage in a job, there are no input links and the Input
step is empty. Even if the Input step is empty, it remains a permanent part of an
assembly; you cannot remove it. Parallel jobs can receive input from multiple input
links, while server jobs can only receive input from a single input link.

Output step
The Output step describes how the hierarchical data structure is mapped to a
relational data structure.
The Configuration tab of the Output step provides two windows: Output and
Mappings.
In the Output window, you can display two views: a Links view and a Tree view.
The Links view displays the same column definition table that you see on the
Columns tab of a stage. From the Links view, you can edit the column definitions
and then view the result in the step Output. When you save the assembly, the
edited column definitions are saved in the job properties.
OK
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The Tree view displays the relational links structure after it has been transformed
into a hierarchical structure. The root element is Top, and it contains the entire
output data. Each output link is transformed into a child list item of the
OutputLinks node. Each column is transformed into a content item and assigned a
primitive type. For example, a column that is assigned the SQL Varchar type is
transformed into an a content item that has the String data type.
In the Mappings window, you map the hierarchical data structure to a relational
data structure.
You must map a source item to every item that is in the target structure and that
you want to include in the output. Start at the top of the target structure and map
items from the top down. Start by mapping target list nodes to source lists nodes.
As soon as you map a target list node, the target content nodes of that list are
available for mapping. Map the target content nodes of each mapped list node to
source content nodes.
In the Mappings window, you can delete multiple columns from the Mappings
table by selecting the columns and clicking Delete button from the keyboard.
For more information about mapping, see Mapping data.
Not all assemblies use an Output step. For example, if the Hierarchical Data stage
is used as a target stage in a job and doesn't have any output links, the Output
step is empty. Even if the Output step is empty, it is a permanent part of an
assembly; you cannot remove it.

Assembly Editor
Use the Assembly Editor to create an assembly.
Each Hierarchical Data stage that you add to a job requires an assembly. An
assembly defines a series of steps that parse, compose, and transform hierarchical
data.
The Assembly Editor has three panes: the Assembly Outline, the Step pane, and
the step Input/step Output pane. The Assembly Outline lists the names of the
assembly steps in the order in which they are performed.
To add a step to the assembly, you click the Palette button. Then you drag a step
from the palette to the location in the assembly where you want that step to be
performed or double-click a step to add it below the currently selected step in the
assembly. Steps are available for a variety of transformations, including sorting,
aggregating, joining, and pivoting.
When you click the name of a step in the Assembly Outline, the step displays in
the Step pane. Each step has three tabs: Configuration, Information, and Test
Data. The Configuration tab always contains mandatory fields that you must
complete to configure the step. The step Information tab is similar to the assembly
Overview; it displays creation and modification information, as well as optional
fields that you can use to document the name and purpose of the step. You use the
Test Data tab when you test the assembly. Testing is optional but extremely useful.
By testing, you can see the incremental change that each step makes. You can
evaluate how the step transformations affect the data and confirm that the
assembly is performing exactly the transformation that you want.

10

Hierarchical Data Transformation Guide

As you configure each step in the assembly, the Assembly Editor monitors your
work and maintains a running total of the issues that you need to address. An
issue is not necessarily an error. In many cases, an issue describes a specific field
that requires input or a item that requires mapping. To see all of the issues in the
assembly, click View All. The issues display, sorted by step. For each step, a handy
link is available, so that you can quickly jump to the step and start addressing the
issues. The issues are also displayed on the Configuration tab of the step that has
issues.
The step Input/step Output pane displays the step input and the step output as
schema trees. The step Input is the result of the enrichments and transformations
that were made by all of the previous steps in the assembly. The step Output
describes the output of the current step. For example, if the step adds a new node
to the data structure, the step Output highlights the new node. Within the
assembly, the output of one step is always the input for the next step in the
outline.
On the Output step, you can right-click on an item to display a menu of actions
that you can perform on that step. You can rename items so that they have more
meaningful names, delete unnecessary sub-trees, and perform other modifications.

Opening the Assembly Editor
After you add the Hierarchical Data stage to a job, use the Assembly Editor to
create the assembly.

Procedure
1. From the Real Time section of the palette in the IBM InfoSphere DataStage and
QualityStage Designer, drag to add an Hierarchical Data stage to a job.
2. Double-click the Hierarchical Data stage to open the stage editor.
3. Click Edit assembly to display the Assembly Editor.
Note: The Edit assembly button provides the only way to open the Assembly
Editor; there is no menu choice for the Assembly Editor.

What to do next
After you finish working on the assembly, close the Assembly Editor to return to
the Hierarchical Data stage editor and to the job. If you plan to work for an
extended period of time on an assembly, be sure to close the Assembly Editor
occasionally, so that your changes are saved.

Modifying items in the step Output
Rename or drop an item, change a list item into a group item, or change a group
item into a list item.

About this task
Each step in an assembly transforms or enriches the schema and then presents the
result of all of the changes in the step Output. You can make minor modifications
to items in the step Output. These modifications are passed to the next step in the
assembly as part of the step Input.

Hierarchical data
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Procedure
Select an item in the step Output, and then right-click to display a menu of choices
that are appropriate for the selected item.
Table 3. Item modifications
Choice

Action

Revert

Removes all modifications from the selected item.

Rename

Changes the name of the item. The previous item name displays when
you hover over the new item name.

Drop

Removes an item and all of its children.

Group-to-List

Changes a group item to a list item. Creates a list item that has the
selected list item as the only element. This option is available only for an
item that has children but that is not a list item. This option is useful
when a list transformation such as a join or a union should be conducted
on an optional group. When the group exists, it will have a list size of 1.
When the group does not exist, it will be an empty list.

List-to-Group

Changes the list item to a group item by taking only the first element of
the list. This option is available only for a list item. This action is useful
when a list item contains only one child item, and you want to remove
the complexity of dealing with the list. If the list contains more than one
instance, however, only the first instance is selected and the rest of the
instances are ignored.

Testing assemblies
As you work on an assembly, you can use randomly generated data or XML source
data to test each step and view the output data.

About this task
Testing the assembly allows you to run the assembly in design mode without
compiling and running the job. Unlike a job, which you can test only when it is
complete and has no errors, you can test an assembly at any time during the
design process. Even if the assembly is incomplete and has errors, you can test the
steps in the assembly that do not have errors.
To test an assembly, you provide source data or use randomly generated data.
Then after you run the test, you can view the output from each step and see the
log messages that the stage would produce if it were run as part of the job.
You can test an assembly as soon as you add a step that is after the Input step and
that does not contain errors. Testing an assembly processes the data in the Input
step and in all of the subsequent steps. The test stops if it reaches a step that
contains errors. Incrementally test an assembly to determine if the steps in the
assembly are performing the transformations that you expect. If a step is not
performing as you expect, you can modify that step and then retest the assembly.
When you are sure that the assembly is working just as you want it to, you are
ready to run the job.
To test the assembly, you must provide test input data to the XML Parser step. If
the XML Parser step obtains its data from an upstream stage, you do not need to
provide test data. For any other case, you must either generate random test data or
provide actual source data to use in the test. If you do not provide input data, the
test automatically uses randomly generated data.

Procedure
1. To provide input test data for the Input step, click the Test Data tab and then
do one of the following:
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v In the Input Links field, select the link that provides the real source data to
use.
v Click Generate Random Data to produce sample data to use in the test.
2. To provide input test data for the XML Parser step, click the Test Data tab and
then do one of the following:
v In the Disk Input Test Data window, select the link that provides the real
source data to use.
v Click Generate Random Data to produce sample data to use in the test.
3. Above the Test Data tab, click Test Assembly and then perform the following
steps:
a. Optional: If you created job parameters for the job, enter the values for the
parameters in the Test Values column of the Job Parameter Values table.
b. Click Run Test.
The Test Execution Log displays messages that describe the test.
4. Open each step that was included in the test. The Downstream Output Test
Data shows the data that the step produces for the next step. The Disk Output
Test Data shows the data that will be sent to an external resource.

Parsing large schemas
To parse a schema that has over 2,000 nodes, you use configure multiple XML
Parser steps.
When you configure an XML Parser step and select a schema that has over 2,000
nodes, the first 2,000 nodes are available to be parsed. However, the remaining
nodes are automatically put into a chunk. To parse the chunk, you add a second
XML Parser step to the assembly and select String set for the XML Source. Then
select the chunk as the String set source item. On the Document Root tab, select
the global element that corresponds to the chunked sub-tree. If the global element
does not exist, modify the schema by creating global elements from in-line
elements.

Icons in the schema tree
The tables describe the icons that represent the types of items and the state of
specific items in the schema tree.
The following table shows the icons the represent the types of items in the schema
tree.
Table 4. Icons that represent types in the schema tree
Icon

Name

Description

All

A complex type. The child
elements can appear 0 or 1
time, in any order, in the
data.

Any simple type

A simple type. The type can
contain the data for any
concrete simple type.

Base-64 binary

A binary type. The type
contains base-64-encoded
data.
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Table 4. Icons that represent types in the schema tree (continued)
Icon
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Name

Description

Boolean

A logical type. The legal
values are true or 1 and false
or 0.

Byte

Numeric data that is in the
range from -128 to 127.

Byte string

Unparsed binary data.

Choice

A complex type. Only one
child can appear in the data.
If any child is optional, the
type can be empty.

Date

A date type that is in the
format CCYY-M-DD. A
trailing time zone is optional.

Date time

A datetime type that is in the
format CCYY-MMDDThh:mm;ss.sss. A trailing
time zone is optional.

Decimal

An arbitrary precision
decimal number.

Double

Double-precision 64-bit
floating-point number.

Duration

A time period that is in the
format PnYnMnDTnHnMnS,
where n is one or more
digits.

Empty

A simple type that does not
contain any content.

Float

A single-precision 32-bit
floating-point number.

Hex binary

A simple binary type that
contains
hexadecimal-encoded data.

ID

A unique identifier.

ID reference

A reference to a unique
identifier.

Integer

Numeric data that is in the
range from -2147483648 to
2147483647

List

An array of a simple type.

List all

An array of the complex type
all.

List choice

An array of the complex type
choice.

List sequence

An array of the complex type
sequence.

Table 4. Icons that represent types in the schema tree (continued)
Icon

Name

Description

Locale

The locale.

Long integer

Numeric data that is in the
range from
-9223372036854775808 to
9223372036854775807.

Name

A valid XML name. The
name starts with a letter,
underscore, or colon; and it
can contain letters,
underscores, colons,
hyphens, and periods.

Namespaces

Absolute or relative URI
references.

NCname

A non-colonized name. The
name starts with a letter or
an underscore; and it can
contain letters, underscores,
hyphens, and periods.

NMtoken

A single token that does not
contain any whitespace.

NMtokens

Multiple tokens that are
separated by whitespace.

Qname

A simple type for a qualified
name. Qualification is
optional.

Recursive XML

Recursive, unparsed XML
data.

Sequence

A complex type. The child
elements must appear in the
specified order in the data.

Short integer

Numeric data that is in the
range from -32768 to 32767.

String

A string that has unmodified
whitespace.

Time

A time type that is in the
format hh:mm;ss.sss. A
trailing timezone is optional.

Token

A string in which all
whitespace is replaced by a
space and multiple spaces
are replaced by a single
space.

Type schema

A graphical view of the
schema.

Unknown

A new or unknown type.

URI

An absolute or relative URI
reference.
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Table 4. Icons that represent types in the schema tree (continued)
Icon

Name

Description

Unparsed XML

Unparsed XML data.

The following table shows the icons that indicate the state of specific items in the
schema tree.
Table 5. Icons that indicate the state of items in the schema tree
Icon

Description
Indicates the selected item.
Indicates that the item was renamed.
Indicates that the item was removed.
Indicates that multiple actions were
performed on the item – for example,
renaming it and changing it from a group to
a list.
Indicates that the item was changed from a
group to a list or from a list to a group.
Indicates the enrichment root item – that is,
the addition to the schema that occurs as a
result of the current step.
Indicates that the enrichment root item was
renamed.
Indicates that the enrichment root item was
removed.
Indicates that multiple actions were
performed on the enrichment root item.
Indicates that the enrichment root item was
changed from a group to a list or from a list
to a group.

Details Inspector
The Details Inspector displays information about the attributes and facets of a
selected item and about the definition of DataStage columns.
Table 6. Attributes in the Details Inspector
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Name

Description

Name

The name of the item that was selected for
inspection.

Type

The XML type of the item.

Type Name

The base type of the item.

Optional

Indicates if the item is optional. For
example, in XML, an item is optional when
it has minOccurs="0" or when it has the
attribute xs:use="optional".

List

Indicates if the item is an array.
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Table 6. Attributes in the Details Inspector (continued)
Name

Description

Recursive

Indicates if the item is recursive.

TypeName Namespace URI

The namespace URI of the type.

Item Namespace URI

The namespace URI of the item.

Type Documentation Annotation

An annotation that is defined in the XML
schema for the type or an explanation of a
created type.

Item Documentation Annotation

An annotation that is defined in the XML
schema for the item.

Nillable

Indicates if the item can have nil as its
value.

Max Occurs

The maximum times that the item can occur.

Min Occurs

The minimum times that the item can occur.

Table 7. Facets in the Details Inspector
Name

Description

Whitespace

Indicates how whitespace is handled:
preserve all whitespace, replace each
whitespace with a space, or replace all
whitespace with a single space.

Fraction Digits

The maximum number of fractional digits.

Total Digits

The maximum number of significant digits.

Max Length

The length of the value must be less than or
equal to maxLength.

Min Length

The length of the value must be greater than
or equal to minLength.

Max Exclusive

The value must be less than maxExclusive.

Min Exclusive

The value must be greater than
minExclusive.

Max Inclusive

The value must be less than or equal to
maxInclusive.

Min Inclusive

The value must be greater than or equal to
minInclusive.

Enumeration Value

The value must match one of the
enumerated values.

Length

The length of the item.

Pattern

The pattern that is defined for the item.

When you select an item in the Output schema of the Input step or when you
select an item in the Input schema of the Output step, the Details Inspector
displays information about the selected DataStage column.
Table 8. DataStage column definition information in the Details Inspector
Name

Description

Type

Indicates if the item selected represents a
link or a column.
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Table 8. DataStage column definition information in the Details Inspector (continued)
Name

Description

SQL Type

The SQL type that is defined for the column.

Key Position

Indicates if the column is defined as a key.

Extended

The extended type of the column.

Precision

The precision value defined in the column.

Scale

The scale value defined in the column.

Nullable

Indicates if the column value can be null.

Level Number

The level number defined in the column.

Display Size

The display size defined in the column.

Data Element

The data item defined in the column.

Description

The description defined in the column.

Mapping data
Understanding how to map source data to target data is key to obtaining the
results that you want when you transform hierarchical data.

Working with the mapping table
Some steps, such as the Output step and the XML Composer step, require that you
create mappings that define how to create the target nodes.
For these steps, the Mappings tab displays the mapping table. This table contains
three columns: Source, Result, and Target. The Target column displays the elements
in the target structure. The Source column contains the mapping for each mapped
element in the target structure. The Result column displays the status of the
current mapping. The table contains one row for every level in the target data
structure. While every level is shown, you only map target list nodes to source list
nodes and target content nodes to source content nodes. The mapping table does
not allow you to map a list node to a content node or to map a content node to a
list node.
Content items have a primitive value and correspond to actual values. List items
repeat in the data. Elements that have maxOccurs>1, xs:list items, and links are all
represented by list items.
You must map a source item to every required item in the target structure. Start at
the top of the target structure and map items from the top down. Start by mapping
target list nodes to source lists nodes. As soon as you map a target list node, the
target content nodes of that list are available for mapping. Map the target content
nodes of each mapped list node to source content nodes.
A list mapping defines how instances in the target list are created. For each item in
the source list, a target item is created, and the content mapping is computed in
the context of that source item. The context is defined as all of the parent items
that contain the item.
For each target node, the mapping table provides a list of valid mapping
candidates. The valid candidates are evaluated based on the target position in the
target tree, its parent mappings, and its data type. The valid candidates are than
scored and ordered based on name similarity to the target node and path.
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There are four ways to map an item. First, you select the row in the mapping table,
and then perform one of the following steps:
1. Click the down-arrow in the Source column to display a partial list of valid
mapping candidates. Then select an item from that list.
2. Click Auto Map to automatically map the source item that received the highest
mapping score. Automatic mapping is context-sensitive. If you select a list item
and then click Auto Map, the list item and all of its descendent items are
automatically mapped.
3. Click the down-arrow in the source column, and then click More to display the
entire source structure as tree. In the tree, you can select any node, even if it is
not a valid mapping candidate. If you select an invalid node, a message
displays to describe why the mapping is invalid.
To see the source structure as a list, click Switch to List View. Then select an
item to map. The list view displays a Target Similarity button. To control how
many mapping candidates display, select a target score. Only the candidates
that have a score higher than the one that you select display in the list.
4. To assign a fixed value to the target content item, click the down-arrow in the
source column, click Constant, and then enter a fixed value to map to the
target item. Note that the Constant option is not available for list items.
As you perform the mappings on the Output step, you might determine that the
target contains one or more items that you do not need. To remove an item from
the target structure, select the item, and then click the delete icon in the rightmost
column of the table. This action is similar to removing columns from the output
link.
If you decide to change a mapping, select the item and then choose a different
mapping candidate.
If you use any method other than automatic mapping to map an item, a Lock icon
displays in the first column of the table to indicate that the mapping is locked.
If you decide that you want to remove one or more mappings, select an item and
click Clear Mappings.

Determining mapping candidates
For each item in the target structure, the mapping table automatically presents a
list of valid mapping candidates.
To determine the candidates to display in the mapping candidate list and to
determine which candidate to use for the Auto Map option, the mapping
algorithm uses the following process:
1. Create a list that contains all of the valid mapping candidates. Valid candidates
are unambiguous.
2. Select only the candidates that meet the specified level of conversion accuracy.
By default, the level for conversion accuracy is lossy; candidates must have a
data type that can be converted to the target data type without creating a
possible runtime error.
3. Evaluate the similarity of the name and of the data type of the source and
target items. Assign a score to each candidate, based on the similarity of the
names and data types.
4. Select the highest scoring candidate to use for the Auto map option.
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5. Select the highest scoring candidates to present on the mapping candidate list,
which displays when you press the down-arrow on the source item in the
mapping table. By default, the mapping candidate list displays the top 5
candidates.
To change the level of conversion accuracy and the number of mapping candidates
to present on the candidate list, choose Administration > Mapping Configuration.

Mapping example
To understand why certain mapping candidates are valid or invalid, review this
example. The following figure shows the step Input. The step Input contains the
following items that are peers of each other:
v An item named documentID.
v A list named mySourceList, which contains an item named sourceChildField and
a list item named sourceChildList, which contains an item named
sourceDescendentField.
v A list named Peer-List, which contains an item named peerField.

The following figure shows the instance data that the step receives and transforms
to the target structure:
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The following is the XML data that this example uses. As you read about valid and
invalid mapping candidates, refer to this data so that you can understand how the
data values are determined:
<SourceDoc>>
<documentID>ID001</documentID>
<mySourceList>
<sourceChildField>A1</sourceChildField>
</sourceChildList>
<sourceDescendentField>A11</sourceDescendentField>
</sourceChildList>
<sourceChildList>
<sourceDescendentField>A12</sourceDescendentField>
</mySourceList>
<mySourceList>
<sourceChildField>A2</sourceChildField>
</sourceChildList>
<sourceDescendentField>A21</sourceDescendentField>
</sourceChildList>
<sourceChildList>
<sourceDescendentField>A22</sourceDescendentField>
</mySourceList>
<Peer-List>
<peerField>peer1</peerField>
</Peer-List>
<Peer-List>
<peerField>peer2</peerField>
</Peer-List>
</SourceDoc>

Hierarchical data

21

The following figure of the mapping table shows that list item mySourceList is
mapped to list item myTargetList, and all of the child items of myTargetList are
correctly mapped.

Valid mappings
List mapping determines how the items of a target list are created. During item
creation, the source list is iterated; and for each item in the source list, a new item
is created in the target list. A child list is similarly iterated in a nested loop.
Content mappings are evaluated in the context of the iteration. In other words, the
target value of an item depends on the source list item that is currently being
iterated and on the mapping .
The following mappings are valid for the example:
List mapping
For each item in mySourceList, one item in myTargetList is created.
Therefore, two myTargetList items are created for the two mySourceList
items that are in the input data.
Simple content mapping
To create the first myTargetList item, the mapping top/result/SourceDoc/
mySourceList/sourceChildField evaluates to A1. Therefore, the value of
targetField is A1. To create the second myTargetList item, the mapping
top/result/SourceDoc/mySourceList/sourceChildField evaluates to A2.
Therefore, the value of targetField is A2.
Ancestor content mapping
To create the first myTargetList item, the mapping top/result/SourceDoc/
documentID evaluates to ID001. When looking for the value of
documentID, the containment relationship is taken into account. Because
mySourceList is contained within a single document that has only a single
documentID value, the mapping is unambiguous; and the value of
targetDocumentID is ID001. The second myTargetList item has the same
containment relationship. Therefore, the mapping top/result/SourceDoc/
documentID valuates to ID001. Consequently, both target items have the
same documentID value.
Child list mapping
Valid mappings always preserve containment relationships. Therefore,
targetChildList must be mapped to a descendent list of mySourceList. Each
child list has two items because the sourceChildList has two items in the
input data.
To modify or create a containment relationship, add a transformation step,
such as an HJoin step or a Union step, before the step that contains the
mapping table.
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Invalid mappings
The mapping table prevents you from creating ambiguous, invalid mappings. An
ambiguous mapping occurs when you map an item that, when evaluated, returns
multiple values. The following mappings are invalid:
Mapping the content child of a peer list to a child content item
When iterating on the first mySourceList and trying to evaluate the
mapping top/result/SourceDoc/Peer-List/peerField, the two values peer1
and peer2 are returned. The containment relationship for the mySourceList
item does not help to resolve which value should be returned. Therefore,
the mapping is ambiguous and is not allowed.

Mapping content child of a descendent list to a child content item
When iterating on the first mySourceList and trying to evaluate the
mapping top/result/SourceDoc/sourceChildList/sourceDescendentField,
the two values A11 and A12 are returned. The containment relationship for
the mySourceList item does not help to solve which value to return
because both values are contained in the mySourceList. Therefore, this
mapping is ambiguous and it not allowed.

Mapping peer list to a child list
List mapping can be ambiguous. When iterating on the first mySourceList
and trying to evaluate the mapping top/result/SourceDoc/Peer-List, the
mapping cannot determine whether to return the first or the second
Hierarchical data
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Peer-List item. Without a containment relationship between the items of
Peer-List and mySourceList, the ambiguity cannot be resolved. Therefore,
this mapping is invalid.

The following figures show the valid choices:

Configuring how mapping candidates are determined
Configure how mapping candidates are calculated and displayed.

Procedure
1. Click Administration and then select Mapping Configuration.
2. Perform one or more of the following steps:
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v In the Strings to Use as Keys field, enter one or more strings to use to
recognize good key items. Items with names that contain one of the common
key identifiers are scored higher than other items and presented as choices in
key fields.
v In the Data Type Conversion Accuracy field, select the default conversion
accuracy to use to select the mapping candidates that display in the Source
column of the Mappings table. The choices are:
Same type
Only source items that have the same type of the target item are
presented as mapping candidates.
Lossless
Only source items that have a type that can be converted without
loss of data to the target item type are presented as mapping
candidates.
Lossy (Default) Only source items that have a type that can be converted to
the target item type without causing a possible runtime error are
presented as mapping candidates.
v Select Map optional lists to automatically map lists that are optional.
v Select Map optional primitive data types to automatically map primitive
data types that are optional.
v In the Number of mapping candidates to display field, select the number
results to display as mapping candidates.

XML Parser step
Use the XML Parser step to parse one or more documents that have the same
structure.

XML Source
For the source of the XML data, specify one of the following:
String set
Select the input schema item that contains the document string. Only items
that have the String, normalizedString, byteString, or XML data types are
available for selection.
Single file
Enter the path and file name, or click Insert Parameter and then select the
name of the parameter. The parameters that are available are those that
you previously defined in the job and the built-in macros that are in IBM
InfoSphere DataStage. Only items that have the String, normalizedString,
or byteString data types are available for selection.
File set
A file set option is used to read multiple xml files that are based on the
same xsd. Select the input schema item that will contain in runtime the
absolute paths (example, c:\test.xml) of the xml files. Only items that have
the String, normalizedString, or byteString data types are available for
selection.
Enable Filtering
Enable filtering to apply an XSLT style sheet to the document before
parsing it. The document root must reflect the document that is created
from the result of the XSLT transformation. This option is not
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recommended for large documents because the entire processing is done in
memory. For large documents, use transformation steps.

Document Root
Select the top-level element that describes the documents that you are parsing. The
types that display under the library's namespace are top-level element definitions.
Following the XML Schema standard, only top-level elements can describe
documents. The name of the element that you select must match the top-level
element name in the instance documents. For example, if you are parsing Order
documents, you select the Order element. When you select the element, you can
view its structure and verify that the structure is correct for the documents that
you want to parse.
Note: The elements from which you select the document root are from the
resources that were previously imported into the schema libraries. If you need to
import the resource that contains the document root for the XML Parser step, click
the Libraries tab and import the resource that you need. Then return to the
Assembly Editor and configure the document root.

Validation
By default, when the XML Parser step runs, it uses minimal validation, which
disables all of the validation rules and provides better performance than strict
validation does. Strict validation is initially configured so that each validation rule
is set to Fatal, and the job stops as soon as it parses the first occurrence of invalid
data. To customize validation, specify the action to perform when a violation
occurs.
For more information about validation rules, see “XML Parser validation rules.”
For an example that includes the XML Parser step, see Example 1.

XML Parser validation rules
By default, the XML Parser uses minimal validation and ignores violations. To
customize validation, specify the action to perform when a violation occurs.
The following tables describe the validation rules and the applicable actions.
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Table 9. Value validation rules
Rule

Description

Data type has an illegal
value

The value must match
the value rules for the
data type of the
corresponding item.

Actions
Ignore Type-checking and
type-conversion are not
performed. The types of the
items as they are defined by
the schema are replaced by
the String type. For
example, if the schema
includes an item named
startDate that is of type
Date, the type of that item
in the Step Output becomes
String, not Date.
Log per Occurrence; Log per
Document
Type-checking is performed.
If a type fails the check, a
log error is reported either
once for each occurrence or
once for the entire
document; however, parsing
continues. Type-conversion
is not performed. The real
types of the items in the
Step Output are replaced by
string types.
Reject

Type-checking and
type-conversion are
performed. Only invalid
values fail the invalid
document parsing. The
ParsingStatus item is added
as a new group to the Step
Output for the XML Parser
step and is set to False and
contains the corresponding
error message.

Fatal

Type-checking and
type-conversion are
performed. An invalid
value causes the job to fail.

Convert to Default
Type-checking and
type-conversion are
performed. An invalid
value is replaced with its
default value.
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Table 9. Value validation rules (continued)
Rule

Description

Actions

The value is checked
Value fails facet
Ignore Facet-checking is not
constraint
against the facets of its
performed.
Note: If you enable this corresponding item type.
rule, the Datatype has
Log per Occurrence; Log per
illegal value rule is also
Document
set with the same value
Facet-checking is
that is chosen for Value
performed. Log errors are
fails facet constraint rule.
issued for the violations,
and parsing continues.
Reject

Facet-checking is
performed. Invalid values
will fail only the invalid
document parsing, and the
ParsingStatus item, which is
added as a new group to
the step Output for the
XML Parser step, is set to
False with the
corresponding error
message.

Fatal

Facet-checking is
performed. An invalid
value causes the job to fail.

Convert to Default
Facet-checking is
performed. An invalid
value is replaced with its
default value.
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Table 9. Value validation rules (continued)
Rule

Description

Item that cannot be null
has a null value

Non-nullable items are
checked to ensure that
they do not contain null
values.

Actions
Ignore Null-checking is not
performed. All items in the
step Output for the XML
Parser step become
nullable. All items in the
step output become
nullable.
Log per Occurrence; Log per
Document
Null-checking is performed,
and log errors are issued.
Null values are set. As a
result, all items in the step
Output for the XML Parser
step become nullable.
Reject

Null-checking is performed.
Invalid values will fail only
the invalid document
parsing, and the
ParsingStatus item, which is
added as a new group to
the step Output for the
XML Parser step, is set to
False and includes the
corresponding error
message.

Fatal

Null-checking is performed.
An invalid value causes the
job to fail.

Convert to Default
Null-checking is performed.
An invalid value is replaced
with its default value.
Write no data for this value
Null checking is not
performed. The output
column will contain no
data.
Use global default values
for missing values

Missing values are
replaced with their
default values.

False

If the schema defines a
default value for the item,
that default value is used.
Otherwise, the value is set
to nil.

True

If the schema defines a
default value for the item,
that default value is used.
Otherwise, the value is set
to the default value that is
specified in the Assembly
Administration panel.
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Table 9. Value validation rules (continued)
Rule

Description

Trim values

Trim the white space
before and after a value
before performing
type-checking and
type-conversion.

Actions
False

Trimming is not performed.

True

Trimming is performed on
both sides of the value.

Table 10. Structure validation rules
Rule

Description

Actions

Document is malformed

The document is
malformed.

Ignore No error message is logged.
Log per Document
An error message is logged.

Items are not declared in
schema
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Items in the instance
document must be
declared in the schema.
Violations might occur
when a job uses an
out-of-date version of a
schema.

Reject

The ParsingStatus item,
which is added as a new
group to the step Output
for the XML Parser step, is
set to False and includes the
corresponding error
message.

Fatal

A malformed document
causes the job to fail.

Ignore No error message is logged.
Items are parsed based on
best guess.
Log per Occurrence; Log per
Document
Error messages are logged.
Items are parsed based on
best guess.
Reject

The ParsingStatus item,
which is added as a new
group to the step Output
for the XML Parser step, is
set to False and includes the
corresponding error
message.

Fatal

An item that is not declared
in the schema causes the job
to fail.

Table 10. Structure validation rules (continued)
Rule

Description

Nil element has value

Nullable items are
Ignore No error message is logged.
checked to ensure that
Items are parsed based on
they do not contain data
best guess.
values. This applies only
to those items where
Log per Occurrence; Log per
nullable is set to true in Document
the xml document.
Error messages are logged.
Items are parsed based on
best guess.

Mandatory item is
missing

Actions

Reject

The ParsingStatus item,
which is added as a new
group to the step Output
for the XML Parser step, is
set to False and includes the
corresponding error
message.

Fatal

A null element having a
value causes the job to fail.

Items must appear
Ignore Checking for mandatory
correctly in the instance
items does not occur. No
document. Violations
error message is logged. As
might occur if a required
a result, all items in the step
attribute is missing or if
Output become optional.
an element appears out
of order in a sequence
Log per Occurrence; Log per
content.
Document
Error messages are logged.
Parsing continues, even
though data is missing. As a
result, all items in the step
Output become optional.
Reject

The ParsingStatus item,
which is added as a new
group to the step Output
for the XML Parser step, is
set to False and includes the
corresponding error
message.

Fatal

A missing mandatory item
causes the job to fail.
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Table 10. Structure validation rules (continued)
Rule

Description

List has invalid number
of occurrences

The number of
occurrences must be
between the value of the
MinOccurs attribute and
the MaxOccurs attribute,
as defined in the
schema.

ID values are not unique

Each document must
have a unique ID.

Actions
Ignore No error message is logged.
Log per Occurrence; Log per
Document
Error messages are logged.
Reject

The ParsingStatus item,
which is added as a new
group to the step Output
for the XML Parser step, is
set to False and includes the
corresponding error
message.

Fatal

If the list has invalid
number of occurrences, the
job fails.

Ignore No error message is logged.
Log per Occurrence; Log per
Document
Error messages are logged.
Reject

The ParsingStatus item,
which is added as a new
group to the step Output
for the XML Parser step, is
set to False and includes the
corresponding error
message.

Fatal

Duplicate ID values cause
the job to fail.

Controlling how specific items are parsed
Pass data as a chunk, disable type derivation, or change a recursive item into a list
item.

About this task
By default, the XML Parser step applies the schema that you specify to all items in
the schema. However, there might be situations when you do not want to apply
the schema to a specific item. To control how a specific item is parsed, you apply
one of the parsing options: Chunk, Disable Type Derivation, or Recursive to List.
To prevent data from being parsed, use the Chunk option. When you apply this
option to a schema item, all of the data for the item and its child items, if there are
any, is concatenated into a single string; and that string is passed as a chunk to the
next step or stage. The Chunk option is useful when the data that you want to
parse is inconsistent with the schema. In this case, you can pass the data as a
chunk and in a subsequent step or stage, parse the chunk. Another use for the
Chunk option is when you want to apply validation rules to only a specific section
of a document. In this case, you pass the data as a chunk, and then in a
subsequent XML Parser step, you configure validation rules that apply specifically
to that chunk.
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To prevent the schema tree from becoming unnecessarily complex and to optimize
processing, use the Disable Type Derivation option. An XML schema can contain
derivations. For example, a derivation occurs when the schema defines a base
element and also defines a child element that inherits, or derives, attributes from
the base element. By default, when the XML Parser step creates the schema tree,
the tree includes all of the attributes that all of the child elements inherit from the
base elements. This schema enrichment ensures that no information about the
element is lost. If you know that you do not need the child elements in the data,
you can select the base element in the schema and disable type derivation.
To turn a recursive type into a list of items, use the Recursive to List option. The
attributes recursiveParentReferenceID and recursiveID are added to the schema to
maintain the relationship via unique keys that the parser generates. The
recursiveID is a unique key for each parent of the recursion. The
recursiveParentReferenceID attribute stores the key for the parent of each child.

Procedure
1. In the Document Root window of the XML Parser step, right-click the item to
which you want to apply a parsing option.
2. From the menu that displays, select the parsing option.

Setting default values for types
Specify a default value for the XML Parser to use when the schema does not define
a default value for a type.

Procedure
1. From the Assembly Editor, click Administration and then select Default Data
Type Values.
2. Enter default values.
3. On the XML Parser step, open the Validation window and set the Use global
default values for missing values rule to True.

XML Composer step
Use a specified structure to compose XML content.

XML Target
Write to File
Enter the output directory and the file name prefix for the files that will be
composed, or click Insert Parameter and then select the name of the
parameter for the output directory and file name prefix. The parameters
that are available are those that you previously defined in the job and the
built-in macros that are in IBM InfoSphere DataStage.
Pass as String
Pass the composed XML string to a downstream step or stage for further
processing.
Pass as Large Object
Pass the composed XML string as a large object. The final target stage –
that is the last stage in the job – must be a LOB-aware stage, such as the
DB2 connector, Oracle connector, ODBC connector, Teradata connector, or
Websphere MQ connector. These stages use the LOB locator string to
obtain the XML data and then write it to the target database or message
queue. The job can contain non-LOB-aware stages, but these stages must
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not modify the LOB locator string. If the last stage in the job is not
LOB-aware, the LOB locator is written out as data, rather than being
interpreted as a locator.

Document Root
Select the top-level element that describes the documents that you are composing.
The types that display under the library's namespace are top-level element
definitions. Following the XML Schema standard, only top-level elements can
describe documents. The name of the element that you select must match the
top-level element name in the instance documents. For example, if you are
composing Order documents, you select the Order element. When you select the
element, you can view its structure and verify that the structure is correct for the
documents that you want to compose.
Note: The elements from which you select the document root are from the
resources that were previously imported into the schema libraries. If you need to
import the resource that contains the document root for the XML Composer step,
click the Libraries tab and import the resource that you need. Then return to the
Assembly Editor and configure the document root.

Validation
By default, the XML Composer uses strict validation, and the job fails if a violation
occurs. To customize validation, specify the action to perform when a violation
occurs.
For more information about validation rules, see “XML Composer validation rules”
on page 35.

Mappings
Create a mapping to the document_collection item. How you map this item
determines whether one document or multiple documents are created. To produce
only one document, map the root of the Input (top) to document_collection. To
produce multiple documents, map a list item to the document_collection item.
Then one file will be created for each item in the list. For more information about
mapping, see “Working with the mapping table” on page 18.

Header
Specify additional optional information to include at the beginning of the XML
output.
Generate XML fragment
Do not include the XML declaration, comments, and processing
instructions.
Include XML declaration
Include the XML declaration, for example, <?xml version="1.0"
encoding="UTF-8">.
Include comments
Include the comments that you enter in the Comments field.
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Include processing instructions
Include the processing instructions that you enter in the Processing
Instructions field. Enclose each processing instruction in the <? and ?>
tags.
Include schemaLocation
Include the schemaLocation attribute in the xml file with the value that you
enter in the Schema Location field.
Include noNamespaceSchemaLocation
Include the noNamespaceSchemaLocation attribute in the xml file with the
value that you enter in the No Namespace Schema Location field.

Format
Encoding type
Select the encoding to use for the document. The default encoding is
UTF-8.
Format style
Check the box to apply the following format options to the XML output:
v Spaces per indentation level – Select the number of characters to use for
each indentation level in the XML output.
v New line style – Select the type of new line. Choices are UNIX (LF),
DOS(CRLF) or MAC(CR).
v Time Zone – Specify the time zone value from +14:00 to -14:00. If the
composer output data has any elements of date data type (time,
dateTime, or gMonth), then the composer step converts the date data
type according to the specified time zone and appends the converted
data to the composer output data. If the composer output data does not
contain any time zone information then the time zone specified in the
text field is appended to the composer output data.
You can select the Insert Parameter option to insert parameters
containing time zone at run time instead of specifying them at design
time.
v Omit attributes with default value – For attributes that have default
values and are in the data or for attributes that have fixed values, omit
the values from the XML output.
v Omit null elements – For nullable elements that are not in the data,
omit the elements from the XML output.
For examples to use the XML Composer step, see Example 2 and Example 3.

XML Composer validation rules
By default, the XML Composer uses strict validation, and the job fails if a violation
occurs. To customize validation, specify the action to perform when a violation
occurs.
The following tables describe the validation rules and the applicable actions.
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Table 11. Value validation rules
Rule

Description

Data type has an illegal
value

The value must match the
value rules for the data type
of the corresponding item.

Actions
Ignore Type-checking and
type-conversion are
not performed. The
data types of the
items in the Target
column of the
mapping table are
replaced with the
String data type.
Log per Occurrence; Log per
Document
Type-checking is
performed. If a type
fails the check, a log
error is reported
either once for each
occurrence or once
for the entire
document; however,
parsing continues.
Type-conversion is
not performed. The
data types of the
items in the Target
column of the
mapping table are
replaced with the
String data type.
Fatal

Value fails facet constraint
Note: If you enable this
rule, the “Data type has an
illegal value” rule is also set
to the same action that you
choose for this rule.

The value is checked against
the facets of its
corresponding item type.

Ignore Facet-checking is
not performed.
Log per Occurrence; Log per
Document
Facet-checking is
performed. Errors
are logged.
Fatal
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(Default)
Type-checking and
type-conversion are
performed. An
invalid value causes
the job to fail.

(Default)
Facet-checking is
performed. An
invalid value causes
the job to fail.

Table 11. Value validation rules (continued)
Rule

Description

Item that cannot be null has
a null value

Non-nullable items are
checked to ensure that they
do not contain null values.

Actions
Ignore Null-checking is not
performed. All items
in the Target column
of the mapping
table become
nullable.
Log per Occurrence; Log per
Document
Null-checking is
performed, and
errors are logged.
Null values are set.
As a result, all items
in the Target column
of the mapping
table become
nullable.
Fatal

(Default)
Null-checking is
performed. An
invalid value causes
the job to fail.

Write no data for this value
Null checking is not
performed. In the
output, no data will
be written for the
element i.e. empty
element will appear
in the output.
Trim values

Trim the white space before
and after a value before
performing type-checking
and type-conversion.

False

Trimming is not
performed.

True

(Default) Trimming
is performed on
both sides of the
value.
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Table 12. Structure validation rules
Rule

Description

Mandatory item is missing

Items must appear correctly
in the instance document.
Violations might occur if a
required attribute is missing
or if an element appears out
of order in a sequence
content.

Actions
Ignore Checking for
mandatory items
does not occur.
Error messages are
not logged. As a
result, all items in
Target column of the
mapping table are
optional and you do
not need to provide
a mapping for them.
Log per Occurrence; Log per
Document
Error messages are
logged. Missing
values are not filled
in. As a result, all
items in the Target
column of the
mapping table are
optional.
Fatal

List has invalid number of
occurrences

(Default) A missing
mandatory item
causes the job to
fail.

The number of occurrences
Ignore No error message is
must be between the value of
logged.
the MinOccurs attribute and
the MaxOccurs attribute, as
Log per Occurrence; Log per
defined in the schema.
Document
Error messages are
logged.
Reject

The
ComposingStatus
item, which is
added as a new
group to the step
Output for the XML
Composer step, is
set to False and
includes the
corresponding error
message.

Fatal

(Default) If the list
has invalid number
of occurrences, the
job fails.

JSON transformation
Use the Hierarchical Data stage to create powerful hierarchical transformations, as
well as parse and compose JSON data with high performance and scalability.
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JSON (JavaScript Object Notation) is a light weight data interchange format for the
representation of structured data. JSON is derived from the JavaScript language.
Some limitations apply when you use the Hierarchical Data stage to parse and
compose JSON data. For a list of known limitations, see http://www-01.ibm.com/
support/docview.wss?uid=swg21639597

Schema management
Before you can use the Hierarchical Data stage to parse or compose JSON data,
you must import a JSON data instance that describes the data into the metadata
repository. Use the Schema Library Manager to import JSON files into the
metadata repository and to organize them into libraries that can be shared across
all InfoSphere DataStage projects.
After you import a JSON data instance, the schema library manager automatically
validates the instance to determine if the data contains any errors. If the data
instance is valid, the schema library manager creates a schema in the metadata
repository to describe the data types and structures in the instance. Click Browse
to open the library to view the imported schema and to browse the type structure
of the schema. You use these types to define the JSON processing in the
Hierarchical Data stage.
When you create a library, you specify a unique name for the library and an
optional category name. Library names must be unique across all categories.
Organizing libraries into categories ensures that you can later locate a specific
library.
Within a library, you cannot repeat the same global type definition; however, two
different libraries can have the same type definition. Each library can be used to
import only one JSON data instance.
You can create views on top of a generated JSON schema by selecting or
de-selecting elements and performing chunking operations.

Opening the Schema Library Manager
You use the Schema Library Manager to import the schemas to use in jobs that
include the Hierarchical Data stage.

About this task
You can open the Schema Library Manager from IBM InfoSphere DataStage and
QualityStage Designer or from the Libraries tab, which is available from the
Assembly Editor.

Procedure
Do one of the following:
v From the InfoSphere DataStage and QualityStage Designer, choose Import >
Schema Library Manager.
v From the Assembly Editor, click the Libraries tab.

Working with libraries and resources
Use the Schema Library Manager to import resources, such as JSON files, and to
create and manage libraries of resources.
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Use the istool command line to transfer contract libraries between metadata
repositories of IBM InfoSphere Information Server. Libraries are stored in the
metadata repository and are available for use in any job that uses the Hierarchical
Data stage. In the metadata repository, a contract library is represented by the
library name, followed by the extension .cl. When you work with multiple
installations of InfoSphere Information Server, you might want to transfer a
contract library from one installation to another installation, for example, from a
test environment to a production environment.
You can import and export contract libraries using the istool functionality. For
more information, see . For more information about exporting and importing
common metadata assets by using the command line, see http://
publib.boulder.ibm.com/infocenter/iisinfsv/v8r7/topic/
com.ibm.swg.im.iis.iisinfsv.assetint.doc/topics/pdrassets.html.
Table 13. Working with libraries
Task

Action

Creating libraries

1. Click New Library.
2. Enter a name.
3. Enter a description and the name of a
new or existing category.

Refreshing library lists

Click the Refresh icon at the top of the
Libraries pane.

Removing libraries

Select a library, and click Remove.

Opening libraries

Select a library, and click Open. You can
open a library only if it has been validated
and has no errors. The Types tab displays a
list of namespaces and the belonging types.
To view the schema for a type, select a type
from the Types tab. To view the facets and
attributes for a node, select the node from
the Schema tab.

Recategorizing libraries

To move a library to a different category,
edit the Category field in the library details.

Table 14. Working with resources
Task

Action

Importing resources

1. Select the name of a library, and click Import new
resource.
2. Select the file to import, and click Open. You can
select a single json file. You cannot import json files
from a zip file.
3. After importing all of the required resources into the
library, the library is automatically validated. If the
library is valid, a green checkmark displays beside its
name. If it is not valid, a red exclamation point
displays beside its name.
4. If the library is invalid, click Validate to display the
list of errors.
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Table 14. Working with resources (continued)
Task

Action

Displaying the types in schemas

Double-click the name of a library to display the Types
and Schema tabs. On the Types tab, click the plus sign
beside a namespace to display a list of types that belong
to the namespace. Click a type to display the schema for
the type on the Schemas tab. Browsing the types and
their structures is useful for a variety of reasons. You can
determine which type corresponds to a specific
document instance by matching the top-level element
name with the type name. You can determine which
pieces of information are optional but could be included
in similar documents. You can view the characteristics of
the data, so that you can understand how to set
transformation options.

Exporting resources

Select the resource, and then click Export to save a copy
of the resource on the local computer.

Updating resources

If you modify a resource and want to update it in the
library, select the resource, and then click Replace
Selected Resource. The updated resource has no effect
on jobs that used the earlier version of the resource. To
use the updated version in an existing job, you must edit
the assembly.

Deleting resources

Click the Delete icon that displays beside the resource
name. Deleting a resource has no effect on existing jobs
that use the resource.

Displaying the resources in a library

Click the name of a library. For the Hierarchical Data
stage, the Resources view displays a file location and a
namespace for each schema in the library. Click the name
of a schema to display additional details about each
schema.

Editing resource details

Only the File Location and Description fields can be
updated. After you update the file location, the library is
automatically validated.

Creating an JSON schema in the schema library
You can create an library and import the JSON file to create a JSON schema.

About this task
If you select a JSON instance, the contract library derives an XML schema from the
JSON instance and imports the derived schema into the contract library.

Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer.
2. Click Libraries tab from the Assembly Editor to open the Contract Libraries
window.
3. On the Contract Libraries window, click New Library.
4. In the New Contract Library window, enter the name of the library, and then
click OK.
5. Select the library that you created, and then click Import New Resource from
the Resource View to import the JSON file.
6. Select the JSON file from the list of files. The file type can be .json, .jsn or
.jsd
7. Click OK to close the Libraries window. The contract library derives an XML
schema from the JSON file.

JSON Parser step
Use the JSON Parser step to parse one or more documents that have the same
structure.
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JSON source
In this section, specify the source of the JSON data.
String set
Select the node that contains the JSON data. The node can be a field which
comes from the previous input step in the DataStage or a chunked node
from the previous parser step. You can select only items that contains the
JSON data.
Single file
Enter the path and file name, or click Insert Parameter, and then select the
name of the parameter. You can select parameters that you defined in the
job and built-in macros that are in IBM InfoSphere DataStage.
File set
Select the input schema item that contains the full file paths of the JSON
files at run time. For example, the full file path might be C:\test.json. Use
this option to read multiple JSON files that are based on the same schema.

Document root
Select the top-level element or a view of a JSON schema that describes the JSON
data that you want to parse. The JSON schema is a schema generated while
importing a JSON data instance into the schema library.
When you select the document root, the list of elements includes only elements
available in the resource selected as document root.

Validation
By default, when the JSON Parser step runs, it uses minimal validation, which
disables some of the validation rules and provides better performance than strict
validation does. Strict validation is configured so that each validation rule is set to
Fatal, and the job aborts if the input file has invalid data. To customize validation,
specify the action to be taken when a violation occurs.
Related tasks:
“Example 1: Parsing JSON data” on page 194
You can create a simple job that uses the JSON Parser step to parse contact data,
which is stored in one JSON data file, into two flat files.

JSON Parser validation rules
By default, the JSON Parser uses minimal validation and ignores violations. To
customize validation, specify the action to perform when a violation occurs.
The following tables describe the validation rules and the actions that the JSON
Parser can complete based on the setting of the rule.
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Table 15. Value validation rules
Rule

Description

Actions

Data type has illegal
value

The value must conform
Ignore Type checking is not
to the value rules for the
performed. The data types
data type of the
of the items as they are
corresponding item.
defined by the schema are
replaced by the String type.
For example, if the schema
includes an item named
income that has the decimal
data type, the data type of
the item in the step output
becomes String.
Log per Occurrence; Log once per
Document
Log per occurrence logs
error for each occurrence
and log once per document
logs error for the first
occurrence of all errors of
the entire document.
Reject

Type checking is performed.
Only invalid values fail the
invalid document parsing.
The ParsingStatus item is
added as a new group to
the step output for the
JSON Parser step and is set
to False. The ParsingStatus
item contains the
corresponding error
message.

Fatal

Type checking is performed.
An invalid value causes the
job to fail.

Using global default value
If the value is not present
for any key, then it takes
the value that is specified in
the administration page.
Trim values

Trim the white space
before and after a value
before performing type
checking and type
conversion.

False

Trimming is not performed.

True

Trimming is performed on
both sides of the value.
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Table 16. Structure validation rules
Rule

Description

Actions

Document is malformed

The document is
malformed.

Ignore No error message is logged.
Log once per Document
An error message is logged.

Items are not declared in
the schema

Reject

The ParsingStatus item,
which is added as a new
group to the step Output
for the JSON Parser step, is
set to False and includes the
corresponding error
message.

Fatal

A malformed document
causes the job to fail.

Items in the instance
Ignore No error message is logged.
document must be
Items are parsed based on
declared in the schema.
best guess.
Violations might occur
when a job uses a
Log per Occurrence; Log once per
version of a schema that Document
is outdated.
Error messages are logged.
Items are parsed based on
best guess.
Reject

The ParsingStatus item,
which is added as a new
group to the step Output
for the JSON Parser step, is
set to False and includes the
corresponding error
message.

Fatal

An item that is not declared
in the schema causes the job
to fail.

JSON Composer step
Use a JSON schema or a view created from the JSON schema to compose JSON
data.

JSON Target
Write to file
Enter the output directory and the file name prefix for the files to compose,
or click Insert Parameter and then select the name of the parameter for the
output directory and file name prefix. The parameters that are available are
those that you previously defined in the job and the built-in macros that
are in IBM InfoSphere DataStage.
Pass as string
Pass the composed JSON string to a downstream step or stage for further
processing.
Pass as large object
Pass the composed JSON string as a large object. The last stage in the job
must be a LOB-aware stage, such as the DB2 connector, Oracle connector,
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ODBC connector, Teradata connector, or Websphere MQ connector. These
stages use the LOB locator string to obtain the JSON data and then write it
to the target database or message queue. The job can contain stages that
are not LOB-aware, but the stages must not modify the LOB locator string.
If the last stage in the job is not LOB-aware, the LOB locator is written as
data and is not interpreted as a locator.

Document Root
Select the top-level element or a view of a JSON schema that describes the JSON
data that you want to compose. The JSON schema is a schema generated while
importing a JSON data instance into the schema library.

Validation
By default, the JSON Composer uses strict validation, and the job fails if a
violation occurs. To customize validation, specify the action to perform when a
violation occurs.

Mappings
Create a mapping to the document_collection item. How you map this item
determines whether one document or multiple documents are created. To produce
only one document, map the root of the input (top) to the document_collection
item. If you want each item in the list to be in a separate document, then map a
list to the document_collection item.. If you produce multiple documents, one file
is created for each item in the list. For more information about mapping, see
“Working with the mapping table” on page 18.
An JSON array is modelled as multiple occurrences of mixed types. The
choiceDescriminator indicates which choice branch you should select for the
particular array element. Below is an example of JSON array.
[
{"type": "home", "number": "212 555-1234"},
[116, 943, 234],
true
]

In the above example, the choiceDescriminator has the value of objectValue for the
first array element which is an object. The choiceDescriminator has the value of
arrayValue because the second array element is a nested array. The
choiceDescriminator has the value of booleanValue. The choiceDescriminator value
contains stringValue, numberValue, booleanValue, nullValue, objectValue, and
arrayValue. When composing the JSON data you need to choose which value
should be used from the available values. If you want the value as objectValue for
the choiceDescriminator, then from the Source column, select Constant from the
drop down list and enter the Constant Value as objectValue and click OK. In a
similar way, if you want the value as stringValue, then the Constant value should
be stringValue

Format
Encoding type
Select the encoding to use for the document. The default encoding is
UTF-8.
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Format style
Apply the following format options to the JSON output:
Indentation length
Select the number of characters to use for each indentation level in
the JSON output.
New line style
Select the type of new line. Choices are UNIX (LF), DOS(CRLF) or
MAC(CR).
Related concepts:
Working with the mapping table
Some steps, such as the Output step and the XML Composer step, require that you
create mappings that define how to create the target nodes.
Related tasks:
“Example 2: Composing JSON data by using the JSON Composer and HJoin steps”
on page 204
Build this job that uses the JSON Composer and HJoin steps in the Hierarchical
Data stage to create a hierarchical structure.

JSON Composer validation rules
By default, the JSON Composer uses strict validation, and the job fails if a
violation occurs. To customize validation, specify the action to perform when a
violation occurs.
The following tables describe the validation rules and the applicable actions.
Table 17. Value validation rules
Rule

Description

Data type has illegal value

The value must conform to
the value rules for the data
type of the corresponding
item.

Actions
Ignore Type checking is not
performed. The data
types of the items in
the Target column of
the mapping table
are replaced with
the String data type.
Log per Occurrence; Log
once per Document
Log per occurrence
logs error for each
occurrence and the
log once per
document logs error
for the first
occurrence of all
errors of the entire
document.
Fatal
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(Default) Type
checking is
performed. An
invalid value causes
the job to fail.

Table 17. Value validation rules (continued)
Rule

Description

Trim values

Trim the white space before
and after a value before
performing type checking
and type conversion.

Output JSON elements for
null values

Actions
False

Trimming is not
performed.

True

(Default) Trimming
is performed on
both sides of the
value.

If the data is null for one of
False
the columns which is an
element in the JSON schema,
that element having null
value is listed in the output
schema file when composed. True

The element having
null values are not
written to the
generated JSON file.
The element having
null values are
written to the
generated JSON file.

REST web services
Representational State Transfer (REST) is a resource-oriented architecture that can
be used to design web applications that consist of clients and servers that send
requests and responses.
REST is an alternative to Simple Object Access Protocol (SOAP) and Web Services
Description Language (WSDL) and is based on web services. By using REST, you
can design web applications that use different clients and that are written in
different languages.
REST web applications use HTTP to create client applications and APIs and do not
require any middleware. REST supports various content types, such as JSON,
XML, text, image, and audio. You can design the job by using REST to post
messages to social networking sites or use maps and directions.
Related reference:
“Examples of invoking REST web services” on page 214
You can build jobs that invoke REST web services from the Hierarchical Data stage
by using HTTP methods.

REST step pages
You configure settings for the connection, security, request, and response body of
the REST step to invoke a REST web service.

General
On the General page of the REST step, you can set up a connection to the REST
web service. You can also create a reusable connection which can be used to set up
the connections for multiple REST steps.
You must specify values for the following fields to configure connection settings
for the REST web service.
HTTP method
Select the HTTP methods to use to connect to the REST web service.
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GET

Retrieves the information in the form of an entity that is identified
by the request Uniform Resource Identifier (URI) of the request
body.

POST Requests that the origin server accept the data that is enclosed in
the body of the request message. This method is often used to
upload resource data.
PUT

Requests that the enclosed entity be stored under the request URI
that is specified.

DELETE
Requests that the origin server delete the resource that is identified
by the request URI.
OPTIONS
Displays a list of HTTP methods that are supported by the server
for the specified URI.
HEAD
Retrieves only the header information in the response. This method
is often used to verify that hypertext links are valid and identify
whether the links changed.
PATCH
Changes existing resources. You can use the PATCH method to
update a single field of the resource.
Reusable connection
You can reuse a connection object that was created in the another REST
step in the same assembly. Reusable connections are available only in the
assembly where you created them. While the job is running, the connection
is shared to invoke multiple REST services created by the multiple steps
which use the same reusable connection. The reusable connection is also
designed to pass the session cookies among various requests without any
user configuration. Reusable connection saves the time of creating a
connection with the server where the REST service is deployed. When the
Reusable connection option is selected, the URI suffix field is shown on
the General page in which you specify a part of the URL of the REST
service.
URL

Specify a URL string for the REST web service. You can include a local
parameter in the URL by specifying the <localparam> tag. You must map
the local parameters to input data items or fixed values on the Mappings
page. To specify a DataStage job parameter in the URL at run time, click
Insert Parameter, and then select the name of a job parameter.

HTTP version
Select the HTTP version on which you want to run the REST web service.
The OPTIONS method is not available for HTTP Version 1.0 because the
OPTIONS method was introduced in HTTP Version 1.1.
Timeout duration
Specify the number of milliseconds to wait before the request times out.
The default value is 180000 milliseconds, and the maximum value is
1800000 milliseconds.
Proxy configuration
Select this option to choose a proxy server as an intermediate gateway for
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accessing REST resources. Click Configure to specify the connection
details, such as name, port, realm, domain, user name, and password to
use to connect to the proxy server.
If this option is selected, the client uses an HTTP proxy server to connect
to the destination. The proxy server then connects on behalf of the client.
When the connection is established, the proxy server maintains the TCP
stream to and from the client.
Abort job on error
Select this option to stop the job when the REST call fails.

Security
On the Security page of the REST step, you can specify the security details of the
REST web service.
You must specify values for the following fields to configure security settings for
the REST web service.
Authentication
Select the type of authentication to use for the REST web service.
Basic

Uses the HTTP Basic authentication mechanism specified in the
RFC2617. When the Basic option is selected, you must provide a
valid user name and password to access the content. You can also
specify a realm, which defines a protected space that identifies
valid users of a web application by associating each user name
with a password and role. You need to select the encoding type of
the user credentials that the REST service is configured to accept
for the Basic authentication. For example, if the Information Server
is installed on Japanese locale Windows system and Japanese users
try to access any REST APIs by providing the user name and
password in Japanese characters, then you may need to provide
encoding type shift_jis.

Digest Uses the HTTP Digest authentication mechanism specified in the
RFC2617. When the Digest option is selected, you must provide a
valid user name and password to access the content. You can also
specify a realm. You need to select the encoding type of the user
credentials that the REST service is configured to accept for the
Digest authentication.
LTPA

Is the IBM Lightweight Third-Party Authentication mechanism. The
application server sends a session cookie to the browser that
contains an LTPA token after the user is authenticated. This LTPA
token is used for a single session. When the LTPA option is selected,
user must provide a valid user name and a password to access the
content. You can also specify a realm. You also need to select the
encoding type of the user credentials that the REST service is
configured to accept for the LTPA authentication.
Select Use LTPA cookie from input to use the LTPA cookie from
the previous REST step. If you select this option, on the Mappings
page, you must map the LTPA cookie to the output cookie from the
previous REST step.
Select Send LTPA cookie to output to create an LTPA cookie
element in the output schema that can be used in the next REST
step. For further connections, you can use the LTPA cookie instead
of specifying credentials.
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For example, suppose that in REST step 1 you specify a user name
and password for LTPA. If you select Send LTPA cookie to output,
the REST step creates an LTPA cookie element in the output
schema that can be used in the next REST step. In REST step 2,
you can configure the REST service with LTPA without specifying
user credentials by selecting Use LTPA cookie from input. On the
Mappings page, you must then map the LTPA cookie to the input
value from REST step 1.
OAuth2Bearer
Helps access the protected resource on behalf of a resource owner
by providing a bearer token. A bearer token is a security token that
was issued to the client by an authorization server. When a bearer
token is specified, you do not need to specify a user name and
password to access the resource.
Select Use authorization from input to use the bearer token value
from the previous REST step. The authorization header is created
on the Mappings page. You must map the authorization header to
the bearer token value from the previous REST step.
Enable SSL
Uses the Secure Socket Layer (SSL) protocol to encrypt the data that is sent
between the client and the server. The SSL protocol supports host name
verification, which ensures that the host name in the URL to which the
client connects matches the common name in the server SSL certificate
before the SSL connection is made. If the REST client should accept the
self-signed certificates, then you need to select Accept self-signed
certificates. The SSL protocol also supports both SSL server and client
authentications by providing the keystore and truststore files for the REST
service that is configured.

Request
On the Request page of the REST step, you can specify the request body of the
REST step as a text, a binary data, or as a file.
Select Load the outgoing body from to specify the part of the HTTP request that
contains the data to process with the REST web service. The request body of the
REST step can be a maximum of 10 MB. Then, you need to select the following
properties:
A text node named body on the Mappings page
Select if the HTTP request body is text data. If you select this option, the
body node is created in the target schema on the Mappings page and the
node needs to be mapped to a text input data field or a fixed string.
A binary node named body on the Mappings page
Select if the HTTP request body is binary data. If you select this option, the
body node of binary type is created in the target schema on the Mappings
page and the node needs to be mapped to a binary input data field.
A file whose path is set on the Mappings page as bodyFilePath
If you select this option, the bodyFilePath node is created in the target
schema on the Mappings page, and the node must be mapped to a text
input data field or a fixed string that contains file path.
Content type
Select the content type and the encoding type for the request.

50

Hierarchical Data Transformation Guide

Compress the body before sending
Select to send the HTTP request body to the REST service as compressed.
The request body supports only gzip format.
Custom headers
Specify the headers for the HTTP request in the Name field. HTTP headers
are name and value pairs that are separated by a colon, for example,
name:value. If you add HTTP headers in the Custom headers field, ensure
that the header names are unique. You can specify an HTTP header as text
by clicking the edit as text link.
To set a constant value for the header, specify the constant value in the
Default value field. Select the Map option to map the header on the
Mappings page. If the Replace null values with the default value option
is selected, you can set a default value for the header which is used if the
source column mapped to the header contains no data.
Custom cookies
Specify the cookies to the HTTP request in the Name field. HTTP cookie is
a token or packet of status information that the HTTP agent and the target
server can exchange to maintain a session. The state information consists of
name-value pairs for attributes such as version, domain, a path that
specifies the subset of URLs on the origin server to which the cookie
applies, and the maximum time for which the cookie is valid. You can
specify as HTTP cookie as text by clicking the edit as text link.
To set a constant value for the cookie, specify the value in the Default
value field. Select the Map option to map the cookie on the Mappings
page. If the Replace null values with the default value option is selected,
you can set a default value for the cookie which is used if the source
column mapped to the cookie contains no data.

Response
On the Response page of the REST step, you can specify the response body as a
text, a binary data, a file, or a large object (LOB).
If you select Pass the received body to, you need to select the following
properties:
A text node named body in the Output schema
Select if the HTTP response body is text and the body node is created in
the output schema.
A binary node named body in the Output schema
Select if the HTTP response body is binary and the body node of the
binary type is created in the output schema.
A node named bodyLobObject that a downstream connector will process as a
binary large object
Select to get the response body of type binary from the REST web service
as a LOB object. The bodyLobObject node of the binary type is created in
the output schema.
A node named bodyLobObject that a downstream connector will process as a
character large object
Select to get the response body of type text from the REST web service as a
LOB object. The bodyLobObject node of the character type is created in the
output schema.
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A file whose path is set below
Select to write the response data directly to a file. Then, you need to
specify values for the following properties:
Output directory
Specify the directory to store the file that contains the response
body.
Filename prefix
Specify the prefix name of the file that contains the response body.
Note: If the prefix name of the file is not specified, the job creates the file
with the prefix name restPayload.
File extension
Specify the file extension, for example,.xml or .json.
The bodyFilePath node is created in the output schema that contains the
path of the file.
Content type
Select the content type that you expect the response body to have based on
the REST call.
De-compress the received body
Select to extract the HTTP response body if the Rest service sends the data
in compressed format (gzip).
Custom headers
You can extract the headers from the HTTP responses. If the HTTP
response does not contain a value for the custom header, the REST step
uses the default value that you specified in the headers area of the
Response page.
Custom cookies
You can extract the cookies from the HTTP responses and send them to the
output. If the HTTP response does not contain a value for the custom
cookie, the REST step uses the default value that you specified in the
cookies area of the Response page.

Mappings
The Mappings page contains the parameters or elements in the connection and
request which need to be mapped to fixed values or input data items.
You must map all the elements or parameters that are listed in the Target column
to elements or parameters in the Source column.
For example, map the bodyFilePath node to the constant value of the Source column
that contains the path of the source file.

Output schema of the REST step
When you specify values on the REST step, two group nodes, callStatus and
statusLine, are created in the output schema of the REST step. The values for these
nodes indicate whether REST calls ran successfully.
The callStatus group node contains details about the REST service calls that did not
run successfully. The details are in the following nodes:
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success
Returns the Boolean values True or False. True indicates that the REST
service call ran successfully, and False indicates that the REST service call
did not run successfully.
errorMessage
Returns a string that contains details about errors if the REST service call
did not run successfully.
faultHTTPStatusCode
Returns a string that contains the failure status code of the REST service
call.
faultHTTPbody
Returns a string that contains details about the failed invocation of the
REST service call.
The statusLine group node contains details about the REST service calls that ran
successfully. The details are in the following nodes:
httpVersion
Returns a string that contains the HTTP version that was used by the REST
service call.
statusCode
Returns an integer value that contains the status code of the REST service
call. Some of the status code are:
v 200: Indicates that the successful invocation of the REST service.
v 401: Indicates that the user is not authorized to access the REST service.
v 500: Indicates the internal server error hence server can't process the
REST request.
reasonPhrase
Returns a string that contains details about the successful invocation of the
REST service call.

Large Schema
Use the Hierarchical Data stage to parse and compose XML files based on large
schemas.

Auto Chunking
The auto-chunk feature provides an automated and quick approach to limit the
size of the schema tree for an XML parser step and parse the XML data with large
schema.
The auto-chunk algorithm performs a breadth-first search, counts the number of
encountered nodes, and starts auto-chunk operations based on the configurable
soft and hard limits. For more information about configuring the soft and hard
limits, see “Configuring the auto-chunked elements in the assembly” on page 55
For large schemas, some of the XML elements are automatically chunked by a
parser step. Chunking refers to converting all child XML elements to a single XML
element.
Figure 1 shows the actual schema representation. When a large schema is loaded
as the document root for an XML parser, the element name is automatically
chunked as shown in the Figure 2. The auto-chunked element is represented with
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the greater than symbol and less than symbol (<>) and all the child elements of the
element name are contained within this single element.
Figure 1. Example of actual schema representation

Figure 2. Example of schema representation after chunking
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Configuring the auto-chunked elements in the assembly
You can use a configuration screen to set the thresholds to trim the schema tree.

Procedure
1. Specify the value in the Schema Trimming start at and Maximal Schema Tree
size fields.
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2. The Hierarchical Data stage starts to chunk the top-level XML elements when
the tree size reaches the value for the schema trimming property.
3. When the tree size reaches the value specified for the maximum size, the
Hierarchical Data stage automatically chunks all the qualified XML elements
(both the top-level XML elements and the nested XML elements).
a. For schemas with fewer than 500 nodes the Hierarchical Data stage does not
automatically chunk any schema elements. To select a large schema as a
document root for the XML parser step, use multiple parsers to extract the
auto-chunked elements.
4. Each parser step can have different auto-chunking values set. After defining the
schema in the Document Root of the Parser Step, the values can be changed.
The changed values cannot affect the schema representation in the Parser Steps
where the Document Root is already defined

Parsing XML data with a large schema
To parse XML in a large schema, you must configure multiple XML Parser steps in
the assembly for each auto-chunked set of elements.

About this task
The parser step does not parse the XML data for the descendants of an
auto-chunked element. The data for the auto-chunked element and its descendants
are passed to next step as an XML data chunk. You need to configure multiple
XML Parser steps to parse the data chunk for the descendants.

Procedure
1. Import the schema in to the schema library.
2. Add an XML Parser step to the assembly outline.
3. In the XML source field, enter the source of the XML data.
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4. On the Document Root tab, click Browse and select the schema element that
describes the documents that the step parses.
5. Add a second Parser step to the assembly.
6. In the second Parser step, select the String Set option in the XML source tab
and select an auto-chunked node in the Document Root tab.
7. After configuring the second Parser Step, the child items of the auto-chunked
element are available for mapping in the Output Step.
Related concepts:
“Parsing an XML file using schema views” on page 58
By using the schema views, you can parse an XML file with only a single Parser
step.

Design Consideration in the Assembly Editor
When the auto-chunked element is selected in the second Parser Step, then the
Document Root is automatically defined. This method holds true if the first and
second Parser Steps are defined one after another without saving the assembly in
between. But in case the Assembly Editor is closed after defining the first Parser
Step, then the Document Root will not be automatically populated in the second
Parser Step when it is added to the assembly on reopening the Assembly Editor.
To address this issue, you need to go to the first parser and set the document root
again. You must note the following points:
v There is no need to delete or reconfigure the first parser, you need to reset the
Document Root.
v This also applies to the following scenarios where you have several parsers in
the assembly:
– When the first Parser is used to import the whole schema and the rest of the
Parsers are used to parse some auto-chunked elements from the output of the
first parser.
– If you reopen the job and want to add another parser to parse another
auto-chunked schema element, then you need to reset the document root in
the first parser

Schema views
A schema view is a defined subset of a schema.
When a schema contains a large number of nodes, you create schema views to
reduce the size of schema tree, enhance the design experience, and improve the
efficiency of the parsing and composing processes.
Schema views are saved in the schema library manager so that they can be reused
for different steps and different job designs.

Creating and modifying schema views
To reduce the size of the schema tree of a large schema, create a schema view from
any XML element.

Procedure
1. Start the IBM® InfoSphere® DataStage® and QualityStage™ Designer.
2. On Libraries tab, click New Library or select an existing schema library.
3. Select the node in the XML schema that you want to create a schema view for.
4. Click Create View.
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5. Enter the Schema library name and the description.
6. Use the Find option to locate the nodes by a name. You can also search the
nodes by specifying the node level. Click Next after entering the node name
and specifying the node level.
7. Specify the properties for the schema view.
Table 18. Specifying the values for creating view
Property

Description

Include in View

Select this check box for the optional nodes
that you want to include in the view.
Mandatory nodes are selected automatically.
You need to manually select the nodes that
are optional.

Include All Descendants

Select this check box to include all XML
elements that are under the selected node.

Chunk

Select this check box to chunk schema tree
of a selected XML element as one single
XML node with the XML type.

8. Click OK to save the view.

Parsing an XML file using schema views
By using the schema views, you can parse an XML file with only a single Parser
step.
When parsing a small XML file by using the Hierarchical Data stage, it requires a
large number of Parser steps as there will be a large number of auto-chunked
nodes in the schema that needs separate Parser steps to parse it. For example,
consider parsing a XML file for the FPML 4.9 schema. Assume that the XML file
has only certain number of elements and not all the elements are defined in the
schema. To parse such a small XML file, Hierarchical Data stage requires a large
number of Parser steps. The following figure displays the auto-chunked node in
the schema and the assembly design.
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The schema view allows you to simplify the assembly when parsing such small
XML files. You can create the view on top of the original schema to include only
the required elements which are present in the XML file. Hence, you can reduce
the schema size and there will be no auto-chunked nodes in the schema. You can
also import the view into the Parser step. Now you require only a single Parser
step to parse the file as there will not be any auto-chunked node as the size of the
schema will be smaller.
Note: If the schema view created for the schema is also very large, then the
auto-chunked nodes can be present in the view.
Related tasks:
“Parsing XML data with a large schema” on page 56
To parse XML in a large schema, you must configure multiple XML Parser steps in
the assembly for each auto-chunked set of elements.

Composing an XML file using schema views
By creating a schema view from a large schema, you can use the composer step to
compose XML data based on the structures and types defined in the schema view,
rather than in the original schema.
XML schemas can be very complicated. They can contain XML types, elements,
structures, and definitions for many XML documents. They can contain thousands
of XML nodes and provide large amounts of information. You can create views
from those complex schemas to reduce the size of schema tree and simplify your
composing design process.
You can use schema views to compose an XML document in the following cases:
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v If the XML schema contains the definitions of many types of XML documents
and you want to compose XML data for one particular type, you can create a
view for the XML document type from your XML schema and remove all the
features that are not related to your document type from the view. You can then
select the view as the document root for the XML composer step, define the
mappings, and compose your XML documents.
v If the schema that describes the XML data contains large amounts of
information, you can define multiple views on top of your schema; each view
describing one part of your XML schema. You can add one XML composer step
for each view to build one part of your XML document. You can assembly all
the generated parts by using the additional views and composer steps.
The following figure shows an example of using schema views to compose XML
data from multiple parts of an XML document.

Creating Schema Views
Schema views help you to reduce the size of the schema tree. Schema views are
saved in the schema library manager.

Procedure
1. Create two views based on the original department schema as shown in the
below figure.
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2. The employee_view contains only the types and elements that describe the
employee information.

3. The departments_view is created to combine the information described in the
employee_view with the department information. As shown in the below
figure, the employee in the departments_view is chunked and represented by a
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single node. The types and elements of the chunked node "employee" are
described by the employee_view.

Creating an assembly
Using the Assembly Editor, you can create an assembly. By default, an assembly
contains an Overview, an Input step, and an Output step. You add additional steps
to the assembly, based on the type of transformations that you want to perform.

About this task
In this example, you need to add multiple steps to compose an XML document.

Procedure
1. Create two HJoin steps and two composer steps for the below described
schema.
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2. The HJoin_Employee_Address Step joins the “Employee” list with the
“Address” list.
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3. The XML_Composer_Employee Step composes an XML data described by the
“employee_view”. As shown in the following figure, the “employee_view” is
selected as the document root to describe the XML data produced by the
XML_Composer_Employee Step.

4. The HJoin_Dept_Employee Step joins the “DeptInfo” list with the “Employee”
list.
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5. The XML_Composer_depts Step combines the XML data generated from the
XML_Composer_Employee Step with the department information and
generates the final XML data described by the “departments_view”.
As shown in the following figure, the “departments_view” is selected as the
document root to describe the XML data produced by the XML_Composer_depts
Step.

6. The result-string generated from the XML_Composer_Employee Step is
mapped to the value for the chunked node “employee”.
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Transformation steps for the Hierarchical Data stage
Transformation steps for the Hierarchical Data stage are available from the palette
in the Assembly Editor.

Aggregate step
Perform hierarchical aggregations on the items in a list.
In the example below, the aggregate function, average, is computed for the salary
of all employees in each department. The departmentID is used as the key to
group Employee items and the averageSalary is computed for each group. The
result list contains an item for each distinct departmentID/grouping.
Company[]
Employee[]
departmentID
salary
result[]
keys
departmentID
aggregate
averageSalary

List to Aggregate
Specify the list that contains the elements that will be iterated on.
Scope Select the item that defines when to produce the result of the aggregation.
Aggregation Item and Aggregation Function
Select an items and the function to use for the aggregation. The function
that you select must be applicable to the data type of the selected item.
The following table describes the available aggregation functions.
Table 19. Aggregation functions
Function

Description

Average

Calculates the average value in the list.

Count

Counts the elements in the list. Ignore null
values.

Concatenate

Concatenates all strings in the list, starting
with the first element.
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Table 19. Aggregation functions (continued)
Function

Description

First

Selects first value in the list.

Last

Selects last value in the list.

Maximum

Selects the maximum value in the list. If the
list contains Boolean strings, True is greater
than False.

Minimum

Selects the minimum value in the list. If the
list contains Boolean strings, False is less
than True.

Sum

Calculates the sum of all of the values in the
list.

Variance

Calculates the variance value of all of the
values in the list.

Aggregation Keys
Specify aggregation keys to produce multiple aggregation rows for each
unique key value.

H-Pivot step
Transpose a list into a set of items, based on a key.
Scope Specify the list to transform.
Columns
Specify the columns to convert into rows. For each column that you
specify, a new record is created.

HJoin step
Transform the items from two lists into one nested list.
Parent List
Specify the parent list. The parent list cannot already have a containment
relationship with the child List.
Child List
Specify the child list.
Optimization Type
If all of the records have the same key and are consecutive to each other,
select In-memory as the optimization type.
Parent Keys
Specify the key to use to join the lists.
Child Keys
Specify the key to use to join the lists.
For an example of using the HJoin step, see .Example 3

Order Join step
Join items based on their position in two lists.
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Select two lists to join into one list. The items in each list are joined, based on their
position in the list. For example, item 1 in list 1 is joined to item 1 in list 2. If one
list has fewer items than the other list, items that have a null value are added to
the shorter list.

Regroup step
Use the Regroup step to create a parent-child list relationship from a single list.
Remove redundancy in a data set by using the Regroup step to transform the
items in one list into nested list. Identify items that contain redundant data and
move them into a parent list. Identify child items to move in to a child list.
List to regroup
Select the list to regroup.
Scope Select the scope.
Parent and Child Items
Drag items to identify which belong to the parent list and which belong to
the child list.
Keys

Specify one or more keys to use for the regroup operation. For each unique
instance of a key field, a separate entry is made in the list.

Input records of regroup lists are clustered by key – optimize execution
If the input records have already been sorted by the selected key, select this
option to improve performance.
For an example that includes the Regroup step, see Example 2.

Sort step
Sort the items in a list by one or more keys.
List to Sort
Specify the list to sort.
Scope Specify the scope.
Data set fits into memory; optimize sort
Select this option to improve performance.
Keys and Order
Specify one or more keys by which to sort the values, and specify the sort
order for each key.

Switch step
Use the Switch step to classify items into one or more new target lists, based on
constraints that you specify.
Each target list is associated with a constraint. The target list contains all of the
items that passed the constraint. The Default list contains all of the items that
failed all of the constraints.
To create a new target list and one or more constraints, click Add Target.
The following table describes the functions that you can use to create a constraint:
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Table 20. Functions for the Switch step
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Function

Type

Description

isNull

All types

Returns True if the value is
null.

Greater than

Any number

Returns true if the value is
greater than the value of the
parameter.

Greater than or equal

Any number

Returns true if the value is
greater than or equal to the
value of the parameter.

Less than

Any number

Returns true if the value is
less than the value of the
parameter.

Less than or equal

Any number

Returns true if the value is
less than or equal to the
value of the parameter.

Equals

All types

Returns true if the two
values are the same.

Between

Any number

Returns true if the value is
within the specified range.

IsTrue

Boolean

Returns true if the value is
true.

IsFalse

Boolean

Returns true if the value is
false.

Compare

String

Returns true if the string
value is the same as the
string value of the parameter.

CompareNoCase

String

Returns true if the string
value is the same as the
string value of the parameter.
Ignores the case.

Contains

String

Returns true if the string
value contains the string
value of the parameter.

ContainsCaseInsensitive

String

Returns true if the string
value contains the string
value of the parameter.
Ignores the case.

IsBlank

String

Returns true if the string is
empty or null.

IsNotBlank

String

Returns true if the string is
not empty and not null.

Like

String

Returns true if the string
value matches the pattern
defined by the parameter
value. Use a percent sign (%)
to define missing letters
before and after the pattern.
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Union step
Use the Union step to combine two lists that have different structures into a single
list that has a predefined structure.
On the Union Type tab, you select the target list schema. On the Mappings tab,
you map the two lists.

V-Pivot step
Use the V-Pivot step to transform records into fields of another record.
You define the record source and scope. For each column name, the step output
contains a branch with a single item that has the same structure as the step input.
Based on the value of the Source of Column Names field, the record is classified
into the correct branch.

Examples of transforming XML data
Build these sample jobs that parse and compose XML data.
The examples all use one data file, departments.xml, and two schemas
(Employee.xsd and Organization.xsd). You can create each example yourself, by
following the step-by-step instructions, or you can import the finished job and
explore it on your own. The data for the examples is an XML file that contains
information about the employees in one department of a company. The schemas
define the structure for the employee information and for the department
information.
If you are just getting started with the Hierarchical Data stage, begin by building
Example 1, which includes tasks that illustrate the use of the Assembly Editor and
the Schema Library Manager.
To get the files for the examples, go to http://www.ibm.com/support/
docview.wss?uid=swg27019894.

Example 1: Parsing XML data
Create a simple job that uses the Hierarchical Data stage and the XML Parser step
to parse employee data, which is stored in one XML data file, into two flat files.

About this task
This basic parsing example uses the sample XML data file, departments.xml, and
the sample schemas, Employee.xsd and Organization.xsd, to illustrate parsing
source data from one XML file into two files. The departments.xml file contains
information about the employees of one department in a company. In this example,
you parse the XML data into two files. One file contains employee business
information: employee name, date of hire, date of birth, gender, title, employee ID
and department ID. The second file contains employee address information:
employee ID, street, city, state, postal code, country, and address type.
To create the example, complete these tasks:

Example 1: Creating the job
Create the example job that includes one Hierarchical Data stage and two
Sequential File stages.
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About this task
The following figure shows the job that you create for the parsing example. The
job includes one Hierarchical Data stage, named Departments, and two Sequential
File stages, named Employee_File and Address_File. The Departments stage is
linked to the Employee_File stage by a link named Employee, and it is also linked
to the Address_File stage by a link named Address.

Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas.
4. Perform the following steps to create a job property for the location of the
example files:
a. Choose Edit > Job Properties.
b. On the Parameters tab, in the Parameter Name field, enter
xml_example_root_folder and then specify the following values:
Table 21. Specifying the values for field names
Field name

Value

Prompt

Root of example folder tree

Type

String

Help Text

Point to the root of the file tree folder

Each example uses this job parameter.
5. Open the File section of the palette, and drag two Sequential File stages to the
canvas. Position these stages to the right of the Hierarchical Data stage.
6. Create a link from the Hierarchical Data stage to each sequential file stage.
7. Rename the stages and links as shown in the following table:
Table 22. Names for job elements
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Element

Name

Hierarchical Data stage

Departments

Sequential File stage

Employee_File

Sequential File stage

Address_File

Link from Departments to Employee_File

Employee

Link from Departments to Address_File

Address
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8. By looking at the departments.xml file, which contains the XML data, you
determine which columns to create to hold the employee data that the
Hierarchical Data stage will pass to the Employee_File stage and the
Address_File stage. Double-click the Employee_File stage to open the stage
properties. Then click the Columns tab, and configure the following columns:
Table 23. Columns for the Employee_File stage
Column name

SQL type

Length

LastName

VarChar

40

MiddleName

VarChar

40

FirstName

VarChar

40

Gender

VarChar

BirthDate

Date

Title

VarChar

HireDate

Date

EmployeeID

VarChar

DepartmentID

VarChar

The column names that you create closely resemble the names of the XML
schema elements. In the Output step of the assembly, where you configure the
mapping between target items and source items, you will see how name
similarity affects the mapping suggestions that are returned.
9. Click the Properties tab, and configure the following properties that define the
output file:
Table 24. Configuring the properties
Field name

Value

Target > File

Enter the path where you want the output
file to be created, followed by the file name
employee.txt.

Target > File Update Mode

Choose Overwrite to create the file.

First line is column name

Set to True.

10. Click OK to close the Employee_File stage.
11. Double-click the Address_File stage. On the Properties tab, configure the
following properties that define the output file:
Table 25. Configuring the properties
Field name

Value

Target > File

Enter the path where you want the output
file to be created, followed by the file name
address.txt.

Target > File Update Mode

Choose Overwrite to create the file.

First line is column name

Set to True.

12. For the Address_File stage, do not create any columns now. You will later use
the Assembly Editor to propagate those columns automatically.
13. Click OK to close the stage properties.
14. Choose File > Save, and name the job as xml_parser_example.
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Example 1: Opening the Assembly Editor and viewing the issues
For each Hierarchical Data stage, you open the Assembly Editor, which you use to
define an XML transformation within the context of a job.

About this task
Using the Assembly Editor, you create an assembly. An assembly contains a series
of steps that parse, compose, and transform hierarchical data. By default, an
assembly contains an Overview, an Input step, and an Output step. You add
additional steps to the assembly, based on the type of transformations that you
want to perform. In this example, you add one XML_Parser step to parse XML
data into two output Sequential File stages, Employee_File and Address_File.

Procedure
1. To open the Assembly Editor, double-click the Departments stage on the
canvas. The Hierarchical Data stage editor opens. From the Hierarchical Data
stage editor, click Edit assembly to open the Assembly Editor.

2. The Assembly Outline displays the steps in the assembly. This assembly
requires an XML Parser step. Click Palette to open the palette and then
double-click the XML Parser step to add it to the outline. Because this is the
first step that you are adding to the assembly, the step is automatically added
between the Input step and the Output step. When you add another step, first
select the step above which you want the new step to be located, and then
double-click the step in the Palette. The new step is added below the selected
step.
3. Now you have created the basic assembly structure, but you still need to
configure the steps in the assembly. Before you perform the configuration,
notice that in the outline, an error icon (a red exclamation mark) displays
beside the XML Parser step and the Output step. The error icon indicates that
you must address one or more issues in that step. The total number of issues
appears in the upper-right corner of the Assembly Editor. To view the issues
list, click View All. The following figure shows the issues for this assembly:
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The XML Parser step has two errors, indicating that you must complete two
mandatory fields. The Output step has 12 errors. Notice that the errors that
require mandatory input are for the output links Employee and Address and
the columns that you defined on the Employee link. These links and columns
are listed as errors because you have not yet mapped the hierarchical structure
of the assembly back to a relational structure. The first error in the Output list
indicates the no columns were defined on the Address link. For now, you can
ignore these errors; you will correct them when you create mappings in the
Output step.
4. Close the issues list.

Example 1: Importing the schemas for the examples
Use the Schema Library Manager to import the example schemas into a library.

About this task
You must import the schemas that the example job uses. Imported schemas are
stored in the metadata repository, where they are available for use in any assembly
that you create.

Procedure
1. From the Assembly Editor, click the Libraries tab to open the Schema Library
Manager. The Schema Library Manager is available from the Assembly Editor
and from the IBM InfoSphere DataStage and QualityStage Designer client. From
the InfoSphere DataStage and QualityStage Designer client, you choose Import
> Schema Library Manager.
2. To create a library for the example schemas, click New Library. For the library
name, enter Schemas_for_XML_examples. For the category, enter Examples. The
library is now categorized under Examples. If you have additional example
schemas, you can add them to this library or create a new library for them; all
of your example schemas can be categorized under the Examples category.
3. Expand the Examples category, select Schemas_for_XML_examples, and then
click Import New Resource. Find the Employee.xsd and Organization.xsd,
import both into the library.
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Note: Multiple .xsd files can be imported at a time into the library. This can be
done by selecting multiple files in the browse window on clicking Import New
Resource.
4. Click the Assembly Editor tab to return to the assembly.

Example 1: Configuring the Overview
The Overview provides creation and modification information about the assembly
and includes a Description field that you can modify.

About this task
On the Overview, you can enter an optional description for the assembly. This field
documents the purpose of the assembly and is helpful when you or others later
need to modify the assembly.

Procedure
In the Description field, enter the following description: This assembly uses the
Organization.xsd and Employee.xsd schemas. The assembly parses the
departments.xml data file and sends the output to two files named
address.txt and employee.txt.

Example 1: Configuring the XML Parser step
Configure the location of the XML source data and the schema that you want to
use to parse it.

Procedure
1. Click the XML Parser step in the outline. By default, the Configuration tab for
the step opens. The following figure shows the Configuration tab for the step:

2. On the XML Source tab, you specify the location of the XML source data. In
this example, the XML source data is in the single file departments.xml. Select
Single file, and then click Insert Parameter and select the
xml_example_root_folder parameter. You will specify the exact location of the
file when you run the job. You can also specify the absolute path to
departments.xml.
3. On the Document Root tab, you select the schema element that describes the
documents that the step parses. Click Browse. Open the
Schemas_for_XML_examples library, which is the library into which you
imported the Organization.xsd and Employee.xsd schemas.
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4. Click to open the Organization.xsd schema, click the root element
departments, and then click OK. The Document Root tab displays the structure
of the schema. The step Output also displays this same structure.
5. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are automatically converted
to the String type.

Example 1: Configuring the Output step
In the Output step, create mappings that define how to map source items in one
data structure to target items in another data structure.

About this task
In this assembly, you use the Output step to map a hierarchical data structure to a
relational data structure.

Procedure
1. Click the Output step in the Assembly Outline to open the step. The step
displays the Output window of the Configuration tab. In the Output window,
the output table describes the data structure that is the output of the assembly.
The following figure shows the relevant columns of the output table for this
assembly:

The default view in the Output window is the Links view. The Links view
looks similar to the table that displays on the Columns tab in the Hierarchical
Data stage editor. The output structure for Employee link is shown. Notice
that the columns that you defined in the Hierarchical Data stage editor
display in the output table. In the Links view, you can modify the columns
that you already defined. Any changes that you make to the columns are
propagated to the column definitions in the Hierarchical Data stage properties.
2. From the Output Links drop-down list, select Address. The following figure
shows that the output table does not display any columns because when you
created the job, you did not define any columns for the Address link. The lack
of columns is not an error. However, if no columns are defined on the link,
you cannot map any source items in the hierarchical data structure to this
link. Because this job is designed to produce a file that contains address data,
Hierarchical data

77

you need to create the address columns. But instead of returning to the job
and manually creating columns, you can automatically create them from the
Mappings tab of the Output step.

3. Click the Mappings tab. The following figure shows the mapping table. In
this table, each item in the output structure is represented by a row in the
table. You map target items to source items. For this job, the target structure is
two links, Address and Employee, and the columns that are defined on those
links. In the Target column, the Employee link is represented as a list item.
Under the Employee list item, each column displays as a content item.

4. To create mappings, first map target list items to source list items. Then map
target content items to source content items. There are four ways to specify a
mapping: use automatic mapping, select a mapping candidate from a list of
valid mapping candidates, select a mapping candidate from the entire source
structure using More option in the drop-down list, or specify a constant value
as the mapping using Constant option in the drop-down list.
5. Select the Employee list item from the Target column. In the Source column,
click and choose employee from the drop-down list. Click Auto Map.
Automatic mapping is context-sensitive, it creates a mapping for the selected
item and all of its descendent items. Each source item that is automatically
mapped is determined based on similar name and data type.
The following figure shows the result of Auto Map for the Employee list item.
The target Employee list item and all of its child items are automatically
mapped to source items. If the Employee list item had a descendent list that
contained content items, the descendent list and all of its content items would
also be automatically mapped.
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6. In this example, the target item, BirthDate is wrongly mapped to the source
item, hireDate. You need to manually create the correct mapping. Click
hireDate in the source list to choose the correct item from the drop-down list.
The items in the list appear in order, from highest to lowest, based on their
mapping similarity. Select dateOfBirth as the right candidate for the target
item, BirthDate from the drop-down list.
7. Next you need to map the Address list item from the Target column. In the
Source column, click and choose Address from the drop-down list and click
Propagate.
Propagate automatically creates one column for each item that is a descendent
of the Address item in the source structure and automatically maps those
items to the respective items in the source column. When you use the
Propagate button to create items, the items are automatically mapped. The
following figure shows the result:

8. Look at Address item in the target structure. The child items describe the
address of an employee; however, the structure does not currently contain any
way of identifying that employee. To make the resulting data useful, you need
to add a column that identifies the employee. You can define a new column
directly in the Output step. Then when you save the assembly, the column is

Hierarchical data

79

automatically propagated back to the Address link in the job. To relate the
Employee to each Address, create an EmployeeID field in the Address list.
Follow these steps:
a. Open the Output window on the Configuration tab.
b. In the Output Links field, choose Address. The columns that are mapped
to the Address link display in the table.
c. Click the first empty row at the bottom of the table where Click to add is
displayed. Enter the item, EmployeeID in the Name field.
d. Choose VarChar in the Type field.
9. Next you must map a source item to the new target item, EmployeeID. Click
and open the Mappings window. You will see that the EmployeeID is added
to the Address list in the Target column. Manually map the EmployeeID in the
source column to the EmployeeID in the Address list of target column. In the
Source column, click and choose employeeID from the drop-down list.
If you do not see the items in the drop-down list, click More to find the
required item. The following figure shows the result of mapping:

10. Click OK to save your work and return to the Hierarchical Data stage editor.
Click the Address link in the preview window, and then click the Columns
tab to see that the EmployeeID column that you just created has been
propagated back to the job. The following figure displays the preview
window.
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11. Click OK to close the stage editor.

Example 1: Viewing the output of the job
After you run the parsing job, open the text files, and look at the output.

Procedure
1. From the Assembly Editor, click OK to return to the Hierarchical Data stage
editor. Then click OK to close the Hierarchical Data stage editor.
2. From the IBM InfoSphere DataStage and QualityStage Designer client, choose
File > Compile to compile the job.
3. Choose File > Run to run the job.
4. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you have unzipped your examples zip
file. For example, if you have downloaded and saved the examples zip file in
the directory, C:\Examples, enter this directory as the Value for the first
parameter, Root of example folder tree.
The following is an example input file that contains the employee and address
information:
- <department xmlns="" departmentID="A100" departmentKind="Division">
<manager>A7100</manager>
- <ns1:employees>
- <ns1:employee employeeID="A8990" departmentID="A100">
- <name>
<firstName>Zen</firstName>
<middleName>P</middleName>
<lastName>Wright</lastName>
</name>
<gender>male</gender>
<dateOfBirth>1980-04-04</dateOfBirth>
<title>Mr</title>
- <Address>
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
<address_type>O</address_type>
</Address>
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- <Address>
<street>2001 West Street</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78300</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2008-07-11</hireDate>

5. After the job runs, open the address.txt file and the employee.txt file to look
at the results.
The address.txt file contains this data:
"employeeID","street","city","state","country","postalCode","address_type"
"A8990","2301 East Lamar Blvd","Arlington","Texas","USA","78363","O"
"A8990","2001 West Street","Arlington","Texas","USA","78300","H"
"B6540","San Felipe, Suite 2400.","Houston","Texas","USA","77057","O"
"B6540",""53rd West Street.","Houston","Texas","USA","77000","H"
"C1230","5th South Street.","Miami","Florida","USA","32599","O"
"C1230","54th South Street","Miami","Florida","USA","32501","H"

The employee.txt file contains this data:
"LastName","MiddleName","FirstName","Gender","BirthDate","Title","HireDate",
"EmployeeID","DepartmentID"
"Wright","P","Zen","male","1980-04-04","Mr","2008-07-11","A8990","A100"
"Donald","P","Cynthia","female","1987-01-17","Miss","2000-07-25","B6540","A100"
"William","G","Tania","female","1980-01-17","Miss","2002-07-25","C1230","A100"

You can now expand or modify this example. If you look closely at the sample
XML data file, you see that you can add two additional Sequential File stages
to the job. One might store job information about each employee, such as start
date and salary; and second might store information about each department,
such as the department name, department type, and manager. After you learn
the basics of parsing by going through this basic example, you might want to
modify the job and the assembly to include these additional stages.

Example 2: Creating a hierarchical structure by using the XML
Composer and Regroup steps
You can build a job that uses the Hierarchical Data stage, XML Composer and
Regroup steps.

About this task
This example uses a single list named employee.txt and schema files named
Employee.xsd and Organization.xsd to compose an XML file. The employee.txt file
contains information about employees: employeeID, firstName, middleName,
lastName, gender, dateOfBirth, title, street, city, state, country, postalCode,
phoneNumber, addressType, and hireDate.
The Regroup step is used to create a hierarchical structure from a single list based
on the specified keys. In this example, you use two Regroup steps in the assembly
to create a parent-child list from the employee list. You then use the XML
Composer step to create an XML structure with a parent-child list created from the
employee list. The output XML file contains information about each employee and
include their office address, home address, phone number, and job details.
You can follow these steps to build the job, or you can look at the completed job,
which is named xml_regroup_example.dsx. To look at the completed job or use it as
the starting point for expanding the example, import the job from the Examples
folder into IBM InfoSphere DataStage.

82

Hierarchical Data Transformation Guide

Example 2: Setting up the job and configuring the stages
You set up an example job that includes a Hierarchical Data stage and a Sequential
File stage. You then configure columns for the Sequential File stage.

About this task
The following figure shows the job that you create for the composing example that
uses multiple Regroup steps. The job includes one Sequential File stage named
Employee_File and a Hierarchical Data stage named Employee_Details. The
Sequential File stage is linked to the Hierarchical Data stage by a link named
Employee.

Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and then click New >
Parallel job.
3. Open the File section of the palette, and drag one Sequential File stage to the
canvas.
4. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas. Position the Hierarchical Data stage to the right of the
Sequential File stage.
5. Create a job parameter for the location of the example files:
a. Click Edit > Job Properties.
b. On the Parameters page, in the Parameter Name field, enter
xml_example_root_folder, and then specify values that are shown in the
following table.
Table 26. Specifying the values for field names
Field name

Value

Prompt

Path where the file exists

Type

String

Help Text

Point to the folder tree where the file exists

6. Create a link from the Sequential File stage to the Hierarchical Data stage.
7. Rename the stages and links as shown in the following table.
Table 27. Names for job elements
Element

Name

Sequential File stage

Employee_File
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Table 27. Names for job elements (continued)
Element

Name

Hierarchical Data stage

Employee_Details

Link from the Employee_File stage to the
Employee_Details stage

Employee

8. Configure the Employee_File stage.
a. Double-click the Employee_File stage, and configure the columns that are
listed in following table on the Columns page.
Table 28. Columns for the Employee_File stage
Column name

SQL type

employeeID

VarChar

firstName

VarChar

middleName

VarChar

lastName

VarChar

gender

VarChar

dateOfBirth

Date

title

VarChar

street

VarChar

city

VarChar

state

VarChar

country

VarChar

postalCode

VarChar

phoneNumber

VarChar

addressType

Char

hireDate

Date

b. On the Properties page, define the input file, and then click OK.
Table 29. Properties for the input file
Field name

Value

Source > File

employee.txt

Options > First Line is Column Names

True

9. Click File > Save, and name the job xml_regroup_example.

Example 2: Opening the Assembly Editor and viewing the issues
You open the Assembly Editor for the Hierarchical Data stage to define an XML
transformation.

Before you begin
Import the example schemas Employee.xsd and Organization.xsd from the
Examples folder. For more information about importing the schemas, see Importing
the schemas for the examples.
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Procedure
1. Double-click the Hierarchical Data stage, and then click Edit assembly.
2. Add a Regroup step.
a. Click Palette, and then double-click the Regroup step to add it to the
outline. Because the Regroup step is the first step that you added to the
assembly, the step is added between the Input step and the Output step.
b. Click the Regroup step.
c. On the Information page, rename the step name Address_Regroup.
In the outline, an error icon (a red exclamation mark) is shown beside the
Regroup step. The error icon indicates that you must address one or more
issues in the step.
3. To view the issues list, click View All. The links and columns that you defined
on the Employee link are listed as errors because the hierarchical structure of
the assembly is not mapped to a relational structure. You can correct these
errors when you map elements in the Output step.
4. Close the issues list.
This assembly uses the default Input step, which shows the columns of the
input link named Employee that are passed to the Hierarchical Data stage. You
cannot modify the input columns, but you can view them as links or as a tree.
The following figure shows the relational structure that the Input step provides
to the Regroup step.
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Example 2: Configuring the Regroup step by using the
employeeID key
You use the Address_Regroup step to create a parent-child hierarchy between an
address and an employee list by extracting the address list from the employee list.

About this task
The Input step to the Address_Regroup step contains one list, Employee. When
you configure the Address_Regroup step, you identify parent and child lists, and
you specify the keys to base the grouping on.

Procedure
1. In the outline, click the Address_Regroup step.
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2. On the Configuration page of the Address_Regroup step, specify values for the
fields that are shown in the following table.
Table 30. Configuring the fields
Field name

Value

List to Regroup

top/InputLinks/Employee

Scope

top

The Child Items list is populated with the children of the Employee list.
3. From the Child Items list, drag the employeeID, firstName, middleName,
lastName, gender, dateOfBirth, title, and hireDate elements to the Parent Items
list to indicate that these elements are parent elements in the hierarchical
structure. The elements that remain in the Child Items list are the child
elements. Although the phoneNumber element in the Child Items list is not a
part of the Address list, you can extract the phoneNumber list in a separate
Regroup step.
4. On the Keys page, select employeeID as the key for grouping the elements in
the Parent Items list. The employeeID element is the key because it is the only
unique identifier of an employee.

Results
The output of the Address_Regroup step shows a parent-child list named
Address_Regroup:result. The Address_Regroup:result list contains elements that
are grouped based on employeeID.
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Example 2: Configuring the Regroup step by using the addressID
key
You add and configure another Regroup step to create a parent-child hierarchy
between the phoneNumber list and the address list by adding the phoneNumber
list as a child of the address list. The address list was generated by the
Address_Regroup step.

About this task
The input to the Regroup step that you add contains the output of the
Address_Regroup step. When you configure this Regroup step, you identify the
parent and child lists, and you specify the keys to base the grouping on.

Procedure
1. Add a Regroup step.
a. Click Palette, and then double-click the Regroup step to add another
Regroup step to the outline.
b. Click the Regroup step.
c. On the Information page, rename the step name phoneNumber_Regroup.
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2. On the Configuration page of the phoneNumber_Regroup step, specify values
for the fields that are shown in the following table.
Table 31. Configuring the fields
Field name

Value

List to Regroup

top/Address_Regroup:result/Employee

Scope

top/Address_Regroup:result

The Child Items list is populated with the children of the Employee list. The
particular operation of any step is performed within the list that is selected as
scope and the output of the step is shown as a child list of that list. The
Regroup step adds the phoneNumber list under the Address list.
3. From the Child Items list, drag the addressID, addressType, street, city, state,
country, and postalCode elements to the Parent Items list to indicate that these
elements are parent elements in the hierarchical structure.
4. On the Keys page, select addressID as the key for grouping the elements in the
Parent Items list.

Results
The output of the phoneNumber_Regroup step shows another parent-child list
named phoneNumber_Regroup:result. The phoneNumber_Regroup:result list
contains the address list and is grouped based on addressID, and also contains the
phoneNumber list.
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Example 2: Configuring the XML Composer step
You configure the XML Composer step to create an XML file that lists each
employee with their two addresses and the phone numbers for each address.

Procedure
1. Click Palette, and then double-click the XML_Composer step to add the XML
Composer step to the outline.
2. Specify the output file that is created from the XML Composer step.
a. On the XML Target page of the XML Composer step, select Write to File.
b. For the Output Directory field, click Insert Parameter and select
xml_example_root_folder.
c. In the Filename Prefix field, enter the name of the output file,
employee_output.
3. Select the schema element that describes the documents that the step composes.
a. On the Document Root page, click Browse, and then open the
Schemas_for_XML_examples library, which is the library where you
imported the Organization.xsd and Employee.xsd schemas.
b. Click to open the Employee.xsd schema, click the employees root element,
and then click OK. The Document Root page shows the structure of the
schema.
4. Click the Mappings tab. Each item in the output structure is represented by a
row in the mappings table.
5. Map target items in the employee list to source items:
a. In the Target column, click the employee list item.
b. In the Source column, select the Address_Regroup:result item from the list.
c. To map the selected item and all of its child items, click Map automatically.
6. Map target items in the address list to source items:
a. In the Target column, click the address list item.
b. In the Source column, select the PhoneNumber_Regroup:result item from
the list.
c. To map the selected item and all of its child items, click Map automatically.
The following figure shows the result of the mappings.
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A warning icon corresponding to the addressID element indicates that the
ID XML data type is mapped to the VarChar relational data type. In the
schema, addressID is defined as the ID XML data type. There are various
XML data types such as ID, Name, and NCName for which there is no
exact associated relational data type.
If you want to avoid the warning icon on the Mappings page, you can
select the Minimal validation option on the Validation page of the XML
Composer step. You then specify the Ignore action for the Data type has an
illegal value validation rule.
7. Click OK to close the Assembly Editor.

Example 2: Viewing the output of the job
After you run the job, open the .xml file, and look at the output.

Procedure
1. From the Assembly Editor, click OK to return to the Hierarchical Data stage
editor, and then click OK to close the Hierarchical Data stage editor.
2. To compile the job, select File > Compile from the IBM InfoSphere DataStage
and QualityStage Designer client.
3. To run the job, click File > Run.
4. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you extracted your example .zip file. For
example, if you saved the example .zip file in the C:\Examples folder, enter
this directory for the parameter, and then click OK.

Results
The job uses the information that is specified in the Regroup and Composer steps
to create a hierarchical structure, which is represented by an XML file. To view the
job results, open the employee_output.xml output file, which is in the C:\Examples
folder.
In the employee_output.xml output file, you can view the information of each
employee with their office address, home address, phone number, and job details.

Example 3: Creating a hierarchical structure by using the XML
Composer and HJoin steps
You can build a job that uses the Hierarchical Data stage, XML Composer and
HJoin steps to create a hierarchical structure.

About this task
You use the HJoin step to create a hierarchical structure from the multiple
relational data files (lists) based on the parent and child keys. This example uses
the lists employee.txt, address.txt, phoneNumber.txt, and job.txt and the schema
files Employee.xsd and Organization.xsd to compose source data into an XML file.
The employee.txt list contains information about the employees of one department
in a company: employee name, date of hire, date of birth, gender, title, department
ID, and employee ID.
The address.txt list contains employee address information: street, city, state,
postal code, country, address type (home or office), and employee ID. Each
employee has two addresses, a home address and an office address.

92

Hierarchical Data Transformation Guide

The phoneNumber.txt list contains phone number information: phone number,
employee ID, and address type.
The job.txt list contains information related to the job of the employee: job title,
start date, end date, annual salary, current job, department, ID, managerial job or
not, and employee ID.
In this example, you use three HJoin steps in the assembly to create a hierarchical
structure from the lists. Then, you use the XML Composer step to create an XML
structure based on these lists. The XML file that is created contains information for
each employee, including their office address, home address, phone number, and
job details.
The completed example job, xml_hjoin_example.dsx, is also available. To view the
complete example or use it as the starting point for expanding the example, import
the job into IBM InfoSphere DataStage.

Example 3: Setting up the job and configuring the stages
You set up an example job that includes a Hierarchical Data stage and four
Sequential File stages. You then configure the columns of the Sequential File stages.

About this task
The following figure shows the job that you create for the composing example that
uses multiple HJoin steps. The job includes four Sequential File stages named
Employee_File, Address_File, PhoneNumber_File, and Job_File. These Sequential
File stages are linked to a Hierarchical Data stage named Join_Details by four links
named Employee, Address, PhoneNumber, and Job.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and click New > Parallel
job.
3. Open the File section of the palette, and drag four Sequential File stages to
the canvas.
4. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas. Position the Hierarchical Data stage to the right of
Sequential File stages.
5. Create a job parameter for the location of the example files.
a. Click Edit > Job Properties.
b. On the Parameters page, in the Parameter Name field, enter
xml_example_root_folder and then specify values that are shown in the
following table.
Table 32. Specifying the values for field names
Field name

Value

Prompt

Path where the file exists

Type

String

Help Text

Point to the root of the file tree folder

6. Create links from the Sequential File stages to the Hierarchical Data stage.
7. Rename the stages and links as shown in the following table.
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Table 33. Names for job elements
Element

Name

Sequential File stage

Employee_File

Sequential File stage

Address_File

Sequential File stage

PhoneNumber_File

Sequential File stage

Job_File

Hierarchical Data stage

Join_Details

Link from the Employee_File stage to the
Join_Details stage

Employee

Link from the Address_File stage to the
Join_Details stage

Address

Link from the PhoneNumber_File stage to
the Join_Details stage

PhoneNumber

Link from the Job_File stage to the
Join_Details stage

Job

8. Configure the Employee_File stage.
a. Double-click the Employee_File stage, and configure the columns that are
listed in following table on the Columns page.
Table 34. Columns for the Employee_File stage
Column name

SQL type

firstName

VarChar

middleName

VarChar

lastName

VarChar

gender

VarChar

dateOfBirth

Date

title

VarChar

employeeID

VarChar

hireDate

Date

b. On the Properties page, define the input file, and then click OK.
Table 35. Properties for the input file
Field name

Value

Source > File

employee.txt

Options > First Line is Column Names

True

9. Configure the Address_File stage.
a. Double-click the Address_File stage, and configure the columns that are
listed in following table on the Columns page.
Table 36. Columns for the Address_File stage
Column name

SQL type

street

VarChar

city

VarChar

state

VarChar
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Table 36. Columns for the Address_File stage (continued)
Column name

SQL type

country

VarChar

postalCode

VarChar

addressID

VarChar

employeeID

VarChar

b. On the Properties page, define the input file, and then click OK.
Table 37. Properties for the input file
Field name

Value

Source > File

address.txt

Options > First Line is Column Names

True

10. Configure the PhoneNumber_File stage.
a. Double-click the PhoneNumber_File stage, and configure the columns that
are listed in following table on the Columns page.
Table 38. Columns for the PhoneNumber_File stage
Column name

SQL type

phoneNumber

VarChar

employeeID

VarChar

addressType

VarChar

b. On the Properties page, define the input file, and then click OK.
Table 39. Properties for the input file
Field name

Value

Source > File

phoneNumber.txt

Options > First Line is Column Names

True

11. Configure the Job_File stage.
a. Double-click the Job_File stage, and configure the columns that are listed
in following table on the Columns page.
Table 40. Columns for the Job_File stage
Column name

SQL type

jobTitle

VarChar

startDate

VarChar

endDate

VarChar

annualSalary

BigInt

currentJob

Bit

department

VarChar

id

VarChar

isManager

Bit

employeeID

VarChar

b. On the Properties page, define the input file, and then click OK.

96

Hierarchical Data Transformation Guide

Table 41. Properties for the input file
Field name

Value

Source > File

job.txt

Options > First Line is Column Names

True

12. Click File > Save, and name the job xml_hjoin_example.

Example 3: Opening the Assembly Editor and viewing the issues
You open the Assembly Editor for the Hierarchical Data stage to define an XML
transformation.

Before you begin
Import the Employee.xsd and Organization.xsd example schemas from the
Examples folder. For more information about importing the schemas, see Importing
the schemas for the examples.

Procedure
1. Double-click the Hierarchical Data stage, and then click Edit assembly.
2. Add a HJoin step.
a. Click Palette, and then double-click the HJoin step to add it to the outline.
Because the HJoin step is the first step that you added to the assembly, the
step is added between the Input step and the Output step.
b. Click the HJoin step.
c. On the Information page, rename the step name phoneNumber_HJoin.
In the outline, an error icon (a red exclamation mark) is shown beside the
phoneNumber_HJoin step. The error icon indicates that you must address one
or more issues in the step.
3. To view the issues list, click View All. The links and columns that you defined
on the Employee, Address, PhoneNumber, and Job links are listed as errors
because the hierarchical structure of the assembly is not mapped to a relational
structure. You can correct these errors when you create mapping in the Output
step.
4. Close the issues list.
This assembly uses the default Input step, which shows the columns from the
four input links that are passed to the Hierarchical Data stage. You cannot
modify the input columns, but you can view them as links or as a tree. The
following figure shows that the four lists are at the same level in the hierarchy:
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Example 3: Configuring the HJoin step by using the Address and
PhoneNumber lists
You use the HJoin step to create a parent-child hierarchy from the Address and
PhoneNumber lists.

About this task
The Input step to the phoneNumber_HJoin step contains the Address and
PhoneNumber lists. When you configure the HJoin step, you identify the parent
and child lists, and you specify keys named addressID and employeeID to use to
join the two lists together. Wherever the value of the key item is the same in both
lists, the HJoin step joins the lists.

Procedure
1. In the outline, click the phoneNumber_HJoin step.
2. On the Configuration page of the phoneNumber_HJoin step, specify the parent
list and child list, as shown in the following table.
Table 42. Values for the parent list and child list
Field name

Value

Parent List

top/InputLinks/Address

Child List

top/InputLinks/PhoneNumber

3. From the Optimization Type list, select In-memory. By using the In-memory
option, job reads the data from memory to work on the HJoin step. If you
select the Disk-based option, then the job reads the data from the disk instead
of the memory.
4. From the Parent Keys column, select top/InputLinks/Address/addressID in the
first row, and select top/InputLinks/Address/employeeID in the second row to
specify the keys based on the parent list is joined to the child list.
5. From the Child Keys column, select top/InputLinks/PhoneNumber/addressID in
the first row, and select top/InputLinks/PhoneNumber/employeeID in the second
row to specify the keys based on the child list is joined to the parent list.

Results
On the Output schema page of the phoneNumber_HJoin step, the PhoneNumber
child list is added to the Address list. The result also contains a new node named
phoneNumber_HJoin:orphans, which contains items that do not match the keys.
The following figure shows the result of the phoneNumber_HJoin step:
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Example 3: Configuring the HJoin step by using the Employee
and Address lists
You use another HJoin step to create a parent-child hierarchy from the Employee
and Address lists.

About this task
The Input step to the HJoin step contains the Employee and Address lists. When
you configure the HJoin step, you identify the parent and child lists, and then you
specify key named employeeID to use to join the two lists together. Wherever the
value of the key item is the same in both lists, the HJoin step joins the lists.
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Procedure
1. Add a HJoin step.
a. Click Palette, and then double-click the HJoin step to add another HJoin
step to the outline.
b. Click the HJoin step.
c. On the Information page, rename the step name address_HJoin.
2. On the Configuration page of the address_HJoin step, specify the parent list
and child list, as shown in the following table.
Table 43. Values for the parent list and child list
Field name

Value

Parent List

top/InputLinks/Employee

Child List

top/InputLinks/Address

3. From the Optimization Type list, select In-memory.
4. From the Parent Keys column, select top/InputLinks/Employee/employeeID to
specify the key based on the parent list is joined to the child list.
5. From the Child Keys column, select top/InputLinks/Address/employeeID to
specify the key based on the child list is joined to the parent list.

Results
On the Output schema page of the address_HJoin step, the Address child list is
added to the Employee list. The result also contains a new node named
address_HJoin:orphans, which contains items that do not match the keys. The
following figure shows the result of the address_HJoin step:
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Example 3: Configuring the HJoin step by using the Employee
and Job lists
You use another HJoin step to create a parent-child hierarchy from the Employee
and Job lists.
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About this task
The Input step to the HJoin step contains the Employee and Job lists. When you
configure the HJoin step, you identify the parent and child lists, and then you
specify key named employeeID to use to join the two lists together. Wherever the
value of the key item is the same in both the lists, the HJoin step joins the lists.

Procedure
1. Add a HJoin step.
a. Click Palette, and then double-click the HJoin step to add another HJoin
step to the outline.
b. Click the HJoin step.
c. On the Information page, rename the step name job_HJoin.
2. On the Configuration page of the job_HJoin step, specify the parent list and
child list, as shown in the following table.
Table 44. Values for the parent list and child list
Field name

Value

Parent List

top/InputLinks/Employee

Child List

top/InputLinks/Job

3. In the Optimization Type field, choose In-memory.
4. From the Parent Keys column, select top/InputLinks/Employee/employeeID to
specify the key based on the parent list is joined to the child list.
5. From the Child Keys column, select top/InputLinks/Job/employeeID to specify
the key based on the child list is joined to the parent list.

Results
On the Output schema page of the job_HJoin step, the Job child list is added to the
Employee list. The result also contains a new node named job_HJoin:orphans,
which contains items that do not match the keys. The following figure shows the
result of the job_HJoin step.
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Example 3: Configuring the XML Composer step
You configure the XML Composer step to create an XML file that lists each
employee and their two addresses.

Procedure
1. Click Palette, and then double-click the XML_Composer step to add an XML
Composer step to the outline.
2. Specify the output file that is created from the XML Composer step.
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a. On the XML Target page of the XML Composer step, select Write to File.
b. For the Output Directory field, click Insert Parameter and select
xml_example_root_folder.
c. In the Filename Prefix field, enter the name of the output file,
employee_output.
3. Select the schema element that describes the documents that the step composes.
a. On the Document Root page, click Browse, and then open the
Schemas_for_XML_examples library, which is the library where you
imported the Organization.xsd and Employee.xsd schemas.
b. Click to open the Employee.xsd schema, click the employees root element,
and then click OK. The Document Root page shows the structure of the
schema.
4. Click the Mappings tab. Each item in the output structure is represented by a
row in the mappings table.
5. Map target items in the employee list to source items:
a. In the Target column, click the employee list item.
b. In the Source column, select the Employee link from the list.
c. To map the selected item and all of its child items, click Map automatically.
The following figure shows the result of the mappings.

A warning icon corresponding to the addressID element indicates that the ID
XML data type is mapped to the VarChar relational data type. In the schema,
addressID is defined as the ID XML data type. There are various XML data
types such as ID, Name, and NCName for which there is no exact associated
relational data type.
If you want to avoid the warning icon on the Mappings page, you can select
the Minimal validation option on the Validation page of the XML Composer
step. You then specify the Ignore action for the Data type has an illegal value
validation rule.
6. Click OK to close the Assembly Editor.

Hierarchical data

105

Example 3: Viewing the output of the job
After you run the job, open the .xml file, and look at the output.

Procedure
1. From the Assembly Editor, click OK to return to the Hierarchical Data stage
editor. Then click OK to close the Hierarchical Data stage editor.
2. To compile the job, select File > Compile from the IBM InfoSphere DataStage
and QualityStage Designer client.
3. To run the job, click File > Run.
4. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you extracted your example .zip file. For
example, if you saved the example .zip file in the C:\Examples folder, enter
this directory for the parameter, and then click OK.

Results
The job uses the information that is specified in the HJoin and Composer steps to
create a hierarchical structure, which is represented by an XML file. To view the job
results, open the employee_output.xml output file.

Example 4: Using the XML Parser and Switch steps
Create a job that uses the External Source Stage, Hierarchical Data stage, and two
sequential files. The Switch step is used to filter the data.

About this task
This example uses the sample XML data files, employee1.xml and employee2.xml,
and the sample schemas, Employee.xsd and Organization.xsd, to illustrate how to
filter the data based on the predefined conditions. The employee1.xml and
employee2.xml files contain information about the employees in a department. In
this example, you use External Source stage to read the files. Then you use the
XML Parser step and the Switch step within the Hierarchical Data stage, where the
Parser step validates the XML files and the Switch step filters the files based on the
predefined conditions. The output files contain the employee information: last
name, middle name, first name, gender, birth date, title, hire date, employee ID
and department ID.
Note: In this example, the employee2.xml file is invalid. The employee2.xml file
contains the data for the element dateOfBirth as 17-01-1987. The default format for
the date is YYYY-MM-DD. As the data does not follow this format, it is invalid. In
the XML Parser step, in Validation tab, there is a rule called, Data type has an
illegal value which checks if the value specified for an element is valid. This rule
is used in this example to validate the data.
After you complete all the steps in the assembly, the Assembly Editor will look as
shown in the figure below:
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The completed example job, xml_switch_example.dsx, is also available. To look at
the completed example or use it as the starting point for expanding the example,
import it into IBM InfoSphere DataStage.
To create the example, complete these tasks:

Example 4: Creating the job
Create the Switch example job that includes one External Source stage, one
Hierarchical Data stage, and two Sequential File stages.

About this task
The following figure shows the job that you create for this Switch example. The job
includes one External Source stage named Employee_Files, one Hierarchical Data
stage named Employee_Filter, and two Sequential File stages, named
Employee_Validfile and Employee_Invalidfile. The External Source stage is linked
to the Hierarchical Data stage by a link named Employee, and the Hierarchical
Data stage is linked to two sequential files, Employee_Validfile and
Employee_Invalidfile by a link named Valid_file and Invalid_file respectively.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the File section of the palette, and drag one External Source stage to the
canvas.
4. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas. Position the Hierarchical Data stage to the right of
External Source stage.
5. Open the File section of the palette, and drag two sequential file stages to the
canvas. Position the two sequential file stages to the right of the Hierarchical
Data stage.
6. Create a link from the External Source stage to the Hierarchical Data stage,
and create links from the Hierarchical Data stage to the two sequential file
stages.
7. Rename the stages and links as shown in the following table:
Table 45. Names for job elements
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Element

Name

External Source stage

Employee_Files

Hierarchical Data stage

Employee_Filter

Link from External Source stage to
Hierarchical Data stage

Employee

First Sequential File Stage

Employee_Validfile

Second Sequential File Stage

Employee_Invalidfile

Link from Hierarchical Data stage to
Employee_Validfile

Valid_file

Link from Hierarchical Data stage to
Employee_Invalidfile

InValid_file

Hierarchical Data Transformation Guide

8. Create job properties for the location of the example files:
icon on the toolbar.
a. Click the Job Properties
b. On the Parameters tab, in the Parameter Name field, enter
xml_example_root_folder, and then specify the following values for the
first parameter.
Table 46. Specifying the values for field names
Field name

Value

Prompt

Root of example folder tree

Type

String

Help Text

Point to the root of the file tree folder

c. On the Parameters tab, in the Parameter Name field, enter file_location,
and then specify the following values for the second parameter.
Table 47. Specifying the values for field names
Field name

Value

Prompt

Location of XML files

Type

String

Default Value

ls <Enter_the_location_of_the_zip>/xml_examples/
switch_step/example1/input_files/*.xml

Help Text

The location of the input files.

d. Click OK.
9. Double-click the External Source stage to configure the stage properties.
10. Click the Properties tab, and select Source > Source Program. Enter the path
for the input files, in the Source Program field. You can use the parameter,
file_location to specify the location of the input files.
Note: The External Source stage returns the absolute location of the xml files.
For example, if your data files (employee1.xml and employee2.xml) are in the
C:\Test\ directory, the output of the External Source stage will be
C:\Test\employee1.xml and C:\Test\employee2.xml.
11. Click the Columns tab, and create these columns:
Table 48. Columns for the Employee_Files stage
Column name

SQL type

employee_file_list

VarChar

12. Click OK.
13. By looking at the input file, employee1.xml, which contains the XML data,
you determine which columns to create to hold the employee data that the
Hierarchical Data stage will pass to the Employee_Validfile stage and the
Employee_Invalidfile stage.
14. Double-click the Employee_Validfile stage to configure the stage properties.
15. Click the Properties tab, and configure the following properties that define the
output file:
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Table 49. Configuring the properties
Field name

Value

Target > File

Enter the path to where you want the
output file to be created, followed by the file
name for example, valid_emp.txt.

Target > File Update Mode

Choose Overwrite to create the file.

First line is column name

Set to True.

16. Click the Columns tab, and create these columns:
Table 50. Columns for the Employee_Validfile stage
Column name

SQL type

Length

LastName

VarChar

40

MiddleName

VarChar

40

FirstName

VarChar

40

Gender

VarChar

BirthDate

VarChar

Title

VarChar

HireDate

Date

EmployeeID

VarChar

DepartmentID

VarChar

17. Click OK to close the Employee_Validfile stage.
18. Double-click the Employee_Invalidfile stage to configure the stage properties.
19. Click the Properties tab, and configure the following properties that define the
output file:
Table 51. Configuring the properties
Field name

Value

Target > File

Enter the path to where you want the
output file to be created, followed by the file
name for example, InValid_emp.txt.

Target > File Update Mode

Choose Overwrite to create the file.

First line is column name

Set to True.

20. Click the Columns tab, and create these columns:
Table 52. Columns for the Employee_Invalidfile stage
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Column name

SQL type

Length

LastName

VarChar

40

MiddleName

VarChar

40

FirstName

VarChar

40

Gender

VarChar

BirthDate

VarChar

Title

VarChar

HireDate

Date

EmployeeID

VarChar
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Table 52. Columns for the Employee_Invalidfile stage (continued)
Column name

SQL type

DepartmentID

VarChar

Length

21. Click OK to close the Employee_Invalidfile stage.
22. Choose File > Save , and name the job as xml_switch_example.

Example 4: Creating the assembly
Use the XML Parser stage to parse the XML files, the Switch step to separate input
files into valid and invalid files, and the Output step to map the data to the
sequential files.

Before you begin
Import the example schemas employee.xsd and organization.xsd. If you have
already built any of the previous examples, you have imported the schemas as part
of that example. For more information about importing the schemas, see Importing
the schemas for the examples.

Procedure
1. Double-click the Hierarchical Data stage to open the stage properties.
2. Click the Edit assembly to open the Assembly Editor.
3. Open the Palette, and then double-click the XML_Parser Step to add it to the
Assembly Outline.
4. Select the XML_Parser Step, and then from the palette, double-click the Switch
Step to add it below the XML_Parser Step in the Assembly Outline.
5. On the Overview, in the Description field, enter the following description: This
assembly uses the Organization.xsd and Employee.xsd schemas. The
XML_Parser Step reads xml files, the Switch Step filters the files, and
the Output Step maps the files into two sequential files.

Example 4: Configuring the XML Parser step
Configure the location of the XML source data and the schema that you want to
use.

Procedure
1. Click the XML Parser step in the Assembly Outline. By default, the
Configuration tab for the step opens. The following figure shows the
Configuration tab for the step:
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2. On the XML Source tab, specify the location of the XML source data. In this
example, the XML source data is in multiple files, employee1.xml and
employee2.xml. Select File set, and choose the value from the list. The value is
top/InputLinks/Employee/employee_file_list where employee_file_list is the
column specified in the External Source stage.
3. On the Document Root tab, select the schema element that describes the
documents that the step parses.
a. Click Browse, and then open the Schemas_for_XML_examples library,
which is the library into which you imported the Organization.xsd and
Employee.xsd schemas.
b. Click to open the Employee.xsd schema, click the root element employees,
and then click OK. The Document Root tab displays the structure of the
schema. The step Output also displays this same structure.
4. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are automatically set to the
String type.
5. In Value Validation, set the Data type has an illegal value rule to 'Reject'.
When you select the action as 'Reject', the Output schema displays two
elements named success and message in XML_Parser: ParserStatus. If the XML
file is valid, the 'success' will hold the parsing status as 'True' and if the XML
file is invalid, it holds the value 'False'. The 'message' will hold the reason for
the parsing failure if the 'success' is 'False'. The Data type has an illegal value
rule checks if the values specified for each of the elements in the XML file is
valid and within the specified range for that data type.
Note: In this example, the employee2.xml file is invalid. The employee2.xml
file contains the data for the element dateOfBirth as 17-01-1987. The default
format for the date is YYYY-MM-DD. As the data does not follow this format, it
is invalid and the 'success' will hold the value 'False'.
The following figure shows the Output Schema of the Parser step:
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Example 4: Configuring the Switch step
Use the Switch step to separate the input files into valid and invalid files.
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About this task
With the Switch step you classify elements from the input files and place them into
new target lists. Each target list is associated with the criteria that you specify. You
can use multiple criteria in the target list. The data that passes the criteria is placed
in the corresponding target list and the default list will contain the data that fails
all the other criteria.

Procedure
1. On the Configuration tab of the Switch step, configure these fields:
Table 53. Configuring the fields
Field name

Value

List to Categorize

Select top/InputLinks/Employee. This is the list
that contains the items on which you specify the
criteria.

Scope

Choose top.

2. Select Add Target. In the New Target Constraint window, configure these fields:
v Specify the Target Name. In this example you specify the name as valid_file.
v Select the element in the Filter Field as 'success'.
v Select the function as 'IsTrue'.

Results
The Output step contains a new node named Switch:filtered, which contains two
lists. The valid data is placed in the valid_file list and the invalid data is placed in
the default list. The following figure shows this portion of the step Output.

114

Hierarchical Data Transformation Guide

Hierarchical data

115

Example 4: Configuring the Output step
In the Output step, create mappings that define how to map source items in one
data structure to target items in another data structure.

About this task
In this assembly, you use the Output step to map a hierarchical data structure to a
relational data structure.

Procedure
1. Click the Output Step in the Assembly Outline to open the step. The step
displays the Configuration tab in the Output Step window. In the Output
window, the output table describes the data structure that is the output of the
assembly. The following figure shows the relevant columns of the output table
for this assembly:

The default view in the Output window is the Links view. The Links view
looks similar to the table that displays on the Columns tab in the Hierarchical
Data stage editor. The output structure for Valid_file link is shown above. In
the Links view, you can modify the columns that you already defined. Any
changes that you make to the columns are propagated to the column
definitions in the Sequential file.
2. From the Output Links drop-down list, select Invalid_file. The output structure
for Invalid_file link is shown below.
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3. Click the Mappings tab. The following figure shows the mapping table. In this
table, each item in the output structure is represented by a row in the table.
You map target items to source items. For this job, the target structure has two
links, Valid_file and Invalid_file, and the columns that are defined on those
links. In the Target column, the Valid_file and Invalid_file links are represented
as a list item and each column displays as a content item.
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4. To create mappings, first map target list items to source list items. Then map
target content items to source content items. Select the Valid_file list item in the
Target list and then in the Source select from the drop-down list,
top/Switch:filtered/valid_file/XML_Parser:result/tns:employees/employee
and click Auto Map.
The following figure shows the results of the automatic mapping for the
Valid_file.
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5. Next you need to map the Invalid_file list item. Select the Invalid_file list item
in the Target list and then in the Source select from the drop-down list,
top/Switch:filtered/default/XML_Parser:result/tns:employees/employee and
click Auto Map.
The following figure shows the results of the automatic mapping for the
Invalid_file.

When you map the Source items from the Suggestion list, you see only the
relative path. To view the entire path you can hover over each element.
6. Click OK to close the assembly editor.
7. Click OK to close the Stage Editor.
8. Save the job.

Example 4: Viewing the output of the job
After you run the switch job, open the text files, and look at the output.
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Procedure
1. From the IBM InfoSphere DataStage and QualityStage Designer client, choose
File > Compile to compile the job.
2. Choose File > Run to run the job.
3. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you have unzipped your examples zip
file. For example, if you have downloaded and saved the examples zip file in
C:\Test folder, enter this directory as the Value for the first parameter, Root of
example folder tree.
4. For the second parameter, after ls, change only the text within braces to specify
the path to the directory where you saved the example files. For example, if
you have placed the example files in C:\Test folder, specify ls
C:\Test\xml_examples\switch_step\example1\input_files\*.xml.
5. Click Run.
6. After the job runs, open the Valid_file.txt file and the Invalid_file.txt file
to look at the results.
The Valid_file.txt file contains this data:
"firstName","middleName","lastName","gender","dateOfBirth","title","hireDate",
"employeeID","departmentID"
"Zen","P","Wright","male","1980-04-04","Mr","2008-07-11","A8990","A100"

The Invalid_file.txt file contains this data:
"firstName","middleName","lastName","gender","dateOfBirth","title","hireDate",
"employeeID","departmentID"
"Cynthia","P","Donald","female","17-01-1987","Miss","2000-07-25","B6540","A100"

Example 5: Using the XML Parser and Union steps
Create a job that uses the Hierarchical Data stage and a Sequential file stage. The
Union step is used to combine two lists into a single list.

About this task
This example uses the sample XML data files, employee1.xml and employee2.xml,
and multiple sample schemas, to illustrate how to combine the two lists into a
single list that has a predefined structure. The employee1.xml and employee2.xml
files contain information about the employees in a department. In this example,
use the XML Parser steps within the Hierarchical Data stage to parse the files.
Then you use the Union step within the Hierarchical Data stage, to combine two
lists into a single file. The XML Composer step is used to compose a XML file that
contains the employee information. The output step maps the employee
information to a single column in the sequential file.
After you complete all the steps in the assembly, the Assembly Editor will look as
shown in the figure below:
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The completed example job, xml_union_example.dsx, is also available. To look at
the completed example or use it as the starting point for expanding the example,
import it into IBM InfoSphere DataStage.
To create the example, complete these tasks:

Example 5: Creating the job
Create the job that includes a Hierarchical Data stage, and a Sequential File stage.

About this task
The following figure shows the job that you create for the Union example. The job
includes a Hierarchical Data stage named Employees, and a Sequential File stage
named Employees_File. The Hierarchical Data stage is linked to a Sequential file
stage by a link named Employee_Union.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the Real Time section of the palette, and drag Hierarchical Data stage to
the canvas.
4. Create job properties for the location of the example files:
a. Choose the Edit > Job Properties.
b. On the Parameters tab, in the Parameter Name field, enter
xml_example_root_folder and then specify the following values:
Table 54. Specifying the values for field names
Field name

Value

Prompt

Root of example folder tree

Type

String

Help Text

Point to the root of the file tree folder

5. Open the File section of the palette, and drag a Sequential File stage to the
canvas. Position this stage to the right of the Hierarchical Data stage.
6. Create a link from the Hierarchical Data stage to the Sequential file stage.
7. Rename the stages and link as shown in the following table:
Table 55. Names for job elements
Element

Name

Hierarchical Data stage

Employees

Link from Hierarchical Data stage to
Sequential File stage

Employee_Union

Sequential File stage

Employees_File

8. Double-click the Employees_File stage to configure the stage properties.
9. Click the Properties tab, and configure the following properties that define the
output file:
Table 56. Configuring the properties
Field name

Value

Target > File

Enter the path where you want the output
file to be created, followed by the file name
employees_output.xml.

Target > File Update Mode

Choose Overwrite to create the file.

10. Click the Format tab. Right-click the field Quote = double, and select
Remove.
11. For the Employees_File stage, do not create any columns now. You will later
use the Assembly Editor to propagate the columns automatically.
12. Click OK to close the Employees_File stage.
13. Choose File > Save , and name the job as xml_union_example.

Example 5: Importing the schemas for the Union example
Use the Schema Library Manager to import the example schemas into the library.
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About this task
You must import the schemas that the example job uses. Imported schemas are
stored in the metadata repository, where they are available for use in any assembly
that you create.

Procedure
1. Double-click the Hierarchical Data stage to open the stage properties, and then
click Edit assembly to open the Assembly Editor.
2. From the Assembly Editor, click Libraries tab to open the Schema Library
Manager. You can either use Schema Library Manager from the Assembly
Editor or choose Import > Schema Library Manager from the IBM InfoSphere
DataStage and QualityStage Designer client.
3. To create a library for the example schemas, click New Library. In the New
Contract Library window, specify Schemas_for_XML_example for the library
name and Example for the category. The library is now categorized under
Example.
Note: If you have already built the previous examples, the library
Schemas_for_XML_example has been created and you need not perform the
step 3.
4. Similarly, create two more libraries, Schemas_for_XML_example1 and
Schemas_for_XML_example2 with the categories Example1, and Example2
respectively. The library is now categorized under Example1, and Example2.
5. Expand the category Example, select the library, Schemas_for_XML_example,
and then click Import New Resource. Browse to find the Employee.xsd schema.
Select the schema and then click OK. Repeat this process to import the
Organization.xsd schema. Similarly, import Employee1.xsd and
Organization1.xsd for the library, Schemas_for_XML_example1, and
Employee2.xsd and Organization2.xsd for the library,
Schemas_for_XML_example2.
The following schemas are located in the respective folders as shown:
Table 57. Schema location
Schema

Folder

Employee.xsd and Organization.xsd

xml_examples\schemas

Employee1.xsd, Organization1.xsd, and
Employee2.xsd, Organization2.xsd

xml_examples\union_step\example1\
union_schemas

6. If you have imported only one schema for example, Employee.xsd and have
not imported the other schema, Organization.xsd, then an error message is
displayed indicating that the library has failed validation. The error indicates
that the Employee.xsd schema cannot resolve the element JobType that has
been defined in the Organization.xsd schema, which you have not yet
imported. Repeat the import process to import the Organization.xsd schema.
The library passes the validation.
Similar issues might appear for the other schemas, Employee1.xsd,
Organization1.xsd, and Employee2.xsd, Organization2.xsd, if you have
imported only one schema among these.
Note: Multiple .xsd files can be imported at a time into the library. This can be
done by selecting multiple files in the browse window on clicking Import New
Resource.
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7. Click OK to close the Assembly Editor.
8. Click OK to close the Stage Editor.
9. Choose File > Save.

Example 5: Creating the assembly
In the assembly, you add the Parser, Union, and Composer steps where the Parser
parses the xml files, Union combines the files into a single file and the Composer
composes the XML file.

Before you begin
You have already imported the schemas in the previous step, Example 5: importing
the schemas for the Union example.

Procedure
1. Double-click the Hierarchical Data stage to open the stage properties, and then
click Edit assembly to open the Assembly Editor.
2. Open the Palette, and then double-click the XML_Parser Step to add it to the
Assembly Outline.
3. Select the XML_Parser Step, and then from the palette, double-click to add
another parser step below XML_Parser Step. This time it will be named as
XML_Parser_1 Step.
4. Select the XML_Parser_1 Step, and then from the palette, double-click the
Union Step to add it below the XML_Parser_1 Step.
5. Select the Union Step, and then from the palette, double-click the
XML_Composer Step to add it below the Union Step.
6. On the Overview, in the Description field, enter the following description: In
this assembly, the XML_Parser Step reads xml files, the Union Step
combines the two files, the Composer Step composes the xml file, and the
Output Step writes the xml file into a sequential file.

Example 5: Configuring the first XML Parser step
Configure the location and the schema of the first XML source data that you want
to parse.

Procedure
1. Click the XML_Parser step in the Assembly Outline. By default, the
Configuration tab for the step opens. The following figure shows the
Configuration tab for the step:
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2. On the XML Source tab, you specify the location of the XML source data. In
this example, the XML source data is in a single file, employee1.xml. Select
Single file and then click Insert Parameter, and select the
xml_example_root_folder parameter. You need to specify the exact location of
the file when you run the job. Enter the complete location of the XML input file
as, #xml_example_root_folder#/xml_examples/union_step/example1/
input_files/employee1.xml.
3. On the Document Root tab, you select the schema element that describes the
documents that the step parses. Click Browse. Open the
Schemas_for_XML_example1 library, which is the library into which you have
imported the Organization1.xsd and Employee1.xsd schemas.
4. Click to open the Employee1.xsd schema, click the root element Employee_List,
and then click OK. The Document Root tab displays the structure of the
schema. The step Output also displays this same structure.
5. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are automatically converted
to the String type.
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Example 5: Configuring the second XML Parser step
Configure the location and the schema of the second XML source data that you
want to parse.

Procedure
1. Click the XML_Parser_1 Step in the Assembly Outline. By default, the
Configuration tab for the step opens. The following figure shows the
Configuration tab for the step:

2. On the XML Source tab, you specify the location of the XML source data. In
this example, the XML source data is in a single file, employee2.xml. Select
Single file and then click Insert Parameter, and select the
xml_example_root_folder parameter. You need to specify the exact location of
the file when you run the job. Enter the complete location of the XML input file
as, #xml_example_root_folder#/xml_examples/union_step/example1/
input_files/employee2.xml.
3. On the Document Root tab, you select the schema element that describes the
documents that the step parses. Click Browse. Open the
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Schemas_for_XML_example2 library, which is the library into which you have
imported the Organization2.xsd and Employee2.xsd schemas.
4. Click to open the Employee2.xsd schema, click the root element
Dep_Employees_List, and then click OK. The Document Root tab displays the
structure of the schema. The step Output also displays this same structure.
5. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are automatically set the
String type.

Example 5: Configuring the Union step
Use the Union step to combine two lists to create a single list.

About this task
In the Union step you select the target schema definition from the Contract
Libraries and then map the target schema to the source schema in the mapping
table.

Procedure
1. On the Configuration tab of the Union step, configure these fields:
v Union Type – Click Browse to open the library, Schema_for_XML_example.
v Expand Employee, and select the root element, employee.
v Click OK.
The Union Type tab displays the structure of the employee schema.
2. Click the Mappings tab.
3. To create mappings, first map target list items to source list items.
4. On the Source, corresponding to the left list, click to choose EmployeeInfo from
the Suggestions list or drop-down list.
5. Click Auto Map. The Employee and Address information is mapped for the left
list. The following figure shows the result of Auto Map for the left list. The
target left list item and all of its child items are automatically mapped to source
items.
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6. You will see that the target item, dateOfBirth is wrongly mapped to the source
item, hireDate. You need to update this entry to create the correct mapping.
Click hireDate in the Source list to choose the correct item from the drop-down
list. The items in the list appear in order, from highest to lowest, based on their
mapping scores. Select DOB as the right candidate for the target item,
dateOfBirth from the drop-down list.
7. You will also see that the address fields are not mapped correctly in the Source
column. Make sure to map all the fields correctly and they are available in the
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output. If you see the incorrect mapping in the Source column, click the pencil
icon in the Source list for that item, and then click More to display a list of
choices. Click and choose the appropriate field from the drop-down list to map
the item. Following table shows the target items and the corresponding source
items that you need to manually map to:
Table 58. Corresponding source items to the target items
Source items

Target items

street_name

street

city_name

city

state_name

state

country_name

country

8. On the Source, corresponding to the right list, click to choose Dept_Employee
from the Suggestions list or drop-down list.
9. Click Auto Map. The Employee and Address information is mapped for the
right list.
As seen above, you can map two different schema structures to a common
schema structure in the Union step. The common schema structure is the one
that you define in the Union Type tab. In the Mappings tab, the left and right
lists have this common structure and you can map each of these lists to
different schema structures in the Source view. In this example, two different
schema structures are used in the parser. In the first parser, the EmployeeInfo
list contains the employee information and in the second parser,
Dept_employee list also contains the employee information. You can map the
EmployeeInfo list to the left list and Dept_employee list to the right list in the
Mappings tab. The following figure shows this view.
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Results
The step output contains a new node named Union:result. The structure of the
Union:result is same as the structure that is defined in the Union Type. The
following figure shows this portion of the step output.

Example 5: Configuring the XML Composer step
Configure the XML Composer step to create a XML file of the employees in a
department.

Hierarchical data

131

Procedure
1. In the XML Target window of the XML Composer step, choose Pass as String.
This passes the composed XML string to a downstream step or stage for further
processing.
2. In the Document Root window, select the schema element that describes the
documents that the step composes:
a. Click Browse, and then open the Schemas_for_XML_examples library,
which is the library into which you imported the Organization.xsd and
Employee.xsd schemas.
b. Click to open the Employee.xsd schema, click the root element employees,
and then click OK. The Document Root tab displays the structure of the
schema.
3. On the Validation tab, by default Strict validation is selected. You need not
make any changes to the fields in this tab.
4. In the Union step, you combined two lists into a single hierarchical list. Now in
the Composer step, on the Mappings tab, map the items from the target
schema to the items in the Union:result list. To create the mappings, perform
the following steps:
a. Map top/Union:result in the Source list to the employee item in the Target
list, and then click Automap.
b. Using automatic mapping, you map each item from the Union:result list to
the employee list.
c. Evaluate all the items to see if the correct mapping is done. It is seen that
the mapping is done correctly.
5. On the Format tab, default encoding is UTF-8. You need not change this field.
6. Select the Format Style and configure the following fields.
a. In the Indentation length field, select the number of characters to use for
each indentation level in the XML output.
b. In the New Line Style field, select the type of new line. Choices are UNIX
(LF), DOS(CRLF) or MAC(CR).

Results
The step Output contains a new node, named XML_Composer:result. This node
carries the entire hierarchical data during runtime. The following figure shows the
output of the XML Composer step.

Example 5: Configuring the Output step
In the Output step, you create the mappings that define how to map target items
in one data structure to source items in another data structure.

About this task
In this assembly, you use the Output step to map the output of the composer to a
sequential file.
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Procedure
1. Click the Output Step in the Assembly Outline to open the step. The step
displays the Configuration tab in the Output Step window.

The default view in the Output window is the Links view. The output structure
for Employee_Union link is shown. The above figure shows that the output
table does not display any columns because when you created the job, you did
not define any columns for the Employee_Union link. The lack of columns is
not an error. However, if no columns are defined on the link, you cannot map
any source items in the hierarchical data structure to this link.
The composer output, result-string is a single column that contains the
employee data and you need to create that single column in this step. But
instead of returning to the job and manually creating the column, you can
automatically create it from the Mappings tab of the Output step.
2. Click the Mappings tab. The following figure shows the mapping table. In this
table, each item in the output structure is represented by a row in the table.
You map target items to source items. For this job, the target structure has a
single link, Employee_Union, and no columns are defined for this link. In the
Target column, the Employee_Union link is represented as a list item.

3. Next you need to map the Employee_Union list item. Select the
Employee_Union item. For this item, in the Source, select top from the
Suggestion list, and click Propagate. The Propagate automatically creates one
column for each item that is a descendent of the top item in the source
structure. When you use the Propagate button to create items, the items are
automatically mapped. The following figure shows the result.
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4. Click OK to close the assembly editor.
5. Click OK to close the Stage Editor.
6. Save the job.

Example 5: Viewing the output of the job
After you run the Union job, open the text file, and look at the output.

Procedure
1. From the IBM InfoSphere DataStage and QualityStage Designer client, choose
File > Compile to compile the job.
2. Choose File > Run to run the job.
3. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you have unzipped your examples zip
file. For example, if you have downloaded and saved the examples zip file in
directory, C:\Examples, enter this as the Value for the first parameter, Root of
example folder tree.
4. Click Run.
5. After the job runs, open the employees_output.xml file to look at the results.
The employees_output.xml file contains this data:
<?xml version="1.0" encoding="UTF-8"?><prn:employees
xmlns:prn="http://ibm.com/infosphere/xml/Employee">
<prn:employee employeeID="B6540" departmentID="A100">
<name>
<firstName>Cynthia</firstName>
<middleName>P</middleName>
<lastName>Donald</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1987-01-17</dateOfBirth>
<title>Miss</title>
<Address>
<street>San Felipe Suite 2400</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77057</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>53rd West Street</street>
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<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77000</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2000-07-25</hireDate>
</prn:employee>
<prn:employee employeeID="A8990" departmentID="A100">
<name>
<firstName>Zen</firstName>
<middleName>P</middleName>
<lastName>Wright</lastName>
</name>
<gender>male</gender>
<dateOfBirth>1980-04-04</dateOfBirth>
<title>Mr</title>
<Address>
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>2001 West Street</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78300</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2008-07-11</hireDate>
</prn:employee>
</prn:employees>

Example 6: Using the XML Composer and H-Pivot steps
Create a job that uses a Sequential file stage and the Hierarchical Data stage. The
H-Pivot step is used to combine multiple fields into a single list.

About this task
This example is used to convert the relational file, address.txt into a XML file.
The address.txt contains address information of the employees in an organization.
Using the H-Pivot step you can map multiple fields into a single list. Use the XML
Composer step to create a hierarchical structure that contains employee address
information. The output step maps the address information to a single XML file.
The job includes one Sequential File stage, named Address_file, and a Hierarchical
Data stage, named Address_compose. The Sequential file stage is linked to a
Hierarchical Data stage by a link named Address.
After you complete all the steps in the assembly, the Assembly Editor will look as
shown in the figure below:
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The completed example job, xml_hpivot_example.dsx, is also available. To look at
the completed example or use it as the starting point for expanding the example,
import it into IBM InfoSphere DataStage.
To create the example, complete these tasks:

Example 6: Creating the job
Create the example job that includes one Sequential File stage and a Hierarchical
Data stage.

About this task
The following figure shows the job that you create for the H-Pivot example. The
job includes one Sequential File stage named Address_file, and a Hierarchical Data
stage named Address_compose. The Sequential file stage is linked to a Hierarchical
Data stage by a link named Address.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the File section of the palette, and drag a Sequential File stage to the
canvas.
4. Open the Real Time section of the palette, and drag Hierarchical Data stage to
the canvas. Position this stage to the right of the Sequential File stage.
5. Perform the following steps to create a job property for the location of the
example files:
a. Choose Edit > Job Properties.
b. On the Parameters tab, in the Parameter Name field, enter
xml_example_root_folder and then specify the following values:
Table 59. Specifying the values for field names
Field name

Value

Prompt

Root of example folder tree

Type

String

Help Text

Point to the root of the file tree folder

Each example uses this job parameter.
6. Create a link from the Sequential File stage to the Hierarchical Data stage.
7. Rename the stages and links as shown in the following table:
Table 60. Names for job elements
Element

Name

Sequential File stage

Address_file

Hierarchical Data stage

Address_compose

Link from Sequential File stage to
Hierarchical Data stage

Address

8. Click OK.
9. Configure the Address_file stage. Double-click the Address_file stage to open
the stage properties.
10. Click the Properties tab, and configure the following properties that define the
output file:
Table 61. Configuring the properties
Field name

Value

Source > File

Enter the path and file name of the file. For
the Address_file stage, the file name is
address.txt

Source > Read Method

Select Specific File

Options > First Line is Column Names

Select True

11. Click the Columns tab, and create these columns:
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Table 62. Columns for the Address_file stage
Column name

SQL type

street

VarChar

city

VarChar

state

VarChar

country

VarChar

postalCode

VarChar

phonenumber1

VarChar

phonenumber2

VarChar

address_type

VarChar

12. Click OK to close the stage properties.
13. Choose File > Save , and name the job as xml_hpivot_example.

Example 6: Creating the assembly
Use the H-Pivot step to combine multiple fields into a single list.

Before you begin
Make sure that you have already imported the example schemas Employee.xsd
and Organization.xsd. If you have built the XML Parser example, you have
imported the schemas as part of that example. For more information about
importing the schemas, see Importing the schemas for the examples.

Procedure
1. Double-click the Hierarchical Data stage to open the stage properties, and then
click Edit assembly to open the Assembly Editor.
2. Open the Palette, and then double-click the H-Pivot Step to add it to the
Assembly Outline.
3. Select the H-Pivot Step, and then from the palette, double-click the
XML_Composer step to add it below the H-Pivot step
4. On the Overview, in the Description field, enter the following description: This
assembly uses the Organization.xsd and Employee.xsd schemas. In the
H-Pivot step you combine multiple fields into a list. The XML_Composer
step composes the data and saves the output in a file named
address_output.

Example 6: Configuring the H-Pivot step
Use the H-Pivot step to transform fields or items into a list.

About this task
With the H-Pivot step you combine multiple fields into a list. This helps in
mapping multiple fields into a single list in the composer.

Procedure
1. On the Configuration tab of the H-Pivot step, configure the field:
Table 63. Configuring the field
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Field name

Value

Scope

Choose Address.
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Note: The list that you select as the Scope contains the fields that need to be
transformed into a list.
2. Click and select the field, phonenumber1 from the drop-down list.
3. Click and select the field, phonenumber2 again from the drop-down list.

Results
The following figure shows the output of the H-pivot on the Output tab.

The output of the H-Pivot contains the list named rows. The rows include two
fields, name and value. The name represents the name of the field that you have
defined in the H-Pivot and the value holds the data for the corresponding names.
In this example, the field name contains phonenumber1 and phonenumber2, and
the field value contains the data related to the name.

Example 6: Configuring the XML Composer step
Configure the XML Composer step to create a XML file containing address
information.

Procedure
1. In the XML Target window of the XML Composer step, choose Write to File.
For the Output Directory, click Insert Parameter, and then select
xml_example_root_folder. For the Filename Prefix, enter address_output.
2. In the Document Root window, select the schema element that describes the
documents that the step composes:
a. Click Browse, and then open the Schemas_for_XML_examples library,
which is the library into which you imported the Organization.xsd and
Employee.xsd schemas.
b. Click to open the Employee.xsd schema, click the root element addresses,
and then click OK. The Document Root tab displays the structure of the
schema.
3. On the Validation tab, by default Strict validation is selected. You need not
make any changes to the fields in this tab.
4. On the Mappings tab, map the items from the target schema to the items in the
address list. To create the mappings, perform the following steps:
a. Map top/InputLinks/Address in the Source list to the address item in the
Target list, and then click Automap.
b. Using automatic mapping, you create the majority of the mappings that you
need, but you also create some mappings that you do not need. For
example, the name is mapped to e2res:text(), which is not a correct mapping
and you need to change this to value.
c. The following figure shows the mapping.
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5. Notice that the H-Pivot:result/rows is mapped to the list, phoneNumber. In
H-Pivot step, you have combined the fields, phonenumber1 and phonenumber2
into a single list, rows and the data is stored in the field, value. Hence the
H-pivot step allows you to map two relational fields in the input to a single list
in the composer.
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Results
The following figure shows the results of the mapping:

Example 6: Viewing the output of the job
After you finish building the assembly, run the job and look at the output.

Procedure
1. From the IBM InfoSphere DataStage and QualityStage Designer client, choose
File > Compile to compile the job.
2. Choose File > Run to run the job.
3. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you have unzipped your examples zip
file. For example, if you have downloaded and saved the examples zip file in
the directory, C:\Examples, enter this as the Value for the first parameter, Root
of example folder tree.
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4. Click Run.
5. After the job runs, open the address_output.xml file to look at the results. The
address_output.xml file contains this data:
<?xml version="1.0" encoding="UTF-8"?>
<tns:addresses xmlns:tns="http://ibm.com/infosphere/xml/Employee">
<tns:address>
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
<phoneNumber>1-234-234-4567</phoneNumber>
<phoneNumber>1-234-234-4566</phoneNumber>
<address_type>O</address_type>
</tns:address>
<tns:address>
<street>2001 West Street</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78300</postalCode>
<phoneNumber>1-876-456-4321</phoneNumber>
<phoneNumber>1-876-456-4320</phoneNumber>
<address_type>H</address_type>
</tns:address>
<tns:address>
<street>San Felipe Suite 2400</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77057</postalCode>
<phoneNumber>1-965-234-1234</phoneNumber>
<phoneNumber>1-965-234-1235</phoneNumber>
<address_type>O</address_type>
</tns:address>
<tns:address>
<street>53rd West Street</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77000</postalCode>
<phoneNumber>1-000-000-8765</phoneNumber>
<phoneNumber>1-000-000-8764</phoneNumber>
<address_type>H</address_type>
</tns:address>
<tns:address>
<street>5th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32500</postalCode>
<phoneNumber>1-999-999-0989</phoneNumber>
<phoneNumber>1-999-999-0979</phoneNumber>
<address_type>O</address_type>
</tns:address>
<tns:address>
<street>54th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32501</postalCode>
<phoneNumber>1-567-654-7890</phoneNumber>
<phoneNumber>1-567-654-7891</phoneNumber>
<address_type>H</address_type>
</tns:address>
</tns:addresses>
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Example 7: Using the XML Parser and Aggregate steps
In this example, create a job that uses the Hierarchical Data stage and a Sequential
file stage. The Aggregate step is used to perform hierarchical aggregations on the
items in a list. For example, use it to concatenate the data, count the number of
items in the list, and look for the first and last element in the list of items.

About this task
This example uses the sample XML data file, departments.xml, and the sample
schemas, Employee.xsd and Organization.xsd, to illustrate parsing source data
from one XML file into a sequential file. The departments.xml file contains
information about the employees of various departments in a company. In this
example, you parse the XML data into a sequential file. The file contains employee
business and address information. The employee business information contains the
details such as employee name, date of hire, date of birth, gender, title, employee
ID, and department ID. The employee address information contains employee ID,
street, city, state, postal code, country, and address type.
After you complete all the steps in the assembly, the Assembly Editor will look as
shown in the following figure.

The completed example job, xml_aggregate_example.dsx, is also available. To look
at the completed example or use it as the starting point for expanding the example,
import it into IBM InfoSphere DataStage.
To create the example, complete these tasks:

Step 7.1: Creating the job
Create the job that includes an Hierarchical Data stage and a Sequential File stage.
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About this task
The following figure shows the job that you create for the Aggregate example. The
job includes an Hierarchical Data stage named Employees and a Sequential File
stage named Employee_File. The Hierarchical Data stage is linked to a Sequential
file stage by a link named Employees_Aggregate.

Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the Real Time section of the palette, and drag Hierarchical Data stage to
the canvas.
4. Create job properties for the location of the example files:
a. Choose Edit > Job Properties.
b. On the Parameters tab, in the Parameter Name field, enter
xml_example_root_folder and then specify the following values:
Table 64. Specifying the values for field names
Field name

Value

Prompt

Points to the location of the example folder

Type

String

Help Text

Points to the location of the example folder

5. Open the File section of the palette, and drag a Sequential File stage to the
canvas. Position this stage to the right of the Hierarchical Data stage.
6. Create a link from the Hierarchical Data stage to the Sequential file stage.
7. Rename the stages and link as shown in the following table:
Table 65. Names for job elements
Element

Name

Hierarchical Data stage

Employees

Link from Hierarchical Data stage to
Sequential File stage

Employees_Aggregate

Sequential File stage

Employee_File

8. Double-click the Employee_File stage to configure the stage properties.
9. Click the Properties tab, and configure the following properties that define the
output file:
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Table 66. Configuring the properties
Field name

Value

Target > File

Enter the path where you want the output
file to be created, followed by the file name
employees_output.xml.

Target > File Update Mode

Choose Overwrite to create the file.

First Line is Column Names

Choose True.

For the Employee_File stage, do not create any columns now. You let the
Assembly Editor to propagate the columns automatically.
10. Click OK to close the Employees_File stage.
11. Choose File > Save, and name the job as xml_aggregate_example.

Step 7.2: Creating the assembly
Use the XML Parser stage to parse the XML files, the Aggregate step to perform
hierarchical aggregations on the items in a list, and the Output step to map the
data to the sequential file.

Before you begin
Import the example schemas employee.xsd and organization.xsd. If you have
already built any of the previous examples, you have imported the schemas as part
of that example. For more information about importing the schemas, see Importing
the schemas for the examples.

Procedure
1. Double-click the Hierarchical Data stage to open the stage properties.
2. Click the Edit assembly button to open the Assembly Editor.
3. Open the Palette, and then double-click the XML_Parser Step to add it to the
Assembly Outline.
4. Select the XML_Parser Step, and then from the palette, double-click the
Aggregate Step to add it below the XML_Parser Step in the Assembly Outline.
5. On the Overview, in the Description field, enter the following description: This
assembly uses the Organization.xsd and Employee.xsd schemas to read the
input XML file. In this example, the Aggregate Step counts the number of
employees in various departments.

Step 7.3: Configuring the XML Parser step
Configure the location of the XML source data and the schema that you want to
use.

Procedure
1. In the Assembly Outline, click the XML Parser step. By default, the
Configuration tab for the step opens. The following figure shows the
Configuration tab for the step:

Hierarchical data

145

2. On the XML Source tab, specify the location of the XML source data. In this
example, the XML source data is in the single file departments.xml. Select
Single file, and then click Insert Parameter and select the
xml_example_root_folder parameter. You will specify the exact location of the
file when you run the job. You can also specify the absolute path to
departments.xml.
3. On the Document Root tab, select the schema element that describes the
documents that the step parses.
a. Click Browse, and then open the Schemas_for_XML_examples library,
which is the library into which you imported the Organization.xsd and
Employee.xsd schemas.
b. Click to open the namespace, http://ibm.com/infosphere/xml/
Organization, click the root element department, and then click OK. The
Document Root tab displays the structure of the schema. The step Output
also displays this same structure.
4. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are treated as String type.
The following figure shows the output schema of the Parser step:
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Step 7.4: Configuring the Aggregate step
Use the Aggregate step to perform hierarchical aggregations on the items in a list.
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About this task
In the Aggregate step you specify the input list on which the aggregation is
performed. You can also specify the Aggregation key for the input list to be
grouped and to perform the aggregation on all the groups separately rather than
on the whole list.

Procedure
1. On the Configuration tab of the Aggregate step, configure these fields:
Table 67. Configuring the fields
Field name

Value

List to Aggregate

Choose employee.

Scope

Choose top.

The Scope in the Aggregate step defines the scope of the Aggregate function.
The elements are aggregated within the list that is selected as the scope. The
Scope also determines the location of the output of the Aggregate step.
The Scope should always be the parent node of the list selected in the List to
Aggregate field. In this example, because the List to Aggregate is selected as
employee, you can only select the scope as either top or department. This is
because there are two lists existing above the employee list which is department
and top.
If you choose the scope as top, the Aggregation step looks into the elements
within the top list and performs the aggregation. For example, if the scope is
set as top and the item for aggregation is employeeID, the Aggregation step
checks for all the employeeIDs within the top list and then performs the
aggregation. Therefore the employeeID is checked for within the entire input file
and aggregated. The following figure shows the step result output under the
top list.

If you choose the scope as department, the Aggregation step looks for items
within each department one at a time and does the aggregation. For example, if
the scope is department and the item for aggregation is ‘employeeID’, the
Aggregation step checks for the employeeID’s within the first department and
move on to the next department until all the departments are checked for or
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covered and performs the aggregation. Therefore the employeeID is aggregated
within each department. The following figure shows step result output when
the scope is selected as department.

2. There are two tabs located on the Configuration tab. They are Aggregation
Items and Aggregation keys.
v In Aggregation Items tab, you specify the list on which the aggregation is
performed. For example, the Aggregation Item may be employeeID.
v In Aggregation Keys tab, you specify the key on which the input list is
grouped. For example, the key can be deparmentID.
3. Select the Aggregation Items tab.
v From the drop-down list, select employeeID . The employeeID is the unique
key that is specified for each employee.
v From the drop-down list, select Count . The count function counts the
number of employees in a department. There are multiple functions for
example, first, last, and concatenate that you can make use of based on your
requirement.
4. Select the Aggregation keys tab.
v From the drop-down list, select departmentID . The departmentID is the key
on which the employee details are aggregated.
If you choose the List to Aggregate field as employee and set the scope as top,
and selected the Aggregation item as employeeID, and Aggregation function as
count, on Aggregation, the Aggregation step checks for all the employees
within top list and counts the number of employees. Similarly if you select the
Aggregation key as departmentID, the Aggregation step checks for the
employees within top list, group them based on the departmentID and counts
the number of employees in each group.
If you choose the List to Aggregate field as employee and set the scope as
department, and have selected the Aggregation item as employeeID and
Aggregation function as count, on Aggregation, the Aggregation step checks
for all the employees within each department and counts the number of
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employees. Note that the checks are not performed from the top node as the
criterion set in the scope is department. Similarly if you select the Aggregation
key as departmentID, the Aggregation step checks for the employees within the
department list, group them based on the departmentID and counts the number
of employees in each group.

Results
The following figure shows the output of the Aggregate on the Output tab.

The output of the Aggregate step contains a new list named Aggregate:result,
which contains two nodes; aggregate and Aggregate_Input:keys. The
employeeID_CNT holds the count of the number of employees in a department.
The Aggregate_Input:keys holds the aggregation keys which contains the
departmentID.

Step 7.5: Configuring the Output step
In the Output step, create mappings that define how to map source items in one
data structure to target items in another data structure.

About this task
In this example, you use the Output step to map the output of the composer to a
sequential file.

Procedure
1. In the Assembly Outline, click the Output Step to open the step. The step
displays the Configuration tab in the Output Step window. In the Output
window, the output table describes the data structure that is the output of the
assembly. The following figure shows the relevant columns of the output table
for this assembly:
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The default view in the Output window is the Links view. The output structure
for Employee_Aggregate link is shown. The previous figure shows that the
output table does not display any columns because when you created the job,
you did not define any columns for the Employee_Aggregate link. The lack of
columns is not an error. However, if no columns are defined on the link, you
cannot map any source items in the hierarchical data structure to this link.
Instead of returning to the job and manually creating the column, you can
automatically create it from the Mappings tab of the Output step
2. Click the Mappings tab. The following figure shows the mapping table. In this
table, each item in the output structure is represented by a row in the table.
You map target items to source items. For this job, the target structure has a
single link, Employee_Aggregate, and no columns are defined for this link. In
the Target column, the Employee_Aggregate link is represented as a list item.

3. Map the Employee_Aggregate list item. Select the Employee_Aggregate item.
For this item, in the Source, from the Suggestion list, select Aggregate:result,
and click Propagate. One column for each item that is a descendent of the
Aggregate:result item is created in the source structure. When you use the
Propagate button to create items, the items are automatically mapped. The
following figure shows the result:
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4. Click OK to close the assembly editor.
5. Click OK to close the Stage Editor.
6. Save the job.

Step 7.6: Viewing the output of the job
After you run the Aggregate job, open the text file, and look at the output.

Procedure
1. From the IBM InfoSphere DataStage and QualityStage Designer client, choose
File > Compile to compile the job.
2. Choose File > Run to run the job.
3. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you have extracted the files from your
examples compressed file, examples.zip. For example, if you have downloaded
and saved the examples.zip file in the directory, C:\Examples, enter this
directory as the Value for the first parameter, Root of example folder tree.
The following is a part of the input file that contains the employee information
of a single department:
<department xmlns="" departmentID="A100" departmentKind="Division">
<manager>A7100</manager>
<ns1:employees>
<ns1:employee employeeID="A8990" departmentID="A100">
<name>
<firstName>Zen</firstName>
<middleName>P</middleName>
<lastName>Wright</lastName>
</name>
<gender>male</gender>
<dateOfBirth>1980-04-04</dateOfBirth>
<title>Mr</title>
<Address>
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
<address_type>O</address_type>
</Address>
<Address>

152

Hierarchical Data Transformation Guide

<street>2001 West Street</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78300</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2008-07-11</hireDate>
<Jobs>
<job department="A100" id="1000" isManager="false">
<jobTitle>Software Engineer</jobTitle>
<startDate>2008-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>1200000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="CF300" id="2000" isManager="false">
<jobTitle>Associate Engineer</jobTitle>
<startDate>2006-05</startDate>
<endDate>2008-07</endDate>
<annualSalary>600000</annualSalary>
<currentjob>0</currentjob>
</job>
</Jobs>
</ns1:employee>
<ns1:employee employeeID="B6540" departmentID="A100">
<name>
<firstName>Cynthia</firstName>
<middleName>P</middleName>
<lastName>Donald</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1987-01-17</dateOfBirth>
<title>Miss</title>
<Address>
<street>San Felipe Suite 2400</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77057</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>53rd West Street</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77000</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2000-07-25</hireDate>
<Jobs>
<job department="A100" id="3000" isManager="false">
<jobTitle>QA Analyst</jobTitle>
<startDate>2000-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>2000000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="DV100" id="4000" isManager="false">
<jobTitle>Test Engineer</jobTitle>
<startDate>1999-01</startDate>
<endDate>2000-07</endDate>
<annualSalary>1000000</annualSalary>
<currentjob>0</currentjob>
</job>
</Jobs>
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</ns1:employee>
<ns1:employee employeeID="C1230" departmentID="A100">
<name>
<firstName>Tania</firstName>
<middleName>G</middleName>
<lastName>William</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1980-01-17</dateOfBirth>
<title>Miss</title>
<Address>
<street>5th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32500</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>54th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32501</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2002-07-25</hireDate>
<Jobs>
<job department="A100" id="5000" isManager="false">
<jobTitle>Software Developer</jobTitle>
<startDate>2002-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>2000000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="DV100" id="6000" isManager="false">
<jobTitle>Associate Developer</jobTitle>
<startDate>1998-01</startDate>
<endDate>2002-07</endDate>
<annualSalary>1000000</annualSalary>
<currentjob>0</currentjob>
</job>
</Jobs>
</ns1:employee>
</ns1:employees>
<annualBudget>100000000</annualBudget>
</department>

4. After the job runs, open the employees_output.txt file to look at the results.
The employees_output.txt file contains this data:
"employeeID_CNT","departmentID"
"3","A100"
"3","A101"

As you see in the output file, the Aggregate step has counted the number of
employees in each department in the input file under the top element.

Example 8: Using the XML Composer and Sort steps
In this example, you create a job that uses the Hierarchical Data stage and a
Sequential file stage. The Sort step is used to sort the items in a list either in
ascending or descending order.
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About this task
This example uses the sample XML data file, departments.xml, and the sample
schemas, Employee.xsd and Organization.xsd. The departments.xml file contains
information about the employees of various departments in a company. This file
contains employee business and address information. The employee business
information contains the details such as employee name, date of hire, date of birth,
gender, title, employee ID, and department ID. The employee address information
contains employee ID, street, city, state, postal code, country, and address type.
In this example, you parse the input XML file and sort the employee list in
ascending order based on the hire date. After this, you compose the sorted output
into a XML file.
After you complete all the steps in the assembly, the Assembly Editor will look as
shown in the following figure.

The completed example job, xml_sort_example.dsx, is also available. To look at the
completed example or use it as the starting point for expanding the example,
import it into IBM InfoSphere DataStage.
To create the example, complete these tasks:

Step 8.1: Creating the job
Create the job that includes an Hierarchical Data stage and a Sequential File stage.

About this task
The following figure shows the job that you create for the Sort example. The job
includes an Hierarchical Data stage named Employees and a Sequential File stage
named Employee_File. The Hierarchical Data stage is linked to a Sequential file
stage by a link named Employees_Sort.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the Real Time section of the palette, and drag Hierarchical Data stage to
the canvas.
4. Create job properties for the location of the example files:
a. Choose Edit > Job Properties.
b. On the Parameters tab, in the Parameter Name field, enter
xml_example_root_folder and then specify the following values:
Table 68. Specifying the values for field names
Field name

Value

Prompt

Points to the location of the example folder

Type

String

Help Text

Points to the location of the example folder

5. Open the File section of the palette, and drag a Sequential File stage to the
canvas. Position this stage to the right of the Hierarchical Data stage.
6. Create a link from the Hierarchical Data stage to the Sequential file stage.
7. Rename the stages and link as shown in the following table:
Table 69. Names for job elements
Element

Name

Hierarchical Data stage

Employees

Link from Hierarchical Data stage to
Sequential File stage

Employees_Sort

Sequential File stage

Employee_File

8. Double-click the Employee_File stage to configure the stage properties.
9. Click the Properties tab, and configure the following properties that define the
output file:
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Table 70. Configuring the properties
Field name

Value

Target > File

Select the xml_example_root_folder
parameter and enter the path as
xml_examples/sort_step/example1/output/
employees_output.xml.
The output file, employees_output.xml is
created in the location #xml_example_root#/
xml_examples/sort_step/example1/output.

Target > File Update Mode

Choose Overwrite to create the file.

10. Click the Format tab. Right-click the fields, Quote=double and Delimiter =
comma and select Remove.
For the Employee_File stage, do not create any columns now. You let the
Assembly Editor to propagate the columns automatically.
11. Click OK to close the Employees_File stage.
12. Choose File > Save, and name the job as xml_sort_example.

Step 8.2: Creating the assembly
Use the XML Parser stage to parse the XML files, the Sort step to perform sort on
the items in a list either in ascending or descending order, and the Composer to
compose the XML file.

Before you begin
Import the example schemas employee.xsd and organization.xsd. If you have
already built any of the previous examples, you have imported the schemas as part
of that example. For more information about importing the schemas, see Importing
the schemas for the examples.

Procedure
1. Double-click the Hierarchical Data stage to open the stage editor.
2. Click the Edit assembly button to open the Assembly Editor.
3. Open the Palette, and then double-click the XML_Parser Step to add it to the
Assembly Outline.
4. Select the XML_Parser Step, and then from the palette, double-click the Sort
Step to add it below the XML_Parser Step in the Assembly Outline.
5. Select the Sort Step, and then from the palette, double-click the XML_Composer
Step to add it below the Sort Step in the Assembly Outline.
6. On the Overview, in the Description field, enter the following description: This
assembly uses the Organization.xsd and Employee.xsd schemas. The sort
step sorts the employee list in ascending order based on hiredate.

Step 8.3: Configuring the XML Parser step
Configure the location of the XML source data and the schema that you want to
use.

Procedure
1. In the Assembly Outline, click the XML Parser step . By default, the
Configuration tab for the step opens. The following figure shows the
Configuration tab for the step:
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2. On the XML Source tab, specify the location of the XML source data. In this
example, the XML source data is in the single file named departments.xml.
Select Single file, and then click Insert Parameter and select the
xml_example_root_folder parameter. Along with this, you need to enter the
path as #xml_example_root_folder#/sort_step/example1/input_files/
departments.xml. When you run the job, you have to specify the exact location
of the example folder where you unzipped your examples zip file.
3. On the Document Root tab, select the schema element that describes the
documents that the step parses.
a. Click Browse, and then open the Schemas_for_XML_examples library,
which is the library into which you imported the Organization.xsd and
Employee.xsd schemas.
b. Click to open the namespace, http://ibm.com/infosphere/xml/
Organization, and click the root element department.
c. Click OK. The Document Root tab displays the structure of the schema.
The step Output also displays this same structure.
4. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are treated as String type.
The following figure shows the output schema of the Parser step:
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Step 8.4: Configuring the Sort step
Use the Sort step to sort the items in the list in ascending or descending order.
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About this task
In the Sort step you specify the input list on which the sort is performed. You can
also specify the Sort key for the list to be sorted.

Procedure
1. On the Configuration tab of the Sort step, configure these fields:
Table 71. Configuring the fields
Field name

Value

List to Sort

Choose employee.

Scope

Choose department.

The Scope in the Sort step defines the scope of the Sort function. The elements
are sorted within the list that is selected as the scope. The Scope also
determines the location of the output of the Sort step.
The Scope should always be the parent node of the list selected in the List to
Sort field. In this example because the List to Sort is selected as employee, you
can only select the scope as either top or department. This is because there are
two lists existing above the employee list which is department and top.
If you choose the scope as top, the Sort step looks into the elements within the
top list and performs the sort. For example, if the scope is set as top and the
key selected is hireDate, the Sort step checks for all hireDates within the top
list and then performs the sort. Therefore the hireDate is checked for within
the entire input file and sorted. The following figure shows the step result
output under the top list.
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If you choose the scope as department, the Sort step looks for items within each
department one at a time and does the sort within this scope. For example, if
the scope is department and the key selected for sort is hireDate, the Sort step
checks for the hireDate’s within the first department, sorts the data and move
Hierarchical data
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on to the next department until all the departments are checked for and sorted.
Therefore the hireDate is sorted within each department. The following figure
shows step result output when the scope is selected as department.

2. Select the Keys tab.
3. From the drop-down list, select hireDate or use the More option to find it.
4. Select the Order field. The default option set is Ascending.
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Results
The following figure shows the output of the Sort on the Output tab.

The step output contains a new node named Sort:result. The Sort:result contains
the sorted employee list.

Step 8.5: Configuring the XML Composer step
Configure the XML Composer step to compose the sort step output into a XML
file.

Procedure
1. In the XML Target window of the XML Composer step, choose Pass as String.
This passes the composed XML string to a downstream step or stage for further
processing.
2. In the Document Root window, select the schema element that describes the
documents that the step composes:
a. Click Browse, and then open the Schemas_for_XML_examples library,
which is the library into which you imported the Organization.xsd and
Employee.xsd schemas.
b. Click to open the namespace, http://ibm.com/infosphere/xml/
Organization, and select the root element department.
c. Click OK. The Document Root tab displays the structure of the schema.
3. On the Validation tab, by default Strict validation is selected. You do not need
to make any changes to the fields in this tab.
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4. In the Sort step, you sorted the input file. Now in the Composer step, on the
Mappings tab, map the items from the target schema to the items in the output
schema coming from the previous steps. To create the mappings, perform the
following steps:
a. Map top/XML_Parser:result/org:departments/ns0:department in the Source
list to the department in the Target list. Also manually map the manager.
b. Next manually map the Sort:result/tns:employee in the source list to the
employee in the target list, and then click Automap. The Automap
automatically maps each item under Sort:result/tns:employee list with the
items under the target employee list.
c. You also need to manually map the items, annualBudget, departmentID,
and departmentKind in the target list to the corresponding items from the
XML Parser result in the source list.
d. Review all the items to see if the correct mapping is done.
5. On the Format tab, default encoding is UTF-8. You do not need to change this
field.
6. Select the Format Style and configure the following fields.
a. In the Indentation length field, select the number of characters to use for
each indentation level in the XML output. By default, number of characters
is set to 4.
b. In the New Line Style field, select the type of new line. Choices are UNIX
(LF), DOS(CRLF) or MAC(CR). By default, the choice selected is DOS.

Results
The following figure shows the output of the XML Composer step:

The step Output contains a new node, named XML_Composer:result. This node
carries the entire hierarchical data during runtime.

Step 8.6: Configuring the Output step
In the Output step, you create the mappings that define how to map target items
in one data structure to source items in another data structure.

About this task
In this example, you use the Output step to map the output of the composer to a
sequential file.

Procedure
1. In the Assembly Outline, click the Output Step to open the step. The step
displays the Configuration tab in the Output Step window.
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The default view in the Output window is the Links view. The output structure
for Employees_Sort link is shown. The previous figure shows that the output
table does not display any column because when you created the job, you did
not define any column for the Employees_Sort link. The lack of column is not
an error. However, if no column is defined on the link, you cannot map any
source items in the hierarchical data structure to this link. Instead of returning
to the job and manually creating the column, you can automatically create it
from the Mappings tab of the Output step
2. Click the Mappings tab. The following figure shows the mapping table. In this
table, each item in the output structure is represented by a row in the table.
You map target items to source items. For this job, the target structure has a
single link, Employees_Sort, and no column is defined for this link. In the
Target column, the Employees_Sort link is represented as a list item.

3. Map the Employees_Sort list. Select the Employees_Sort list. For this item, in
the Source, from the Suggestion list, select top and click Propagate. One
column for each item that is a descendent of the top item is created in the
source structure. When you use the Propagate button to create items, the items
are automatically mapped. The following figure shows the result:
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4. Click OK to close the assembly editor.
5. Click OK to close the Stage Editor.
6. Save the job.

Step 8.7: Viewing the output of the job
After you run the Sort job, open the XML file, and look at the output.

Procedure
1. From the IBM InfoSphere DataStage and QualityStage Designer client, choose
File > Compile to compile the job.
2. Choose File > Run to run the job.
3. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you have extracted the files from your
examples compressed file, examples.zip. For example, if you have downloaded
and saved the examples.zip file in the directory, C:\Examples, enter this
directory as the Value for the first parameter, Root of example folder tree.
The following is an input file that contains the employee information of a
single department:
<departments xmlns:ns1="http://ibm.com/infosphere/xml/Employee"
xmlns="http://ibm.com/infosphere/xml/Organization"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://ibm.com/infosphere/xml/Organization file:
/C:/work/rtc2/XMLPack_docs/documentation/sampledata/Organization.xsd">
<department xmlns="" departmentID="A100" departmentKind="Division">
<manager>A7100</manager>
<ns1:employees>
<ns1:employee employeeID="A8990" departmentID="A100">
<name>
<firstName>Zen</firstName>
<middleName>P</middleName>
<lastName>Wright</lastName>
</name>
<gender>male</gender>
<dateOfBirth>1980-04-04</dateOfBirth>
<title>Mr</title>
<Address>
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
<address_type>O</address_type>

166

Hierarchical Data Transformation Guide

</Address>
<Address>
<street>2001 West Street</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78300</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2008-07-11</hireDate>
<Jobs>
<job department="A100" id="1000" isManager="false">
<jobTitle>Software Engineer</jobTitle>
<startDate>2008-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>1200000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="CF300" id="2000" isManager="false">
<jobTitle>Associate Engineer</jobTitle>
<startDate>2006-05</startDate>
<endDate>2008-07</endDate>
<annualSalary>600000</annualSalary>
<currentjob>0</currentjob>
</job>
</Jobs>
</ns1:employee>
<ns1:employee employeeID="B6540" departmentID="A100">
<name>
<firstName>Cynthia</firstName>
<middleName>P</middleName>
<lastName>Donald</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1987-01-17</dateOfBirth>
<title>Miss</title>
<Address>
<street>San Felipe Suite 2400</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77057</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>53rd West Street</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77000</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2000-07-25</hireDate>
<Jobs>
<job department="A100" id="3000" isManager="false">
<jobTitle>QA Analyst</jobTitle>
<startDate>2000-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>2000000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="DV100" id="4000" isManager="false">
<jobTitle>Test Engineer</jobTitle>
<startDate>1999-01</startDate>
<endDate>2000-07</endDate>
<annualSalary>1000000</annualSalary>
<currentjob>0</currentjob>
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</job>
</Jobs>
</ns1:employee>
<ns1:employee employeeID="C1230" departmentID="A100">
<name>
<firstName>Tania</firstName>
<middleName>G</middleName>
<lastName>William</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1980-01-17</dateOfBirth>
<title>Miss</title>
<Address>
<street>5th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32500</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>54th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32501</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2002-07-25</hireDate>
<Jobs>
<job department="A100" id="5000" isManager="false">
<jobTitle>Software Developer</jobTitle>
<startDate>2002-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>2000000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="DV100" id="6000" isManager="false">
<jobTitle>Associate Developer</jobTitle>
<startDate>1998-01</startDate>
<endDate>2002-07</endDate>
<annualSalary>1000000</annualSalary>
<currentjob>0</currentjob>
</job>
</Jobs>
</ns1:employee>
</ns1:employees>
<annualBudget>100000000</annualBudget>
</department>
</departments>

4. After the job runs, open the employees_output.xml file to look at the results.
The employees_output.xml file contains this data:
<org:departments xmlns:org="http://ibm.com/infosphere/xml/Organization">
<department departmentID="A100" departmentKind="Division">
<manager>A7100</manager>
<tns:employees xmlns:tns="http://ibm.com/infosphere/xml/Employee">
<tns:employee employeeID="B6540" departmentID="A100">
<name>
<firstName>Cynthia</firstName>
<middleName>P</middleName>
<lastName>Donald</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1987-01-17</dateOfBirth>
<title>Miss</title>
<Address>
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<street>San Felipe Suite 2400</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77057</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>53rd West Street</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77000</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2000-07-25</hireDate>
<Jobs>
<job department="A100" id="3000" isManager="false">
<jobTitle>QA Analyst</jobTitle>
<startDate>2000-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>2000000</annualSalary>
<currentjob>true</currentjob>
</job>
<job department="DV100" id="4000" isManager="false">
<jobTitle>Test Engineer</jobTitle>
<startDate>1999-01</startDate>
<endDate>2000-07</endDate>
<annualSalary>1000000</annualSalary>
<currentjob>false</currentjob>
</job>
</Jobs>
</tns:employee>
<tns:employee employeeID="C1230" departmentID="A100">
<name>
<firstName>Tania</firstName>
<middleName>G</middleName>
<lastName>William</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1980-01-17</dateOfBirth>
<title>Miss</title>
<Address>
<street>5th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32500</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>54th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32501</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2002-07-25</hireDate>
<Jobs>
<job department="A100" id="5000" isManager="false">
<jobTitle>Software Developer</jobTitle>
<startDate>2002-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>2000000</annualSalary>
<currentjob>true</currentjob>
</job>
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<job department="DV100" id="6000" isManager="false">
<jobTitle>Associate Developer</jobTitle>
<startDate>1998-01</startDate>
<endDate>2002-07</endDate>
<annualSalary>1000000</annualSalary>
<currentjob>false</currentjob>
</job>
</Jobs>
</tns:employee>
<tns:employee employeeID="A8990" departmentID="A100">
<name>
<firstName>Zen</firstName>
<middleName>P</middleName>
<lastName>Wright</lastName>
</name>
<gender>male</gender>
<dateOfBirth>1980-04-04</dateOfBirth>
<title>Mr</title>
<Address>
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>2001 West Street</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78300</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2008-07-11</hireDate>
<Jobs>
<job department="A100" id="1000" isManager="false">
<jobTitle>Software Engineer</jobTitle>
<startDate>2008-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>1200000</annualSalary>
<currentjob>true</currentjob>
</job>
<job department="CF300" id="2000" isManager="false">
<jobTitle>Associate Engineer</jobTitle>
<startDate>2006-05</startDate>
<endDate>2008-07</endDate>
<annualSalary>600000</annualSalary>
<currentjob>false</currentjob>
</job>
</Jobs>
</tns:employee>
</tns:employees>
<annualBudget>1.0E8</annualBudget>
</department>
</org:departments>

As you see in the output file, the Sort step has sorted the employee list based
on the hire date.

Example 9: Using the XML Composer and OrderJoin steps
In this example, you create a job that uses the Hierarchical Data stage and a
Sequential file stage. The OrderJoin step is used to merge the items in the
employee and address lists into a single list based on their position.
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About this task
This example uses the sample XML files, employee.xml and address.xml, and the
sample schemas, Employee.xsd and Organization.xsd. The employee.xml file
contains information such as name, gender, date of birth, and employee ID. The
second file contains employee address information: street, city, state, postal code,
country, and employee ID. In this example, you use the OrderJoin step to merge
the employee and address list into a single list. Then you use the XML Composer
step to compose a XML file that contains employee name and address details.
In this example, you parse the input XML file and sort the employee list in
ascending order based on the hire date. After this, you compose the sorted output
into a XML file.
After you complete all the steps in the assembly, the Assembly Editor will look as
shown in the following figure.

The completed example job, xml_orderjoin_example.dsx, is also available. To look
at the completed example or use it as the starting point for expanding the example,
import it into IBM InfoSphere DataStage.
To create the example, complete these tasks:

Step 9.1: Creating the job
Create the job that includes an Hierarchical Data stage and a Sequential File stage.

About this task
The following figure shows the job that you create for the OrderJoin example. The
job includes an Hierarchical Data stage named Employees and a Sequential File
stage named Employees_File. The Hierarchical Data stage is linked to a Sequential
file stage by a link named Employees_OrderJoin.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the Real Time section of the palette, and drag Hierarchical Data stage to
the canvas.
4. Specify job properties for the location of the example files:
a. Choose Edit > Job Properties.
b. On the Parameters tab, in the Parameter Name field, enter
xml_example_root_folder and then specify the following values:
Table 72. Specifying the values for field names
Field name

Value

Prompt

Points to the location of the example folder

Type

String

Help Text

Points to the location of the example folder

5. Open the File section of the palette, and drag a Sequential File stage to the
canvas. Position this stage to the right of the Hierarchical Data stage.
6. Create a link from the Hierarchical Data stage to the Sequential file stage.
7. Rename the stages and link as shown in the following table:
Table 73. Names for job elements
Element

Name

Hierarchical Data stage

Employees

Link from Hierarchical Data stage to
Sequential File stage

Employees_OrderJoin

Sequential File stage

Employees_File

8. Double-click the Employees_File stage to configure the stage properties.
9. Click the Properties tab, and configure the following properties that define the
output file:
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Table 74. Configuring the properties
Field name

Value

Target > File

Select the xml_example_root_folder
parameter and enter the path as
xml_examples/orderjoin_step/example1/
output/employees_output.xml.
The output file, employees_output.xml is
created in the location
#xml_example_root_folder#/xml_examples/
orderjoin_step/example1/output/
employees_output.xml.

Target > File Update Mode

Choose Overwrite to create the file.

10. Click the Format tab. Right-click the fields, Quote=double and Delimiter =
comma and select Remove.
For the Employees_File stage, do not create any columns now. You let the
Assembly Editor to propagate the columns automatically.
11. Click OK to close the Employees_File stage.
12. Choose File > Save, and name the job as xml_orderjoin_example.

Step 9.2: Creating the assembly
Use the OrderJoin step to merge the items in the employee and address lists into a
single list based on their relative positions.

Before you begin
Import the example schemas employee.xsd and organization.xsd. If you have
already built any of the previous examples, you have imported the schemas as part
of that example. For more information about importing the schemas, see Importing
the schemas for the examples.

Procedure
1. Double-click the Hierarchical Data stage to open the stage editor.
2. Click the Edit assembly button to open the Assembly Editor.
3. Open the Palette, and then double-click the XML_Parser Step to add it to the
Assembly Outline.
4. Select the XML_Parser Step, and then from the palette, double-click to add
another parser step below XML_Parser Step. This time it will be named as
XML_Parser_1 Step.
5. Select the XML_Parser_1 Step, and then from the palette, double-click the
OrderJoin Step to add it below the XML_Parser_1 Step.
6. Select the OrderJoin Step, and then from the palette, double-click the
XML_Composer Step to add it below the OrderJoin Step.
7. On the Overview, in the Description field, enter the following description: This
assembly uses the Organization.xsd and Employee.xsd schemas. The
OrderJoin step is used to merge the items in the employee and address
lists into a single list based on their relative positions.

Step 9.3: Configuring the first XML Parser step
Configure the location and the schema of the first XML source data that you want
to parse.
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Procedure
1. In the Assembly Outline, click the XML Parser step . By default, the
Configuration tab for the step opens. The following figure shows the
Configuration tab for the step:

2. On the XML Source tab, specify the location of the XML source data. In this
example, the XML source data is in the single file named employee.xml. Select
Single file and then click Insert Parameter, and select the
xml_example_root_folder parameter. You need to specify the exact location of
the xml example folder when you run the job. Enter the complete location of
the XML input file as, #xml_example_root_folder#/xml_examples/
orderjoin_step/example1/input_files/employee.xml.
3. On the Document Root tab, select the schema element that describes the
documents that the step parses.
a. Click Browse. Open the Schemas_for_XML_example1 library, which is the
library into which you have imported the Organization1.xsd and
Employee1.xsd schemas.
b. Click to open the namespace, http://ibm.com/infosphere/xml/ Employee1,
and click the root element Employee_Names.
c. Click OK. The Document Root tab displays the structure of the schema.
The step Output also displays this same structure.
4. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are treated as String type.
The following figure shows the output schema of the first Parser step:
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Step 9.4: Configuring the second XML Parser step
Configure the location and the schema of the second XML source data that you
want to parse.

Procedure
1. In the Assembly Outline, click the XML_Parser_1 Step . By default, the
Configuration tab for the step opens. The following figure shows the
Configuration tab for the step:

2. On the XML Source tab, specify the location of the XML source data. In this
example, the XML source data is in the single file named, address.xml. Select
Single file and then click Insert Parameter, and select the
xml_example_root_folder parameter. You need to specify the exact location of
Hierarchical data
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the xml example folder when you run the job. Enter the complete location of
the XML input file as, #xml_example_root_folder#/xml_examples/
orderjoin_step/example1/input_files/address.xml.
3. On the Document Root tab, select the schema element that describes the
documents that the step parses.
a. Click Browse. Open the Schemas_for_XML_example1 library, which is the
library into which you have imported the Organization1.xsd and
Employee1.xsd schemas.
b. Click to open the namespace, http://ibm.com/infosphere/xml/ Employee1,
and click the root element Employee_Addresses.
c. Click OK. The Document Root tab displays the structure of the schema.
The step Output also displays this same structure.
4. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are treated as String type.
The following figure shows the output schema of the second Parser step:

Step 9.5: Configuring the OrderJoin step
Use the OrderJoin step to merge the items in the employee and address lists into a
single list based on their position.

About this task
The Input to the OrderJoin step contains two lists, employee and address. When
you configure the OrderJoin step, make a selection for the left and right list.

Procedure
On the Configuration tab of the OrderJoin step, configure these fields:
Table 75. Configuring the fields
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Field name

Value

Left List

Select top/XML_Parser:result/
prn:Employee_Names/employee.
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Table 75. Configuring the fields (continued)
Field name

Value

Right List

Select top/XML_Parser_1:result/
prn:Employee_Addresses/address.

Results
The step Output contains a new node named OrderJoin:result, which contains the
merged list of employee and address lists. The following figure shows this portion
of the step Output.

Step 9.6: Configuring the XML Composer step
Configure the XML Composer step to compose the OrderJoin step output into a
XML file.

Procedure
1. In the XML Target window of the XML Composer step, choose Pass as String.
This passes the composed XML string to a downstream step or stage for further
processing.
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2. In the Document Root window, select the schema element that describes the
documents that the step composes:
a. Click Browse, and then open the Schemas_for_XML_examples library,
which is the library into which you imported the Organization1.xsd and
Employee1.xsd schemas.
b. Click to open the namespace, http://ibm.com/infosphere/xml/
Organization1, and select the root element Employees.
c. Click OK. The Document Root tab displays the structure of the schema.
3. On the Validation tab, by default Strict validation is selected. You do not need
to make any changes to the fields in this tab.
4. In the OrderJoin step, you merged two lists into a single list based on their
position. Now on the Mappings tab, map the items from the target schema to
the items in the output schema coming from the previous steps. To create the
mappings, perform the following steps:
a. Map top/OrderJoin:result in the Source list to the Employee in the Target
list, and then click Automap.
b. The Automap automatically maps each item under top/OrderJoin:result
list with the items under the target Employee list.
c. Review all the items to see if the correct mapping is done.
5. On the Format tab, default encoding is UTF-8. You need not change this field.
6. Select the Format Style and configure the following fields.
a. In the Indentation length field, select the number of characters to use for
each indentation level in the XML output. By default, number of characters
is set to 4.
b. In the New Line Style field, select the type of new line. Choices are UNIX
(LF), DOS(CRLF) or MAC(CR). By default, the choice selected is DOS.

Results
The following figure shows the results of the mappings:

The step Output contains a new node, named XML_Composer:result. This node
carries string representation of the result of the XML composer.

Step 9.7: Configuring the Output step
In the Output step, you create the mappings that define how to map target items
in one data structure to source items for downstream stage.

About this task
In this example, you use the Output step to map the output of the composer to a
sequential file.

Procedure
1. In the Assembly Outline, click the Output Step to open the step. The step
displays the Configuration tab in the Output Step window.
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The default view in the Output window is the Links view. The output structure
for Employees_OrderJoin link is shown. The previous figure shows that the
output table does not display any columns because when you created the job,
you did not define any column for the Employees_OrderJoin link. The lack of
columns is not an error. However, if no column is defined on the link, you
cannot map any source items in the hierarchical data structure to this link.
The composer output, result-string is a single column that contains the
employee data and you need to create that single column in this step. But
instead of returning to the job and manually creating the column, you can
automatically create it from the Mappings tab of the Output step.
2. Click the Mappings tab. The following figure shows the mapping table. In this
table, each item in the output structure is represented by a row in the table.
You map target items to source items. For this job, the target structure has a
single link, Employees_OrderJoin, and no column is defined for this link. In the
Target column, the Employees_ OrderJoin link is represented as a list item.

3. Map the Employees_OrderJoin list item. Select the Employees_OrderJoin item.
For this item, in the Source, from the Suggestion list, select top and click
Propagate. One column for each item that is a descendent of the top item is
created in the source structure. When you use the Propagate button to create
items, the items are automatically mapped. The following figure shows the
result:
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4. Click OK to close the assembly editor.
5. Click OK to close the Stage Editor.
6. Save the job.

Step 9.8: Viewing the output of the job
After you run the OrderJoin job, open the XML file, and look at the output.

Procedure
1. From the IBM InfoSphere DataStage and QualityStage Designer client, choose
File > Compile to compile the job.
2. Choose File > Run to run the job.
3. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you have extracted the files from your
examples compressed file, examples.zip. For example, if you have downloaded
and saved the examples.zip file in the directory, C:\Examples, enter this
directory as the Value for the first parameter, Root of example folder tree.
The following are the two input files that contain the employee and address
information:
employee.xml file:
<tns:Employee_Names xmlns:tns=
"http://ibm.com/infosphere/xml/Employee1">
<tns:employee EmpId="A8990">
<name>
<firstName>Zen</firstName>
<middleName>P</middleName>
<lastName>Wright</lastName>
</name>
<gender>male</gender>
<dateOfBirth>1980-04-04</dateOfBirth>
<title>Mr</title>
</tns:employee>
<tns:employee EmpId="B6540">
<name>
<firstName>Cynthia</firstName>
<middleName>P</middleName>
<lastName>Donald</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1987-01-17</dateOfBirth>
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<title>Miss</title>
</tns:employee>
<tns:employee EmpId="C1230">
<name>
<firstName>Tania</firstName>
<middleName>G</middleName>
<lastName>William</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1980-01-17</dateOfBirth>
<title>Miss</title>
</tns:employee>
<tns:employee EmpId="A8991">
<name>
<firstName>John</firstName>
<middleName>K</middleName>
<lastName>Milsted</lastName>
</name>
<gender>male</gender>
<dateOfBirth>1982-08-07</dateOfBirth>
<title>Mr</title>
</tns:employee>
<tns:employee EmpId="B6541">
<name>
<firstName>Emily</firstName>
<middleName>P</middleName>
<lastName>Cheeseman</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1987-07-07</dateOfBirth>
<title>Miss</title>
</tns:employee>
</tns:Employee_Names>

address.xml file:
<tns:Empolyee_Addresses xmlns:tns=
"http://ibm.com/infosphere/xml/Employee1">
<tns:address EmpId="A8990">
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
</tns:address>
<tns:address EmpId="B6540">
<street>San Felipe Suite 2400</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77057</postalCode>
</tns:address>
<tns:address EmpId="C1230">
<street>54th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32501</postalCode>
</tns:address>
<tns:address EmpId="A8991">
<street>609 Eighth Street</street>
<city>portland</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78374</postalCode>
</tns:address>
<tns:address EmpId="B6541">
<street>750 Agronomy Road</street>
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<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77843</postalCode>
</tns:address>
</tns:Empolyee_Addresses>

4. After the job runs, open the employees_output.xml file to look at the results.
The following is a portion of the employees_output.xml file.
<Employee>
<prn:employee xmlns:prn=
"http://ibm.com/infosphere/xml/Employee1" EmpId="A8990">
<name>
<firstName>Zen</firstName>
<middleName>P</middleName>
<lastName>Wright</lastName>
</name>
<gender>male</gender>
<dateOfBirth>1980-04-04</dateOfBirth>
<title>Mr</title>
</prn:employee>
<prn:address xmlns:prn=
"http://ibm.com/infosphere/xml/Employee1" EmpId="A8990">
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
</prn:address>
</Employee>
<Employee>
<prn:employee xmlns:prn=
"http://ibm.com/infosphere/xml/Employee1" EmpId="B6540">
<name>
<firstName>Cynthia</firstName>
<middleName>P</middleName>
<lastName>Donald</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1987-01-17</dateOfBirth>
<title>Miss</title>
</prn:employee>
<prn:address xmlns:prn=
"http://ibm.com/infosphere/xml/Employee1" EmpId="B6540">
<street>San Felipe Suite 2400</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77057</postalCode>
</prn:address>
</Employee>
<Employee>

As you see in the output file, the Order join step has merged the employee and
address lists.

Example 10: Using the XML Parser and V-Pivot steps
In this example, you create a job that uses the Hierarchical Data stage and a
Sequential file stage. The V-Pivot step is used to transform the values in a column
in to a single row.

About this task
This example uses the sample XML data file, departments.xml, and the sample
schemas, Employee.xsd and Organization.xsd, to illustrate parsing source data
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from one XML file into a sequential file. The departments.xml file contains
information about the employees of various departments in a company. In this
example, you parse the XML data into a sequential file. The file contains employee
business and address information. The employee business information contains the
details such as employee name, date of hire, date of birth, gender, title, employee
ID, and department ID. The employee address information contains employee ID,
street, city, state, postal code, country, and address type.
After you complete all the steps in the assembly, the Assembly Editor will look as
shown in the following figure.

The completed example job, xml_vpivot_example.dsx, is also available. To look at
the completed example or use it as the starting point for expanding the example,
import it into IBM InfoSphere DataStage.
To create the example, complete these tasks:

Step 10.1: Creating the job
Create the job that includes an Hierarchical Data stage and a Sequential File stage.

About this task
The following figure shows the job that you create for the V-Pivot example. The job
includes an Hierarchical Data stage named Department and a Sequential File stage
named Employee_File. The Hierarchical Data stage is linked to a Sequential file
stage by a link named Employees_Vpivot.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and select New > Parallel
job.
3. Open the Real Time section of the palette, and drag Hierarchical Data stage to
the canvas.
4. Specify job properties for the location of the example files:
a. Choose Edit > Job Properties.
b. On the Parameters tab, in the Parameter Name field, enter
xml_example_root_folder and then specify the following values:
Table 76. Specifying the values for field names
Field name

Value

Prompt

Points to the location of the example folder

Type

String

Help Text

Points to the location of the example folder

5. Open the File section of the palette, and drag a Sequential File stage to the
canvas. Position this stage to the right of the Hierarchical Data stage.
6. Create a link from the Hierarchical Data stage to the Sequential file stage.
7. Rename the stages and link as shown in the following table:
Table 77. Names for job elements
Element

Name

Hierarchical Data stage

Department

Link from Hierarchical Data stage to
Sequential File stage

Employees_Vpivot

Sequential File stage

Employee_File

8. Double-click the Employee_File stage to configure the stage properties.
9. Click the Properties tab, and configure the following properties that define the
output file:
Table 78. Configuring the properties
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Field name

Value

Target > File

Enter the path where you want the output
file to be created, followed by the file name
employees_output.txt.
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Table 78. Configuring the properties (continued)
Field name

Value

Target > File Update Mode

Choose Overwrite to create the file.

First Line is Column Names

Choose True.

For the Employee_File stage, do not create any columns now. You let the
Assembly Editor to propagate the columns automatically.
10. Click OK to close the Employee_File stage.
11. Choose File > Save, and name the job as xml_vpivot_example.

Step 10.2: Creating the assembly
Use the XML Parser stage to parse the XML files, the V-Pivot transforms the field
values of columns into a single row, and the Output step to map the data to the
sequential file.

Before you begin
Import the example schemas employee.xsd and organization.xsd. If you have
already built any of the previous examples, you have imported the schemas as part
of that example. For more information about importing the schemas, see Importing
the schemas for the examples.

Procedure
1. Double-click the Hierarchical Data stage to open the stage editor.
2. Click the Edit assembly button to open the Assembly Editor.
3. Open the Palette, and then double-click the XML_Parser Step to add it to the
Assembly Outline.
4. Select the XML_Parser Step, and then from the palette, double-click the V-Pivot
Step to add it below the XML_Parser Step in the Assembly Outline.
5. On the Overview, in the Description field, enter the following description: This
assembly uses the Organization.xsd and Employee.xsd schemas to read the
input XML file. In this example, the V-Pivot Step transforms the field
values of columns into a single row.

Step 10.3: Configuring the XML Parser step
Configure the location of the XML source data and the schema that you want to
use.

Procedure
1. In the Assembly Outline, click the XML parser step . By default, the
Configuration tab for the step opens. The following figure shows the
Configuration tab for the step:
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2. On the XML Source tab, specify the location of the XML source data. In this
example, the XML source data is in the single file departments.xml. Select
Single file, and then click Insert Parameter and select the
xml_example_root_folder parameter. You will specify the exact location of the
file when you run the job. You can also specify the absolute path to
departments.xml.
3. On the Document Root tab, select the schema element that describes the
documents that the step parses.
a. Click Browse, and then open the Schemas_for_XML_examples library,
which is the library into which you imported the Organization.xsd and
Employee.xsd schemas.
b. Click to open the namespace, http://ibm.com/infosphere/xml/
Organization, click the root element department, and then click OK. The
Document Root tab displays the structure of the schema. The step Output
also displays this same structure.
4. On the Validation tab, select Strict Validation. By selecting Strict Validation,
you automatically ensure that the data types conversion is performed. If you
use the default Minimal Validation, all data types are treated as String type.
The following figure shows the output schema of the Parser step:
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Step 10.4: Configuring the V-Pivot step
Use the V-Pivot step to transform the field values of columns into a single row.
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About this task
In the V-Pivot step you transform the fields that are represented in a list of
columns into a single row. In this step you specify the address_type values as
column names based on which the V-Pivot function is performed.
In V-Pivot, the column values can contain alphabets, digits and the special
characters, . (dot), _ (underscore), and - (hyphen). The column values can only start
with either alphabets or underscores. The column values cannot contain special
characters such as, : (colon), @, etc. This is because the given column values are
treated as column names, and the column names cannot contain special characters.

Procedure
1. On the Configuration tab of the V-Pivot step, configure these fields:
Table 79. Configuring the fields
Field name

Value

Source of Rows

Choose Address.

Scope

Choose employee.

The Scope in the V-Pivot step defines the scope of the V-Pivot function. The
fields in the columns within this scope are transformed into a single row. The
Scope also determines the location of the output of the V-Pivot step.
The Scope should always be the parent node of the list selected in the Source
of Rows field. In this example, because the Source of Rows is selected as
Address, you can only select the scope as employee.
You cannot select top as the scope. By default, the scope is set to top. You have
to specify proper scope based on your specific V-Pivot use case.
2. Select the Source of Column Names.
3. Choose value of Source of Column Names as address_type. Specify the
address type as H and O under the Column Name field where H and O are the
address type values in the input file. The column names should match the
values that are present in the input file.
4. The value that you selected under Column Name is the result output that
appears in a single row rather than in different columns.
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Results
The following figure shows the output of the V-Pivot on the Output tab.

The output of the V-Pivot step contains a new list named V-Pivot:result, which
contains two nodes; H and O. The node, 'H' holds the house address of the
employees in a department. The node, 'O' holds the office address of the
employees in a department.

Step 10.5: Configuring the Output step
In the Output step, you create the mappings that define how to map target items
in one data structure to source items in another data structure.

About this task
In this example, you use the Output step to map the output of the composer to a
sequential file.
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Procedure
1. In the Assembly Outline, click the Output Step to open the step. The step
displays the Configuration tab in the Output Step window.

The default view in the Output window is the Links view. The output structure
for Employee_Vpivot link is shown. The previous figure shows that the output
table does not display any column because when you created the job, you did
not define any column for the Employee_Vpivot link. The lack of column is not
an error. However, if no column is defined on the link, you cannot map any
source items in the hierarchical data structure to this link. Instead of returning
to the job and manually creating the column, you can automatically create it
from the Mappings tab of the Output step.
2. Click the Mappings tab. The following figure shows the mapping table. In this
table, each item in the output structure is represented by a row in the table.
You map target items to source items. For this job, the target structure has a
single link, Employee_Vpivot, and no column is defined for this link. In the
Target column, the Employee_Vpivot link is represented as a list item.

3. Map the Employee_Vpivot list item. Select the Employee_Vpivot item. For this
item, in the Source, from the Suggestion list, select 'employee' and click
Propagate. One column for each item that is a descendent of the 'employee'
item is created in the source structure. When you use the Propagate button to
create items, the items are automatically mapped. The following figure shows
the result:
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4. Click OK to close the assembly editor.
5. Click OK to close the Stage Editor.
6. Save the job.

Step 10.6: Viewing the output of the job
After you run the V-Pivot job, open the text file, and look at the output.

Procedure
1. From the IBM InfoSphere DataStage and QualityStage Designer client, choose
File > Compile to compile the job.
2. Choose File > Run to run the job.
3. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you have extracted the files from your
examples compressed file, examples.zip. For example, if you have downloaded
and saved the examples.zip file in directory, C:\Examples, enter this directory
as the Value for the first parameter, Root of example folder tree.
The following is an input file that contains the employee information in a
department:
<department xmlns="" departmentID="A100" departmentKind="Division">
<manager>A7100</manager>
<ns1:employees>
<ns1:employee employeeID="A8990" departmentID="A100">
<name>
<firstName>Zen</firstName>
<middleName>P</middleName>
<lastName>Wright</lastName>
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</name>
<gender>male</gender>
<dateOfBirth>1980-04-04</dateOfBirth>
<title>Mr</title>
<Address>
<street>2301 East Lamar Blvd</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78363</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>2001 West Street</street>
<city>Arlington</city>
<state>Texas</state>
<country>USA</country>
<postalCode>78300</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2008-07-11</hireDate>
<Jobs>
<job department="A100" id="1000" isManager="false">
<jobTitle>Software Engineer</jobTitle>
<startDate>2008-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>1200000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="CF300" id="2000" isManager="false">
<jobTitle>Associate Engineer</jobTitle>
<startDate>2006-05</startDate>
<endDate>2008-07</endDate>
<annualSalary>600000</annualSalary>
<currentjob>0</currentjob>
</job>
</Jobs>
</ns1:employee>
<ns1:employee employeeID="B6540" departmentID="A100">
<name>
<firstName>Cynthia</firstName>
<middleName>P</middleName>
<lastName>Donald</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1987-01-17</dateOfBirth>
<title>Miss</title>
<Address>
<street>San Felipe Suite 2400</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77057</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>53rd West Street</street>
<city>Houston</city>
<state>Texas</state>
<country>USA</country>
<postalCode>77000</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2000-07-25</hireDate>
<Jobs>
<job department="A100" id="3000" isManager="false">
<jobTitle>QA Analyst</jobTitle>
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<startDate>2000-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>2000000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="DV100" id="4000" isManager="false">
<jobTitle>Test Engineer</jobTitle>
<startDate>1999-01</startDate>
<endDate>2000-07</endDate>
<annualSalary>1000000</annualSalary>
<currentjob>0</currentjob>
</job>
</Jobs>
</ns1:employee>
<ns1:employee employeeID="C1230" departmentID="A100">
<name>
<firstName>Tania</firstName>
<middleName>G</middleName>
<lastName>William</lastName>
</name>
<gender>female</gender>
<dateOfBirth>1980-01-17</dateOfBirth>
<title>Miss</title>
<Address>
<street>5th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32500</postalCode>
<address_type>O</address_type>
</Address>
<Address>
<street>54th South Street</street>
<city>Miami</city>
<state>Florida</state>
<country>USA</country>
<postalCode>32501</postalCode>
<address_type>H</address_type>
</Address>
<hireDate>2002-07-25</hireDate>
<Jobs>
<job department="A100" id="5000" isManager="false">
<jobTitle>Software Developer</jobTitle>
<startDate>2002-07</startDate>
<endDate>2010-12</endDate>
<annualSalary>2000000</annualSalary>
<currentjob>1</currentjob>
</job>
<job department="DV100" id="6000" isManager="false">
<jobTitle>Associate Developer</jobTitle>
<startDate>1998-01</startDate>
<endDate>2002-07</endDate>
<annualSalary>1000000</annualSalary>
<currentjob>0</currentjob>
</job>
</Jobs>
</ns1:employee>
</ns1:employees>
<annualBudget>100000000</annualBudget>
</department>
</departments>

4. After the job runs, open the employees_output.txt file to look at the results.
The employees_output.txt file contains this data:
"firstName","middleName","lastName","gender","dateOfBirth","title",
"hireDate","employeeID","departmentID","street","city","state","country",
"postalCode","address_type","street_2","city_2","state_2","country_2",
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"postalCode_2","address_type_2""Zen","P","Wright","male","1980-04-04",
"Mr","2008-07-11","A8990","A100","2001 West Street","Arlington","Texas",
"USA","78300","H","2301 East Lamar Blvd","Arlington","Texas","USA",
"78363","O""Cynthia","P","Donald","female","1987-01-17","Miss",
"2000-07-25","B6540","A100","53rd West Street","Houston","Texas","USA",
"77000","H","San Felipe Suite 2400","Houston","Texas","USA","77057","O"
"Tania","G","William","female","1980-01-17","Miss","2002-07-25","C1230",
"A100","54th South Street","Miami","Florida","USA",
"32501","H","5th South Street","Miami","Florida","USA","32500","O"

As you see in the output file, the V-Pivot step has transformed the values in
columns into a single row.

Examples of transforming JSON data
You can build sample jobs that parse and compose JSON data.
The examples all use one schema file schema.json. You can create each example or
you can import the completed job. The data for the examples is a JSON file that
contains contact information. The schema defines the contact information structure.
To get the files for the examples, go to http://www.ibm.com/support/
docview.wss?uid=swg27038750.

Example 1: Parsing JSON data
You can create a simple job that uses the JSON Parser step to parse contact data,
which is stored in one JSON data file, into two flat files.

About this task
This basic parsing example uses the sample JSON data file, schema.json,. You
parse contact information from the schema.json file into two files. One file contains
contact information: first name, last name, age, street address, city, postal code,
new subscription, and the company name. The second file contains phone
numbers: number and type.
Related reference:
“JSON Parser step” on page 41
Use the JSON Parser step to parse one or more documents that have the same
structure.

Creating the job
Create the example job that includes one Hierarchical Data stage and two
Sequential File stages.

About this task
The following figure shows the job that you create for the parsing example. The
job includes one Hierarchical Data stage, named JSON_Parser, and two Sequential
File stages, named Contacts_File and PhoneNumbers_File. The JSON_Parser stage
is linked to the Contacts_File stage by a link named Contacts, and it is also linked
to the PhoneNumbers_File stage by a link named PhoneNumbers.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and then click New >
Parallel job.
3. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas.
4. Create a job parameter for the location of the example files:
a. Click Edit > Job Properties.
b. On the Parameters page, specify the values in the following table.
Table 80. Values for parameter
Field name

Value

Parameter Name

json_example_root_folder

Prompt

Root of example folder tree

Type

String

Help Text

Point to the root of the file tree folder

Each example uses this job parameter.
5. Open the File section of the palette, and drag two Sequential File stages to the
canvas. Position these stages to the right of the Hierarchical Data stage.
6. Create a link from the Hierarchical Data stage to each Sequential File stage.
7. Rename the stages and links as shown in the following table.
Table 81. Names for job elements
Element

Name

Hierarchical Data stage

JSON_Parser

Sequential File stage

Contacts_File

Sequential File stage

PhoneNumbers_File

Link from JsonParser to Contacts_File

Contacts

Link from JsonParser to PhoneNumbers_File PhoneNumbers
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8. Double-click the Contacts_File stage, and configure the columns that are listed
in the following table in the Columns tab. By looking at the schema.json file,
which contains the JSON data, you determine which columns to create to hold
the contacts data that the Hierarchical Data stage will pass to the
Contacts_File stage and the PhoneNumbers_File stage.
Table 82. Columns for the Contacts_File stage
Column name

SQL type

FirstName

VarChar

LastName

VarChar

Age

VarChar

StreetAddress

VarChar

City

VarChar

State

VarChar

PostalCode

VarChar

NewSubscription

VarChar

CompanyName

VarChar

The columns can also be auto-generated by using the Propagate button in the
Mappings tab in the Output step.
a. On the Properties page, configure the properties that define the output file:
Table 83. Properties for the output file
Field name

Value

Target > File

Enter the path where you want the output
file to be created, followed by the file name
Contacts.txt.

Target > File Update Mode

Choose Overwrite to create the file.

First line is column name

Set to True.

b. Click OK to close the Contacts_File stage.
9. Double-click the PhoneNumbers_File stage , and then, on the Properties page,
configure the properties that are listed in the following table: For the
PhoneNumbers_File stage, do not create any columns. Later, you will use the
Assembly Editor to propagate those columns automatically.
Table 84. Configuring the properties
Field name

Value

Target > File

Enter the path where you want the output
file to be created, followed by the file name
PhoneNumbers.txt.

Target > File Update Mode

Choose Overwrite to create the file.

First line is column name

Set to True.

a. Click OK to close the stage properties.
10. Choose File > Save, and name the job json_parser_example.

Opening the Assembly Editor and viewing the issues
For each Hierarchical Data stage, you open the Assembly Editor, which you use to
define an XML transformation within the context of a job.

196

Hierarchical Data Transformation Guide

About this task
You use the Assembly Editor to create an assembly. An assembly contains a series
of steps that parse, compose, and transform hierarchical data. By default, an
assembly contains an overview, an input step, and an output step. You add steps
to the assembly based on the type of transformations that you want to perform. In
this example, you add one JSON_Parser step to parse JSON data into two output
Sequential File stages, Contacts_File, and Employee_File.

Procedure
1. Double-click the JSON_Parser stage and then, click Edit assembly.
2. Click Palette to open the palette, and then double-click the JSON Parser step to
add it to the outline. Because the JSON Parser step is the first step that you
added to the assembly, the step is added between the Input step and the
Output step.
3. In the outline, an error icon (a red exclamation mark) is shown beside the JSON
Parser step and the Output step. The error icon indicates that you must address
one or more issues in that step. To view the issues list, click View All. The
following figure shows the issues for this assembly:

The JSON Parser step has two errors, indicating that you must complete two
mandatory fields. The Output step has nine errors. Notice that the errors that
require mandatory input are for the Contacts and PhoneNumbers output links
and the columns that you defined on the Contacts link. These links and
columns are listed as errors because the hierarchical structure of the assembly is
not mapped to a relational structure. The first error in the Output list indicates
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that no columns were defined on the PhoneNumbers link. For now, you can
ignore these errors; you correct them when you create mappings in the Output
step.
4. Close the issues list.

Importing the schemas for the examples
Use the schema library manager to generate a schema to describe a selected JSON
data and import the schema into a library.

About this task
You must generate and import the schemas that the example job uses. Imported
schemas are stored in the metadata repository, where you can access them to use in
any assembly that you create.

Procedure
1. From the Assembly Editor, click the Libraries tab to open the Schema Library
Manager.
2. Click New Library to create a library for the example schemas.
a. Enter Example_Parser for the library name.
b. Enter Examples for the category
The library is now categorized under Examples.
3. Expand the Examples category, select Example_Parser, and then click Import
New Resource. Set the Files of type to JSON Instance to show the available
json files. Find the schema.json , and import it into the library.
a. Import schema.json file. This will generate a schema to describe the
structure and types in the selected schema.json file. The schema is imported
into the specified library.
4. To return to the assembly, click the Assembly Editor tab.
Related tasks:
“Opening and configuring the Assembly Editor” on page 208
In the Assembly Editor, you add the HJoin step, which is used to create a
parent-child hierarchy from two lists. Then, you add the JSON Composer step,
which can compose the JSON file.

Configuring the overview
The Overview provides creation and modification information about the assembly
and includes a Description field that you can modify.

About this task
On the Overview, you can enter an optional description for the assembly. This field
documents the purpose of the assembly and is helpful when you or others later
need to modify the assembly.

Procedure
In the Description field, enter the following description: This assembly uses the
schema.json schema. The assembly parses the schema.json data file and sends
the output to two files named Contacts.txt and PhoneNumbers.txt.
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Configuring the JSON Parser step
Configure the location of the JSON source data and the schema that you want to
use to parse it.

Procedure
1. Click the JSON Parser step in the outline.
2. On the JSON Source page specify the location of the JSON source data. In this
example, the JSON source data is in the single file schema.json.
a. Select Single file.
b. Click Insert Parameter and select the json_example_root_folder parameter.
Specify the exact location of the file when you run the job. For example if
you have downloaded and saved the json schema file in the directory,
C:\json_example_root_folder, enter this directory as the value for the first
parameterc:/json_example_root_folder/schema.json.
3. On the Document Root page, you select the schema element that describes the
documents that the step parses. Click Browse. Open the Example_Parser
library, which is the library into which you imported the schema.json file.
4. Select the root element and then click OK. The Document Root page displays
the structure of the schema. The Output schema page also displays the same
structure.
5. On the Validation page, select Minimal Validation. If you use Minimal
Validation all data types are automatically converted to the String type.

Configuring the Output step
In the Output step, create mappings that define how to map source items in one
data structure to target items in another data structure.

About this task
In this example, you use the Output step to map a hierarchical data structure to a
relational data structure.

Procedure
1. From the Assembly Editor, click the Output step. On the Output page, the
output table shows the data structure that is the output of the assembly.
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The output structure for the Contacts link is shown. Notice that the columns
that you defined in the Sequential file stage editor are shown in the output
table. In the Links view, you can modify the columns that you defined. Any
changes that you make to the columns are propagated to the column
definitions in the Sequential file stage properties.
2. From the Output Links list, select PhoneNumbers. The output table does not
show any columns because, you did not define any columns for the
PhoneNumbers link when you created the job. If no columns are defined on the
link, you cannot map any source items in the hierarchical data structure to this
link. Because this job is designed to produce a file that contains phone numbers
data, you need to create the phone numbers columns. But instead of returning
to the job and manually creating columns, you can automatically create them
from the Mappings tab of the Output step.
3. Click the Mappings tab. Each item in the output structure is represented by a
row in the mappings table. You map target items to source items. For this job,
the target structure has two links, Contacts and PhoneNumbers, and the
columns that are defined on those links. In the Target column, the Contacts link
is represented as a list item. Under the Contacts list item, each column displays
as a content item.
a. To create mappings, map target list items to source list items. Then map
target content items to source content items.
Table 85. Five ways to specify mapping
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Method

Description

Auto Map

Click Auto Map to map target content items
to source content items automatically.
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Table 85. Five ways to specify mapping (continued)
Method

Description

More

Select a mapping candidate from a list of
valid mapping candidates or select a
mapping candidate from the entire source
structure using the More option in the list.

Constant

Specify a constant value as the mapping
using the Constant option in the list.

Map to selected target

Right-click on a potential mapping source
node in the Input schema tree control, and
select Map to selected target.

Add as new column for link or Add
children as new column for link

Select Add as new column for link menu
item to propagate the node as new column.
If you right-click on a vector or group node,
the Add children as new column for link
menu item propagates the direct children as
new columns for the link.

4. Select the Contacts list item from the Target section.
a. In the Source section, click and choose the item from the list.
b. To create a mapping for the selected item and all of its descendent items,
click Auto Map
Each source item that is automatically mapped is determined based on similar
name and data type.
In the following figure the target Contacts list item and all of its child items are
automatically mapped to source items.
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5. Map the PhoneNumbers list item from the Target column.
a. In the Source column, select PhoneNumbers from the list, and then, click
Propagate . Propagate automatically creates one column for each item that
is a descendent of the PhoneNumbers item in the source structure and
automatically maps those items to the respective items in the source
column.
The following figure shows the mapping result after propagating.

6. Click OK to close the stage editor.

Viewing the output of the job
After you run the parsing job, open the text files, and look at the output.
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Procedure
1. From the Assembly Editor, click OK to return to the Hierarchical Data stage
editor, and then click OK to close the Hierarchical Data stage editor.
2. To compile the job, choose File > Compile from the IBM InfoSphere DataStage
and QualityStage Designer client.
3. Click File > Run to run the job.
4. In the parameter window, for the first parameter, Root of example folder tree,
enter the path of the directory where you extracted your examples .zip file. For
example, if you downloaded and saved the examples .zip file in the
C:\Examples directory, enter this directory.
The following is an example input file that contains the contacts and phone
number information:
{
"contacts": [
{
"firstName": "John",
"lastName": "Smith",
"age": 25,
"address": {
"streetAddress": "21 2nd Street",
"city": "New York",
"state": "NY",
"postalCode": "10021"
},
"phoneNumbers": [
{ "type": "home", "number": "212 555-1234" }
],
"newSubscription": false,
"companyName": "FakeOne"
},
{
"firstName": "John",
"lastName": "Smith",
"age": 25,
"address": {
"streetAddress": "21 2nd Street",
"city": "New York",
"state": "NY",
"postalCode": "10021"
},
"phoneNumbers": [
{ "type": "home", "number": "212 555-1234" },
{ "type": "fax", "number": "646 555-4567" }
],
"newSubscription": false,
"companyName": "FakeOne"
}
]
}

5. After the job runs, open the Contacts.txt and the PhoneNumbers.txt files to
look at the results.
The Contacts.txt file contains this data:
"FirstName","LastName","Age","StreetAddress","City","State","PostalCode",
"newSubscription","CompanyName"
"John","Smith","25","21 2nd Street","New York","NY","10021","false","FakeOne"
"John","Smith","25","21 2nd Street","New York","NY","10021","false","FakeOne"

The PhoneNumbers.txt file contains this data:
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"type","number"
"home","212 555-1234"
"home","212 555-1234"
"fax","646 555-4567"

Example 2: Composing JSON data by using the JSON
Composer and HJoin steps
Build this job that uses the JSON Composer and HJoin steps in the Hierarchical
Data stage to create a hierarchical structure.

About this task
This basic example uses two relational data files, Contacts.txt and
PhoneBooks.txt, and the schema.json sample JSON data file to compose source
data from two relational files into a JSON file. The Contacts.txt file contains these
contact details: first name, last name, age, street address, city, state, postal code,
new subscription, and company name. The PhoneBooks.txt file contains first name,
last name, number, and type. Each person has an address and a phone number. In
this example, you use an HJoin step in the assembly to join two tables to create
hierarchical structure. Then you use the Address_JSON_Composer Step and
PhoneNumbers_JSON_Composer Step for each view to build one part of your
JSON document and JSON_Composer Step to assemble all the generated parts and
to compose a JSON file that contains contact information followed by the phone
numbers.
This example illustrates how to use schema views to compose JSON sample data.
A schema view is used to define a subset of a large schema. When you design an
assembly to compose JSON data based on a small schema, such as the one in this
example, you do not need to split the composing process into multiple parts. You
can compose the sample JSON data by using one composer step. For more
information about large schema, see “Large Schema” on page 53
Related reference:
“JSON Composer step” on page 44
Use a JSON schema or a view created from the JSON schema to compose JSON
data.

Creating the job
Create the example job that includes one Hierarchical Data stage and two
Sequential File stages.

About this task
The following figure shows the job that you create for the composing example. The
job includes two Sequential File stages that are named Contacts_file and
PhoneNumbers_file. These Sequential File stages are linked to an Hierarchical Data
stage by two links that are named Contacts and PhoneNumbers. In this example,
instead of using a Join stage in the job to join the files into a list and a Regroup
step in the assembly to join the files into a nested list, you use the HJoin step in
the assembly to perform both actions.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and then click New >
Parallel job.
3. Open the File section of the palette, and drag two Sequential File stages to the
canvas.
4. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas. Position the Hierarchical Data stage to the right of the
Sequential File stages.
5. Create a job parameter for the location of the example files:
a. Click Edit > Job Properties.
b. On the Parameters page, specify the values in the following table.
Table 86. Values for the parameter
Field name

Value

Parameter Name

json_example_root_folder

Prompt

Root of example folder tree

Type

String

Help Text

Point to the root of the file tree folder

c. Click OK to save the values for the parameter.
6. Create a link from each Sequential File stage to the Hierarchical Data stage.
7. Rename the stage and links as shown in the following table.
Table 87. Names for stages and links
Stage or link

Name

Sequential File stage

Contacts_file

Sequential File stage

PhoneNumbers_file
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Table 87. Names for stages and links (continued)
Stage or link

Name

Link from Contacts_file to Hierarchical Data
stage

Contacts

Link from PhoneNumbers_file to
Hierarchical Data stage

PhoneNumbers

Hierarchical Data stage

ComposeJSON

Configuring the Sequential file stages
Configure the Sequential file stages to read the required files.

About this task
This job uses two sequential file stages. Configure the properties for Contacts_file
and PhoneNumbers_file stages.

Procedure
1. Configure the Contacts_file stage.
a. Double-click the Contacts_file stage.
b. Click the Output tab, and then click the Properties tab.
c. Specify values for the properties in the following table.
Table 88. Values for properties
Field name

Value

File

The path and file name of the file. For the
Contacts_file stage, the file name is contacts.txt

Read Method

Specific File(s)

First Line is Column Names

True

2. Click the Columns tab, and create the columns in the following table.
Table 89. Columns for the Contacts_file stage
Column name

SQL type

Length

FirstName

VarChar

40

LastName

VarChar

40

Age

VarChar

40

StreetAddress

VarChar

City

VarChar

State

VarChar

PostalCode

VarChar

NewSubscription

VarChar

CompanyName

VarChar

3. Configure the PhoneNumbers_file stage. Double-click the PhoneNumbers_file
stage to open the stage properties. On the Properties tab of the Output page,
configure the following properties:
a. Double-click the PhoneNumbers_file stage.
b. Click the Output tab, and then click the Properties tab.
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c. Specify values for the properties in the following table.
Table 90. Values for properties
Field name

Value

File

The path and file name of the file. For the
PhoneNumbers_file stage, the file name is
phonenumbers.txt

Read Method

Specific File(s)

First Line is Column Names

True

4. Click the Columns tab and create the columns in the following table.
Table 91. Columns for the PhoneNumbers_file stage
Column name

SQL type

FirstName

VarChar

LastName

VarChar

Number

VarChar

Type

VarChar

5. Click File > Save, and then name the job json_hjoin_example

Creating schema views
When a schema contains a large number of nodes, you create schema views to
reduce the size of schema tree and improve the efficiency of the parsing and
composing processes. Schema views are saved in the Schema Library Manager so
that they can be reused for different steps and different job designs.

Before you begin
The schema.json is a simple schema hence does not require views to compose
JSON data. To show case how views can be used, we have used simple schema to
compose JSON data by using views.

About this task
Create three views based on the original root schema.

Procedure
1.
2.
3.
4.
5.

Start the IBM® InfoSphere® DataStage® and QualityStage™ Designer.
Open Assembly Editor from the Hierarchical Data stage.
On Libraries tab, click New Library or select an existing schema library.
Select the node in the JSON schema that you want to create a schema view for.
Click Create View.

6. Enter the view name and the description.
7. Use the Find option to locate the nodes by a name. You can also search the
nodes by specifying the node level. Click Next after entering the node name
and specifying the node level.
8. Specify the properties for the schema view.
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Table 92. Properties for the schema view
Property

Description

Include in View

Select this check box for the optional nodes
that you want to include in the view.
Mandatory nodes are selected automatically.
You need to manually select the nodes that
are optional.

Include All Descendants

Select this check box to include all XML
elements that are under the selected node.

Chunk

Select this check box to chunk schema tree
of a selected XML element as one single
XML node with the XML type.

9. Click OK to save the view. Create address_view, phonenumbers_view, and
root_view. The address_view contains the address information. The
phoneNumbers_view contains the phone numbers. The root_view is created to
combine the information in the address_view and phonenumbers_view. As
shown in the below figure, the address and the phone numbers in the
root_view are chunked and represented by a single node.

Opening and configuring the Assembly Editor
In the Assembly Editor, you add the HJoin step, which is used to create a
parent-child hierarchy from two lists. Then, you add the JSON Composer step,
which can compose the JSON file.

Before you begin
To create a schema to describe the structures and types in the example JSON data
file, import the schema.json file. If you built the example job that parsed JSON
data, you already have a schema to describe the JSON data that you want to
compose.
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About this task
You can use the Assembly Editor to create an assembly. An assembly contains a
series of steps that parse, compose, and transform hierarchical data. By default, an
assembly contains an Overview, an Input step, and an Output step. You can add
steps to the assembly based on the type of transformations that you want to
perform. In this example you need add multiple steps to compose an JSON
document.

Procedure
1. Double-click the Hierarchical Data stage and then click Edit assembly.
2. On the Overview page, in the Description field, enter the following
description: This assembly uses the OneContact.json schema. The HJoin step
creates a hierarchical structure, where the contact information is the
parent and the phone number information is the child. The JSON_Composer
step composes the data and saves the output in a file named
contacts_output.
This assembly uses the default Input step, which shows the columns that the
two input links, Contacts and Phone Numbers, pass to the Hierarchical Data
stage. You can display the input columns either as links or a tree.
3. Open the Palette, and then double-click the HJoin step to add it to the
assembly.
4. Select the HJoin step, and then double-click the JSON Composer step in the
palette to add the JSON Composer step below the HJoin step. Create one HJoin
step and three JSON Composer steps.
5. Name the JSON Composer steps as Address_JSON_Composer step,
PhoneNumbers_JSON_Composer step, and JSON_Composer step.
Related tasks:
“Importing the schemas for the examples” on page 198
Use the schema library manager to generate a schema to describe a selected JSON
data and import the schema into a library.

Configuring the HJoin step
You can configure the HJoin step to create a parent-child list from items that share
the same key.

About this task
The input to the HJoin step contains two lists, Contact and PhoneNumbers. When
you configure the HJoin step, you identify the parent list and the child list, and
you specify the keys to use to join the two lists together. Where the value of the
key item is the same in both lists, the HJoin step joins the lists.

Procedure
1. On the Configuration page of the HJoin step, specify the parent and child lists:
Table 93. Specify the values for Parent and Child list
Field name

Value

Parent List

top/InputLinks/Contacts.

Child List

top/InputLinks/PhoneNumbers

2. In the Optimization Type field, select In-memory.
3. In the Parent Keys column, select top/InputLinks/Contacts/firstName.
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4. In the Child Keys column, select top/InputLinks/PhoneNumbers/firstName.
The Output page shows the child list PhoneNumbers is added to the Contacts
list. The Output page also contains a new node named HJoin:orphans, which
contains items that do not match the keys. The following figure shows this
portion of the Output page.
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Configuring the JSON Composer step
Configure the JSON Composer step to create a JSON file that lists contact
addresses, followed by phone numbers.

Procedure
1. In the JSON Target page of the Address_JSON_Composer Step, choose Pass as
string.
2. In the Document Root page of the Address_JSON_Composer Step, select the
address_view to describe the JSON data produced by the
Address_JSON_Composer Step.
a. Click Browse, and then open Schemas_for_JSON_examples library, which is
the library where you imported the schema.json sample data and generated
a schema that describes the sample data.
b. Select address_view element.
c. Click OK. The Document Root displays the structure of the address_view
element.
3. In the JSON Target page of the PhoneNumbers_JSON_Composer Step, choose
Pass as string.
4. In the Document Root page of the PhoneNumbers_JSON_Composer Step, select
the phonenumbers_view to describe the JSON data produced by the
PhoneNumbers_JSON_Composer Step.
a. Click Browse, and then open Schemas_for_JSON_examples library, which is
the library where you imported the schema.json sample data and generated
a schema that describes the sample data.
b. Select phonenumbers_view element.
c. Click OK. The Document Root displays the structure of the
phonenumbers_view element.
5. In the JSON Target page of the JSON_Composer Step, choose Write to File.
a. For the Output Directory, click Insert Parameter, and then select
json_example_root_folder.
b. For the Filename Prefix, enter contacts_output.
6. In the Document Root page of the JSON_Composer Step, select the schema
element that describes the documents that the step composes:
a. Click Browse, and then open Schemas_for_JSON_examples library, which is
the library where you imported the schema.json sample data and generated
a schema that describes the sample data.
b. Select the root_view element as the document root to describe the JSON
data produced by the JSON_Composer Step.
c. Click OK. the Document Root displays the structure of the root_view
element.
7. On the Validation page of the JSON_Composer Step, select Strict validation.
8. On the Mappings page of the JSON_Composer Step, map the items from the
Target list to the items in the Source list: The mapping for the
document_collection item determines how many JSON files are created. If you
map the top element of the input to the document_collection item, one
document is created. If you map a list item to the document_collection item,
one document is created for each item in the list. The name of each document
that is generated has the file name prefix that you specified on the JSON Target
page and an index that is an increasing number, for example
contacts_output_1.json.
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a. Map top/InputLinks/Contacts/first name in the Source list to the first
name item in the Target list, and then click Automap. Using automatic
mapping, you create the majority of the mappings that you need, but you
also create some mappings that you do not want.
b. Select the Job item in the Target list that has incorrect mapping. From the
drop down list select More, and then select the correct item for mapping.
The result-string generated from the Address_JSON_Composer Step and
PhoneNumbers_JSON_Composer Step are mapped to the value for the
chunked node "address" and "phoneNumbers". The following figure shows
the result of the mapping

The Output page contains a new node named JSON_Composer:result. This
node carries the path and file name for the output file during runtime.

Viewing the output of the job
After you run the job, look at the output.

Procedure
1. In the IBM InfoSphere DataStage and QualityStage Designer client, compile and
run the job.
2. In the Job Run Optionswindow, click Parameters page, for the Root of
example folder tree parameter, enter the path of the directory where you
extracted your example .zip file. For example, if you downloaded and saved
the examples .zip file in the\Examples folder, enter C:\Examples.
3. Open the contacts_output.json file to view the results, which are shown
below. The resulting file contains a list of address, and phone numbers for each
person.
{
"contacts" : [ {
"firstName" : "John",
"lastName" : "Smith",
"age" : "25",
"address" : {
"streetAddress" : "21 2nd Street",
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"city" : "New York",
"state" : "NY",
"postalCode" : "10021"
},
"phoneNumbers" : [ {
"type" : "home",
"number" : "212 555-1234"
}, {
"type" : "fax",
"number" : "646 555-4567"
} ],
"newSubscription" : "false",
"companyName" : "IBM"
}, {
"firstName" : "Adam",
"lastName" : "Li",
"age" : "15",
"address" : {
"streetAddress" : "21 2nd Street",
"city" : "BOca Raton",
"state" : "FL",
"postalCode" : "33334"
},
"phoneNumbers" : [ ],
"newSubscription" : "true",
"companyName" : "IBM"
} ]
}

Examples of invoking REST web services
You can build jobs that invoke REST web services from the Hierarchical Data stage
by using HTTP methods.
In the examples, the REST step invokes the REST web service by using the HTTP
methods such as GET, POST, DELETE, and PUT. The REST step supports various
content types, such as JSON, XML, text, image, and audio. In the examples, the
client uses the HTTP methods to send a request to the server in JSON or XML
format. The client gets the response in JSON or XML format. The output file
contains values that indicate whether the REST service calls ran successfully.
Although sample data is not provided for these examples, you can use the
information in the examples when you use your own data to invoke REST services.

Example 1: Using the HTTP POST method
In this example, a trainer creates a job that uses the REST step to invoke the REST
web service by using the HTTP POST method.

About this task
John, a trainer, develops training material and project plans. In this example, John
posts development plans on the website of the organization. The client uses the
POST method to send a request to the server and gets the response in JSON
format.

Example 1: Setting up the job and configuring the stages
John sets up a job that includes one Hierarchical Data stage and one Sequential
File stage. He then configure columns for the Sequential File stage.
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About this task
The following figure shows the job that John creates. The job includes a
Hierarchical Data stage named Hierarchical_POST and a Sequential File stage
named Sequential_File_POST. The Hierarchical_POST stage is linked to the
Sequential_File_POST stage by a link named httpPOST.

Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and then click New >
Parallel job.
3. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas.
4. Open the File section of the palette, and drag one Sequential File stage to the
canvas. Position the Sequential File stage to the right of the Hierarchical Data
stage.
5. Create the job parameters:
a. Select Edit > Job Properties.
b. On the Parameters tab, specify the job parameters for the HTTP POST
example, which are listed in the following table, and then click OK.
Table 94. Job Parameters for the HTTP POST example
Parameter Name

Prompt

Type

Directory

Specify the directory where
the input or output file is
created

String

restServer

Specify the IP address of the String
REST server where the REST
service is running

restServerPort

Specify the port number of
the REST server on which
the REST service is running

String

6. Create a link from the Hierarchical Data stage to the Sequential File stage.
7. Rename the stages and links as shown in the following table.
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Table 95. Names for job elements
Element

Name

Hierarchical Data stage

Hierarchical_POST

Sequential File stage

Sequential_File_POST

Link from the Hierarchical_POST stage to
the Sequential_File_POST stage

httpPOST

8. Configure the Sequential_File_POST stage:
a. Double-click the Sequential_File_POST stage, and configure the columns
that are listed in the following table on the Columns page.
Table 96. Columns for the Sequential_File_POST stage
Column name

SQL type

success

VarChar

errorMessage

VarChar

faultHttpStatusCode

VarChar

faultHttpBody

VarChar

httpVersion

VarChar

statusCode

VarChar

reasonPhrase

VarChar

body

VarChar

b. On the Properties page, configure the properties that define the output file.
Table 97. Properties for the output file
Property

Value

Target > File

The path where you want the output file to
be created, followed by the file name, for
example, #Directory#/output_http.txt.

Target > File Update Mode

Overwrite

First line is column name

True

c. Click OK to close the Sequential_File_POST stage.
9. Click File > Save, and name the job rest_POST.
Note: When you change the link name, or you add, delete, or modify datastage
columns or job parameters on the DataStage designer, you need to reopen and
save the assembly in the Hierarchical Data stage to validate the assembly
design.

Example 1: Opening the Assembly Editor and viewing the issues
John opens the Assembly Editor for the Hierarchical Data stage to design the job
that uses the HTTP POST method in the REST web service.

About this task
John adds a REST step that accesses the REST web service by using the HTTP
POST method to post the data on the server.
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Procedure
1. Double-click the Hierarchical Data stage, and then click Edit assembly.
2. Click Palette, and then double-click the REST step to add it to the outline.
Because the REST step is the first step that you added to the assembly, the step
is added between the Input step and the Output step.
a. In the outline, error icons (red exclamation marks) are shown beside the
REST step and the Output step. The error icon indicates that you must
address one or more issues in that step.
b. To view the issues list, click View All. The links and columns that you
defined on the httpPOST link are listed as errors because the hierarchical
structure of the assembly is not mapped to a relational structure. You can
correct these errors when you create mappings in the Output step.
c. Close the issues list.

Example 1: Configuring the REST step
In the REST step, John configures the URL and the HTTP POST method to use to
invoke the REST web service.

Procedure
1. In the outline, click the REST step.
2. On the General page, select POST from the HTTP method list.
3. In
a.
b.
c.
d.

the URL field, specify a parameter for the URL string:
Click Insert Parameter.
In the Insert Parameter window, select the restServer job parameter.
Click OK to add the parameter to the URL.
Repeat steps a to c to enter the restServerPort job parameter to the URL.

e. Enter the rest of the URL manually: http://
#restServer#:#restServerPort#/jackson/pojo/person/
collectionofcollection
4. On the Request page, specify information about the request body of the REST
web service:
a. Select the Load the outgoing body from check box.
b. From the Content type list, select application/json.
c. From the Encoding list, select UTF-8.
d. Select the A file whose path is set on the Mappings page as bodyFilePath
check box.
The bodyFilePath node is created on the Mappings page. You will map the
bodyFilePath node to the source file path that contains the request body.
5. On the Response page, specify information about the response body of the
REST web service:
a. Select the Pass the received body to check box.
b. Select the A text node named body in the Output schema option.
c. From the Content type list, select application/json.
6. On the Mappings page, map the bodyFilePath node to the constant value
'#Directory#/inputHTTP.json', which specifies the path of the text file that
contains the request body.
Note: Test Assembly feature is not enabled for the REST step in the Designer
client. So, you can not run the assembly in design mode if there is a REST step
in the assembly.
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Example 1: Configuring the Output step
In the Output step, John maps items in a hierarchical data structure to items in a
relational data structure.

Procedure
1. From the Assembly Editor, click the Output step. On the Output page, the
output table shows the data structure that is the output of the assembly. Notice
that the columns that you defined in the Sequential File stage editor are shown
in the output table.
2. Click the Mappings tab. Each item in the output structure is represented by a
row in the Mappings table. You map target items to source items. For this job,
the target structure has one link, httpPOST and the columns that are defined on
those links. In the Target column, the httpPOST link is represented as a list
item. Under the httpPOST list item, each column is a content item.
3. Map target items of the httpPOST link to source items:
a. In the Target column, click the httpPOST list item.
b. In the Source column, click the top item in the list.
c. To map the selected item and all of its descendent items, click Map
Automatically.
In the following figure, the target httpPOST list item and all of their child items
are mapped to source items.

4. Click OK to close the stage editor.

Example 1: Viewing the output of the job
After John runs the job, he opens the text files and looks at the output.

Procedure
1. From the Assembly Editor, click OK to return to the Hierarchical Data stage
editor, and then click OK to close the Hierarchical Data stage editor.
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2. To compile the job, click File > Compile from the IBM InfoSphere DataStage
and QualityStage Designer client.
3. Click File > Run to run the job.
4. In the parameter window, specify values for the Directory, restServer, and
restServerPort parameters.
This example uses the input file, inputHTTP.json that contains the request
body:

5. After the job runs, open the output file, output_http.txt, to view the result of
the REST web service invocation.
The output_http.txt file contains data that indicates that the REST web service
was invoked successfully.

Results
By using the Hierarchical Data stage, John posted the required details on the web
site.

Example 2: Using the HTTP DELETE method
In this example, a business analyst creates a job that uses the REST step to invoke
the REST web service by using the HTTP DELETE method.

About this task
Tom, a business analyst, adds, edits, and deletes bookmarks for web documents.
He uses a bookmarking service to add bookmarks by specifying the index value. In
this example, Tom deletes a bookmark by passing its index value to the URL. The
client sends a request to the bookmarking service to delete the bookmark that has
the index value 1 by using the DELETE method.

Example 2: Setting up the job and configuring the stages
Tom sets up a job that includes one Hierarchical Data stage and one Sequential File
stage. He then configures columns for the Sequential File stage.
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About this task
The following figure shows the job that Tom creates. The job includes a
Hierarchical Data stage named Hierarchical_ DELETE and a Sequential File stage
named Sequential_File_DELETE. The Hierarchical_DELETE stage is linked to the
Sequential_File_DELETE stage by a link named httpDELETE.

Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and then click New >
Parallel job.
3. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas.
4. Open the File section of the palette, and drag one Sequential File stage to the
canvas. Position the Sequential File stage to the right of the Hierarchical Data
stage.
5.

Create the job parameters:
a. Select Edit > Job Properties.
b. On the Parameters tab, specify the job parameters for the HTTP DELETE
example, which are listed in the following table, and then click OK.

Table 98. Job Parameters for the HTTP DELETE example
Parameter Name

Prompt

Type

Directory

Specify the directory where
the input or output file is
created

String

restServer

Specify the IP address of the String
REST server where the REST
service is running

restServerPort

Specify the port number of
the REST server on which
the REST service is running

String

6. Create a link from the Hierarchical Data stage to the Sequential File stage.
7. Rename the stages and links as shown in the following table.
Table 99. Names for job elements
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Element

Name

Hierarchical Data stage

Hierarchical_DELETE

Sequential File stage

Sequential_File_DELETE
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Table 99. Names for job elements (continued)
Element

Name

Link from the Hierarchical_DELETE stage to httpDELETE
the Sequential_File_DELETE stage

8. Configure the Sequential_File_DELETE stage:
a. Double-click the Sequential_File_DELETE stage, and configure the columns
that are listed in the following table on the Columns page.
Table 100. Columns for the Sequential_File_DELETE stage
Column name

SQL type

httpVersion

VarChar

statusCode

VarChar

reasonPhrase

VarChar

b. On the Properties page, configure the properties that define the output file:
Table 101. Properties for the output file
Property

Value

Target > File

The path where you want the output file to
be created, followed by the file name
#Directory#/output_delete.txt.

Target > File Update Mode

Overwrite

c. Click OK to close the Sequential_File_DELETE stage.
9. Click File > Save, and name the job rest_DELETE.

Example 2: Opening the Assembly Editor and viewing the issues
Tom opens the Assembly Editor for the Hierarchical Data stage to design the job
that uses the HTTP DELETE method in the REST web service.

About this task
Tom adds one REST step in the assembly to access the REST web service.

Procedure
1. Double-click the Hierarchical Data stage, and then click Edit assembly.
2. Click Palette, and then double-click the REST step to add it to the outline.
Because the REST step is the first step that you added to the assembly, the step
is added between the Input step and the Output step.
3. In the outline, error icons (red exclamation marks) are shown beside the REST
step and the Output step. The error icons indicate that you must address one or
more issues in that step.
4. To view the issues list, click View All. The links and columns that you defined
on the httpDELETE link are listed as errors because the hierarchical structure of
the assembly is not mapped to a relational structure. You can correct these
errors when you create mappings in the Output step.
5. Close the issues list.

Example 2: Configuring the REST step
In the REST step, Tom configures the URL and the HTTP DELETE method to use
to invoke the REST web service.
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Procedure
1. In the outline, click the REST step.
2. On the General page, select DELETE from the HTTP method list.
3. In the URL field, specify a URL string that includes job parameters:
a. Click Insert Parameter.
In the Insert Parameter window, select the restServer job parameter.
Click OK to add the parameter to the URL.
Repeat steps a to c to enter the restServerPort job parameter to the URL.
Enter the rest of the URL manually: http://
#restServer#:#restServerPort#/Bookmarks/rest/bookmarks/1
In this URL, index entry 1 is the resource to remove from the bookmarks
service. Bookmarks is the service where you can add bookmarks by specifying
the index value. In this job, you delete a bookmark by passing its index value
to the URL.
4. On the Response page, specify information about the response body of the
REST web service:
a. Select the Pass the received body to check box.
b.
c.
d.
e.

b. Select the A text node named body in the Output schema option.
c. From the Content type list, select application/xml.

Example 2: Configuring the Output step
In the Output step, Tom maps items in a hierarchical data structure to items in a
relational data structure.

Procedure
1. From the Assembly Editor, click the Output step. On the Output page, the
output table shows the data structure that is the output of the assembly. The
columns that you defined in the Sequential File stage are shown in the output
table.
2. Click the Mappings tab. Each item in the output structure is represented by a
row in the Mappings table. You map target items to source items. For this job,
the target structure has one link, httpDELETE, and the columns that are
defined on that link. In the Target column, the httpDELETE link is represented
as a list item. Under the httpDELETE list item, each column is a content item.
3. Map target items on the httpDELETE link to source items:
a. In the Target column, click the httpDELETE list item.
b. In the Source column, click the top item in the list.
c. To map the selected item and all of its child items, click Map
Automatically.
In the following figure, the target httpDELETE list item and all of its child
items are automatically mapped to source items.
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4. Click OK to close the stage editor.

Example 2: Viewing the output of the job
After Tom runs the job, he opens the text file and looks at the output.

Procedure
1. From the Assembly Editor, click OK to return to the Hierarchical Data stage
editor, and then click OK to close the Hierarchical Data stage editor.
2. To compile the job, click File > Compile from the IBM InfoSphere DataStage
and QualityStage Designer client.
3. Click File > Run to run the job.
4. In the parameter window, specify values for the Directory, restServer, and
restServerPort parameters.
After you run the job, the resource that is specified in the URL is deleted. You
can view the result of the REST call by opening the output_delete.txt output
file. The output_delete.txt file contains data that indicates that the REST web
service call was invoked successfully.

The status code 200 indicates that the resource that was specified in the URL
was deleted.

Results
By using the Hierarchical Data stage, Tom deleted the bookmark having index
value 1.
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Example 3: Updating InfoSphere Information Governance
Catalog terms by using the REST API
In this example, a business analyst creates a job that uses the InfoSphere
Information Governance Catalog REST API to invoke the REST web service. He
searches for a term that has an incorrect definition in the business glossary and
then corrects the term definition.

About this task
The InfoSphere Information Governance Catalog REST API is used by client
applications to access and create business glossary content. The REST service
exposes the data that is stored in the business glossary as resources. These
resources are addressed by uniform resource identifier (URI)s and are represented
by XML documents.
Tom, a business analyst, is responsible for managing business vocabulary, defining
the business processes, and defining the terms that are used in the business
glossary of the company. One day, when Tom reviews the business glossary for his
company, he is surprised to see that the definition of the term 012 Farming Of
Animals is not accurate. He uses the Hierarchical Data stage to correct the
definition of the term.
To modify the definition, Tom needs the URI for the term. He then searches for the
term name by using the HTTP GET method. The REST step provides the response
body for the term in XML form. Then, the XML Parser step parses the response
body of the REST step, which is the XML document, to get the URI of the term.
The URI of the term is the input for the next REST step, which corrects the term
definition by using the HTTP PUT method.

Example 3: Setting up the job and configuring the stages
Tom sets up a job that includes a Hierarchical Data stage and two Sequential File
stages. He then configures columns for the Sequential File stages.

About this task
The following figure shows the job that Tom creates to update InfoSphere
Information Governance Catalog terms by using the REST API. The job includes a
Hierarchical Data stage named EditTerm and Sequential File stages named
Get_Output and Put_Output. The EditTerm stage is linked to the Get_Output stage
by a link named httpGET. The EditTerm stage is linked to the Put_Output stage by
a link named httpPUT.
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Procedure
1. Start the IBM InfoSphere DataStage and QualityStage Designer client.
2. In the Repository pane, right-click the Jobs folder, and then click New >
Parallel job.
3. Open the Real Time section of the palette, and drag one Hierarchical Data
stage to the canvas.
4. Open the File section of the palette, and drag two Sequential File stages to the
canvas. Position the Sequential File stages to the right of the Hierarchical Data
stage.
5. Create the job parameters:
a. Select Edit > Job Properties.
b. On the Parameters tab, specify the job parameters for this example, which
are listed in the following table, and then click OK.
Table 102. Job Parameters for the example
Parameter Name

Prompt

Type

Directory

Specify the directory where
the input or output file is
created

String

BGServer

Specify the IP address of the
Information Server Catalog
server where the REST
service is running

String

BGServerPort

Specify the port number of
the Information Server
Catalog server on which the
REST service is running

String

6. Create links from the Hierarchical Data stage to the Sequential File stages.
7. Rename the stages and links as shown in the following table.
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Table 103. Names for job elements
Element

Name

Hierarchical Data stage

EditTerm

Sequential File stage

Get_Output

Sequential File stage

Put_Output

Link from the EditTerm stage to the
Get_Output stage

httpGET

Link from the EditTerm stage to the
Put_Output stage

httpPUT

8. Configure the Get_Output stage:
a. Double-click the Get_Output stage, and configure the columns that are
listed in the following table on the Columns page.
Table 104. Columns for the Get_Output stage
Column name

SQL type

success

VarChar

errorMessage

VarChar

faultHttpStatusCode

VarChar

reasonPhrase

VarChar

statusCode

Integer

b. On the Properties page, configure the properties that define the output file:
Table 105. Properties for the output file
Property

Value

Target > File

The path where you want the output file to
be created followed by the file name, for
example, #Directory#/
FetchTerm_Author.txt.

Target > File Update Mode

Overwrite

First line is column name

True

c. Click OK to close the Get_Output stage.
9. Configure the Put_Output stage:
a. Double-click the Put_Output stage, and configure the columns that are
listed in the following table on the Columns page.
Table 106. Columns for the Put_Output stage
Column name

SQL type

success

VarChar

errorMessage

VarChar

faultHttpStatusCode

VarChar

faultHttpBody

VarChar

statusCode

Integer

reasonPhrase

VarChar

b. On the Properties page, configure the properties that define the output file.
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Table 107. Properties for the output file
Property

Value

Target > File

The path where you want the output file to
be created followed by the file name, for
example, #Directory#/EditTerm_Author.txt.

Target > File Update Mode

Overwrite

First line is column name

True

c. Click OK to close the Put_Output stage.
10. Click File > Save, and name the job rest_BG.

Example 3: Opening the Assembly Editor and viewing the issues
Tom opens the Assembly Editor for the Hierarchical Data stage to design a job that
uses the HTTP methods in the REST web service.

About this task
Tom adds the first REST step to search for a term that has an incorrect definition in
the business glossary. Then, Tom adds one XML Parser step to parse the output of
the REST step to get the resource URI of the term. Finally, Tom adds one more
REST step between the XML Parser step and the Output step to correct the term
definition.

Procedure
1. Double-click the Hierarchical Data stage, and then click Edit assembly.
2. Click Palette, and then double-click the REST step to add it to the outline.
Because the REST step is the first step that you added to the assembly, the step
is added between the Input step and the Output step.
3. In the outline, error icons (red exclamation marks) are shown beside the REST
step and the Output step. The error icons indicate that you must address one or
more issues in that step.
4. To view the issues list, click View All. The links and columns that you defined
on the httpGET and httpPUT links are listed as errors because the hierarchical
structure of the assembly is not mapped to a relational structure. You can
correct these errors when you create mappings in the Output step.
5. Close the issues list.

Example 3: Configuring the REST step to get the term
In the REST step, Tom specifies the URL and uses the HTTP GET method to get
the term that has an incorrect definition. IBM InfoSphere Information Governance
Catalog supports a set of APIs that you can include in the URL to implement the
REST web services. Information Governance Catalog REST APIs are secured with
Secure Socket Layer (SSL).

About this task
Tom searches for the term name, 012 Farming Of Animals, which has an incorrect
definition by using the HTTP GET method in the REST step.

Procedure
1. In the outline, click the REST step.
2. On the General page, select GET from the HTTP method list.
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3. In
a.
b.
c.
d.

the URL field, specify a URL string that includes the job parameters:
Click Insert Parameter.
In the Insert Parameter window, select theBGServer job parameter.
Click OK to add the parameter to the URL.
Repeat steps a to c to enter the BGPort job parameter to the URL.

e. Enter the rest of the following URL manually: https://
#BGServer#:#BGPort#/ibm/iis/bgrestapi/v4/search?pattern=012%20Farming
%20Of%20Animals&queriedClasses=term
In this URL, 012 Farming Of Animals, is the pattern to search for the term class
of the business glossary.
4. On the Security page, specify information about the security of the IGC REST
API.
a. From the Authentication list, select Basic, and then specify the user name
and password to use to access the REST web service.
b. Select the Enable SSL check box because IGC REST APIs are secured with
SSL.
c. Select the SSL server authentication check box.
d. From the Trustore type list, select PKCS12.
e. In the Trustore file field, specify the path of the truststore file
iis-client-truststore.p12, which is available in the Information
Server/ASBNode/conf folder.
5. On the Response page, specify information about the response body of the
REST web service:
a. Select the Pass the received body to check box.
b. Select the A text node named body in the Output schema option.
c. From the Content type list, select application/xml.
The REST step gets the response body, which contains the term with an
incorrect definition, in XML form. The response body of the REST step is the
input for the XML Parser step.
Related information:
InfoSphere Information Governance Catalog REST API

Example 3: Configuring the XML parser
Tom parses the output of the REST step by using the XML parser. The parsed
information is the input to the next REST step, which corrects the definition of the
term.

About this task
Tom uses the response body of the previous REST step as the input for the XML
Parser step to get the URI of the term, 012 Farming Of Animals, which has an
incorrect definition.

Procedure
1. Click Palette, and then double-click the XML Parser step to add it to the
outline. The step is added between the REST step and the Output step.
2. On the XML Source page, select String set.
3. From the String set list, select the XML source data, which is the output of the
previous REST step.
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4. On the Document Root page, click Browse, and then select the sourceResource
schema from the Select Document Root window. This schema is the schema for
the XML body of the XML Parser step.

Example 3: Configuring the REST step to edit the term
In the REST step, Tom edits the term, which is in the output of the XML Parser
step.

About this task
Because Tom has the Information Governance Catalog Glossary Author role, he can
read and write content in the business glossary. To modify the term definition, Tom
needs the URI for the term, which he got from the XML Parser step. He modifies
the term definition by using the HTTP PUT method in the REST step.

Procedure
1. Click Palette, and then double-click the REST step to add another REST step to
the outline. The step is added between the XML Parser step and the Output
step.
2. On the General page, select PUT from the HTTP method list.
3. In the URL field, specify a URL string that includes job parameters:
a. Click Insert Parameter.
b. In the Insert Parameter window, select the BGServer job parameter, to
include in the URL.
c. In the Local parameter field, enter uri to add the local parameter to the
URL.
d. Click OK to add the parameter to the URL.
e. Repeat steps a, b and d to enter the BGPort job parameter to the URL.
f. Enter the rest of the URL manually: https://#BGServer#:#BGPort#/<uri>
In this example, uri is the local parameter that must be mapped to the uri field
of the XML Parser step on the Mappings page.
4. On the Security page, specify information about the security of the IGC REST
API.
a. From the Authentication list, select Basic, and then specify the user name
and password to use to access the REST web service.
b. Select the Enable SSL check box because IGC REST APIs are secured with
SSL.
c. Select the SSL server authentication check box.
d. From the Trustore type list, select PKCS12.
e. In the Trustore file field, specify the path of the truststore file
iis-client-truststore.p12, which is available in the Information
Server/ASBNode/conf folder.
5. On the Request page, specify information about the request body of the REST
web service:
a. Select the Load the outgoing body from check box.
b. From the Content type list, select application/xml.
c. From the Encoding list, select UTF-8.
d. Select the A file whose path is set on the Mappings page as bodyFilePath
check box.
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The bodyFilePath node is created on the Mappings page. You will map the
bodyFilePath node to the path for the source file that contains the request body.
The request body contains term details with the correct definitions.
6. On the Response page, specify information about the response body of the
REST web service:
a. Select the Pass the received body to check box.
b. Select the A text node named body in the Output schema option.
c. From the Content type list, select application/xml.
7. On the Mappings page, map the following items:
a. Map the uri node to the uri field of the XML Parser step.
b. Map the bodyFilePath node to the constant value,
'#Directory#TermInput.xml', which specifies the path of the XML file that
contains the request body.
The following figure shows that the Target items are mapped to the Source
items.

Example 3: Configuring the Output step
In the Output step, Tom maps items in a hierarchical data structure to items in a
relational data structure.

Procedure
1. From the Assembly Editor, click the Output step. On the Output page, the
output table shows the data structure that is the output of the assembly. The
columns that you defined in the Sequential File stage are shown in the output
table.
2. Click the Mappings tab. Each item in the output structure is represented by a
row in the Mappings table. You map target items to source items. For this job,
the target structure has two links, httpGET and httpPUT, and the columns that
are defined on those links. In the Target column, the httpGET link is
represented as a list item. Under the httpGET list item, each column is a
content item.
3. Map the target items on the httpGET link to source items:
a. In the Target column, click the httpGET list item.
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b. In the Source column, click the top item in the list.
c. To map the selected item and all of its child items, click Map
Automatically.
4. Map the target items on the httpPUT link to source items:
a. In the Target column, click the httpPUT list item.
b. In the Source column, click the top item in the list.
c. To map the selected item and all of its child items, click Map
Automatically.
In the following figure, the target httpGET and httpPUT list items and all of
their child items are mapped to source items.

5. Click OK to close the stage editor.

Example 3: Viewing the output of the job
Tom runs the job, views the data from the Sequential File stages, and looks at the
output.

Procedure
1. From the Assembly Editor, click OK to return to the Hierarchical Data stage
editor, and then click OK to close the Hierarchical Data stage editor.
2. Compile and run the job.
3. In the parameter window, specify values for the Directory, BGServer, and
BGServerPort parameters.
4. After the job runs, view the data from the Get_Output and Put_Output stages
to see the result of the REST web service invocation.
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The Get_Output stage contains data that indicates that the REST web service
was invoked successfully and got the term that has an incorrect definition. In
the following figure, the status code 200 indicates that the REST web service
was invoked successfully:

The Put_Output stage contains data that indicates that the REST web service
was invoked successfully and corrected the definition of the term:

Results
By using the Hierarchical Data stage, Tom corrected the definition of the term.

Reference
These topics describe supported XML types and XML-type-to-DataStage-type
mappings, describe how to get the example files, and provide user responses to
error messages and information about working with IBM Software Support.
For more information on Hierarchical Data stage, refer to the Developer article
links below:

Supported XML types and type mappings
When you create an assembly, refer to these tables that describe supported XML
types, DataStage-to-XML type mappings, and XML-to-DataStage type mappings.

XML types
This table describes the types that the Hierarchical Data stage supports and
provides examples of each type.
Table 108. Supported XML types
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XML type

Examples

Duration

P0Y0M0DT0H0M0S
-P120D, P1Y2MT2S

dateTime

1970-01-01T00:00:00
1970-01-01T00:00:002001-04-29T14:29:03.5
2001-04-29T14:29:03+06:00
2001-04-29T14:29:03-06:00
20001-04-29T14:29:00Z

Time

00:00:00
14:29:03.5
14:29:03+06:00
14:39:03-06:00
14:29:00Z
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Table 108. Supported XML types (continued)
XML type

Examples

date

1970-01-01
2001-04-29
-0099-04-29+06:00
2001-04-29-06:00
2001-04-29-06Z

gYear

1970
2065-05:00
-0099

gYearMonth

1989-01
2065-10-05:00
2065-07+05:00
2065-09Z

gMonth

--01
--10-05:00
--07+05:00
--09Z

gMonthDay

--01-29
--10-05:00
--01+07:00
--09Z

gDay--

--01

anyURI

http://sample.gov
../list.html#item
urn:sample.gov

ENTITY

namesNameWithNoColons

ENTITIES

namesNameWithNoColons1
namesNameWithNoColons2

ID

Unique_ID: aNameWithNoColons

IDREF

Reference_to_n_ID: aNameWithNoColons

IDREFS

namesNameWithNoColons1
namesNameWithNoColons2

QName

item
bag:item

token

A token has only single space character in
it.

language

en-US
fr

Name

foo3
foo:bar
non-leading.hyphen

NCName

aNameWithNoColons

NMTOKEN

comb .-:no_whitespace

NMTOKENS

comb_brush.-no_whitespace

NOTATION

item
bag:item

normalizedString

A normalizedString has only space
characters in it.

string

A string, which can include tab characters.
Hierarchical data
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Table 108. Supported XML types (continued)
XML type

Examples

float

32-bit floating-point number. -34E5,
123.65E12, 98.72-2, 12, INF, -INF, NaN

double

64-bit floating-point number. -34E5,
123.65E12, 98.72-2, 12, INF, -INF, NaN

decimal

0, 0.0, +1134.56, -32.1

integer

-4, 0, 76768878778

long

Range is -9223372036854775808 to
9223372036854775807

int

Range is -2147483648 to 2147483647

short

Range is -32768 to 32767.

byte

Range is -128 to 127.

positiveInteger

Range is 1, 2, and so on.

nonPositiveInteger

Range is ..., -2, -1, 0.

negativeInteger

Range is ...-3, -2, -1.

nonNegativeInteger

Range is 0, 1, 2, and so on.

unsignedLong

Range is 0 to 18446744073709551615.

unsignedInt

Range is 0 to 4294967295.

unsignedShort

Range is 0 to 65535.

unsignedByte

Range is 0 to 225.

hexBinary

None.

base64Binary

None.

boolean

Legal values are true and false; 1 and 0.

DataStage-to-XML type mappings
This table shows the mapping of DataStage type to XML type.
Table 109. DataStage-to-XML type mappings
DataStage type

XML type

BigInt

long

Unsigned BigInt

unsignedLong

Binary

binary

Bit

boolean

Char

string

Date

date

Decimal

decimal

Double

double

Float

double

Integer

int

Unsigned Integer

unsignedInt

LongNVarChar

string

LongVarBinary

binary

LongVarChar
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string

Table 109. DataStage-to-XML type mappings (continued)
DataStage type

XML type

NChar

string

Numeric

decimal

NVarChar

string

Real

float

SmallInt

short

Unsigned SmallInt

unsignedShort

Time

time

Timestamp

dateTime

TinyInt

byte

Unsigned TinyInt

unsignedByte

VarBinary

binary

VarChar

string

XML-to-DataStage data type mappings
This table shows the data type mappings.
Table 110. XML-type-to-DataStage data type mappings
XML type

DataStage data type

duration

VarChar

dateTime

TimeStamp

time

Time

date

Date

gYear

Date

gYearMonth

Date

gMonth

Date

gMonthDay

Date

gDay

Date

anyURI

VarChar

ENTITY

VarChar

ENTITIES

VarChar

ID

VarChar

IDREF

VarChar

IDREFS

VarChar

QName

VarChar

token

VarChar

language

VarChar

Name

VarChar

NCName

VarChar

NMTOKEN

VarChar

NMTOKENS

VarChar

NOTATION

VarChar
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Table 110. XML-type-to-DataStage data type mappings (continued)
XML type

DataStage data type

normalizedString

VarChar

string

VarChar

float

Real

double

Double

decimal

Decimal

integer

Decimal

long

BigInt

int

Integer

short

SmallInt

byte

TinyInt

positiveInteger

Decimal

nonPositiveInteger

Decimal

negativeInteger

Decimal

nonNegativeInteger

Decimal

unsignedLong

Unsigned BigInt

unsignedInt

Unsigned Integer

unsignedShort

Unsigned SmallInt

unsignedByte

Unsigned TinyInt

hexBinary

VarChar

base64Binary

VarChar

boolean

Bit

Files for Hierarchical Data stage examples
The files includes schemas and data files that are used in the example jobs that
illustrate how to use steps to create assemblies for the Hierarchical Data stage.
You use these files when you create the example jobs that use the Hierarchical
Data stage. For each example, the finished job is available. You can either follow
the step-by-step instructions to build each example, or import the complete job and
explore it on your own.
To download the examples files, go to http://www.ibm.com/support/
docview.wss?uid=swg27019894.
Table 111. Example files
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Example

Files

Example 1: Parsing XML data

departments.xml (input file), Employee.xsd
(schema), Organization.xsd (schema),
xml_parser_example.dsx (job), employee.txt
(output file), address.txt (output file)

Example 2: Using the XML Composer and
Regroup steps

departments.xml (input file), Employee.xsd
(schema), Organization.xsd (schema),
employee.txt (input file), address.txt (input
file), xml_composer_example.dsx (job),
employee_output.xml, (output file)
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Table 111. Example files (continued)
Example

Files

Example 3: Using the XML Composer and
HJoin steps

departments.xml (input file), Employee.xsd
(schema), Organization.xsd (schema),
employee.txt (input file), address.txt (input
file), xml_hjoin_example.dsx (job),
employee_output_xml (output file)

Example 4: using the XML Parser and
Switch steps

employee1.xml (input file), employee2.xml
(input file), Employee.xsd (schema),
Organization.xsd (schema),
xml_switch_example.dsx (job), valid_emp.txt
(output file), InValid_emp.txt (output file)

Example 5: using the XML Parser and Union employee1.xml (input file), employee2.xml
steps
(input file), Employee.xsd (schema),
Organization.xsd (schema), Employee1.xsd
(union_schemas\schema1),
Organization1.xsd (union_schemas\
schema1),Employee2.xsd
(union_schemas\schema2),
Organization2.xsd (union_schemas\
schema2),xml_union_example.dsx (job),
employees_output.xml (output file)
Example 6: Using the XML Composer and
H-Pivot steps

address.txt (input file), Employee.xsd
(schema), Organization.xsd (schema),
xml_hpivot_example.dsx (job),
address_output.xml (output file)

Example 7: Using the XML Parser and
Aggregate steps

departments.xml (input file), employee.xsd
(schema), organization.xsd (schema),
xml_aggregate_example.dsx (job),
employees_output.txt (output file)

Example 8: Using the XML Composer and
Sort steps

departments.xml (input file), employee.xsd
(schema), organization.xsd (schema),
xml_sort_example.dsx (job),
employees_output.xml (output file)

Example 9: Using the XML Composer and
OrderJoin steps

address.xml (input file), employee.xml
(input file), employee1.xsd (schmema),
organization1.xsd (schema),
xml_orderjoin_example.dsx (job),
employees_output.xml (output file)

Example 10: Using the XML Parser and
V-Pivot steps

departments.xml (input file), employee.xsd
(schema), organization.xsd (schema),
xml_vpivot_example.dsx (job),
employees_output.txt (output file)

Working with IBM Software Support to diagnose problems
Use these settings when you work with IBM Software Support to solve problems.
Choose Options in the Assembly Editor to display the following settings:
Assembly Context File
Click Download to save a copy of the assembly context file. This file,
which has the extension e2d, is useful for problem determination and
testing.
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Logging
The file location of the log file and the log level.
Server Tracing
Enable tracing to record a trace log.
Flash Plug-in Diagnostics
This is informational.
Application Diagnostics
This is informational.
Note: If you change the default settings, they apply only to the current assembly.

Links to developer articles
Use the developer article links in this topic for more information about
Hierarchical Data stage.
v Introduction - http://www.ibm.com/developerworks/data/library/techarticle/
dm-1103datastages/index.html
v Understanding the assembly - http://www.ibm.com/developerworks/data/
library/techarticle/dm-1103datastages2/index.html
v Understanding validation rules - http://www.ibm.com/developerworks/data/
library/techarticle/dm-1104datastages3/index.html
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Appendix A. Product accessibility
You can get information about the accessibility status of IBM products.
The IBM InfoSphere Information Server product modules and user interfaces are
not fully accessible.
For information about the accessibility status of IBM products, see the IBM product
accessibility information at http://www.ibm.com/able/product_accessibility/
index.html.

Accessible documentation
Accessible documentation for InfoSphere Information Server products is provided
in an information center. The information center presents the documentation in
XHTML 1.0 format, which is viewable in most web browsers. Because the
information center uses XHTML, you can set display preferences in your browser.
This also allows you to use screen readers and other assistive technologies to
access the documentation.
The documentation that is in the information center is also provided in PDF files,
which are not fully accessible.

IBM and accessibility
See the IBM Human Ability and Accessibility Center for more information about
the commitment that IBM has to accessibility.

© Copyright IBM Corp. 2011, 2014
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Appendix B. Reading command-line syntax
This documentation uses special characters to define the command-line syntax.
The following special characters define the command-line syntax:
[]

Identifies an optional argument. Arguments that are not enclosed in
brackets are required.

...

Indicates that you can specify multiple values for the previous argument.

|

Indicates mutually exclusive information. You can use the argument to the
left of the separator or the argument to the right of the separator. You
cannot use both arguments in a single use of the command.

{}

Delimits a set of mutually exclusive arguments when one of the arguments
is required. If the arguments are optional, they are enclosed in brackets ([
]).

Note:
v The maximum number of characters in an argument is 256.
v Enclose argument values that have embedded spaces with either single or
double quotation marks.
For example:
wsetsrc[-S server] [-l label] [-n name] source
The source argument is the only required argument for the wsetsrc command. The
brackets around the other arguments indicate that these arguments are optional.
wlsac [-l | -f format] [key... ] profile
In this example, the -l and -f format arguments are mutually exclusive and
optional. The profile argument is required. The key argument is optional. The
ellipsis (...) that follows the key argument indicates that you can specify multiple
key names.
wrb -import {rule_pack | rule_set}...
In this example, the rule_pack and rule_set arguments are mutually exclusive, but
one of the arguments must be specified. Also, the ellipsis marks (...) indicate that
you can specify multiple rule packs or rule sets.

© Copyright IBM Corp. 2011, 2014
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Appendix C. How to read syntax diagrams
The following rules apply to the syntax diagrams that are used in this information:
v Read the syntax diagrams from left to right, from top to bottom, following the
path of the line. The following conventions are used:
– The >>--- symbol indicates the beginning of a syntax diagram.
– The ---> symbol indicates that the syntax diagram is continued on the next
line.
– The >--- symbol indicates that a syntax diagram is continued from the
previous line.
– The --->< symbol indicates the end of a syntax diagram.
v Required items appear on the horizontal line (the main path).
 required_item



v Optional items appear below the main path.
 required_item


optional_item

If an optional item appears above the main path, that item has no effect on the
execution of the syntax element and is used only for readability.
optional_item
 required_item



v If you can choose from two or more items, they appear vertically, in a stack.
If you must choose one of the items, one item of the stack appears on the main
path.
 required_item

required_choice1
required_choice2



If choosing one of the items is optional, the entire stack appears below the main
path.
 required_item


optional_choice1
optional_choice2

If one of the items is the default, it appears above the main path, and the
remaining choices are shown below.
default_choice
 required_item


optional_choice1
optional_choice2

v An arrow returning to the left, above the main line, indicates an item that can be
repeated.
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 required_item  repeatable_item



If the repeat arrow contains a comma, you must separate repeated items with a
comma.
,
 required_item  repeatable_item



A repeat arrow above a stack indicates that you can repeat the items in the
stack.
v Sometimes a diagram must be split into fragments. The syntax fragment is
shown separately from the main syntax diagram, but the contents of the
fragment should be read as if they are on the main path of the diagram.
 required_item

fragment-name



Fragment-name:
required_item
optional_item

v Keywords, and their minimum abbreviations if applicable, appear in uppercase.
They must be spelled exactly as shown.
v Variables appear in all lowercase italic letters (for example, column-name). They
represent user-supplied names or values.
v Separate keywords and parameters by at least one space if no intervening
punctuation is shown in the diagram.
v Enter punctuation marks, parentheses, arithmetic operators, and other symbols,
exactly as shown in the diagram.
v Footnotes are shown by a number in parentheses, for example (1).
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Appendix D. Contacting IBM
You can contact IBM for customer support, software services, product information,
and general information. You also can provide feedback to IBM about products
and documentation.
The following table lists resources for customer support, software services, training,
and product and solutions information.
Table 112. IBM resources
Resource

Description and location

IBM Support Portal

You can customize support information by
choosing the products and the topics that
interest you at www.ibm.com/support/
entry/portal/Software/
Information_Management/
InfoSphere_Information_Server

Software services

You can find information about software, IT,
and business consulting services, on the
solutions site at www.ibm.com/
businesssolutions/

My IBM

You can manage links to IBM Web sites and
information that meet your specific technical
support needs by creating an account on the
My IBM site at www.ibm.com/account/

Training and certification

You can learn about technical training and
education services designed for individuals,
companies, and public organizations to
acquire, maintain, and optimize their IT
skills at http://www.ibm.com/training

IBM representatives

You can contact an IBM representative to
learn about solutions at
www.ibm.com/connect/ibm/us/en/

© Copyright IBM Corp. 2011, 2014
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Appendix E. Accessing the product documentation
Documentation is provided in a variety of formats: in the online IBM Knowledge
Center, in an optional locally installed information center, and as PDF books. You
can access the online or locally installed help directly from the product client
interfaces.
IBM Knowledge Center is the best place to find the most up-to-date information
for InfoSphere Information Server. IBM Knowledge Center contains help for most
of the product interfaces, as well as complete documentation for all the product
modules in the suite. You can open IBM Knowledge Center from the installed
product or from a web browser.

Accessing IBM Knowledge Center
There are various ways to access the online documentation:
v Click the Help link in the upper right of the client interface.
v Press the F1 key. The F1 key typically opens the topic that describes the current
context of the client interface.
Note: The F1 key does not work in web clients.
v Type the address in a web browser, for example, when you are not logged in to
the product.
Enter the following address to access all versions of InfoSphere Information
Server documentation:
http://www.ibm.com/support/knowledgecenter/SSZJPZ/

If you want to access a particular topic, specify the version number with the
product identifier, the documentation plug-in name, and the topic path in the
URL. For example, the URL for the 11.3 version of this topic is as follows. (The
⇒ symbol indicates a line continuation):
http://www.ibm.com/support/knowledgecenter/SSZJPZ_11.3.0/⇒
com.ibm.swg.im.iis.common.doc/common/accessingiidoc.html

Tip:
The knowledge center has a short URL as well:
http://ibm.biz/knowctr

To specify a short URL to a specific product page, version, or topic, use a hash
character (#) between the short URL and the product identifier. For example, the
short URL to all the InfoSphere Information Server documentation is the
following URL:
http://ibm.biz/knowctr#SSZJPZ/

And, the short URL to the topic above to create a slightly shorter URL is the
following URL (The ⇒ symbol indicates a line continuation):
http://ibm.biz/knowctr#SSZJPZ_11.3.0/com.ibm.swg.im.iis.common.doc/⇒
common/accessingiidoc.html

© Copyright IBM Corp. 2011, 2014

247

Changing help links to refer to locally installed documentation
IBM Knowledge Center contains the most up-to-date version of the documentation.
However, you can install a local version of the documentation as an information
center and configure your help links to point to it. A local information center is
useful if your enterprise does not provide access to the internet.
Use the installation instructions that come with the information center installation
package to install it on the computer of your choice. After you install and start the
information center, you can use the iisAdmin command on the services tier
computer to change the documentation location that the product F1 and help links
refer to. (The ⇒ symbol indicates a line continuation):
Windows

IS_install_path\ASBServer\bin\iisAdmin.bat -set -key ⇒
com.ibm.iis.infocenter.url -value http://<host>:<port>/help/topic/

AIX® Linux

IS_install_path/ASBServer/bin/iisAdmin.sh -set -key ⇒
com.ibm.iis.infocenter.url -value http://<host>:<port>/help/topic/

Where <host> is the name of the computer where the information center is
installed and <port> is the port number for the information center. The default port
number is 8888. For example, on a computer named server1.example.com that uses
the default port, the URL value would be http://server1.example.com:8888/help/
topic/.

Obtaining PDF and hardcopy documentation
v The PDF file books are available online and can be accessed from this support
document: https://www.ibm.com/support/docview.wss?uid=swg27008803
&wv=1.
v You can also order IBM publications in hardcopy format online or through your
local IBM representative. To order publications online, go to the IBM
Publications Center at http://www.ibm.com/e-business/linkweb/publications/
servlet/pbi.wss.
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Appendix F. Providing feedback on the product
documentation
You can provide helpful feedback regarding IBM documentation.
Your feedback helps IBM to provide quality information. You can use any of the
following methods to provide comments:
v To provide a comment about a topic in IBM Knowledge Center that is hosted on
the IBM website, sign in and add a comment by clicking Add Comment button
at the bottom of the topic. Comments submitted this way are viewable by the
public.
v To send a comment about the topic in IBM Knowledge Center to IBM that is not
viewable by anyone else, sign in and click the Feedback link at the bottom of
IBM Knowledge Center.
v Send your comments by using the online readers' comment form at
www.ibm.com/software/awdtools/rcf/.
v Send your comments by e-mail to comments@us.ibm.com. Include the name of
the product, the version number of the product, and the name and part number
of the information (if applicable). If you are commenting on specific text, include
the location of the text (for example, a title, a table number, or a page number).
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Notices and trademarks
This information was developed for products and services offered in the U.S.A.
This material may be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.

Notices
IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.
IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:
IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785 U.S.A.
For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:
Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan
The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.
This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:
IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA 95141-1003 U.S.A.
Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.
The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.
Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.
Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.
All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.
This information is for planning purposes only. The information herein is subject to
change before the products described become available.
This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.
COPYRIGHT LICENSE:
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This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.
Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:
© (your company name) (year). Portions of this code are derived from IBM Corp.
Sample Programs. © Copyright IBM Corp. _enter the year or years_. All rights
reserved.
If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Privacy policy considerations
IBM Software products, including software as a service solutions, (“Software
Offerings”) may use cookies or other technologies to collect product usage
information, to help improve the end user experience, to tailor interactions with
the end user or for other purposes. In many cases no personally identifiable
information is collected by the Software Offerings. Some of our Software Offerings
can help enable you to collect personally identifiable information. If this Software
Offering uses cookies to collect personally identifiable information, specific
information about this offering’s use of cookies is set forth below.
Depending upon the configurations deployed, this Software Offering may use
session or persistent cookies. If a product or component is not listed, that product
or component does not use cookies.
Table 113. Use of cookies by InfoSphere Information Server products and components
Component or
feature

Type of cookie
that is used

Collect this data

Purpose of data

Disabling the
cookies

Any (part of
InfoSphere
Information
Server
installation)

InfoSphere
Information
Server web
console

v Session

User name

v Session
management

Cannot be
disabled

Any (part of
InfoSphere
Information
Server
installation)

InfoSphere
Metadata Asset
Manager

v Session

Product module

v Persistent

v Authentication

v Persistent

No personally
identifiable
information

v Session
management

Cannot be
disabled

v Authentication
v Enhanced user
usability
v Single sign-on
configuration
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Table 113. Use of cookies by InfoSphere Information Server products and components (continued)
Product module

Component or
feature

Type of cookie
that is used

Collect this data

Purpose of data

Disabling the
cookies

InfoSphere
DataStage

Big Data File
stage

v Session

v User name

v Persistent

v Digital
signature

v Session
management

Cannot be
disabled

InfoSphere
DataStage

XML stage

Session

v Authentication

v Session ID

v Single sign-on
configuration

Internal
identifiers

v Session
management

Cannot be
disabled

v Authentication
InfoSphere
DataStage

InfoSphere Data
Click

IBM InfoSphere
DataStage and
QualityStage
Operations
Console

Session

InfoSphere
Information
Server web
console

v Session

InfoSphere Data
Quality Console

No personally
identifiable
information

User name

v Persistent

v Session
management

Cannot be
disabled

v Authentication

v Session
management

Cannot be
disabled

v Authentication
Session

No personally
identifiable
information

v Session
management

Cannot be
disabled

v Authentication
v Single sign-on
configuration

InfoSphere
QualityStage
Standardization
Rules Designer

InfoSphere
Information
Server web
console

InfoSphere
Information
Governance
Catalog

InfoSphere
Information
Analyzer

v Session

User name

v Persistent

v Session
management

Cannot be
disabled

v Authentication
v Session

v User name

v Persistent

v Internal
identifiers

v Session
management

Cannot be
disabled

v Authentication

v State of the tree v Single sign-on
configuration
Data Rules stage
in the InfoSphere
DataStage and
QualityStage
Designer client

Session

Session ID

Session
management

Cannot be
disabled

If the configurations deployed for this Software Offering provide you as customer
the ability to collect personally identifiable information from end users via cookies
and other technologies, you should seek your own legal advice about any laws
applicable to such data collection, including any requirements for notice and
consent.
For more information about the use of various technologies, including cookies, for
these purposes, see IBM’s Privacy Policy at http://www.ibm.com/privacy and
IBM’s Online Privacy Statement at http://www.ibm.com/privacy/details the
section entitled “Cookies, Web Beacons and Other Technologies” and the “IBM
Software Products and Software-as-a-Service Privacy Statement” at
http://www.ibm.com/software/info/product-privacy.
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