IBM InfoSphere Information Analyzer
Version 9 Release 1

Troubleshooting Guide
Note

Before using this information and the product that it supports, read the information in “Notices and trademarks” on page 33.

© Copyright IBM Corporation 2012.
US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
## Contents

**Troubleshooting InfoSphere Information Analyzer** ................................................. 1  
Troubleshooting for importing metadata ................................................................. 1  
  Known problems and solutions for metadata import issues ................................. 1  
  Viewing log messages for metadata import problems ........................................ 4  
Troubleshooting for column analysis ..................................................................... 9  
  Viewing log messages for column analysis problems ........................................ 9  
Troubleshooting for data quality analysis ............................................................. 15  
  Viewing log messages for data quality analysis problems ................................ 15  
Troubleshooting reports ......................................................................................... 19  
  Viewing log messages for reporting problems ................................................ 20  

**Appendix B. Reading command-line syntax** .................................................... 27  

**Appendix C. Contacting IBM** ................................................................. 29  

**Appendix D. Accessing and providing feedback on the product documentation** ............ 31  

**Notices and trademarks** ................................................................................. 33  

**Index** ........................................................................................................... 37
Troubleshooting InfoSphere Information Analyzer

These topics contain troubleshooting information for IBM® InfoSphere® Information Analyzer.

Before troubleshooting a specific issue, ensure that the health of the installation is verified. For more information about using IBM Support Assistant Lite to verify the health of your system, see [Download ISA Lite for InfoSphere Information Server](#) on the IBM Support Portal.

Troubleshooting for importing metadata

If problems occur when you import metadata into IBM InfoSphere Information Analyzer, use the following troubleshooting information to help isolate and resolve those problems.

Known problems and solutions for metadata import issues

Some common problems with importing metadata are documented, along with their solutions or workarounds. If you have a problem with importing metadata, review the problem-solution topics to determine if a solution is available to the problem that you are experiencing.

Cannot identify next level

In the Import Metadata workspace, if IBM InfoSphere Information Analyzer fails to identify the metadata, you can check the following potential solutions.

Symptoms

In the Import Metadata workspace, when you select a data store or data schema and click **Identify Next Level** or **Identify All Levels**, you see the following error message:

Failed while importing.
Please see log files for details.

Resolving the problem

- Ensure that your user name has the correct permissions to import metadata. To import metadata, you must have the following roles assigned to you:
  - Suite roles:
    - Suite User
    - Common Metadata Administrator
  - Suite component roles:
    - Information Analyzer User
    - Information Analyzer Data Administrator
- If you are identifying a flat file, you can check the following potential solutions. Each flat file that you want to import must have an entry in the QETXT.INI file, which specifies the format of the data in the flat file. The **Identify Flat File** task in InfoSphere Information Analyzer is a wizard that you can use to create an entry for a flat file in the QETXT.INI file.
  - Ensure that your user name has the correct permissions. You need the following permissions:
- For the directory where the source files are located, you need read and execute (search) permissions.
- For the source files, you need read permissions.
- For the QETXT.INI file, you need write permissions.
- When you use the Identify Flat File task, if a QETXT.INI file does not exist in the directory that contains your source files, you must have permission to create a file. The wizard creates a QETXT.INI file if one does not exist.
- If you have an existing QETXT.INI file that was created or updated outside of InfoSphere Information Analyzer, ensure that the QETXT.INI file is well-formed. The wizard creates correctly formed entries for new files that you identify, but it does not check the existing entries. If the existing QETXT.INI file is malformed, the logic in the Identify Flat File function might not be able to read the file. To read the source file, the text file driver uses the entry that was created in the QETXT.INI file. To check the requirements for entries in the QETXT.INI file, see the documentation for the Progress DataDirect Connect ODBC driver that is located on client computers in the C:\IBM\InformationServer_ODBCDrivers\docs directory.
- On Linux and UNIX platforms, ensure that the newline character in the QETXT.INI file is LF, not CR LF, which is the newline character for Microsoft Windows.

**Incorrect metadata import for non-ASCII characters**

In the Import Metadata workspace, when you use the ODBC connector to import a data source where the metadata contains non-ASCII characters, the characters do not translate correctly. You can check the following potential solution.

**Symptoms**

After you import data from a data source, table names and column names that contain non-ASCII characters appear with garbled characters that seem incorrect.

**Environment**

The data connection for the data store uses the ODBC connector.

**Resolving the problem**

On the computer that contains the engine tier, in the ODBC.INI file, the IANAAppCodePage parameter must be set to the value that corresponds to the code page that your database uses. The DataDirect driver for the ODBC connection uses the IANAAppCodePage parameter to map data. You can find the code page values for the DataDirect ODBC driver in the documentation for the Progress DataDirect Connect ODBC driver that is located on client computers in the C:\IBM\InformationServer_ODBCDrivers\docs directory.

The IANAAppCodePage parameter can be set as the code page value for the entire ODBC.INI file. The parameter can also be set within individual data source names (DSNs) within the ODBC.INI file.

For example, if an IBM DB2 database uses the Extended UNIX Code (EUC) for Japanese, EUC_JP, the value for the code page parameter must be set to 18.

- For UNIX, edit the ODBC.INI file to use the code page for the entire file as shown in the following example:

```
[ODBC]
IANAAppCodePage=18
InstallDir=/opt/IBM/InformationServer/Server/branded_odbc
```
For Microsoft Windows, to edit the registry entry for a specific ODBC DSN:

**Attention**: Any inappropriate changes to the Windows registry can adversely affect your system.

1. Open the registry editor.
   a. Click Start > Run.
   b. Enter regedit and click OK.
2. Select Computer > HKEY_LOCAL_MACHINE > SOFTWARE > ODBC > ODBC.INI.
3. Select the ODBC DSN that was created for this data connection.
4. Right-click and select New > String value.
5. For the name of the value, enter IANAAppCodePage and set the value to 18.

**Cannot access common metadata**

In the Import Metadata workspace, you cannot identify common metadata assets that are shared by other tools in the IBM InfoSphere Information Server suite. You can check the following potential solutions.

**Symptoms**
In the Import Metadata workspace, when you select the data store and click **Identify Next Level**, InfoSphere Information Analyzer fails to discover metadata.

**Resolving the problem**
To use metadata that is shared by other tools in the InfoSphere Information Server suite, you must establish a connection to the source.

Sometimes, when you use a shared data store, you might need to update or add the connection information. You must have the suite administrator role and the Information Analyzer Data Administrator role to perform these tasks.

To update the connection information:
1. In the IBM InfoSphere Information Server console, select **Home > Configuration > Sources**.
2. Select the shared host and data store, and then click **Update Source Connections**.

To add connection information:
1. In the IBM InfoSphere Information Server console, select **Home > Configuration > Sources**.
2. Select the shared host and data store and click **Open Details**.
3. In the Define a Data Connection panel, if the connection information is not present, enter the connection information and click **Connect** to test the connection.
4. Save and close the data store and host.
Viewing log messages for metadata import problems

If the problem that you are experiencing occurs primarily or exclusively when you import metadata, collect diagnostic data from the IBM InfoSphere Information Analyzer logs and connector access service (CAS) logs, which you can use to diagnose and resolve the problem.

Procedure
1. Configure the InfoSphere Information Analyzer and CAS logging components. To complete this step, you must have suite administrator authority.

   a. In the IBM InfoSphere Information Server Web console, select the Connector Access logging component and click Manage Configurations.

   b. Select the active configuration and click Open.

   The default active configuration is ConnectorAccess.WARN.

   c. Set the severity levels to All for the categories that are shown in the following table.

   Table 1. Categories to use in the Connector Access logging component when you troubleshoot metadata import problems

<table>
<thead>
<tr>
<th>Category name</th>
<th>Severity level to use for troubleshooting</th>
<th>Default severity level</th>
</tr>
</thead>
<tbody>
<tr>
<td>ISF</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>ISF-CAS</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>ISF-CAS-CLIENT</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>ISF-CAS-HANDLER</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>ISF-CAS-NATIVE</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>ISF-CAS-SERVER</td>
<td>All</td>
<td>Warn</td>
</tr>
</tbody>
</table>
d. Save and close the Connector Access configuration.

e. Select the Information Analyzer logging component and click Manage Configurations.

f. Select the active configuration and click Open.

The default active configuration is InformationAnalyzer.WARN.

g. Set the severity levels to All for the categories that are shown in the following table.

<table>
<thead>
<tr>
<th>Category name</th>
<th>Severity level to use for troubleshooting</th>
<th>Default severity level</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>IBM-IA</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>IBM-IA-HANDLER</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>IBM-IA-SERVER</td>
<td>All</td>
<td>Warn</td>
</tr>
</tbody>
</table>

Figure 2. A screen capture of the Web console that shows the severity levels for the categories in the Connector Access logging component configuration. The categories that are set to All are useful when you troubleshoot metadata import problems.
h. Save and close the Information Analyzer configuration.

**Note:** Even if **Threshold** is set to All, the categories in the logging components also need to be set to All to write the events in that category to the log file. For example, if the **IBM-IA-HANDLER** category name is set to the severity level, **Warn**, the **IBM-IA-HANDLER** category does not write all events to the **Information Analyzer** logging component, even if **Threshold** is set to All.

2. In the IBM InfoSphere Information Server console, run the import metadata task that you want to troubleshoot.

3. View the InfoSphere Information Analyzer logs.
   a. In the IBM InfoSphere Information Server console, select **Operate > Log Views**.
   b. Select **All > Shared > IA_With_CAS_Log** and click **View Log**.
      
      By default, this log view is installed and the following categories are selected by default: **IBM > IA > SERVER, HANDLER** and **ISF > CAS > CLIENT, Handler, NATIVE, SERVER**. Also, all severity levels are selected by default, which makes the logs useful for debugging purposes.
c. Click **Refresh** to generate a refreshed view of the log events.

d. To specify different parameters for the log, change the filter results that are specified and click **Filter**. The View Log pane shows the events that are specified in the Filter Results pane.
4. If you need to do further troubleshooting, you can raise the severity level for the IBM-IA-XMETA-QUERY category to All. To complete this step, you must have suite administrator authority.

The IBM-IA-XMETA-QUERY category logs events that occur when a query is sent to the metadata repository tier. This tier is involved when you import metadata.

a. In the IBM InfoSphere Information Server Web console, select the Information Analyzer logging component and click Manage Configurations.

b. Select the active configuration and click Open.

The default active configuration is InformationAnalyzer.WARN.

c. For the IBM-IA-XMETA-QUERY category, set the severity level to All.

d. Save and close the Information Analyzer configuration.

e. After you change the configuration, run the import metadata task that you want to troubleshoot.

Figure 5. A screen capture of the Web console that shows the severity levels for the categories in the Information Analyzer logging component configuration. In addition to other categories that log all severity levels, the IBM-IA-XMETA-QUERY category can be useful when you troubleshoot metadata import problems.
f. In the IBM InfoSphere Information Server console, select the IA_With_CAS_Log and click Open.

g. In the Categories panel, select XMETA > QUERY.

h. Click Save and Close.

i. Select the IA_With_CAS_Log and click View Log.

5. After you view the log messages, in the IBM InfoSphere Information Server Web console, return the severity levels to their original levels to conserve disk space.

6. When you no longer need the log messages, a suite administrator can purge messages through a log view. Messages can be purged by using the IBM InfoSphere Information Server console or the IBM InfoSphere Information Server Web console.

Messages that are purged through a log view purges those messages from the system. Those messages are not available for any other log view that was set up to view messages from the same logging components and categories. For example, suppose you purge messages from the IA_Log log view that have a timestamp within the last 10 days, and 100 messages from the IBM > IA > SERVER, HANDLER categories are purged. Those same 100 purged messages are unavailable to the IA_With_CAS_Log log view because the IA_With_CAS_Log is also set up to view messages from the IBM > IA > SERVER, HANDLER categories.

---

**Troubleshooting for column analysis**

If problems occur when you analyze columns in IBM InfoSphere Information Analyzer, use the following troubleshooting information to help isolate and resolve those problems.

**Viewing log messages for column analysis problems**

If the problem that you are experiencing occurs primarily or exclusively when you analyze columns, collect diagnostic data from the IBM InfoSphere Information Analyzer logs, the WebSphere system logs, and the InfoSphere DataStage® logs, which you can use to diagnose and resolve the problem.

**Procedure**

1. Configure the InfoSphere Information Analyzer logging component. To complete this step, you must have suite administrator authority.
a. In the IBM InfoSphere Information Server Web console, select the Information Analyzer logging component and click Manage Configurations.

b. Select the active configuration and click Open.

The default active configuration is InformationAnalyzer.WARN.

c. Set the severity levels to All for the categories that are shown in the following table.

Table 3. Categories to use in the Information Analyzer logging component when you troubleshoot column analysis problems

<table>
<thead>
<tr>
<th>Category name</th>
<th>Severity level to use for troubleshooting</th>
<th>Default severity level</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>IBM-IA</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>IBM-IA-HANDLER</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>IBM-IA-SERVER</td>
<td>All</td>
<td>Warn</td>
</tr>
</tbody>
</table>
d. Save and close the Information Analyzer configuration.

Note: Even if Threshold is set to All, each category in the logging components also needs to be set to All to write the events to the log file. For example, if the IBM-IA-HANDLER category name is set to the default severity level, Warn, the IBM-IA-HANDLER category does not write all events to the Information Analyzer logging component, even if Threshold is set to All.

2. In the IBM InfoSphere Information Server console, select Retain Scripts, which is in the Engine tab of the Run Column Analysis window.

These scripts are used to run the analysis job. Unless you select this option, the scripts and other job artifacts are automatically removed after the job runs. Retaining the scripts uses disk space. If you select Retain Scripts before you submit a job, scripts will be retained only for that job run. Be aware that if Retain Scripts is selected in the project properties, scripts are retained by default for each job that is created in the project, unless you clear the option when you submit a job.

3. Run the column analysis task that you want to troubleshoot.

4. View the InfoSphere Information Analyzer logs.
a. In the IBM InfoSphere Information Server console, select **Operate > Log Views**.

b. Select **All > Shared > IA_Log** and click **View Log**.
   By default, this log view is installed. The selected categories are, **IBM > IA > HANDLER, SERVER**. Also, all severity levels are selected, which makes the logs useful for debugging purposes.

c. Click **Refresh** to generate a refreshed view of the log events.

d. To specify different parameters for the log, change the filter results that are specified and click **Filter**.

e. After you view the log messages, in the IBM InfoSphere Information Server Web console, return the severity levels to their original levels to conserve disk space.

f. When you no longer need the log messages, a suite administrator can purge messages through a log view. Messages can be purged by using the IBM InfoSphere Information Server console or the IBM InfoSphere Information Server Web console.
Messages that are purged through a log view purges those messages from the system. Those messages are not available for any other log view that was set up to view messages from the same logging components and categories. For example, suppose you purge messages from the IA_Log log view that have a timestamp within the last 10 days, and 100 messages from the IBM > IA > SERVER, HANDLER categories are purged. Those same 100 purged messages are unavailable to the IA_With_CAS_Log log view because the IA_With_CAS_Log is also set up to view messages from the IBM > IA > SERVER, HANDLER categories.

5. View the WebSphere system log files on the computer where the services tier is installed.
   a. Navigate to the IBM\WebSphere\AppServer\profiles\InfoSphere\logs\server name directory.
   b. The following files contain events that are related to column analysis jobs:
      • SystemOut.log
      • SystemErr.log

6. View the InfoSphere DataStage log files.
   a. In the InfoSphere DataStage and QualityStage® Director client, connect to the computer that hosts the services tier.
   b. In the Project field, enter the name of the InfoSphere Information Analyzer project that is specified in the Overview > Project Properties > Analysis Engine tab. By default, the project name is ANALYZERPROJECT.
      This project is the project that InfoSphere Information Analyzer uses to run analysis jobs on the engine tier.
   c. In the Director client, view the status of job runs.
   d. Look for the following job names, where column analysis job name is the name of the column analysis job:
      • BaseProfile_column analysis job name
      • BaseProfileLoad1_column analysis job name

   Note: For each table that is included in the job run, there is one BaseProfile_column analysis job name. Each BaseProfile_column analysis job name job has one or more BaseProfileLoad1_column analysis job name jobs, depending on the number of columns that are included in each table. One BaseProfileLoad1_column analysis job name file is created for every 10 columns that exist in a table.
   e. After you identify a column analysis job, select it and click View > Log.
   f. Review the list of log messages. The fatal error messages are the most likely messages to provide clues to the cause of your job failure.
   g. To save the log, click Project > Print. Select Print to file and Full details and click OK.

7. If you need to do further troubleshooting, you can raise the severity level for the IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories to All. To complete this step, you must have suite administrator authority.
   The IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories log events that occur when queries are sent to the analysis database, the metadata repository tier, or both. Depending on the operation that is performed, the analysis database and the metadata repository tier can be involved during column analysis.
a. In the IBM InfoSphere Information Server Web console, select the 
  Information Analyzer logging component and click Manage 
  Configurations.

b. Select the active configuration and click Open.

  The default active configuration is InformationAnalyzer.WARN.

c. For the IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories, set 
  the severity level to All.

d. Save and close the Information Analyzer configuration.

e. After you change the configuration, run the column analysis task that you 
  want to troubleshoot.

f. In the IBM InfoSphere Information Server console, select the IA_Log and 
  click Open.

g. In the Categories panel, select IADB > QUERY and XMETA > QUERY.

h. Click Save and Close.

i. Select the IA_Log and click View Log.
Troubleshooting for data quality analysis

If problems occur when you analyze data quality in IBM InfoSphere Information Analyzer, use the following troubleshooting information to help isolate and resolve those problems.

Viewing log messages for data quality analysis problems

If the problem that you are experiencing occurs primarily or exclusively when you run data quality rules, collect diagnostic data from the IBM InfoSphere Information Analyzer logs, which you can use to diagnose and resolve the problem.

Procedure

1. Configure the InfoSphere Information Analyzer logging component. To complete this step, you must have suite administrator authority.

a. In the IBM InfoSphere Information Server Web console, select the Information Analyzer logging component and click Manage Configurations.

b. Select the active configuration and click Open.

   The default active configuration is InformationAnalyzer.WARN.

c. Set the severity levels to All for the categories that are shown in the following table.

<table>
<thead>
<tr>
<th>Category name</th>
<th>Severity level to use for troubleshooting</th>
<th>Default severity level</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>IBM-IA</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>IBM-IA-HANDLER</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>IBM-IA-SERVER</td>
<td>All</td>
<td>Warn</td>
</tr>
</tbody>
</table>

Figure 10. In the Web console, the Information Analyzer logging component is useful to troubleshoot data quality analysis problems.
d. Save and close the Information Analyzer configuration.

**Note:** Even if **Threshold** is set to **All**, each category in the logging components also needs to be set to **All** to write the events to the log file. For example, if the **IBM-IA-HANDLER** category name is set to the default severity level, **Warn**, the **IBM-IA-HANDLER** category does not write all events to the **Information Analyzer** logging component, even if **Threshold** is set to **All**.

2. In the IBM InfoSphere Information Server console, select **Retain Scripts**, which is in the Engine tab of the Run Column Analysis window.

These scripts are used to run the analysis job. Unless you select this option, the scripts and other job artifacts are automatically removed after the job runs. Retaining the scripts uses disk space. If you select **Retain Scripts** before you submit a job, scripts will be retained only for that job run. Be aware that if **Retain Scripts** is selected in the project properties, scripts are retained by default for each job that is created in the project, unless you clear the option when you submit a job.

3. Run the data quality analysis task that you want to troubleshoot.

4. View the InfoSphere Information Analyzer logs.
a. In the IBM InfoSphere Information Server console, select **Operate > Log Views**.

b. Select **All > Shared > IA_Log** and click **View Log**.

   By default, this log view is installed. The selected categories are, **IBM > IA > HANDLER, SERVER**. Also, all severity levels are selected, which makes the logs useful for debugging purposes.

c. Click **Refresh** to generate a refreshed view of the log events.

d. To specify different parameters for the log, change the filter results that are specified and click **Filter**.

e. After you view the log messages, in the IBM InfoSphere Information Server Web console, return the severity levels to their original levels to conserve disk space.

f. When you no longer need the log messages, a suite administrator can purge messages through a log view. Messages can be purged by using the IBM InfoSphere Information Server console or the IBM InfoSphere Information Server Web console.
Messages that are purged through a log view purges those messages from the system. Those messages are not available for any other log view that was set up to view messages from the same logging components and categories. For example, suppose you purge messages from the IA_Log log view that have a timestamp within the last 10 days, and 100 messages from the IBM > IA > SERVER, HANDLER categories are purged. Those same 100 purged messages are unavailable to the IA_With_CAS_Log log view because the IA_With_CAS_Log is also set up to view messages from the IBM > IA > SERVER, HANDLER categories.

5. View the WebSphere system logs on the computer where the services tier is installed.
   a. Navigate to the IBM\WebSphere\AppServer\profiles\InfoSphere\logs\server name directory.
   b. The following files contain events that are related to data quality jobs:
      • SystemOut.log
      • SystemErr.log

6. View the InfoSphere DataStage logs.
   a. In the InfoSphere DataStage and QualityStage Director client, connect to the computer that hosts the services tier.
   b. In the Project field, enter the name of the InfoSphere Information Analyzer project that is specified in the Overview > Project Properties > Analysis Engine tab. By default, the project name is ANALYZERPROJECT.
      This project is the project that InfoSphere Information Analyzer uses to run analysis jobs on the engine tier.
   c. In the Director client, view the status of job runs.
   d. Look for the following job names, where data rule job name is the name of the data quality job:
      • RunExecutable_data rule job name
   e. After you identify a data quality analysis job, select it and click View > Log.
   f. Review the list of log messages.
   g. To save the log, click Project > Print. Select Print to file and Full details and click OK.

7. If you need to do further troubleshooting, you can raise the severity level for the IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories to All. To complete this step, you must have suite administrator authority.
   The IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories log events that occur when queries are sent to the analysis database, the metadata repository tier, or both. Depending on the operation that is performed, the analysis database and the metadata repository tier can be involved during data quality analysis.
   a. In the IBM InfoSphere Information Server Web console, select the Information Analyzer logging component and click Manage Configurations.
   b. Select the active configuration and click Open.
      The default active configuration is InformationAnalyzer.WARN.
   c. For the IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories, set the severity level to All.
d. Save and close the Information Analyzer configuration.

e. After you change the configuration, run the data quality analysis task that you want to troubleshoot.

f. In the IBM InfoSphere Information Server console, select the **IA_Log** and click **Open**.

g. In the Categories panel, select **IADB > QUERY** and **XMETA > QUERY**.

h. Click **Save and Close**.

i. Select the **IA_Log** and click **View Log**.

**Troubleshooting reports**

If problems occur when you run reports in IBM InfoSphere Information Analyzer, use the following troubleshooting information to help isolate and resolve those problems.
Viewing log messages for reporting problems

If the problem that you are experiencing occurs primarily or exclusively when you run reports, collect diagnostic data from the IBM InfoSphere Information Analyzer logs, the WebSphere system logs and the reporting log files. You can use these logs to diagnose and resolve the problem.

Procedure

1. Configure the InfoSphere Information Analyzer logging component. To complete this step, you must have suite administrator authority.

   a. In the IBM InfoSphere Information Server Web console, select the Information Analyzer logging component and click Manage Configurations.

   b. Select the active configuration and click Open.

   The default active configuration is InformationAnalyzer.WARN.

   c. Set the severity levels to All for the categories that are shown in the following table.

   Table 5. Categories to use in the Information Analyzer logging component when you troubleshoot reporting problems

<table>
<thead>
<tr>
<th>Category name</th>
<th>Severity level to use for troubleshooting</th>
<th>Default severity level</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>IBM-IA</td>
<td>All</td>
<td>Warn</td>
</tr>
<tr>
<td>IBM-IA-REPORTS</td>
<td>All</td>
<td>Warn</td>
</tr>
</tbody>
</table>

   Figure 14. In the Web console, the Information Analyzer logging component is useful to troubleshoot reporting problems
d. Save and close the Information Analyzer configuration.

**Note:** Even if **Threshold** is set to **All**, each category in the logging components also needs to be set to **All** to write the events to the log file. For example, if the **IBM-IA-HANDLER** category name is set to the default severity level, **Warn**, the **IBM-IA-HANDLER** category does not write all events to the **Information Analyzer** logging component, even if **Threshold** is set to **All**.

2. Run the reporting task that you want to troubleshoot.

3. Create a log view for the report logs.
   a. In the IBM InfoSphere Information Server console, select **Operate > Log Views**.
   b. From the Tasks list, select **New Log View**.
   c. Enter a name for the log view. For example, **IA_Log_reports**.
   d. In the Severity Levels panel, select **All**
   e. In the Categories panel, select **IBM > IA > REPORTS**.
f. Click **Save and Close**.

4. View the InfoSphere Information Analyzer logs.
   a. Select the log view you created for the reports and click **View Log**.
   b. Click **Refresh** to generate a refreshed view of the log events.
   c. To specify different parameters for the log, change the filter results that are specified and click **Filter**.
   d. After you view the log messages, in the IBM InfoSphere Information Server Web console, return the severity levels to their original levels to conserve disk space.
   e. When you no longer need the log messages, a suite administrator can purge messages through a log view. Messages can be purged by using the IBM InfoSphere Information Server console or the IBM InfoSphere Information Server Web console.

   Messages that are purged through a log view purges those messages from the system. Those messages are not available for any other log view that
was set up to view messages from the same logging components and categories. For example, suppose you purge messages from the IA_Log log view that have a timestamp within the last 10 days, and 100 messages from the IBM > IA > SERVER, HANDLER categories are purged. Those same 100 purged messages are unavailable to the IA_With_CAS_Log log view because the IA_With_CAS_Log is also set up to view messages from the IBM > IA > SERVER, HANDLER categories.

5. View the WebSphere system log files on the computer where the services tier is installed.
   a. Navigate to the IBM\WebSphere\AppServer\profiles\InfoSphere\logs\server name directory.
   b. The following files contain events that are related to reporting jobs:
      • SystemOut.log
      • SystemErr.log

6. View the reporting log files on the computer where the services tier is installed.
   a. Navigate to the temporary directory nameInformationServer\Reportingserver name\engine\JREPORT\logs directory.
      • Microsoft Windows: C:\Windows\Temp\informationServer\Reportingserver name\engine\JREPORT\logs
      • Linux, UNIX: $temp/InformationServer/Reportingserver name/engine/JREPORT/logs
   b. The following files contain events that are related to reporting jobs:
      • error.log
      • debug.log

7. If you need to do further troubleshooting, you can raise the severity level for the IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories to All. To complete this step, you must have suite administrator authority.

   The IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories log events that occur when queries are sent to the analysis database, the metadata repository tier, or both. Depending on the operation that is performed, the analysis database and the metadata repository tier can be involved when you run reports.
   a. In the IBM InfoSphere Information Server Web console, select the Information Analyzer logging component and click Manage Configurations.
   b. Select the active configuration and click Open.
      The default active configuration is InformationAnalyzer.WARN.
   c. For the IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories, set the severity level to All.
d. Save and close the Information Analyzer configuration.

e. After you change the configuration, run the reporting task that you want to troubleshoot.

f. In the IBM InfoSphere Information Server console, select the IA_Log and click Open.

g. In the Categories panel, select IADB > QUERY and XMETA > QUERY.

h. Click Save and Close.

i. Select the IA_Log and click View Log.

Figure 17. A screen capture of the Web console that shows the severity levels for the categories in the Information Analyzer logging component configuration. In addition to other categories that log all severity levels, the IBM-IA-IADB-QUERY and IBM-IA-XMETA-QUERY categories can be useful when you troubleshoot reporting problems.
Appendix A. Product accessibility

You can get information about the accessibility status of IBM products.

The IBM InfoSphere Information Server product modules and user interfaces are not fully accessible. The installation program installs the following product modules and components:
- IBM InfoSphere Business Glossary
- IBM InfoSphere Business Glossary Anywhere
- IBM InfoSphere DataStage
- IBM InfoSphere FastTrack
- IBM InfoSphere Information Analyzer
- IBM InfoSphere Information Services Director
- IBM InfoSphere Metadata Workbench
- IBM InfoSphere QualityStage

For information about the accessibility status of IBM products, see the IBM product accessibility information at [http://www.ibm.com/able/product_accessibility/index.html](http://www.ibm.com/able/product_accessibility/index.html).

Accessible documentation

Accessible documentation for InfoSphere Information Server products is provided in an information center. The information center presents the documentation in XHTML 1.0 format, which is viewable in most Web browsers. XHTML allows you to set display preferences in your browser. It also allows you to use screen readers and other assistive technologies to access the documentation.

The documentation that is in the information center is also provided in PDF files, which are not fully accessible.

IBM and accessibility

See the [IBM Human Ability and Accessibility Center](http://www.ibm.com/able) for more information about the commitment that IBM has to accessibility.
Appendix B. Reading command-line syntax

This documentation uses special characters to define the command-line syntax.

The following special characters define the command-line syntax:

[ ] Identifies an optional argument. Arguments that are not enclosed in brackets are required.

... Indicates that you can specify multiple values for the previous argument.

| Indicates mutually exclusive information. You can use the argument to the left of the separator or the argument to the right of the separator. You cannot use both arguments in a single use of the command.

{} Delimits a set of mutually exclusive arguments when one of the arguments is required. If the arguments are optional, they are enclosed in brackets ([ ]).

Note:
• The maximum number of characters in an argument is 256.
• Enclose argument values that have embedded spaces with either single or double quotation marks.

For example:

`wsetsrc[-S server] [-l label] [-n name] source`

The `source` argument is the only required argument for the `wsetsrc` command. The brackets around the other arguments indicate that these arguments are optional.

`wlsac [-l | -f format] [key... ] profile`

In this example, the `-l` and `-f format` arguments are mutually exclusive and optional. The `profile` argument is required. The `key` argument is optional. The ellipsis (...) that follows the `key` argument indicates that you can specify multiple key names.

`wrb -import {rule_pack | rule_set}...`

In this example, the `rule_pack` and `rule_set` arguments are mutually exclusive, but one of the arguments must be specified. Also, the ellipsis marks (...) indicate that you can specify multiple rule packs or rule sets.
# Appendix C. Contacting IBM

You can contact IBM for customer support, software services, product information, and general information. You also can provide feedback to IBM about products and documentation.

The following table lists resources for customer support, software services, training, and product and solutions information.

<table>
<thead>
<tr>
<th>Table 6. IBM resources</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Resource</strong></td>
</tr>
<tr>
<td>IBM Support Portal</td>
</tr>
<tr>
<td>Software services</td>
</tr>
<tr>
<td>My IBM</td>
</tr>
<tr>
<td>Training and certification</td>
</tr>
</tbody>
</table>
Appendix D. Accessing and providing feedback on the product documentation

Documentation is provided in a variety of locations and formats, including in help that is opened directly from the product client interfaces, in a suite-wide information center, and in PDF file books.

The information center is installed as a common service with IBM InfoSphere Information Server. The information center contains help for most of the product interfaces, as well as complete documentation for all the product modules in the suite. You can open the information center from the installed product or from a Web browser.

Accessing the information center

You can use the following methods to open the installed information center.

• Click the Help link in the upper right of the client interface.

  Note: From IBM InfoSphere FastTrack and IBM InfoSphere Information Server Manager, the main Help item opens a local help system. Choose Help > Open Info Center to open the full suite information center.

• Press the F1 key. The F1 key typically opens the topic that describes the current context of the client interface.

  Note: The F1 key does not work in Web clients.

• Use a Web browser to access the installed information center even when you are not logged in to the product. Enter the following address in a Web browser: http://host_name:port_number/infocenter/topic/com.ibm.swg.im.iis.productization.iisinfsv.home.doc/ic-homepage.html. The host_name is the name of the services tier computer where the information center is installed, and port_number is the port number for InfoSphere Information Server. The default port number is 9080. For example, on a Microsoft® Windows® Server computer named iisdocs2, the Web address is in the following format: http://iisdocs2:9080/infocenter/topic/com.ibm.swg.im.iis.productization.iisinfsv.nav.doc/dochome/iisinfsrv_home.html.

A subset of the information center is also available on the IBM Web site and periodically refreshed at http://publib.boulder.ibm.com/infocenter/iisinfsv/v8r7/index.jsp.

Obtaining PDF and hardcopy documentation

• A subset of the PDF file books are available through the InfoSphere Information Server software installer and the distribution media. The other PDF file books are available online and can be accessed from this support document: https://www.ibm.com/support/docview.wss?uid=swg27008803&wv=1.

• You can also order IBM publications in hardcopy format online or through your local IBM representative. To order publications online, go to the IBM Publications Center at http://www.ibm.com/e-business/linkweb/publications/servlet/pbi.wss.
Providing comments on the documentation

Your feedback helps IBM to provide quality information. You can use any of the following methods to provide comments:

- To comment on the information center, click the Feedback link on the top right side of any topic in the information center.

- **Send your comments by using the online readers' comment form at [www.ibm.com/software/awdtools/rcf/](http://www.ibm.com/software/awdtools/rcf/)**

- Send your comments by e-mail to comments@us.ibm.com. Include the name of the product, the version number of the product, and the name and part number of the information (if applicable). If you are commenting on specific text, include the location of the text (for example, a title, a table number, or a page number).

- You can provide general product feedback through the Consumability Survey at [www.ibm.com/software/data/info/consumability-survey](http://www.ibm.com/software/data/info/consumability-survey)
Notices and trademarks

This information was developed for products and services offered in the U.S.A.

Notices

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785 U.S.A.

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA 95141-1003 U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information is for planning purposes only. The information herein is subject to change before the products described become available.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. © Copyright IBM Corp. _enter the year or years_. All rights reserved.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.

**Trademarks**

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at [www.ibm.com/legal/copytrade.shtml](http://www.ibm.com/legal/copytrade.shtml).

The following terms are trademarks or registered trademarks of other companies:

Adobe is a registered trademark of Adobe Systems Incorporated in the United States, and/or other countries.

Intel and Itanium are trademarks or registered trademarks of Intel Corporation or its subsidiaries in the United States and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft, Windows and Windows NT are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.

The United States Postal Service owns the following trademarks: CASS, CASS Certified, DPV, LACS\textsuperscript{Link}, ZIP, ZIP + 4, ZIP Code, Post Office, Postal Service, USPS and United States Postal Service. IBM Corporation is a non-exclusive DPV and LACS\textsuperscript{Link} licensee of the United States Postal Service.

Other company, product or service names may be trademarks or service marks of others.
Index

A
accessing common metadata
solution for 3

C
column analysis
  troubleshooting 9
  viewing log messages 9
command-line syntax
  conventions 27
commands
  syntax 27
customer support
  contacting 29

D
data quality analysis
  troubleshooting 15
  viewing log messages 15
diagnostic data
  viewing log messages for column analysis 9
  viewing log messages for data quality analysis 15
  viewing log messages for metadata import 4
  viewing log messages for reports 20

I
identifying next level
  troubleshooting 1
importing metadata
  troubleshooting 1
    accessing common metadata 3
    identifying next level 1
    known problems and solutions 1
    non-Unicode characters 2
    viewing log messages 4
importing non-Unicode characters
  solution for 2

L
legal notices 33

P
problems and solutions
  importing metadata 1
product accessibility
  accessibility 25
product documentation
  accessing 31

R
reports
  troubleshooting 20
    viewing log messages 20

S
software services
  contacting 29
special characters
  in command-line syntax 27
support
  customer 29
syntax
  command-line 27

T
trademarks
  list of 33
troubleshooting
  column analysis 9
  data quality analysis 15
  importing metadata 1
  known problems for importing metadata 1
  reports 20
  viewing log messages for column analysis 9
  viewing log messages for data quality analysis 15
  viewing log messages for metadata import 4
  viewing log messages for reports 20