Before using this information and the product that it supports, read the information in "Notices and trademarks" on page 47.
Chapter 1. Overview of IBM InfoSphere Blueprint Director

InfoSphere® Blueprint Director enables you to define and manage a blueprint of your information project from initial sketches through delivery.

Information integration and transformation is a part of every organization. New systems, infrastructure changes, and new business processes require that the information is restructured, moved, or distributed in new ways. All of these scenarios might result in significant changes to the information project. InfoSphere Blueprint Director helps you to govern your information projects by extending the vision of the projects to all members of your team to foster collaboration and best practices.

Today, governance teams are not sufficiently equipped to plan and manage the future landscape of information projects. Teams typically rely on white boards and drawing tools to document the overall solution outline and vision of the information project. This “big picture” is often captured in drawings that are disconnected from other artifacts, such as:

- Detailed design documents that focus on distinct parts of the projected solution
- Project requirements that are frequently defined in team meetings
- Technical artifacts such as the metadata from a model that represent parts of the evolving solution

InfoSphere Blueprint Director includes several major capabilities that enable governance teams to develop a common blueprint of the “big picture”:

**Use templates to build a blueprint according to information project standards**
Installed templates include the topology and methods to support specific use scenarios, such as business intelligence (BI) and warehousing information projects.

Method content from IBM® Rational® Method Composer helps you to implement effective work processes. You can manage, author, evolve, measure, and deploy effective processes that are tailored to your project needs with an Eclipse-based tool.

**Associate business glossary terms with blueprint elements**
You can download terms from the InfoSphere Information Server business glossary to your local business glossary and then associate them with blueprint elements.

**Associate business glossary assets other than terms with blueprint elements**
You can associate other business glossary assets such as jobs, databases, and mapping projects. You can view these assets in the associated applications: IBM InfoSphere Metadata Workbench, IBM InfoSphere Data Architect, or IBM InfoSphere DataStage®.

**Associate assets that are not in the business glossary with blueprint elements**
You can associate assets whose metadata is not stored in the InfoSphere Information Server business glossary. These assets include IBM Cognos® models, sections of Microsoft Office documents, general files, and web addresses.
Extend palette drawers and elements
You can create palette drawers and elements to tailor the blueprint to meet your information project needs.

Free-form sketching
In addition to palette elements, you can add standard Eclipse shapes to a blueprint diagram. Each shape has an input and an output connector so that you can link shapes to other blueprint elements.

Create conceptual elements from business glossary terms
In addition to palette elements and standard Eclipse shapes, you can drag a term from the Glossary Explorer pane to a diagram to create a conceptual entity.

Publish blueprints for use by other team members
You can publish blueprints to the InfoSphere Information Server business glossary so that they can be viewed and imported into InfoSphere Blueprint Director by other users.

Blueprint scenario
This scenario describes the life cycle of a blueprint.

The following schematic illustrates how to populate the blueprint with assets. After the blueprint is complete, the schematic describes what actions you can do with the blueprint.

Figure 1. Schematic of the life cycle of a blueprint in IBM InfoSphere Blueprint Director

Step 1
When the business glossary is downloaded for the first time, the local business glossary is populated with terms, categories, information governance rules, and information governance policies from the InfoSphere Information Server business glossary. The local business glossary is updated according to the frequency that you configured or on demand.

Step 2
You can associate local business glossary assets with your blueprint elements. In addition, you can associate other types of assets that are in the InfoSphere Information Server business glossary or from other software products with blueprint elements. For example, you might want to
associate BI reports with a Reports blueprint element. Or, you might want to associate a Microsoft Office Word document about quality requirements with the Scoring blueprint element. These associations are saved in the blueprint.

In addition, you organize the blueprint elements according to the needs of your information project. If needed, you can associate methods and assign milestones to blueprint elements.

**Step 3** You publish the blueprint as an asset in the InfoSphere Information Server business glossary. Publication maintains the asset associations and the methods of the blueprint. You can view and download the blueprint from IBM InfoSphere Business Glossary.

**Step 4** You can import the blueprint file that is in a bpt format on your hard disk into a project folder in the InfoSphere Blueprint Director client.

**Step 5** You can export the blueprint file that is in a bpt format to a directory on your hard disk for later import.

### Components of an information project

An information project contains components that describe, display, or guide the project from initial sketches through project delivery.

#### Overview

An information project in IBM InfoSphere Blueprint Director has the following components:

- "Blueprints"
- "Asset associations" on page 5
- "Palette of elements" on page 6
- "Milestones" on page 6
- "Methods" on page 7
- "Templates" on page 8
- "Perspective and panes" on page 8

For example, suppose that you have two information projects: an information project that is created for a new Master Data Management system and an information project for an enterprise data warehouse. You can create a blueprint that contains subdiagrams to depict the shared relationships across both information projects.

An information project contains business artifacts such as requirement documents, statement of work, and spreadsheets. An information project also contains technical artifacts such as the metadata of a database, a model, or an ETL model.

#### Blueprints

A *blueprint* is the collection of elements that define the overall landscape of the information project and of associated standard practices. A *domain* is a group of blueprint elements that share a common goal or functionality. A *diagram* is the graphical part of a blueprint that contains blueprint elements such as databases, warehouses, files, and data rules. A diagram can contain *subdiagrams*. 
The following figure displays a blueprint that is called Integrated_Warehouse. The blueprint is in a project folder called MiscellaneousProject. Integrated_Warehouse is the root diagram for five domains: Analytics, Consumers, Data Integration, Data Repositories, and Data Sources. In this example, the domain Data Integration contains the blueprints elements Integrate Sources and Monitor Data Quality that share common integration functionality. The Data Integration domain is graphically displayed in the root diagram.

![Figure 2. Blueprint Navigator pane with project, domains, blueprint elements, diagrams, and subdiagrams](image)

In this example, the Subdiagram icon indicates that the blueprint element Integrate Sources also has blueprint elements in a subdiagram. The Integrate Sources subdiagram displays the following blueprint elements.

![Figure 3. Display of the Integrate Sources subdiagram](image)

The Integrate Sources subdiagram has a blueprint element called Exceptions. All other blueprint elements in Integrate Sources (Structured Sources, Extract/Subscribe, Staging, Transform, and Cleanse) are subdiagrams. When you nest subdiagrams, you create a “layered” display of your blueprint that shows more complexity and detail as you drill down into the information project.

The Integrate Sources subdiagram refers to a blueprint element called Structured Sources (Ref). A reference element is a blueprint element whose origin is in the root
diagram or a different subdiagram, and is referred to in the Integrate Sources subdiagram. The blueprint element Structured Sources (Ref) belongs to the group called Asset Set.

Arrows between blueprint elements indicate a connection between them. Blueprint elements have generic input and output connectors that indicate the direction of action. In this example, the Extract/Subscribe blueprint element deals the action of information flow to a warehouse. After that action, Staging deals with discovering a unified schema from the assets. The Cleanse action is an ongoing action on the unified schema that results in a list of exceptions and data that has been transformed and loaded to a target system.

You can change the arrangement of diagrams and subdiagrams. You can also display or hide grid marks and rules. You can search for specific blueprint elements and groups.

**Asset associations**

You can associate business glossary assets, files, sections of Microsoft Office documents, IBM Cognos models, and web addresses with blueprint elements. Associate assets to ensure that a blueprint element is aligned with business artifacts such as requirement documents, or with technical artifacts such as the metadata of a database. You can view the details of an associated asset in InfoSphere Blueprint Director or in the software product that InfoSphere Blueprint Director opens.

The following figure shows a blueprint element called Warehouse. A segment of a Microsoft Office document, a term from the local business glossary, and a mapping project from IBM InfoSphere FastTrack are all associated with Warehouse.

![Figure 4. Associating a segment of a Microsoft Office Word document, a term, and an InfoSphere FastTrack mapping project with an asset](image)

**1.1 Information governance**

The world is experiencing an unprecedented explosion of data. An estimate of more than three billion terabytes of digital information is created everyday around the world. Increased levels of complexity and the need to keep pace with a fast-moving world are unforgiving to judgement errors or bad planning and decision making. Organizations realize that they need a better grip on their information and to better manage its creation, use, and distribution. Information management through people, processes, and technology fills this gap to ensure that information is well understood, to improve its quality, and to instill trust in it.
Palette of elements

InfoSphere Blueprint Director provides a palette of elements that you can use to
design your blueprint. Palette elements are graphical representations of specific
functionality or asset types. The palette elements are grouped in drawers according
to type. You can create more palette elements to meet the needs of your
information project.

![Palette pane]

Figure 5. Drawers of palette elements

Elements are dragged from the Palette pane to the diagram or subdiagram of a
blueprint. From the Palette pane, you can zoom in and zoom out to adjust the size
of the blueprint elements in the diagram. In addition, you can add notes to
blueprint elements to provide more information.

Milestones

A milestone represents a certain time or point in the information project timeline.
Use milestones to mark the beginning, end, and other important points in the
information project. You can visualize the evolution of the information project
throughout the timeline.
You can create, edit, and delete milestones. You assign milestones to blueprint elements to indicate when blueprint elements are displayed or hidden from the information project. Milestones are displayed in the Timeline pane.

**Methods**

A *method* describes the required roles, tasks, supporting products, and artifacts that are needed in a particular type of information project. Each blueprint template includes methods that are specific to that template.

The Methods icon next to a blueprint element indicates that methods exist for that blueprint element. Methods help you to check that a specific blueprint element is aligned with business artifacts and technical artifacts. Use methods to understand each blueprint element in the reference architecture: the identification
of roles, tasks, expected artifacts, work statements, and links to manuals. The following example displays the methods for Integrate Sources blueprint element. When you click a method, the method description, tasks, rules, and artifacts are displayed.

![Figure 8. Method elements for the blueprint element Integrate Sources](image.png)

**Templates**

Templates ensure that the blueprint follows a standard reference architecture and contains information that help team members to define the blueprint. A template guides you when you create a blueprint. A list of available templates is displayed in the New Blueprint wizard when you create a blueprint.

Templates include blueprint elements and methods that are typically used in that type of information project. Milestones are not included in templates.

You can create a template from an existing blueprint when you save the blueprint. You must add the new template to the list of templates.

**Perspective and panes**

A perspective is the graphical representation of the initial set and layout of panes and diagrams in the InfoSphere Blueprint Director window. Perspectives control what is displayed in menus and toolbars. You can change the layout of your information project and save the perspective.

InfoSphere Blueprint Director has the following panes:

**Asset Browser**

Displays assets in the local business glossary other than those assets that are displayed in the Glossary Explorer pane. Assets are displayed by asset type.
You can search for a specific asset. You can drag an asset to a blueprint element to associate it with the blueprint element.

**Glossary Explorer**
Displays the navigation tree of categories, terms, information governance rules, and information governance policies in the local business glossary. You download these assets from the business glossary of a selected IBM InfoSphere Information Server to your local business glossary. You can drag a term from the local business glossary to a blueprint element to associate it with the blueprint element.

**Method Browser**
Displays the methods that are specific to the blueprint type. An example might be methods that are specific to Master Data Management (MDM). You can drag a method to a blueprint element to assign it to the blueprint element.

Blueprints that are created from a template have methods already associated with blueprint elements.

**Outline**
Displays the entire contents of the blueprint in condensed size. The area in highlight corresponds to the area of the graphic that is visible. You can drag the highlighted area to move the graphic around in the diagram.

**Properties**
Displays the properties of the blueprint element that you select.
Search
Displays the search results from the blueprint or local business glossary search.

Related tasks:
“Viewing the timeline of milestones” on page 36
You can view when specific milestones start and end in the blueprint to see the progression of your information project. When you click the milestones in the timeline, blueprint elements are displayed or are hidden, based on their milestone assignments. You cannot change the blueprint or its elements when you view the timeline.

“Searching the blueprint and the local business glossary” on page 32
You can search a blueprint to quickly find blueprint elements, groups, and connectors in your blueprint. You can search your local business glossary for terms, categories, information governance policies, and information governance rules.

“Associating assets with blueprint elements” on page 27
You can associate glossary assets, files, parts of Microsoft Office documents, IBM Cognos Framework Manager models, and web addresses with your blueprint elements. These associations provide business meaning to blueprint elements and integrate IT with your information project.

Chapter 4, “Exporting method content to IBM Rational Team Concert work items,” on page 37
You can export method content to IBM Rational Team Concert™ work items to ensure that your information project adheres to proven methods for project development. You can view the progress of the information project by the work items that are associated with each level of the project lifecycle.

“Working with panes in the perspective” on page 17
You can open panes that you need in the perspective and change their position.

Information project owners and their responsibilities

To correctly design the information project, identify subject matter experts who can align the project with the overall business goals. These experts work together to ensure that the blueprint is accurate and complete. Business users can use the blueprint to make clear business decisions that are based on trusted reports.

Team members can review information project proposals to identify inconsistencies and redundancies and to address all goals before the solution is implemented. This review ensures that information projects are better coordinated and that the information landscape is more consistent.

Typically, the following people are involved in design and maintenance of information projects:

Solution architects
Solution architects are responsible for the technical design of the end-to-end information landscape of an information project. They can use specific templates that are provided by IBM InfoSphere Blueprint Director to document an information landscape across specific disciplines such as ETL, warehousing, or business intelligence (BI).

Solution architects can understand the solution as it evolves when they drill into successive subdiagrams. They can also follow links to referenced blueprint elements to understand how subdiagrams relate to each other.
**Business analysts**

Business analysts are responsible for the business requirements of an information project. They can use InfoSphere Blueprint Director to associate business requirements with the high-level components of the solution. This association improves collaboration with the technical implementation of the information project.

In addition, business analysts can track if business requirements are met as the information project progresses.

**Lead architects**

Lead architects are responsible for a part of the information landscape such as ETL, warehouse, BI, and Master Data Management. They can use InfoSphere Blueprint Director to go into their area of responsibility, such as opening a data modeling tool for the warehouse model.

Lead architects can also access other related areas of the solution to improve their own design, such as jobs that populate the warehouse. Lead architects are responsible for lower-level subdiagrams and their contents to determine problems and resolve inconsistencies in the planning stages of the information project.

**Data stewards**

Data stewards are responsible for the information project domains to ensure that the information is correctly used throughout the organization. They can use InfoSphere Blueprint Director to identify which information assets to use for each business requirement.

---

**Information project goals and how to achieve them**

To design an information project that meets your business objectives, you must define clear goals.

For example, consider the following typical goals for an information project:

**Define and manage the information project architecture**

By visualizing the project architecture in a blueprint, team members can understand which tasks are required at each phase of the project, how those tasks must be implemented, who is working on each task, and which assets are involved.

Enterprise architects create blueprints to form the reference architecture for your project. The main blueprint might depict the data sources, data integration points, data repositories, analytic processes, and consumers. Each of these domains represent the different phases of the project, and can be modified as the information project changes.

**Associate the project design with existing assets and methods**

By planning information integration projects and associating the designs to existing assets, enterprise architects can incorporate existing architectures into new designs.

Users can develop their free-form designs into a layered, interactive blueprint that represents your information project. Subdiagrams represent additional parts of each phase of the project and can be associated with the main blueprint. The overall solution connects the visions of each team member with real-world data and concepts, rather than developing a disconnected diagram.
Enterprise architects can develop blueprints based on proven methodologies. By associating a method to a blueprint, enterprise architects can create documentation that describes user roles, responsibilities, and tasks for each phase of the project to provide contextual guidance on the development of solution artifacts.

**Modify the environment as the information project changes**

To highlight changes in each phase of the information project, users can incorporate milestone planning into each blueprint.

Users can define the evolution of a information project over time, and view the blueprint elements that are active during each project milestone. To represent existing assets specific to your business, users can create custom elements from a palette of elements to include in blueprints.

Users can then publish blueprints to a business glossary of IBM InfoSphere Information Server so that the extended team can review blueprints across projects. This visibility helps team members to identify areas for improving reuse and consistency. In addition to publication, users can export a blueprint in a bpt format to the hard disk for later import.

### Integration with other software products

You can work with other software products of IBM InfoSphere Information Server to view asset details and to associate assets with a blueprint element.

IBM InfoSphere Blueprint Director works with the following InfoSphere Information Server suite products:

- IBM InfoSphere Business Glossary, version 8.1.2 or later
- IBM InfoSphere Data Architect, versions 7.5.3.1, 7.6, and 8.1
- IBM InfoSphere DataStage, version 8.1 or later
- IBM InfoSphere Data Click, version 9.1
- IBM InfoSphere FastTrack, version 8.1 or later
- IBM InfoSphere Metadata Workbench, version 8.1.2 or later

In addition, InfoSphere Blueprint Director also works with IBM Cognos Framework Manager, version 8.3 or later.

The software products must be installed on the appropriate platform before InfoSphere Blueprint Director can work with them.

The following schematic illustrates how InfoSphere Blueprint Director can work with other software products, assets in the IBM InfoSphere Information Server business glossary, documents, and web addresses.
In this schematic, InfoSphere Blueprint Director interacts with the business glossary of InfoSphere Information Server to list assets in the Asset Browser pane. In the Glossary Explorer pane, terms, categories, information governance policies, and information governance rules are downloaded from the business glossary of InfoSphere Information Server to the local business glossary. In the Add Asset Link window, InfoSphere Blueprint Director interacts with other InfoSphere Information Server suite products, Cognos, independent software vendors, and internet sites. In addition, InfoSphere Blueprint Director also interacts with InfoSphere Data Architect and with IBM InfoSphere Data Click if InfoSphere Blueprint Director was installed to shell-share with these products.

The following table lists actions that you can do when InfoSphere Blueprint Director is integrated with other software products.

Table 1. How software products work with InfoSphere Blueprint Director

<table>
<thead>
<tr>
<th>IBM Software products</th>
<th>Assets</th>
<th>What you can do in InfoSphere Blueprint Director</th>
</tr>
</thead>
<tbody>
<tr>
<td>InfoSphere Business Glossary</td>
<td>Categories, Terms, Information governance policies, Information governance rules</td>
<td>Download categories, terms, information governance policies, and information governance rules from the InfoSphere Information Server business glossary to a local business glossary. Browse these assets by using the Glossary Explorer pane. Update the local business glossary according to the update preferences that you define. Display details of the asset in the Properties pane. Associate a term with a blueprint element.</td>
</tr>
</tbody>
</table>
### Table 1. How software products work with InfoSphere Blueprint Director (continued)

<table>
<thead>
<tr>
<th>IBM Software products</th>
<th>Assets</th>
<th>What you can do in InfoSphere Blueprint Director</th>
</tr>
</thead>
</table>
| InfoSphere Data Architect   | Data model                                  | • Associate a data model with a blueprint element.  
                                          |                                               | • Open InfoSphere Data Architect to display or edit data models. |
|                             |                                             |                                                 |
| InfoSphere DataStage        | Jobs                                        | • Associate a job or shared container with a blueprint element.  
                                          | Shared containers                            | • Open either InfoSphere DataStage or InfoSphere Metadata Workbench, depending on the preference that you selected in Information Server Asset Links window, to display or edit jobs.  
                                          |                                               | • Open IBM InfoSphere Metadata Workbench to display the details page of the job. |
|                             |                                             |                                                 |
| InfoSphere Data Click       | Warehouse databases                         | Offload warehouse databases or offload select schemas and database tables within warehouse to a private sandbox. |
|                             |                                             |                                                 |
| InfoSphere FastTrack        | Mapping projects                            | • Browse mapping projects by using the Asset Browser pane.  
                                          |                                             | • Associate a mapping project with a blueprint element.  
                                          |                                             | • Open InfoSphere Metadata Workbench to display details of the mapping project. |
|                             |                                             |                                                 |
| InfoSphere Metadata Workbench | Assets, other than terms, in the business glossary of InfoSphere Information Server | • Browse assets in the business glossary of the InfoSphere Information Server by using the Asset Browser pane.  
                                          |                                             | • Associate an asset with a blueprint element.  
                                          |                                             | • Open InfoSphere Metadata Workbench to display details of the asset. |
|                             |                                             |                                                 |
| Cognos Framework Manager    | Cubes                                       | • Associate a business intelligence (BI) model or elements in a sketch with a blueprint element.  
                                          |                                             | • Open IBM Cognos Framework Manager to display a BI model. |

In addition to IBM software products, InfoSphere Blueprint Director also works with Microsoft Office files, general files, and web addresses. These assets, which are not found in the InfoSphere Information Server business glossary, can give business meaning to your blueprint elements.
Table 2. How you can use other assets in a blueprint

<table>
<thead>
<tr>
<th>Other assets that you can use in a blueprint</th>
<th>Examples</th>
<th>What you can do in InfoSphere Blueprint Director</th>
</tr>
</thead>
</table>
| Parts of Microsoft Office files             | • A paragraph in a Microsoft Office Word file  
  • Rows of a spreadsheet in a Microsoft Office Excel file  
  • Slides in a Microsoft Office PowerPoint file | Associate part of a Microsoft Office file with a blueprint element. |
| Files                                        | • Microsoft Office Word, Microsoft Office Excel, and Microsoft Office PowerPoint files  
  • IBM Lotus® Symphony® files  
  • Video files  
  • Microsoft Notes® files  
  • Graphic files | Associate any file from your computer with a blueprint element. |
| Web address (URL)                            | www.my_company.com/MyDocuments/requirements/reqs_for_database_v2_2.mht | Associate a web address with a blueprint element. |

Related tasks:

"Associating assets with blueprint elements” on page 27
You can associate glossary assets, files, parts of Microsoft Office documents, IBM Cognos Framework Manager models, and web addresses with your blueprint elements. These associations provide business meaning to blueprint elements and integrate IT with your information project.

"Configuring preferences” on page 18
You can configure preferences so that the IBM InfoSphere Blueprint Director client works with other software products. You can keep the local business glossary content synchronized with the business glossary content from IBM InfoSphere Information Server. Alternatively, you can update the local business glossary on demand.
Chapter 2. Accessing and setting up InfoSphere Blueprint Director

Use IBM InfoSphere Blueprint Director to develop a blueprint that can be used by the entire team. You configure properties and preferences to integrate InfoSphere Blueprint Director with external tools. You also define connection parameters to access the business glossary of IBM InfoSphere Information Server.

Accessing InfoSphere Blueprint Director

You access the IBM InfoSphere Blueprint Director client from the desktop of the Windows system or from the Eclipse application that it is installed in.

Procedure

To access the client, do either of the following actions:

- If the InfoSphere Blueprint Director client is installed as a stand-alone application, click the Blueprint Director icon in the desktop of the Windows system. No login credentials are needed.
- If the InfoSphere Blueprint Director client is installed in an Eclipse application, open the application.

Actions that are specific to InfoSphere Blueprint Director are displayed when you click an entry in the toolbar at the top of the application. For example, if you click File in the toolbar, Import Blueprint and Publish Blueprint are displayed.

Results

Terms, categories, information governance policies, and information governance rules in the business glossary of IBM InfoSphere Information Server are downloaded to your local business glossary, according to your configuration of the download frequency.

Other assets in the business glossary of InfoSphere Information Server are not downloaded. Rather, connections from the InfoSphere Blueprint Director client to the business glossary of InfoSphere Information Server are made when you click Display Assets in the Asset Browser window.

Related tasks:

“Configuring preferences” on page 18

You can configure preferences so that the IBM InfoSphere Blueprint Director client works with other software products. You can keep the local business glossary content synchronized with the business glossary content from IBM InfoSphere Information Server. Alternatively, you can update the local business glossary on demand.

Working with panes in the perspective

You can open panes that you need in the perspective and change their position.
**Procedure**

1. In the lower-left corner of the IBM InfoSphere Blueprint Director client, click the Fast View icon to list all panes in InfoSphere Blueprint Director.

2. Click the icon of the pane to open. The Method Browser, Outline, and Palette panes are empty until you open a blueprint.

3. To move an opened pane to a different location in the perspective, drag the title bar of the opened pane to the new position. When you close the InfoSphere Blueprint Director client, the perspective is saved.

**Related concepts:**

- "Components of an information project" on page 3
  An information project contains components that describe, display, or guide the project from initial sketches through project delivery.

**Configuring preferences**

You can configure preferences so that the IBM InfoSphere Blueprint Director client works with other software products. You can keep the local business glossary content synchronized with the business glossary content from IBM InfoSphere Information Server. Alternatively, you can update the local business glossary on demand.

**About this task**

Do this task after InfoSphere Blueprint Director is first installed.

When the update process begins, business glossary content on your local computer is compared with the business glossary content in InfoSphere Information Server. If differences exist, all terms, categories, information governance rules, and information governance policies are downloaded to your local computer. This process keeps your local business glossary content synchronized with the InfoSphere Information Server business glossary content.

If you choose to have automatic updates, your local business glossary content is updated whenever you open the InfoSphere Blueprint Director client. In addition, the local business glossary content is updated at the time intervals that you configure.

Automatic updates occur whenever changes are made in the business glossary content in InfoSphere Information Server. In addition, you can manually update the local business glossary content during development.
Procedure

1. In the InfoSphere Blueprint Director client, define your preferences for the blueprint. Click Window > Preferences > Blueprint Director. Do any of the following actions:

<table>
<thead>
<tr>
<th>To do this action</th>
<th>Do these steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the appearance, font, and print output of your blueprints</td>
<td>Expand Blueprint Diagram and select the folder that you want to change.</td>
</tr>
<tr>
<td>Link blueprint elements to models from IBM Cognos Framework Manager</td>
<td>Select Cognos to define installation and project directories for Cognos.</td>
</tr>
<tr>
<td>Open IBM InfoSphere DataStage jobs in InfoSphere DataStage Designer or in IBM InfoSphere Metadata Workbench</td>
<td>Select Information Server Asset Links. If InfoSphere DataStage Designer is not installed, jobs are opened in InfoSphere Metadata Workbench by default.</td>
</tr>
<tr>
<td>Specify the directory for method content to use for a blueprint that was not created by using a template</td>
<td>Select Method Content. Click Browse to select the directory with method content that you want to use in a blueprint diagram.</td>
</tr>
<tr>
<td>Create, edit, move, and delete palette elements and drawers</td>
<td>Select Palette Extensions and do these steps.</td>
</tr>
<tr>
<td>Add a template to the list of templates</td>
<td>Select Templates and do these steps.</td>
</tr>
</tbody>
</table>

2. Define the credentials and network connection to access the InfoSphere Information Server business glossary. In the left pane of the Preferences window, do these steps:
   a. Click Business Glossary. Define the host, port, user name, and password to the InfoSphere Business Glossary server.
   b. Click Business Glossary Updates to configure the frequency that your local business glossary content is updated from the business glossary of InfoSphere Information Server.

   **Note:** To manually update the local business glossary content, right-click the Glossary Explorer icon in the Glossary Explorer pane and select Update.

3. Click OK. The changes take effect immediately.
Related concepts:

“Integration with other software products” on page 12
You can work with other software products of IBM InfoSphere Information Server to view asset details and to associate assets with a blueprint element.

Related tasks:

“Accessing InfoSphere Blueprint Director” on page 17
You access the IBM InfoSphere Blueprint Director client from the desktop of the Windows system or from the Eclipse application that it is installed in.

“Creating and editing a blueprint” on page 24
You can create a blueprint that has no blueprint elements. Alternatively, you can create a blueprint from a template that includes a standard set of blueprint elements and method content.

Server connections

You can define parameters to access applications by using server connections.

All blueprints in an Eclipse workspace share a list of server connections. As a result, any action that you make in any of the server connections changes the list of server connections for all blueprints. Server connections are defined once, but they can be edited. A server connection is available for more than one blueprint.

The list of server connections is stored as part of your blueprint and is distributed with that blueprint. However, user credentials are not stored with the blueprint and are not shared if you distribute a blueprint to other users.

You can create connections to different servers of the InfoSphere Information Server connection type. The connections are differentiated by different connection names and connection credentials.

The following table lists what you can do with the InfoSphere Information Server connection and what role is needed:

<table>
<thead>
<tr>
<th>What are the uses of this connection</th>
<th>What role you need</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to assets that are listed in the Asset Browser pane</td>
<td>Metadata Workbench Administrator</td>
</tr>
<tr>
<td>Link to assets that are listed in the Glossary Explorer pane</td>
<td>Business Glossary Administrator</td>
</tr>
<tr>
<td>Publish blueprints</td>
<td>• Business Glossary Administrator</td>
</tr>
<tr>
<td></td>
<td>• Metadata Workbench Administrator</td>
</tr>
</tbody>
</table>

Creating and editing server connections

You can create server connections and edit their user credentials or connecting information.

Before you begin

You must know the host, port, user credentials of the server to connect to, and if the connection must be secure.

You must have the correct role on the server to connect to.
Procedure
1. From the application main menu of the IBM InfoSphere Blueprint Director client, click Blueprint > Manage Server Connections.
2. To create a server connection, click Add and do the following steps:
   a. In the Connection Name field, type a unique name for the server connection. The name can be in any language and can contain spaces.
   b. From the Connection Type list, select the type of connection that is based on the connection that you need, and then click Next.
   c. Enter the connection credentials:
      • Enter the host name and port number of the server that you want to connect to.
      • Select which version of the server you want to connect to.
      • Select the Secure Connection check box if the connection must be a secure connection.
      The information that you type here differentiates this server connection from other server connections of the same connection type.
3. To edit a server connection, click Edit. Change the user credentials or connecting information for this profile. You cannot change the connection type when you edit a server connection.
4. Click Validate Connection to check that the changes are valid, and then click Finish.

Deleting server connections
You can delete server connections to remove obsolete connections from the list of server connections.

About this task
If you delete a server connection and later open or import a blueprint that uses that connection, the server connection is re-created.

Procedure
1. At the top of the Eclipse application, click Blueprint > Manage Server Connections.
2. Select the server connection that you want to delete and click Delete. To confirm your selection, click Yes.
Chapter 3. Designing and implementing information projects

You can design your information project to integrate different aspects of your information architecture into one entity that can be shared by the entire team.

Implementing an information project by using blueprints

After you configure IBM InfoSphere Blueprint Director, you can use blueprints to develop your information project.

Procedure
1. Create a blueprint and edit it as the needs of the information project change. You can search for blueprint elements and add notes to elements.
2. Define milestones in your information project to see how the blueprint changed during the timeline.
3. Associate glossary assets, files, documents, or models to your blueprint elements.
4. Use methods based on the blueprint type to guide your information project.
5. Publish blueprints to the metadata repository. When you publish blueprints to the metadata repository, other team members can view the blueprints in the Blueprint Viewer window of IBM InfoSphere Business Glossary or IBM InfoSphere Metadata Workbench. You can also export and import the blueprint to a file in an rpt format on your hard disk.

Creating and managing blueprints

When you create a blueprint, you can customize your blueprint by moving elements from the Palette pane to the blueprint. In addition, you can add notes to blueprint elements to give information that might not be available in the properties of the blueprint element. You can search for elements in the blueprint. You can also publish your blueprint to the metadata repository so that team members can view the blueprint in the Blueprint Viewer window of IBM InfoSphere Business Glossary or IBM InfoSphere Metadata Workbench.

Creating a project folder

Every blueprint must be in a project folder. If you do not want to use the default project folder, you can create a project folder for your blueprints.

About this task

Blueprints are contained in project folders that organize your blueprints. You can put the new blueprint into the default project, or, if needed, you can create a different project folder.

For example, a project folder that is created by a Master Data Management system while another project folder is composed of an enterprise data warehouse. You can create a project folder that contains a master blueprint with subdiagrams to depict the shared relationships between the project folders.

Procedure
1. In the IBM InfoSphere Blueprint Director client, click File > New > Project.
2. In the New Project window, open the General folder and select **Project**. Click **Next**.

3. In the New Project Resource window, type in the project name. The default location is the workspace root directory. Clear the **Use default location** check box to use a different location.

4. Click **Finish**.

**Related tasks:**

“Creating and editing a blueprint”

You can create a blueprint that has no blueprint elements. Alternatively, you can create a blueprint from a template that includes a standard set of blueprint elements and method content.

### Creating and editing a blueprint

You can create a blueprint that has no blueprint elements. Alternatively, you can create a blueprint from a template that includes a standard set of blueprint elements and method content.

### About this task

Blueprints are contained in project folders that organize your blueprints. You can put the new blueprint into the default project folder, or, if needed, you can create a project folder before you create a blueprint.

Blueprints that are created from templates contain blueprint elements and methods that are typically used in the type of blueprint. For example, a blueprint that is created from the Business Driven BI Development template contains blueprint elements and methods for a data warehouse and a Business Intelligence (BI) information project.

Blueprints that are not created from templates contain the methods that you defined in the Method Content window (**Window > Preferences > Blueprint Director**).

When you edit a blueprint, the changed blueprint overwrites the existing blueprint.

### Procedure

In the IBM InfoSphere Blueprint Director client, do any of the following tasks:

- **To create a blueprint,** do these steps:
  1. Click **File > New > Blueprint**.
  2. In the New Blueprint window, type in the name for the blueprint and select the project folder to contain the blueprint.
  3. Choose the type of blueprint to create. If the new blueprint is based on a template, select the template.
  4. Click **Finish**.

- **To edit a blueprint,** do any of these steps:
  - To change the blueprint elements, in the Blueprint Navigator pane, double-click the blueprint that you want to edit.
  - To change the blueprint name, version, or description, right-click the blueprint whose properties you want to change and select **Properties > Blueprint Properties**.
– To change the display size of a blueprint diagram, click its tab. In the top menu bar, click Diagram > Zoom. Select the zoom level.
– To add a note to a blueprint element, right-click the blueprint element and select Add Note.
– To create a blueprint element from an asset, do these steps:
  1. Select a term from the Glossary Explorer pane. Alternatively, select other types of assets from the Asset Browser pane. Drag to the subdiagram.
  2. Create connections between blueprint elements.
– To change the arrangement of diagrams and subdiagrams, click Diagram > Align.
– To display or hide grid marks and rules, click Diagram > View > Grid or Ruler. You can search for specific blueprint elements and groups.

Related tasks:
“Configuring preferences” on page 18
You can configure preferences so that the IBM InfoSphere Blueprint Director client works with other software products. You can keep the local business glossary content synchronized with the business glossary content from IBM InfoSphere Information Server. Alternatively, you can update the local business glossary on demand.

“Creating a project folder” on page 23
Every blueprint must be in a project folder. If you do not want to use the default project folder, you can create a project folder for your blueprints.

“Creating connections between blueprint elements” on page 26
You can create connections between blueprint elements to visualize the flow of information in your information project.

“Creating a template from a blueprint” on page 34
You can create a template from an existing blueprint that other users can use as the starting point for their information projects.

Creating subdiagrams
Subdiagrams can provide detailed contextual information about a blueprint element. You can create subdiagrams to further describe each blueprint element.

About this task
Subdiagrams display a specific connection or steps of a task in detail. In a subdiagram, you can refer to existing elements from the main diagram so that the blueprint is consistent.

Procedure
1. In your blueprint, right-click the blueprint element to create a subdiagram for, and select Create Subdiagram. An empty subdiagram opens in a new tab. The name of the subdiagram is the same as the name of the blueprint element.
2. Drag elements from the Palette pane to the new subdiagram to create blueprint elements. Connect the blueprint elements. You can also drag assets from the Blueprint Navigator or from the Asset Browser panes to the new subdiagram to create a referenced element.

   The name of referenced elements is displayed in italics and contain “(Ref)” after the name. An example of a referenced element name might be Structured Sources (Ref).
3. When you close the blueprint, you can save the subdiagram. In the parent diagram, the Subdiagram icon is displayed above the element that you added a subdiagram to.

**Creating connections between blueprint elements**

You can create connections between blueprint elements to visualize the flow of information in your information project.

**About this task**

You can use the palette elements in the Connectors drawer to specify a specific type of connection, such as a General Link or an FTP connection. Alternatively, you can use the generic connectors of a blueprint element and drag the connector to a target blueprint element.

**Procedure**

Create a connection between two blueprint elements by using either of these options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Procedure</th>
</tr>
</thead>
</table>
| Use a specific connector type from the Connectors drawer | 1. From the Palette pane, click **Connectors** and select the connector that you want to use.  
2. Drag the connector from the Palette pane to the blueprint element that is the source for the connection. The mouse pointer changes from to when it is over a blueprint element that you can connect to. Right-click the blueprint element to display a connector line that loops back to the source .  
3. Right-click either end of the connector line and drag it to the element that is the target for the connection. |
Option Procedure

Use a generic connector from the blueprint element

1. Right-click the blueprint element that is the source for the connection. An incoming and an outgoing arrow are displayed. One arrow represents data that flows to the target blueprint element and the other arrow represents data that flows to the source blueprint element.

2. Click the outgoing arrow and drag it to the target blueprint element.

3. If the target blueprint element does not exist in the same domain as the source blueprint element, do these steps:
   a. Drag the outgoing arrow to a blank space on the subdiagram.
   b. Select Create Topology Connector To Existing Element.
   c. In the Select Domain Model Element window, click the blueprint element that is the target. Click OK.

Related tasks:

“Creating and editing a blueprint” on page 24

You can create a blueprint that has no blueprint elements. Alternatively, you can create a blueprint from a template that includes a standard set of blueprint elements and method content.

**Associating assets with blueprint elements**

You can associate glossary assets, files, parts of Microsoft Office documents, IBM Cognos Framework Manager models, and web addresses with your blueprint elements. These associations provide business meaning to blueprint elements and integrate IT with your information project.

**Before you begin**

- To associate local terms with blueprint elements, configure the download schedule to your local business glossary.
- To associate other types of assets such as jobs and mapping projects with blueprint elements, create a server connection to IBM InfoSphere Information Server.
- To associate Cognos models with blueprint elements, you must have Cognos Framework Manager installed.

**About this task**

You can associate assets by using the Add Asset Link pane, or by dragging the asset from the Glossary Explorer or the Asset Browser pane to the blueprint element.

**Table 5. Where to find assets**

<table>
<thead>
<tr>
<th>You can find this asset type</th>
<th>In the Add Asset Link pane</th>
<th>In the Asset Browser pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>Terms</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
Table 5. Where to find assets (continued)

<table>
<thead>
<tr>
<th>You can find this asset type</th>
<th>In the Add Asset Link pane</th>
<th>In the Asset Browser pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cognos models</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>IBM InfoSphere DataStage jobs</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>IBM InfoSphere FastTrack mapping projects</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>IBM InfoSphere Metadata Workbench</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>General files</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Web addresses</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Sections of Microsoft Office documents</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>All other assets</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

By default, the name of an association is the same as the asset name. A blueprint element can have more than one association. You can list the assets that are associated with a blueprint element and view the details of the associated asset.

A Cognos model from Cognos Framework Manager includes all of the folders, queries, reports, views, shortcuts, web addresses, and job definitions associated with that model.

**Procedure**

In the InfoSphere Blueprint Director client, do the following steps, depending on the asset type:
To associate this type of asset with a blueprint element

<table>
<thead>
<tr>
<th>Cognos models</th>
<th>Do these steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>InfoSphere DataStage jobs</td>
<td>1. Right-click the blueprint element that you want to associate with and then click <strong>Add Asset Link</strong>.</td>
</tr>
<tr>
<td>InfoSphere FastTrack mapping projects</td>
<td>2. From the Asset Link Type list, select the asset type and complete the steps that are required for that asset type.</td>
</tr>
<tr>
<td>InfoSphere Metadata Workbench assets</td>
<td>To associate a section of text in a Microsoft Office document, select <strong>Word/Excel Section</strong> and do these steps:</td>
</tr>
<tr>
<td>Sections of Microsoft Office documents</td>
<td>a. In the Microsoft Office document, select some text and then press Ctrl+C.</td>
</tr>
<tr>
<td>Entire files</td>
<td>b. In the InfoSphere Blueprint Director client, click <strong>Paste Word/Excel Link</strong>. A bookmark to the blueprint element is inserted in the Microsoft Office document.</td>
</tr>
<tr>
<td>Web addresses</td>
<td>c. Save and then close the Microsoft Office document. If you do not save the document before you close it, the bookmark is not inserted and no association with the blueprint element is made.</td>
</tr>
</tbody>
</table>

3. Click **Finish**.

Terms

1. Go to the Glossary Explorer pane.
2. Right-click the term and drag it to the blueprint element that you want to associate it with.

All other assets such as databases, database tables, and BI reports

1. Go to the Asset Browser pane.
2. Right-click the asset and drag it to the blueprint element that you want to associate it with.

Example

**Associate a requirement specification document with a database blueprint element**

Suppose that you want to associate a requirement specification document with a database blueprint element. The document is written in Microsoft Office Word and is stored in a local directory.

To associate the entire document with the database blueprint element, you do the following steps:
1. Right-click the database blueprint element to open the Add Asset Link pane.
2. In the Add Asset Link window, select **File** in the Asset Link Type list, because you want to associate the entire specification document with the blueprint element.
3. In the blueprint subdiagram, right-click the Linked Asset icon of the database blueprint element and select the document from the list of associated assets.
Associate a mapping project with a database blueprint element

As another example, you want to associate a mapping project that was generated by InfoSphere FastTrack with a database blueprint element. The mapping project asset is stored in the business glossary of InfoSphere Information Server.

To associate the mapping project asset to the database blueprint element, you do the following steps:
1. Drag the mapping project asset from the Asset Browser pane to the database blueprint element.
2. Right-click the Linked Asset icon of the database blueprint element and select the mapping project from the list.
   Alternatively, right-click the database blueprint element to open the Add Asset Link pane. In the Add Asset Link window, select FastTrack Mapping Project and follow the instructions.

The mapping project details are displayed in a new tab in the InfoSphere Blueprint Director client.

Related concepts:
[Integration with other software products] on page 12
You can work with other software products of IBM InfoSphere Information Server to view asset details and to associate assets with a blueprint element.
[Components of an information project] on page 3
An information project contains components that describe, display, or guide the project from initial sketches through project delivery.

Associating method elements with blueprint elements

Method elements provide contextual guidance on the development of your information project.

About this task

Blueprint templates contain method elements that are associated with blueprint elements. When you create a blueprint from a template, the method elements and their associations are included in the new blueprint. The associated method element is indicated by the Method icon next to the blueprint element icon.

You can also manually associate method elements with blueprint elements from the Method Browser pane. The type of method element that you can associate with a blueprint element depends on the type of the blueprint element.

Procedure
1. In the IBM InfoSphere Blueprint Director client, click Window > Show View > Method Browser.
2. In the Method Browser pane, select the method element to associate with a blueprint element. Drag the method element to that blueprint element on the blueprint.
   If you attempt to associate a method element of the wrong type with a blueprint element, a message is displayed.
Creating, editing, moving, and deleting palette elements and drawers

You can create drawers and elements to existing drawers to customize your blueprint elements.

Before you begin

Elements in the Palette pane and in the subdiagrams are icons. You must have a graphic in 16 pixels x 16 pixels size and a graphic in 32 pixels x 32 pixels size. The graphics must be in either a bmp or a png format.

About this task

In the Palette pane, you can rename elements and drawers and also edit drawers. In the Palette Extensions pane, you can create or delete elements and drawers. You can delete only the elements and drawers that you created. In the Palette Extensions pane, you can also move elements to a different drawer.

Small graphics are used in drawers. Large graphics are used in subdiagrams. You can define any type of element or drawer for your blueprint diagrams.

Procedure

In the InfoSphere Blueprint Director client, do any of the following tasks:

<table>
<thead>
<tr>
<th>Table 6. Tasks that you can do with drawers and elements of a palette</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>To do this task</strong></td>
</tr>
</tbody>
</table>
| Create a drawer or an element | 1. Click Blueprint > Extend Palette. Click either Create Drawer or Create Element.  
2. In the Palette Extensions pane, click either Create Drawer or Create Element.  
3. In the Palette Extension Details window, complete the required fields. Click Browse to locate the directory with the graphic image to use for the icon. Click Next and then click Finish. |
| Rename a drawer or an element | 1. In the Palette pane, right-click the name of the palette drawer or element and select Customize.  
2. In the Customize Palette window, type the new name in the Name field. Click OK. |
| Edit a drawer | 1. In the Palette pane, right-click the name of the palette drawer and do any of these actions:  
   • To change the icon arrangement, select Layout.  
   • To change other palette drawer settings, select Settings.  
2. Click OK. |
Table 6. Tasks that you can do with drawers and elements of a palette (continued)

<table>
<thead>
<tr>
<th>To do this task</th>
<th>Do these steps</th>
</tr>
</thead>
</table>
| Move an element to a different drawer  | 1. Click Blueprint > Extend Palette.  
                                             2. In the Palette Extensions pane, left-click the element that you want to move. Drag the element to the name of the drawer that you want to move the element to.  
                                             3. Click OK to move the element.                                                                 |
| Delete an element or drawer            | 1. Click Blueprint > Extend Palette.  
                                             2. In the Palette Extensions pane, left-click the element or drawer that you want to delete. Click either Delete Drawer or Delete Element.  
                                             3. Click OK to delete the element or drawer.                                                    |

**Searching the blueprint and the local business glossary**

You can search a blueprint to quickly find blueprint elements, groups, and connectors in your blueprint. You can search your local business glossary for terms, categories, information governance policies, and information governance rules.

**Procedure**

In the IBM InfoSphere Blueprint Director client, click Search. Use either of these search types:

<table>
<thead>
<tr>
<th>To do this type of search</th>
<th>Do these actions</th>
</tr>
</thead>
</table>
| Blueprint                 | 1. Click Search > Blueprint Search.  
                                             2. In the Search string field, type the string to search for. The name and the location of all blueprint elements that match the search string are displayed in the Search pane.  
                                             3. To highlight a search result in the blueprint, double-click a search result.                     |
| Glossary                  | 1. Click Glossary and type the search string in the Search string field. The search is not context sensitive.  
                                             2. To see the properties of a search result, double-click a search result.                           |

**Related concepts:**

“Components of an information project” on page 3

An information project contains components that describe, display, or guide the project from initial sketches through project delivery.

**Publishing a blueprint**

If you publish your blueprint, it can be used by other IBM InfoSphere Blueprint Director users. Also, the blueprint can be viewed by users of IBM InfoSphere Business Glossary or IBM InfoSphere Metadata Workbench.
Before you begin

Save all changes to your blueprint.

You must have valid user credentials and either the Business Glossary Administrator role or the Metadata Workbench Administrator role on the IBM InfoSphere Information Server that you publish to. You can only publish to a business glossary of InfoSphere Information Server, version 9.1 or later.

IBM InfoSphere Metadata Workbench must be installed on the server that you want to publish to.

About this task

By default, blueprints are published to the business glossary of IBM InfoSphere Information Server. You can edit the name, version, and description of the blueprint before it is published.

Procedure

1. Select the blueprint that you want to publish.
   - To publish the current blueprint, click **File > Publish Blueprint**.
   - To publish a different blueprint, do these steps:
     a. Click **Window** and select **Show View > Blueprint Navigator**.
     b. In the Blueprint Navigator window, expand **Miscellaneous Project**. Select the blueprint to publish and click **Publish Blueprint**.
2. In the Publish Blueprint window, in the **Connection** list, select a server that you want to publish the blueprint to. To select a different server, click the Manage Server Connections icon and create a connection to that other server.
3. Optional: Update the name, version, and description of the blueprint.
4. Click **Publish** to publish the blueprint.

Blueprint elements that are published

When you publish a blueprint, its elements are also published so that the blueprint can be used by other users.

The following elements are published with the blueprint:

- Blueprint name, version, and description
- Date and time of publication
- Diagrams and subdiagrams
  - Blueprint elements
  - Assets associated with blueprint elements
  - Connectors
  - Methods

Exporting and importing a blueprint

You can export your blueprint as a file in a bpt format that can be imported by other IBM InfoSphere Blueprint Director users.
Before you begin

Save all changes to your blueprint. If you export a blueprint to a file that already exists, the file is overwritten.

Procedure

In the InfoSphere Blueprint Director client, do either of the following actions:

<table>
<thead>
<tr>
<th>To do this action</th>
<th>Do these steps</th>
</tr>
</thead>
</table>
| Export a blueprint | 1. In the Blueprint Navigator pane, right-click the blueprint to export and then click Export Blueprint.  
2. In the Options section of the Export window, select the radio button to export the blueprint with the entire project folder path or with only the immediate project folder path.  
For example, to export the blueprint Integrated_Warehouse with the entire project folder path, you select Create directory structure for files to export Miscellaneous Project > Banking > Integrated_Warehouse.  
Alternatively, to export the blueprint with only the immediate project folder path, select Create only selected directories to export Banking > Integrated_Warehouse. |
| Import a blueprint | Click File > Import Blueprint and follow the wizard steps. |

Creating a template from a blueprint

You can create a template from an existing blueprint that other users can use as the starting point for their information projects.

About this task

When you create a template from an existing blueprint, all blueprint elements, their associations, and their methods are included in the new template. Milestones are not included in the template.

Procedure

1. In the IBM InfoSphere Blueprint Director client, select the blueprint in the Blueprint Navigator pane that you want to save as a template.  
2. Click File > Save As Template. In the New Template window, select the destination directory for the template. The template is saved as a file in a compressed format.  
3. Click Window > Preferences. In the left pane of the Preferences window, open Blueprint Director and select Templates.  
4. In the right pane of the Preferences window, click Add Template. In the Open window, go to the directory where you saved the template and select the file. Click Open. The template is installed in the InfoSphere Blueprint Director client.
5. Click Yes to restart the InfoSphere Blueprint Director client. The new template is not available for use until you restart the client.

6. Optional: To check that the new template is correctly installed after you restart the client, click File > New > Blueprint. The new template is displayed in the list of available templates.

Related tasks:
"Creating and editing a blueprint" on page 24

You can create a blueprint that has no blueprint elements. Alternatively, you can create a blueprint from a template that includes a standard set of blueprint elements and method content.

Configuring milestones

Use milestones to visualize the evolution of the information project throughout the blueprint timeline. You can create, edit, remove, and assign a milestone to any element on the blueprint.

Creating, editing, and deleting milestones

You create and manage milestones that represent a certain time or point in a blueprint timeline. Use milestones to mark the beginning and end of an information project and to indicate other important points in the project.

About this task

Assign a milestone to a blueprint element to define the start and end dates in the timeline.

Procedure

1. In the IBM InfoSphere Blueprint Director client, do either action:
   - Select Blueprint > Manage Milestones.
   - In the Timeline pane, click Manage Milestones.

2. In the Manage Milestones window, click Create or Edit, and then configure the milestone properties. Click Delete to remove the milestone from the information project. When you finish your changes, click Apply.

3. Configure the timeline order of the milestones. For each milestone, click Up or Down until the milestones are in the proper order.
   The order of milestones in the Current Milestones window determines the order of milestones in the Timeline pane.

4. In the diagram or subdiagram, right-click a blueprint element to assign a milestone to and then click Show Properties.

5. In the Properties pane for that blueprint element, click the Milestones tab.
   a. In the Show at list, select the first milestone when the element is displayed.
   b. In the Hide at list, select the final milestone when the element is no longer displayed.

For example, a blueprint has milestones M_1, M_2, M_3, and M_4. You select the blueprint element that is called Data Growth Management. If the Show at milestone is M_1 and the Hide at milestone is M_4, then the Data Growth Management blueprint element is displayed on the blueprint when you step through M_1, M_2, and M_3.
Viewing the timeline of milestones

You can view when specific milestones start and end in the blueprint to see the progression of your information project. When you click the milestones in the timeline, blueprint elements are displayed or are hidden, based on their milestone assignments. You cannot change the blueprint or its elements when you view the timeline.

Procedure

1. In the IBM InfoSphere Blueprint Director, open the Blueprint Navigator pane, and select a blueprint and click any area of the blueprint.

2. In the Timeline pane, select the Enable read-only blueprint by timeline check box. To see changes in the blueprint, use the slider to select a milestone.

3. When you are finished, clear the Enable read-only blueprint by timeline check box.

Related concepts:

“Components of an information project” on page 3

An information project contains components that describe, display, or guide the project from initial sketches through project delivery.
Chapter 4. Exporting method content to IBM Rational Team Concert work items

You can export method content to IBM Rational Team Concert work items to ensure that your information project adheres to proven methods for project development. You can view the progress of the information project by the work items that are associated with each level of the project lifecycle.

Before you begin

IBM InfoSphere Blueprint Director must be installed in Rational Team Concert to enable shell sharing.

The Task Management Integration feature must be enabled during the installation of IBM InfoSphere Blueprint Director. For details, see IBM InfoSphere Blueprint Director Installation Guide.

About this task

You can generate a work item in Rational Team Concert for each method in your blueprint. Additionally, you can generate a work item for each method that you associate with a blueprint element, or for a method that is not associated with any blueprint element. For example, you might associate the Develop BI Structures capability pattern with the model that you use to generate reports. You can also associate this capability pattern with your reports to generate work items to develop BI reports and to review BI structures. When you export method content to Rational Team Concert, work items are generated for your model and for any reports that you associate the Develop BI Structures capability pattern with.

When you export IBM InfoSphere Blueprint Director method content, the method content is mapped to a Rational Team Concert work item in the following manner.

<table>
<thead>
<tr>
<th>Method content in InfoSphere Blueprint Director</th>
<th>Maps to this work item type in Rational Team Concert</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scenario</td>
<td>Project Area</td>
</tr>
<tr>
<td>Phase</td>
<td>Epic</td>
</tr>
<tr>
<td>Capability Pattern</td>
<td>Story</td>
</tr>
<tr>
<td>Task</td>
<td>Task</td>
</tr>
</tbody>
</table>

Procedure

1. In the InfoSphere Blueprint Director client, define a server connection to your Jazz™ repository, if a connection does not exist. Complete these steps:
   a. In the Export Work Items window, click Manage Server Connections. In the Manage Server Connections window, click Add.
   b. In the Add Server Connection window, specify a name for your connection and select Jazz Server Connection from the Connection Type menu. Click Next.
   c. Enter the URL, user ID, and password for your Jazz connection. Click Validate connection. After the connection is established, click Finish.
2. Click Blueprint > Export Work Items.
3. In the Export Work Items window, select the Jazz connection, project area, and category that you want to connect to. Click **Next**.

   **Note:** You must select these items in order because each selection depends on the previous choice.

4. Expand each phase of the method content and select the methods and associated tasks that you want to export to Rational Team Concert. Click **Next**.

5. In the Summary window, review the phases, capability patterns, and tasks that you selected. To make changes, click **Back** and modify your choices. To export your choices, click **Finish**.

   The export process can take several minutes to complete, depending on the number of methods that you selected for export.

6. When the export process completes, click **Yes** to view the results in Rational Team Concert. You can now assign work items to team members. In addition, you can access these work items directly from IBM InfoSphere Blueprint Director or from Rational Team Concert.

**Related concepts:**

"Components of an information project" on page 3

An information project contains components that describe, display, or guide the project from initial sketches through project delivery.
Chapter 5. Accessibility features for IBM InfoSphere Blueprint Director

Accessibility features help users who have a disability, such as restricted mobility or limited vision, to use information technology products successfully.

**Accessibility features**

InfoSphere Blueprint Director uses the accessibility features of Eclipse. You can navigate the user interface by using the keyboard or by using assistive technologies, such as screen-reader software and digital speech synthesizer.

The following list includes the major accessibility features in InfoSphere Blueprint Director:

- Keyboard-only operation
- Interfaces that are commonly used by screen readers
- Keys that are discernible by touch but do not activate just by touching them
- Industry-standard devices for ports and connectors
- The attachment of alternative input and output devices

For information about the accessibility features of Eclipse in this product, in the toolbar at the top of your Eclipse application, click **Help > Help Contents**. In the Workbench User Guide, expand the **Concepts** tree and click **Accessibility features in Eclipse**.

For more information about the accessibility features of Graphical Modeling Framework (GMF), see [GMF keyboard accessibility](#).

**Keyboard navigation**

The InfoSphere Blueprint Director Information Center, and its related publications, are accessibility-enabled. The accessibility features of the information center are described at [Accessibility and keyboard shortcuts in the information center](#).

**IBM and accessibility**

For more information about the commitment that IBM has to accessibility, see [IBM Human Ability and Accessibility Center](#).
Appendix A. Product accessibility

You can get information about the accessibility status of IBM products.

The IBM InfoSphere Information Server product modules and user interfaces are not fully accessible. The installation program installs the following product modules and components:

- IBM InfoSphere Business Glossary
- IBM InfoSphere Business Glossary Anywhere
- IBM InfoSphere DataStage
- IBM InfoSphere FastTrack
- IBM InfoSphere Information Analyzer
- IBM InfoSphere Information Services Director
- IBM InfoSphere Metadata Workbench
- IBM InfoSphere QualityStage®

For information about the accessibility status of IBM products, see the IBM product accessibility information at http://www.ibm.com/able/product_accessibility/index.html.

Accessible documentation

Accessible documentation for InfoSphere Information Server products is provided in an information center. The information center presents the documentation in XHTML 1.0 format, which is viewable in most Web browsers. XHTML allows you to set display preferences in your browser. It also allows you to use screen readers and other assistive technologies to access the documentation.

The documentation that is in the information center is also provided in PDF files, which are not fully accessible.

IBM and accessibility

See the IBM Human Ability and Accessibility Center for more information about the commitment that IBM has to accessibility.
Appendix B. Contacting IBM

You can contact IBM for customer support, software services, product information, and general information. You also can provide feedback to IBM about products and documentation.

The following table lists resources for customer support, software services, training, and product and solutions information.

*Table 8. IBM resources*

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description and location</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM Support Portal</td>
<td>You can customize support information by choosing the products and the topics that interest you at <a href="http://www.ibm.com/support/entry/portal/Software/Information_Management/InfoSphere.Information_Server">www.ibm.com/support/entry/portal/Software/Information_Management/InfoSphere.Information_Server</a></td>
</tr>
<tr>
<td>Software services</td>
<td>You can find information about software, IT, and business consulting services, on the solutions site at <a href="http://www.ibm.com/businesssolutions/">www.ibm.com/businesssolutions/</a></td>
</tr>
<tr>
<td>My IBM</td>
<td>You can manage links to IBM Web sites and information that meet your specific technical support needs by creating an account on the My IBM site at <a href="http://www.ibm.com/account/">www.ibm.com/account/</a></td>
</tr>
<tr>
<td>Training and certification</td>
<td>You can learn about technical training and education services designed for individuals, companies, and public organizations to acquire, maintain, and optimize their IT skills at <a href="http://www.ibm.com/software/sw-training/">http://www.ibm.com/software/sw-training/</a></td>
</tr>
</tbody>
</table>
Appendix C. Accessing and providing feedback on the product documentation

Documentation is provided in a variety of locations and formats, including in help that is opened directly from the product client interfaces, in a suite-wide information center, and in PDF file books.

The information center is installed as a common service with IBM InfoSphere Information Server. The information center contains help for most of the product interfaces, as well as complete documentation for all the product modules in the suite. You can open the information center from the installed product or from a Web browser.

Accessing the information center

You can use the following methods to open the installed information center.

- Click the Help link in the upper right of the client interface.

  Note: From IBM InfoSphere FastTrack and IBM InfoSphere Information Server Manager, the main Help item opens a local help system. Choose Help > Open Info Center to open the full suite information center.

- Press the F1 key. The F1 key typically opens the topic that describes the current context of the client interface.

  Note: The F1 key does not work in Web clients.

- Use a Web browser to access the installed information center even when you are not logged in to the product. Enter the following address in a Web browser:
  http://host_name:port_number/infocenter/topic/com.ibm.swg.im.iis.productization.iisinfsv.home.doc/ic-homepage.html. The host_name is the name of the services tier computer where the information center is installed, and port_number is the port number for InfoSphere Information Server. The default port number is 9080. For example, on a Microsoft® Windows® Server computer named iisdocs2, the Web address is in the following format: http://iisdocs2:9080/infocenter/topic/com.ibm.swg.im.iis.productization.iisinfsv.nav.doc/dochome/iisinfsrv_home.html.

A subset of the information center is also available on the IBM Web site and periodically refreshed at http://publib.boulder.ibm.com/infocenter/iisinfsv/v8r7/index.jsp.

Obtaining PDF and hardcopy documentation

- A subset of the PDF file books are available through the InfoSphere Information Server software installer and the distribution media. The other PDF file books are available online and can be accessed from this support document: https://www.ibm.com/support/docview.wss?uid=swg27008803&wv=1

- You can also order IBM publications in hardcopy format online or through your local IBM representative. To order publications online, go to the IBM Publications Center at http://www.ibm.com/e-business/linkweb/publications/servlet/pbi.wss
Providing comments on the documentation

Your feedback helps IBM to provide quality information. You can use any of the following methods to provide comments:

- To comment on the information center, click the Feedback link on the top right side of any topic in the information center.
- Send your comments by using the online readers’ comment form at www.ibm.com/software/awdtools/rcf/
- Send your comments by e-mail to comments@us.ibm.com. Include the name of the product, the version number of the product, and the name and part number of the information (if applicable). If you are commenting on specific text, include the location of the text (for example, a title, a table number, or a page number).
- You can provide general product feedback through the Consumability Survey at www.ibm.com/software/data/info/consumability-survey
Notices and trademarks

This information was developed for products and services offered in the U.S.A.

Notices

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785 U.S.A.

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites.
sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA 95141-1003 U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information is for planning purposes only. The information herein is subject to change before the products described become available.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. © Copyright IBM Corp. _enter the year or years_. All rights reserved.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.

**Trademarks**

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at [www.ibm.com/legal/copytrade.shtml](http://www.ibm.com/legal/copytrade.shtml).

The following terms are trademarks or registered trademarks of other companies:

Adobe is a registered trademark of Adobe Systems Incorporated in the United States, and/or other countries.

Intel and Itanium are trademarks or registered trademarks of Intel Corporation or its subsidiaries in the United States and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft, Windows and Windows NT are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.

The United States Postal Service owns the following trademarks: CASS, CASS Certified, DPV, LACS\textsuperscript{link}, ZIP, ZIP + 4, ZIP Code, Post Office, Postal Service, USPS and United States Postal Service. IBM Corporation is a non-exclusive DPV and LACS\textsuperscript{link} licensee of the United States Postal Service.

Other company, product or service names may be trademarks or service marks of others.
technical artifact
templates
creating from blueprint 34
definition of 3
terms
associating with blueprint
elements 3, 27
timeline
viewing 36
trademarks
list of 47

web addresses
associating with blueprint
elements 3, 12, 27