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Chapter 1. Introduction to IBM InfoSphere Blueprint Director
By using InfoSphere® Blueprint Director, you can define and manage a blueprint of
your information project landscape from initial sketches through delivery.
Information integration and transformation is a part of every organization.
Introduction of new systems or changes to infrastructure or business processes
require that the information is restructured, moved, or distributed in new ways. All
of these scenarios involve significant changes to the underlying information
infrastructure.
Today, leadership teams are not sufficiently equipped to plan and manage the
future landscape of information-centric projects. Teams typically rely on white
boards and drawing tools to document the overall solution outline and vision of
the project. This “big picture” is often only captured in drawings that are
disconnected from all other artifacts, such as:
v Detailed designs that focus on distinct parts of the projected solution are
developed in separate documents
v Requirements that are frequently defined in long team meetings
v Technical artifacts that represent parts of the evolving solution
InfoSphere Blueprint Director provides consistency and connectivity to your
information architecture solution by linking the solution overview and detailed
design documents together, allowing all team members to understand the project
as it evolves. InfoSphere Blueprint Director includes several major capabilities that
enable governance teams to develop a common information blueprint:
v Creating project blueprints so that you can link blueprint elements to related
artifacts. For example, you can connect elements to metadata and open IBM®
InfoSphere Metadata Workbench from that element to view the referenced
metadata. Similarly, you can use the included linkers to connect elements to data
models (IBM InfoSphere Data Architect), ETL definitions (IBM InfoSphere
DataStage®), measure and dimension models (IBM Cognos® Framework
Manager), URLs (web browsers), or any files and their associated applications.
v Extensible palette of domain elements for use in sketching information
blueprints
v Free-form sketching to define, view, and manage information blueprints
v Linking of blueprint elements to metadata from the InfoSphere metadata
repository (if you have a valid license for IBM InfoSphere Metadata Workbench),
files, and assets accessible by URL
v Tagging blueprint elements with business glossary terms and creating
conceptual models using business glossary terms (if you have a valid license for
and have installed IBM InfoSphere Business Glossary Anywhere)
v Pre-built templates including a topology and method definition that support
specific usage scenarios, such as business intelligence (BI) and warehousing, that
correlate to a defined blueprint, such as a BI reference architecture
InfoSphere Blueprint Director helps you to govern your integration projects by
extending the vision of the projects to all members of your team, fostering
collaboration, best practices, and connectedness.

© Copyright IBM Corp. 2011
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What's new
This version of IBM InfoSphere Blueprint Director contains several new features
and product enhancements.
The following new features are included in this release:
v Integration with task management
v Milestone planning
v
v
v
v
v

Versioning support through integration with source code control systems
Additional templates for lifecycle management and data quality
Project support and enhancements to navigate between blueprints
Context-sensitive help and welcome screen
Shell sharing with other Eclipse applications

Integration with task management
You can export method content that is associated with a blueprint to IBM Rational
Team Concert™. Your team can use this capability to understand the progress of the
project in the context of the tasks that are associated with each level of the project
lifecycle. For each method, you can choose the phase that you want to generate an
epic for in IBM Rational Team Concert. Each phase contains several tasks that
become work items for the epic. You can then assign work items to specific users
so that they can view the work items that are assigned to them, update their
status, and make their work visible to the entire team.
This capability increases the level of governance that your organization can apply
by adhering to proven methods for project development. Because project status is
easily accessible in IBM Rational Team Concert, your team can make decisions
faster based on comprehensive and aligned insight.

Milestone planning
Many projects deliver the future state of the project over time, broken into multiple
phases with milestones for each phase. You can define the evolution of a blueprint
project over time and view the assets that are active during each project milestone.
For example, a data warehouse or master data management solution might add
sources and consumers (such as data marts and business intelligence reports) in
each phase of the project.
After you define milestones and assign them to blueprint elements, you can view
the evolution of the blueprint by using a slider in the product interface. You select
the milestones that you want to view and to visualize the architecture at each
phase of the project. This capability helps your team to understand the end-to-end
supply chain and project vision.

Versioning support through integration with source code control
systems
You can link InfoSphere Blueprint Director to your source code control system
(SCCS) so that your team can collaborate and share blueprints without relying on
email or other external collaboration tools. Blueprints can be created, tracked, and
compared by using your SCCS to avoid unprotected overwrite of existing
blueprints and to ensure that your blueprints are single sourced.
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This capability is valuable when developing and discussing blueprints in a
collaborative team environment because the team has a more controlled, consistent,
and governed approach to modify and view blueprints.

Additional templates for lifecycle management and data quality
New templates are included in this release that were not available in the
InfoSphere Information Server, Version 8.5 release of InfoSphere Blueprint Director.
The Managed Data Cleansing template provides a reference architecture and
associated method to deploy a data warehouse and business intelligence solution.
This template assumes that you have a range of existing information sources of
unknown structure and integrity, and details the patterns that are involved to
integrate information from these sources into a unified data warehouse. Trusted
information from this warehouse is made available to numerous analytics and
reporting patterns, and then to information consumers such as data marts and
business intelligence reports.
The Information Lifecycle Management template provides a logical blueprint and
associated project-level methodology to develop processes that support information
lifecycle management. Key areas that are addressed by this template include data
growth management (archiving), test data management (subsetting), and
application retirement.

Project support and enhancements to navigate between
blueprints
In previous releases, a blueprint existed independently as a single file. In this
release, a project can contain any number of blueprints (or have no blueprints),
with each blueprint belonging to a project. The Blueprint Navigator pane,
previously called the Blueprint Explorer, has been enhanced to display not only the
elements within a blueprint, but also projects and blueprints that belong to that
blueprint.
This capability allows you to open multiple blueprints simultaneously so that you
can copy and paste elements across blueprints, achieving greater reuse of existing
blueprint elements. Viewing projects in the Blueprint Navigator pane shows the
full structure of your project, which helps to better structure your blueprint and
the elements that it contains.

Context-sensitive help and welcome screen
To improve usability of InfoSphere Blueprint Director, this release provides a
welcome screen that highlights frequently used product functions and how to use
them. You can also access context-sensitive help that is specific to the function or
screen that your cursor is focused on. This enhancement ensures that you can
easily access help documentation when you need it.

Shell sharing with other Eclipse applications
InfoSphere Blueprint Director integrates with other Eclipse applications that
support shell sharing such as IBM Optim™ Designer, IBM InfoSphere Data
Architect, and IBM Rational Team Concert. This capability enables a seamless
navigation between and a blueprint and other integrated applications so that you
can use multiple applications within the same window.

Chapter 1. Introduction to IBM InfoSphere Blueprint Director
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Supported user roles
Many key stakeholders must be involved in developing a common information
blueprint, one that connects the various business artifacts and technical artifacts to
the overall solution overview. The information blueprint connects the leadership
and governance teams to help them deliver a more effective solution.
Governance team members can now more effectively view multiple project
proposals to identify potential inconsistencies and redundancies before the solution
is implemented. This expanded view ensures that projects are better coordinated
and that the project landscape is more consistent. In addition, the team can identify
whether the solution addresses all expectations before the solution is finalized to
further improve the alignment of business and IT.

Solution architects
Solution architects are responsible for the technical design of the end-to-end
information landscape.
Solution architects can use IBM InfoSphere Blueprint Director to document an
information landscape project across various specific disciplines (such as ETL,
warehousing, Master Data Management (MDM), or business intelligence (BI))
based on reference architectures and methodologies. By following the links from
the information blueprint to the various technical artifacts such as data models and
ETL designs, the solution architect simultaneously maintains an understanding of
the evolving solution on both a high level and on a deep, technical level.

Business analysts
Business analysts are responsible for capturing the business requirements in the
project.
Business analysts can use InfoSphere Blueprint Director to associate business
requirements with the corresponding high-level components of the solution. This
association improves collaboration with the technical implementation along with
tracking the progress on how the solution addresses business requirements.

Lead architects
Lead architects are responsible for a part of the information landscape such as ETL,
warehouse, BI, and MDM.
Lead architects can use InfoSphere Blueprint Director to start with an overall
solution context and navigate into their area of responsibility, such as opening a
data modeling tool for the warehouse model. Lead architects can also access other
related areas of the solution in order to improve their own design, such as jobs that
are supposed to populate the warehouse. This increased visibility into the overall
solution context helps lead architects to determine problems and resolve
inconsistencies in the planning stages of the project.

Data stewards
Data stewards are responsible for a data domain and ensure that the information is
properly used throughout the organization.
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Data stewards can use InfoSphere Blueprint Director to participate more actively in
the draft of the overall solution context, specifically which information assets are
used for which requirement. Data stewards also have access to key business terms
that are associated to new information consumers (such as BI reports) to further
improve the selection of trusted data sources.

Use cases and scenarios
IBM InfoSphere Blueprint Director supports various use cases and scenarios for
developing an information blueprint.

Defining the project and methodology
Solution architects create a sketch that represents a reusable blueprint for a current
or future project. This blueprint can form a reference architecture for information
architecture projects. For example, solution architects can create a business
intelligence (BI) reference architecture that depicts the data sources, data
integration, data repositories, analytics, and consumers.
You can use IBM InfoSphere Blueprint Director to associate the various tasks of
this architecture with a blueprint to help architects, when they instantiate the
template later on, to understand the related methodology tasks for a particular
blueprint element. By visualizing the architecture in a blueprint, the team can
better understand the implementation process of which tasks must be performed
and how they must be implemented. You can also reuse existing artifacts in the
blueprint by linking to specific assets or documents. You can then save these
diagrams as a template and share them with team members as a starting point for
projects, rather than defining a new architecture without direction.
Related concepts
“Templates, methods, and best practices” on page 12
You can include templates that contain recommended solution architectures,
methods, and best practices for specific solution types in IBM InfoSphere Blueprint
Director.

Linking free-form design to existing metadata
Planning a solution outline typically begins with a free-form sketch to help
understand the various elements of an information landscape. For example,
solution architects might develop a macro design or use prebuilt templates to
develop their information architecture.
Similarly, business analysts or consultants might develop a rough solution outline
by using free-form sketching. This phase might involve business stakeholders and
take place during various interviews. During this process, the team might not want
to be constrained by the actual metadata or might not want to spend time
searching for the metadata. Instead, the team might start with a top-down,
high-level design.
In a second phase (possibly after the first set of interviews with the business
stakeholders), data stewards and architects get involved to map this solution
outline to the existing landscape. These team members must identify existing assets
and “meet in the middle” between the top-down design and the bottom-up
metadata.
The team can develop their free-form designs into a layered, interactive blueprint
by using IBM InfoSphere Blueprint Director, and then link the blueprint to existing
Chapter 1. Introduction to IBM InfoSphere Blueprint Director
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metadata. Data stewards and architects can develop sub diagrams to represent the
existing landscape and then map these diagrams to the overall information
blueprint. The overall solution connects the visions of each team member with
real-world data and concepts rather than developing a disconnected diagram.

Change existing environment through reverse engineering
A project team must change and improve an existing information landscape. For
example, two existing warehouses might exist that must be rationalized into a
common warehouse.
The team must draw a sketch of the existing landscape and then add the new
warehouse and the new operations that are required to populate the existing
warehouse. Data stewards can identify existing data sources and add them to the
project blueprint by using existing metadata definitions. In addition, the team can
create custom elements and add them to the IBM InfoSphere Blueprint Director
palette to represent existing metadata. This process of designing a new solution
based on reverse-engineering existing metadata can significantly accelerate the
project delivery.
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Chapter 2. Installing and configuring
You can install and configure IBM InfoSphere Blueprint Director by using the
following steps. Before you install the application, ensure that you understand and
comply with the system requirements.

Installing the application
You run the IBM InfoSphere Information Server installer to begin installing the
application.

Before you begin
Ensure that your computer meets all system requirements before beginning the
installation. To view the system requirements, go to the InfoSphere Information
Server information center: http://publib.boulder.ibm.com/infocenter/iisinfsv/
v8r7/topic/com.ibm.swg.im.iis.bpdir.relnote.doc/topics/
iisihrinfo_blueprint_director_rnote_v85.html.

About this task
The InfoSphere Information Server installer copies the IBM InfoSphere Blueprint
Director installer (BlueprintDirectorSetup.exe) to your computer during the
installation. After the installation is complete, you can locate the InfoSphere
Blueprint Director installer in the IBM\InformationServer\Blueprint directory.
Important: Ensure that your MAX_PATH system variable is not excessively long.
Microsoft Windows uses this internal system value to enforce a maximum length
of a path on all files and applications. If the installation path is too long, only a
limited path length is available for use by the structures of this tool.

Procedure
1. Insert the product media for InfoSphere Information Server into your CD drive.
2. Open a command prompt and navigate to the is-suite directory.
cd is-suite

3. Run the following command to start the installation program and install the
BlueprintDirectorSetup.exe file to your computer.
./setup -verbose -force

4. Navigate to the IBM\InformationServer\Blueprint Director directory on your
computer.
5. Run the BlueprintDirectorSetup.exe executable file to begin installing the
application.
6. Click Next.
7. Select the installation set that you want to install by selecting the appropriate
check boxes. For example, if you are installing InfoSphere Blueprint Director
and the IBM InfoSphere DataStage linker, you would click the Blueprint
Director and IBM InfoSphere DataStage Integration check boxes.
8. Click Next.
9. Follow the remaining steps in the installation wizard to complete the
installation.
© Copyright IBM Corp. 2011
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Configuring the product
You can manage the preferences for InfoSphere Blueprint Director by clicking
Blueprint > Preferences from the application main menu. You can manage
preferences for external tools only if you have a valid software license for each
tool.

Method content preferences
If you have HTML output from Rational Method Composer that you want to use
in a new blueprint diagram, you can specify the directory that contains that HTML
output.
Open the Preferences window, then select Method Content > Browse to select the
HTML output that you want to use in a blueprint diagram.

Template preferences
You can add templates that you have created or that you have received from IBM
or IBM Business Partners.
Open the Preferences window, then select Templates > Add Template to add a
new template.

IBM InfoSphere Business Glossary preferences
You can define the following preferences for the standard IBM InfoSphere Business
Glossary Client for Eclipse.
v Define the connection to the InfoSphere Business Glossary server, such as the
host, port, user name, and password.
v Configure the refresh frequency. The IBM InfoSphere Business Glossary Client
for Eclipse plug-in creates a local cache of the glossary content that exists on the
server. You use this setting to specify how often this local cache is updated and
how.
Click Blueprint > Preferences > Business Glossary to define preferences for
InfoSphere Business Glossary.

IBM Cognos Framework Manager integration preferences
If you have IBM Cognos Framework Manager installed, you can enable the
integration and then specify where IBM Cognos Framework Manager is installed
and where the IBM Cognos project information is located.
Click Blueprint > Preferences > Cognos Integration to define preferences for IBM
Cognos Framework Manager.

IBM InfoSphere Data Architect integration preferences
You can specify the installation location of your InfoSphere Data Architect
installation, if one exists.
Click Blueprint > Preferences > IDA Integration to define preferences for
InfoSphere Data Architect.
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Loading templates
You can start a new blueprint based on a detailed template that contains a
standard blueprint.

About this task
Templates that contain standard blueprints and associated method content are
delivered as .jar files, which must be placed in the plugins folder of your
installation.

Procedure
1. Navigate to the BlueprintDirectorHome\plugins directory, where
BlueprintDirectorHome is the directory where you installed IBM InfoSphere
Blueprint Director.
2. Copy existing blueprints into this directory.
3. Start the InfoSphere Blueprint Director client.
4. Click File > Open Blueprint from the application main menu to locate a
template.
5. Select the template that you want to use as the basis for a new blueprint.

Chapter 2. Installing and configuring
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Chapter 3. Designing and implementing information blueprints
IBM InfoSphere Blueprint Director provides a highly customizable, multi-pane
client.
You can arrange the position of the various interface elements in the client, such as
moving the palette from the left to the right or from the top half of the screen to
the bottom half of the screen. The following screen capture depicts one possible
example of how to arrange the various interface elements in the client.

Palette [shown at left]
Lists a selection of blueprint elements that can be used in a project.
Diagram canvas [shown at center]
Provides a visualization area where you specify and view the blueprint. You
can have multiple diagram windows opened at the same time, such as a
diagram that represents the top-level diagram and drill down diagram views.
Method Browser pane [upper right]
Shows the method outline. The detailed method content description is shown
in the top center.
Asset Browser pane [upper right; content not shown]
Shows the list of assets from the metadata repository that you can drag onto
the canvas. You must have a license for IBM InfoSphere Metadata Workbench
and have the product installed (not necessarily on the same computer) in order
to use this feature.
Business Glossary pane [upper right; content not shown]
Shows the set of IBM InfoSphere Business Glossary terms that you can drag
© Copyright IBM Corp. 2011
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into your diagram. You must have a license for InfoSphere Business Glossary
and have the product installed (not necessarily on the same computer) in order
to use this feature.
Outline pane [lower left]
Shows a graphical representation of which part of the overall blueprint is
currently shown in the canvas.
Blueprint Navigator pane [lower left]
Shows an expandable list of all the elements that are contained in the blueprint
specification.
Properties pane [lower right]
Shows context-specific properties. For example, this pane shows the properties
of a selected element on the diagram or the properties of a selected metadata
entry in the asset browser.

Templates, methods, and best practices
You can include templates that contain recommended solution architectures,
methods, and best practices for specific solution types in IBM InfoSphere Blueprint
Director.
For example, you can see which activities are required to deploy a business
intelligence solution, which roles perform these activities, which tools they might
use, and what the recommended solution landscapes are. These templates can be
used to define new blueprints based on best practices to reduce the time to
completion of the solution . You use a tool like Rational Method Composer to
create method specifications, which you can import into InfoSphere Blueprint
Director.
Related concepts
“Defining the project and methodology” on page 5
Solution architects create a sketch that represents a reusable blueprint for a current
or future project. This blueprint can form a reference architecture for information
architecture projects. For example, solution architects can create a business
intelligence (BI) reference architecture that depicts the data sources, data
integration, data repositories, analytics, and consumers.

Creating a blueprint based on a template
You can use templates to create a blueprint that is based on a standard set best
practices. Using templates results in a blueprint that follows a standard reference
architecture and is associated with best practices to help guide team members
through the process of creating a blueprint.

About this task
When you create a blueprint, reuse a standard template whenever possible to
ensure consistency and completeness of your blueprint. Templates include method
content that is linked to topology elements. Templates are delivered as .jar files,
which must be placed in the plugins folder of your installation. For example, copy
any blueprint templates into the BlueprintDirectorHome\plugins directory, where
BlueprintDirectorHome is the directory where you installed IBM InfoSphere
Blueprint Director.
If you have used an early version of InfoSphere Blueprint Director as part of an
early release program, you might have blueprint specifications that are saved as
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*.lp_diagram or *.lp files. You can open these files by selecting the appropriate
file type when opening a blueprint file. After you open the files, you can then save
them in the current format, *.bpt.

Procedure
1. Start the IBM InfoSphere Blueprint Director client.
2. Click File > New > Blueprint from the application main menu to begin
creating a blueprint.
3. Select the Create blueprint from template radio button.
4. Select the blueprint template that you want to use as a base for your new
blueprint.
5. Click Finish to create the blueprint.

Associating method elements with blueprint palette elements
When you create a blueprint that is based on a template, you can associate method
elements with blueprint palette elements to provide contextual guidance on the
development of solution artifacts. You can also explicitly associate methodology
items from the Method Browser pane with blueprint elements.

About this task
The Method Browser visualizes a methodology in the context of a blueprint. You
use the Method Browser pane to expose key phases, capability patterns, and
activities of the method for a selected project based on a template. This view
provides you with a high-level overview and guidance for the required steps in a
particular project. When you define and manage a new project, you have access to
the corresponding method in a hierarchical view for high-level phases and
activities, plus detailed descriptions.
When you double-click a node in the Method Browser, a new window opens next
to the diagram window that contains a detailed definition of the method element
and recommended actions for that topic.

Procedure
1. From the main menu, click Window > Show View > Method Browser.

Chapter 3. Designing and implementing information blueprints
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2. In the Method Browser pane, Select the method element that you want to
associate with a blueprint element.
3. Drag the method element onto the blueprint element that you want to create an
association with on the drawing canvas.

What to do next
IBM InfoSphere Blueprint Director establishes an association between the method
element and the blueprint element. The associated method step is indicated by a
blue circle with an “m” next to the element: . When you click this blue circle,
you can view the list of available method elements.

Saving a blueprint as a template
You can define a blueprint and save it as a template for later use.

About this task
When you save a blueprint as a file, you have the option to include the current
method content (if it exists) in the template, binding not just the topology, but also
the method steps into the template.

Procedure
1. From the application main menu, click File > Save As Template.
2. Click Browse to select the blueprint that you want to use as a template.
3. Enter associated metadata for the template, such as the template name, author,
and a description of the template.
4. Click OK.

Creating a blueprint project
You can use IBM InfoSphere Blueprint Director to create a blueprint project that
starts with an empty canvas. A blueprint includes one or more information projects
that define the overall information landscape.

About this task
For example, one information project might be the creation of a new Master Data
Management system while another information project might be extensions to the
enterprise data warehouse. You can create a blueprint project that contains a
master blueprint with several sub diagrams to depict the shared relationships
across both projects.
A blueprint project is saved as a *.bpt file on any file system that is connected to
the computer that the application runs on.
When you start InfoSphere Blueprint Director for the first time, you can select a
new blueprint project that specifies the scope of your work or import an existing
blueprint project.

Procedure
1. Start the IBM InfoSphere Blueprint Director client.
2. Click File > New > Blueprint from the application main menu to begin
creating a blueprint.
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3. Select the Create empty blueprint radio button.
4. Click Finish to create the blueprint.

Adding palette elements to your blueprint
You can choose from an extensible set of palette elements when creating or
modifying a blueprint. To add palette elements to the canvas, select the element
and drag it onto the canvas.

Procedure
1. From the Palette pane, click the element group that you want to select an
element from. For example, click Data Store to select a database, content store,
or mart element.
2. Select the element from the Palette pane that you want to add to your blueprint
and drag the element onto the blueprint canvas. Position the element according
to the flow of your information landscape.
3. Click the element on the blueprint canvas and add additional metadata in the
Properties pane (lower right), such as a description of the element and who
that element is assigned to.

What to do next
Continue building your blueprint by adding elements that are part of your
information project, connecting each element appropriately to depict the flow of
information.

Groups palette elements
You use palette elements in the Groups category to represent sets of assets,
categories of elements, or projects in a diagram. These elements help you to
visualize related groups in your information blueprint.

Asset Set
You use this element to represent a set of assets. For example, you can
create a sub diagram for this element to which you can add a set of assets
such as databases or applications. One use of this element is as a top-level
diagram that represents a larger set of data sources.
Domain
You define a category of elements by using a domain on the canvas. One
use of this element is to specify architecture layers such as a data
integration layer or a business intelligence layer.
Projects
You use this element to define one or more information projects in a single
blueprint. For example, a project might represent a new enterprise
warehousing initiative and domains might represent the source,
integration, and reporting, layers within the project. The layer that includes
Chapter 3. Designing and implementing information blueprints
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integrated data repositories can be further subdivided into a Master data
management and warehousing sub domains to visualize the project at a
high level.

Operations palette elements
You use palette elements in the Operations category to represent related events,
data rules, ETL jobs, and other routines. These elements help you to visualize
complex routines in your information blueprint.

Correlation
A set of event correlation routines that match separate events into a
correlated event set that is related to business information. IBM
WebSphere® Business Events is commonly used to perform event
correlation.
CDC

Change Data Capture (CDC) is a routine that indicates that data must be
moved in real time from a set of sources to a set of targets. IBM InfoSphere
Change Data Capture is commonly used to implement CDC.

Data Rule
This routine indicates that data must be validated against some rules when
passing through this operation. IBM InfoSphere QualityStage™ is
commonly used to implement data rules.
ETL

Extract Transform Load (ETL) is a routine that describes data that must be
extracted from a set of sources, transformed, and then loaded into a set of
target systems.

Federated Query
This routine indicates that data from a set of sources can be integrated
without copying the data and then provided to a set of information
consumers. IBM InfoSphere Federation Server is commonly used to
implement federated queries.
Routine
This routine represents an abstract form of data integration and
transformation that typically contains specific forms of routines such as
ETL jobs, federated queries, or CDC.

Analytics palette elements
You use palette elements in the Analytics category to represent sets of analytics
routine in a blueprint. These elements help you to visualize routines that contain
analytical data, such as instrumented information flows, in your information
blueprint.
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Instrumentation
You use this element to represent a set of analytics routines that monitor
information flows to identify key business or technical statistics regarding
that information flow. Such instrumentation can be used to drive
intelligent information processing and analytics.
Mining
You use this element to represent a set of analytics routines that inspect
data sets when you are looking for patterns and trends that can be used to
inform a predictive or behavioral model.
Prediction
You use this element to represent a set of analytics routines that match
information flows against known patterns, often determined through
mining, in order to categorize or match information or trends
Scoring
You use this element to represent a set of analytics routines that assign
calculated values and metrics to information sets, based on defined scoring
algorithms.

Consumers and Delivery palette elements
You use palette elements in the Consumers and Delivery category to represent
elements that consume information, such as users, and elements that deliver
information, such as queries or reports. These elements help you to visualize the
flow of data in your information blueprint and what is producing it.

Application
You use this element to represent a packaged (such as SAP or Oracle) or
homegrown application that accesses or manages information.
Dimensional
You use this element to indicate dimensional data that represents measures
and dimensions for a business intelligence application.
Chapter 3. Designing and implementing information blueprints
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Information Service
You use this element to indicate that information is exposed as a service.
Message Queue
You use this element to represent a message queue between a sender and
receiver. IBM WebSphere Message Broker is often used to implement
message queues.
Query You use this element to represent a component that can perform complex
queries.
Report
You use this element to represent a business intelligence (BI) report. IBM
Cognos is often used to implement BI reports.
User

You use this element to represent a user or a group of users that require
access to certain information.

Data Store palette elements
You use palette elements in the Data Store category to represent sets of assets,
categories of elements, or projects in a diagram. These elements help you to
visualize related groups in your information blueprint.

Content Store
You use this element to represent a repository that manages unstructured
data. IBM FileNet P8 is commonly used to implement this element.
Database
You use this element to represent a database for structured data.
Mart

You use this element to represent an analytical data store, such as a star
schema.

MDM You use a Master Data Management (MDM) to represent a repository that
manages master data such as party, product, or account. IBM InfoSphere
MDM Server is often used to implement this element.
ODS

You use an Operational data store (ODS) element to represent a special
purpose database that is often deployed as part of a business intelligence
landscape.

Warehouse
You use this element to represent an analytical data store for historical
data. InfoSphere Warehouse is commonly used to implement data
warehouses.
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File palette elements
You use palette elements in the File category to represent collections of data in a
diagram. These elements help you to define an information landscape in your
information blueprint.

Buffer You use this element to represent a generic placeholder for a collection of
data that is in transit. This data might be persisted, managed in memory,
or exist as a hand off between processing elements, such as ETL jobs.
File

You use this element to represent a collection of data that is persisted in a
file.

Conceptual Model palette elements
You use palette elements in the Conceptual Model category to specify conceptual
entities in a diagram. These elements help you to articulate key data elements that
must be supported by a new repository in your information blueprint.

You can add elements for a conceptual model and connect them through the
General Link in the Connector category. Using a General Link does not imply that
an information flow exists between the connected elements, but indicates the
logical connections between conceptual elements.

Connector palette elements
You use palette elements in the Connectors category to represent the flow of
information across systems in a diagram. These elements help you to visualize an
end-to-end information landscape in your information blueprint.
Connectors do not include any advanced logic or behavior that is managed by the
node. You can optionally provide a connection with a name and a description. For
example, the connection between a routine and a file indicates that invalid records
are sent to the error file and valid records to the warehouse.
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Creating extensible palette elements
You can add custom elements to the Palette pane to represent custom tooling or
solution elements. Supplementing the palette with additional groupings, nodes, or
connectors, enhances the authenticity of your blueprints and sub diagrams. You
can define any type of palette element for your blueprint diagrams.

About this task
Use *.png or *.bmp images for icons. The small icon must be 16x16 pixels and the
large icon must be 32x32 pixels.

Procedure
1. From the application main menu, click Blueprint > Extend Palette.
2. Specify a namespace for the new element, an extension name, the element type,
and where the element is to be located in the palette. For example, you can
create an element with the following details:
Namespace: WebService
Extension/Widget Name: Web extender
Extension Type: Topology Element
Palette Container Name: Consumers and Delivery
3. Provide a link to the images that represent your element.
4. Click Next.
5. Specify additional properties that are important for your element, such as
typical characteristics or capabilities.
6. Click Finish to create your element in the palette.

Results
Your element is available in the palette. The extension information is saved in
installation_dir\launchpoint\workspace\extension_namespace_name, where
installation_dir is the directory where you installed IBM InfoSphere Blueprint
Director, and extension_namespace_name is the name of your element name. For
example, C:\IBM1\Blueprint Director\workspace.

Creating connections between blueprint elements
You can specify connections between blueprint elements to visualize the flow of
information in your information project. You must have at least two elements on
the blueprint canvas that you want to connect.

About this task
You can use the Connector palette elements, drag connections between elements, or
drag connections to an empty space on the blueprint canvas to specify the flow of
information. Using the palette is useful when you want to specify a specific type of
connection, such as a general flow or an FTP connection. Similarly, dragging
connections to an empty space on the canvas is useful when creating sub diagrams
because you can reuse elements from the existing blueprint.
If the existing element is on the same blueprint as the first element, the application
creates the connection. If the element does not exist, it is added to your blueprint
so that you can reuse elements across blueprints.
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Procedure
1. Create a connection between two elements using one of the following options.
Option
Using the palette

Procedure
1. From the Palette pane, click Connector.
2. Click the connector that you want to use,
such as General Flow.
3. Click the element where you want the
connection to originate and drag to the
element that you want to connect to.

Clicking and dragging

1. Hover over the element where you want
to create a connection.
2. Click one of the arrows and drag it to the
target or source element. One arrow
represents data that flows to the selected
element and the other arrow represents
data that flows from that element.

Reusing existing elements

1. Hover over the element where you want
to create a connection.
2. Click one of the arrows and drag it to a
blank space on the canvas.
3. Select Create Topology Connector
To/From > Existing Element
4. In the Select domain model element
window, click the element that you want
to establish a connection with.
5. Click OK.

2. Specify a name for the connection in the dialog box.
3. Press the Enter key.

Creating sub diagrams
You can create sub diagrams to further describe each element in the blueprint,
creating a layered blueprint with drill down capabilities. Developing sub diagrams
is useful to help understand the overall solution context when drilling down into a
particular area.

About this task
For example, you might want to specify major subject areas, key data elements,
and high-level relationships for a data warehouse. Sub diagrams can also be useful
for a routine or a connection. In many cases, these data flows consist of many
operations or phases that must be explicitly defined. When defining a sub diagram
for a data flow, reusing existing elements from the main blueprint is helpful to
achieve consistency across your blueprint project.

Procedure
1. In your blueprint diagram, right-click the element that you want to create a sub
diagram for and click Create Sub Diagram. A new blueprint diagram opens
where you can define the content of the sub diagram to develop another layer
of abstraction.
2. Create your sub diagram by dragging palette elements onto the canvas and
connecting them.
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3. Drag elements from the Blueprint Navigator onto the canvas to include
elements from one diagram as a reference in another diagram.
4. Save your sub diagram. After you save the sub diagram, the parent diagram
indicates the existence of a sub diagram for a particular element through a
yellow plus symbol:

.

Enhancing the arrangement of a blueprint
To improve the readability of your blueprint diagram, you can use various
sketching and diagramming features to arrange the elements.

Procedure
Arrange the elements in your blueprint diagram using these sketching and
diagramming features.
Aligning elements on the canvas simultaneously
You can align palette elements by selecting multiple elements and clicking
Diagram > Align > alignment, where alignment is the type of alignment
that you want to use. This feature is helpful when you want to
simultaneously align multiple items.
Enabling a grid and rulers
You can enable a Grid and Rulers to snap elements to the Grid and to
better align palette elements on the canvas. Click Diagram > View > Grid
or Diagram > View > Rulers to enable these features. Using a grid and
rulers are helpful when aligning your palette elements and equally
distributing these elements on the canvas.
Making multiple elements the same size
You can select multiple domain elements and make them the same size by
clicking Diagram > Make Same Size > size_type, where size_type is the
type of sizing that you want to use. This feature is helpful when you have
multiple domain elements on the canvas and want to easily resize them in
one action.

Adding notes to blueprint elements
You can select any elements on the canvas and add notes to provide additional
information to a blueprint.

Procedure
1. Right-click the element that you want to add a note for and click Add Note.
2. Type the text that you want to include in the note. You can enter manual line
breaks within a note by holding the Ctrl key and pressing the Enter key.
3. Press the Enter key to save the note on the canvas.

Managing blueprint milestones
You create and manage blueprint milestones that represent a certain time or point in
the blueprint project timeline. Use blueprint milestones to mark the beginning and
end of a blueprint project and to indicate other important points in the project.

About this task
Assign blueprint milestones to a blueprint element to define when it starts and
ends in the blueprint timeline.
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Procedure
1. Access the Manage Milestones menu.
Option

Description

Using the Timeline pane

In the Timeline pane, click Manage
Milestones.

Using the menu

Select Blueprint > Manage Milestones.

2. Add, edit, or delete a milestone.
Option

Description

Adding a milestone

1. Click Add.
2. Configure the milestone properties.
3. Click Apply to add the milestone to the
Current Milestones list.

Editing a milestone

1. Select the milestone that you want to edit.
2. Click Edit.
3. Configure the milestone properties.
4. Click Apply to apply your changes.

Deleting a milestone

1. Select the milestone you want to delete.
2. Click Delete.
3. In the Delete Milestone dialog box, click
Yes.

3. Configure the timeline order of the milestone. The order of milestones in the
Current Milestones pane determines the order of milestones in the Timeline
pane.
Option

Description

Moving a milestone up in the timeline
order

1. Select the milestone that you want to
move.
2. Click Up until you reach the desired
position.

Moving a milestone down in the timeline
order

1. Select the milestone that you want to
move.
2. Click Down until you reach the desired
position.

Assigning milestones to a blueprint element
You assign milestones to a blueprint element to define when the blueprint element
starts and ends in the blueprint timeline.

About this task
You configure blueprint milestones to visualize the evolution of the information
landscape over the course of the blueprint timeline.
Blueprint milestones can be assigned to any blueprint element.
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Procedure
1. Select any blueprint element in the diagram canvas.
2. In the Properties pane, select the Milestones tab.
a. From the Show at drop-down list, select the milestone start limit.
b. From the Hide at drop-down list, select the milestone end limit.

Viewing the blueprint timeline
You filter the blueprint timeline to view when specific milestones start and end in
the blueprint project. The milestone perspective of the blueprint project is
visualized in the diagram canvas.

Procedure
1. Select a blueprint from the diagram canvas.
2. In the Timeline pane, check the Filter blueprint by timeline check box.
3. To view a milestone perspective in the blueprint, use the slider to select a
milestone.
4. When you are finished viewing the blueprint timeline, uncheck the Filter
blueprint by timeline check box.

Results
Blueprint elements appear and disappear in the diagram canvas based upon their
assigned milestone properties.
Related concepts
“Viewing blueprints” on page 26
You can view and navigate blueprints and sub diagrams in different ways, each of
which provides you with different viewpoints of the overall blueprint.

Generating IBM Rational Team Concert tasks from method
content
You generate tasks in IBM Rational Team Concert based on IBM InfoSphere
Blueprint Director methods.

About this task
Your team can use this capability to understand the progress of the project in the
context of the tasks that are associated with each level of the project lifecycle. For
each method in your blueprint, you can choose to generate an associated work
item in IBM Rational Team Concert. You can generate a work item for each method
that you associate with a blueprint element, or when a method is not associated
with any blueprint. For example, you might associate the Develop BI Structures
capability pattern with the multidimensional model that you use to generate
reports. You can also associate this capability pattern with your reports to generate
tasks such as developing BI reports and reviewing BI structures. When you export
method content to IBM Rational Team Concert, work items are generated for both
your multidimensional model and any reports that you associated the Develop BI
Structures capability pattern with.

Method to task mapping
When you export IBM InfoSphere Blueprint Director method content, it is mapped
to the Project Area in IBM Rational Team Concert.
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Table 1. Terminology mapping between InfoSphere Blueprint Director and IBM Rational Team
Concert
Terminology in InfoSphere Blueprint
Director

Terminology in IBM Rational Team Concert

Scenario

Project Area

Phase

Epic

Capability Pattern

Story

Task

Task

Exporting tasks to IBM Rational Team Concert
You select method content that you want to export to IBM Rational Team Concert.

About this task
Generating tasks from method content ensures that your project adheres to proven
methods for project development.

Procedure
1. From the main menu, click Blueprint > Export Work Items.
2. If you have not defined a server connection, complete the following steps to
connect to your Jazz™ repository:
a. In the Export Work Items window, click Manage Server Connections.
b. In the Manage Server Connections window, click Add.
c. In the Add Server Connection window, specify a name for your connection
and select Jazz Server Connection from the Connection Type menu.

3.

4.
5.
6.
7.

d. Click Next.
e. Enter the URI, user ID, and password for your Jazz connection, then click
Validate connection.
f. After the connection has been established, click Finish.
In the Export Work Items window, select the Jazz connection, project area, and
category that you want to connect to. You must select these items in order
because each selection depends on the previous choice.
Click Next.
Expand each phase and select the methods and associated tasks that you want
to export to IBM Rational Team Concert.
Click Next.
In the Summary window, review the methods (phases, capability patterns, and
tasks) that you selected.
v To make changes, click Back and modify your choices.
v To export your choices, click Finish.
The export process can take several minutes to complete depending on the
number of methods that you selected for export.

Results
When the export process completes, you are prompted to view the generated work
items. Click Yes to view the results in IBM Rational Team Concert. You can now
assign work items to team members and interface with these work items directly
from InfoSphere Blueprint Director or by using IBM Rational Team Concert.
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Viewing blueprints
You can view and navigate blueprints and sub diagrams in different ways, each of
which provides you with different viewpoints of the overall blueprint.
Blueprint Navigator pane
The Blueprint Navigator lists all elements from the current blueprint in a
hierarchical view. You can quickly see which elements exist on diagrams
within the blueprint. These elements can be reused across multiple
diagrams.
This functionality is particularly useful when files, databases, or other
structures are reused across multiple diagrams within a single blueprint.
The hierarchical view shows all elements that are defined within the
current blueprint. The top-level shows all elements on the root diagram of
the blueprint. You can then expand elements that have a sub diagram
defined and see all elements across the full scope of the blueprint.

Outline pane
You use the Outline pane to change the section of the blueprint that is
shown on the canvas. You can drag the gray box in the Outline pane to
highlight the visible area of the overall blueprint.

Zoom You can modify the zoom of your blueprint to focus on specific areas of
the blueprint. Click Diagram > Zoom > zoom_level to change the zoom
level, where zoom_level is the level of zoom that you want to use.
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Abstraction levels
You can switch between different layers of abstraction, that is, between
your main blueprint and sub diagrams. You can open a sub diagram by
double-clicking the linked element in the main blueprint. The sub diagram
opens in a new tab so that you can easily navigate to the main blueprint.
Related tasks
“Viewing the blueprint timeline” on page 24
You filter the blueprint timeline to view when specific milestones start and end in
the blueprint project. The milestone perspective of the blueprint project is
visualized in the diagram canvas.

Search for elements in your blueprint
You can use a blueprint search or a file search to locate elements, groups, or
connectors within your blueprint.
IBM InfoSphere Blueprint Director displays all search results in a new pane in the
lower right of the application main screen.
Blueprint Search
You use the blueprint search by entering a text string to search for within
the blueprint. You access the Blueprint Search window by clicking Search
> Blueprint Search. Click Customize to modify the type of search that you
want to use.
File Search
You use the file search by entering a text string that you want to search for,
along with the file type that you want to use. Click Search > File Search to
search for a file.
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Chapter 4. Linking to related artifacts and external tools
You can link elements of a blueprint to related artifacts to leverage related tools in
the blueprint. You can link blueprint nodes to various external structures through
asset links.
The types assets that you can link to is determined by the asset linkers that are
available in your environment. Therefore, you must have the proper licenses to
leverage several of the following related tools.
In order to use the following linkers, you must have the software license for the
required tool, and the tool must be installed on the computer where you installed
IBM InfoSphere Blueprint Director.
Linker

Capability

IBM InfoSphere Business
Glossary

v

Browse glossary terms
and definitions through
the InfoSphere Business
Glossary Explorer

Required tool
InfoSphere Business Glossary
Anywhere 8.1.2 or higher

v Tag any element in the
diagram with terms as
defined in InfoSphere
Business Glossary
v Define conceptual entities
and attributes by dragging
terms from InfoSphere
Business Glossary
IBM Cognos Framework
Manager

v Associate a blueprint
element with a
corresponding business
intelligence (BI) model

IBM Cognos Framework
Manager 8.3 or higher

v Generate a skeleton BI
model for IBM Cognos
Framework Manager from
conceptual model
definition
v Open IBM Cognos
Framework Manager for
linked BI mode
IBM InfoSphere DataStage

v Associate an element in
the diagram with a
corresponding InfoSphere
DataStage job

InfoSphere DataStage 8.1 or
higher

v Open InfoSphere
DataStage to display or
edit selected jobs
IBM InfoSphere Data
Architect

v Associate an element with
a data model

InfoSphere Data Architect
7.5.x or higher

v Open InfoSphere Data
Architect to display or edit
selected data models
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Linker

Capability

Required tool

File

v Associate any element in
the diagram with any file
from your computer

N/A

v Open a default program
based on Microsoft
Windows settings for the
file extension
Metadata

v Browse the metadata
repository through the
Asset Browser

InfoSphere Metadata
Workbench 8.1.2 or higher

v Associate any element in
the diagram with
corresponding metadata
from IBM InfoSphere
Metadata Workbench
v Open InfoSphere Metadata
Workbench to display
metadata of associated
element
URL

v Associate any element in
the diagram with a URL

N/A

v Open your web browser
for the selected URL based
on Microsoft Windows
settings

External assets
You can use IBM InfoSphere Blueprint Director to establish links to various
external assets such as documents, files, and URLs.
You can connect external assets to elements in your blueprint. For example, you
might want to associate a database element with its corresponding requirement
specification that is stored locally. You would create a link to the asset, name the
asset, and select the file linker. Each linker has a specific wizard that you use to
select the corresponding artifact. When you complete the linking process, the
element on the canvas shows the associated artifact with the name that you
provided. You can then click on the element link and invoke the corresponding
application to access the artifact.
Documents
You can add an external link to provide access to Microsoft Office
documents, such as Microsoft Word documents, Microsoft Excel
spreadsheets, and Microsoft PowerPoint presentations. You can also link an
element to a particular section in a Microsoft Office document by copying
a location from an open document, such as a header in a Microsoft Word
document, and pasting that section into the Add Asset Link window. The
Add Asset Link capability creates a bookmark in your Microsoft Office
document so that InfoSphere Blueprint Director can open the linked
document at the specified location.
Files
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You can add an external link to associate any element in your blueprint
with a local or remote file that is visible to InfoSphere Blueprint Director.

When asked to open a link, Microsoft Windows uses the default
application that is assigned to the file type on your computer.
URLs

You can add an external link to associate a URL with an element on your
blueprint. The Add Asset Link capability acts as a default linker to link to
repositories that make documents and files accessible through a URL, such
as IBM Lotus Connections, Rational Asset Manager, or Microsoft
Sharepoint. Link navigation is delegated to the Microsoft Windows shell to
select the appropriate application for an asset that is linked by a URL.
Therefore, your default browser is used to open the supplied URL.

Linking to external assets
You can use IBM InfoSphere Blueprint Director to establish links to various assets
such as palette elements, artifacts, functions, and documents.

Procedure
1. Right-click on the element from which you want to add an external link to and
click Add Asset Link.
2. Provide a name for your asset link, and select the asset link type that you want
to create.
3. Click Next.
4. Click Browse to specify the path and filename of the file to link your asset to.
5. Click Finish.

Defining server connections in profiles
Some linkers connect to server-side components and require connection
information, such as the host name, port, and user credentials. You can define a set
of profiles so that you are not required to enter connection information multiple
times.

About this task
The ability to define multiple profiles and use different connections enables you to
link the elements in one blueprint to artifacts from different servers and metadata
repositories across the enterprise without consolidating metadata.
Server connections are stored as part of your blueprint and are distributed with
that blueprint. However, user credentials are not stored with the blueprint and are
not shared if you distribute a blueprint to other users. Each blueprint can have an
entirely different set of server connections.

Procedure
1. From the main menu, click Blueprint > Manage Server Connections.
2. Select the server connection type that you want to create a profile for and click
Add.
3. Provide a name for the connection and choose the connection type that you
want to establish.
4. Click Next.
5. Enter all required connection information, such as the host, port, and user
credentials.
6. Click Validate connection to test your connection.
7. If the connection is valid, click Finish.
Chapter 4. Linking to related artifacts and external tools
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IBM InfoSphere Metadata Workbench linker
You can use InfoSphere Metadata Workbench to access, navigate, and manage
metadata of information integration projects. You use this linker to associate assets
from InfoSphere Metadata Workbench with elements in your blueprint.
You must have a valid license for InfoSphere Metadata Workbench to use this
linker.
Because the linker operates through InfoSphere Metadata Workbench, you can
select any asset that is supported by that application, such as physical databases,
IBM InfoSphere DataStage assets, or IBM InfoSphere FastTrack mappings.
After you associate an element with metadata, InfoSphere Blueprint Director adds
a link next to the element to visualize the metadata link. You can click the link to
open InfoSphere Metadata Workbench to view the associated metadata.
Two options exists that you can use to associate elements in a blueprint with
metadata in InfoSphere Metadata Workbench.
Existing elements
You can associate existing metadata with an existing element. This
approach is best suited for a blueprint that was developed with free-form
sketching, such as during a brief consulting engagement without access to
underlying metadata. This approach can also be useful if your organization
has not deployed a metadata solution and is interested in an overall
solution outline. In that instance, you can use either of the following
techniques:
v Use the standard wizard-based approach to associate an element to
metadata.
v Associate an existing element with metadata by tagging the element
with a selected entry from the Asset Browser.
New elements
You can create a new element by dragging existing metadata from the
Asset Browser. This approach is best suited for metadata that is already
registered and for a team that is familiar with the existing environment. In
this instance, you can more easily create elements that are associated with
metadata.

Asset Browser
You can use the Asset Browser to query the InfoSphere metadata repositories.
When you click on an entry in the Asset Browser result list, such as a job, the asset
browser shows all of the related metadata objects. You can view more detailed
metadata information for the selected entry in the Properties pane of the Asset
Browser.
You can select an entry from the Asset Browser result list or the related item list
and drag the element from onto the canvas. If you add the entry to an empty
space on the canvas, a new element is created on the canvas and automatically
linked with the associated metadata. If you drag the selected entry onto an existing
element, the element is tagged with the associated metadata.

32

User's Guide

Associating metadata to blueprint elements
You can associate existing IBM InfoSphere Metadata Server metadata with an
existing blueprint element by using the Add Asset Link wizard.

About this task
You must define a profile for your server connection before associating metadata to
elements.

Procedure
1. Right-click on the element from which you want to add a metadata link to and
click Add Asset Link.
2. Provide a name for your asset link, and select InfoSphere Metadata Server for
the asset link type that you want to create.
3. Click Next.
4. Select the server connection profile that you want to use for the connection.
5. Click Next.
6. Select the asset type that you want to connect to and click Display Assets to
show the list of available assets.
7. Click the name of the assets that you want to connect to.
8. Click Finish.

Results
IBM InfoSphere Blueprint Director establishes a connection between the selected
element and the metadata assets that you specified.

Enabling the Asset Browser to navigate metadata
You can use the Asset Browser to query IBM InfoSphere Metadata Server
repositories.

Before you begin
You must define a profile for your server connection before using the Asset
Browser. The Asset Browser pane is not enabled by default.

Procedure
1. From the main menu, click Window > Show View > Asset Browser.
2. In the Asset Browser pane, select the server connection profile that you want
the Asset Browser to use.
3. Select the asset type that you want to connect to and click Display Assets to
show the list of available assets.
4. Click the name of the assets that you want to connect to.
5. Click Finish.

Results
The Asset Browser displays all entries in the metadata repository that meet the
criteria that you specified. For each of the “objects” in the result list, You can drill
down into each object in the results list and show the metadata assets that are
linked to that object. For example, when you expand a database object, you can see
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the schemas for that database. When you expand the schemas, you can see the
tables and columns for each schema.

IBM InfoSphere Business Glossary linker
You can use this linker to use the IBM InfoSphere Business Glossary Client for
Eclipse and the shared metadata repository that is provided by IBM InfoSphere
Foundation Tools or IBM InfoSphere Information Server.
You must have a valid license for IBM InfoSphere Business Glossary Anywhere to
use this linker.
The InfoSphere Business Glossary Client for Eclipse enables read-only navigation
of a published business glossary and provides access to business glossary
information. Two options exists that you can use to associate elements in a
blueprint with business glossary information in InfoSphere Business Glossary.
Existing elements
You can associate existing glossary terms with an existing blueprint to
classify a blueprint element with one or more glossary terms.
New elements
You can create new elements and attributes to describe the information
constructs that make up a data source, report, or other construct.

Glossary Explorer
You can use the Glossary Explorer to access glossary definitions that are managed
in the shared InfoSphere Business Glossary metadata. You can expand and collapse
categories of business terms, navigate to a particular category or term, and view
the properties of that particular term or category.
You can also search for InfoSphere Business Glossary terms and categories by
right-clicking the Glossary node in the Glossary Explorer and clicking Search.
Search results are shown in the lower right pane and contain information like the
name, short description, and context of the term or category.
You can associate terms with elements in your blueprint by dragging a term from
the Glossary Explorer onto an existing element. You can have more than one
glossary link per blueprint. Similarly, you can drag an element from the Glossary
Explorer onto your blueprint to create a conceptual entity. IBM InfoSphere
Blueprint Director automatically associates the conceptual entity with the term that
you dragged onto the blueprint canvas and uses the InfoSphere Business Glossary
term name for the name of the conceptual entity.

Connecting to your InfoSphere Business Glossary server
You can use the Glossary Explorer to retrieve content from IBM InfoSphere
Business Glossary servers.

About this task
You must define a connection to your InfoSphere Business Glossary server before
using the Glossary Explorer. The Glossary Explorer is not enabled by default.
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Procedure
1. From the main menu, click Windows > Show View > Glossary Explorer. A
blank Glossary Explorer pane opens that you can position in the application,
2. In the Glossary Explorer pane, right-click on the Glossary node and select
Preferences.
3. Specify the server and authentication information for the server that you want
to connect to.
4. In the Preferences window, expand the Business Glossary node and click
Updates.
5. Specify whether you want to automatically check for glossary updates or
manual updates.
6. Click OK.
7. In the Glossary Explorer, right-click on the Glossary node and select Update to
download the glossary content. Depending on the size of the glossary content,
this operation can take several minutes to complete.
8. Click OK when you are prompted to accept the updates.

Results
You see the glossary content in the Glossary Explorer window.

Associating glossary terms to blueprint elements
You can associate existing IBM InfoSphere Business Glossary terms with an
existing blueprint element by using the Add Asset Link wizard.

Before you begin
You must connect to your InfoSphere Business Glossary server before you can
associate glossary terms to blueprint elements.

About this task
Procedure
1. From the main menu, click Window > Show View > Glossary Explorer to
open the Glossary Explorer.
2. In the Glossary Explorer pane, select a glossary term to add to your blueprint
and drag the term onto the element that you want to establish a connection
with.

Results
IBM InfoSphere Blueprint Director establishes a connection between the selected
element and the glossary terms that you specified.

IBM InfoSphere DataStage linker
You can use this linker to associate an InfoSphere DataStage job with elements in
your blueprint.
After you associate a job with an element, IBM InfoSphere Blueprint Director adds
a link next to the element to visualize the link. You can click the link to open
InfoSphere DataStage to view the associated job.

Chapter 4. Linking to related artifacts and external tools
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You must have a valid license for InfoSphere DataStage to use this linker.

Associating jobs to blueprint elements
You can associate existing IBM InfoSphere DataStage jobs with an existing
blueprint element by using the Add Asset Link wizard.

About this task
You must define a profile for your server connection before associating metadata to
elements.

Procedure
1. Right-click on the element from which you want to add a link to a job and click
Add Asset Link.
2. Provide a name for your asset link, and select DataStage job for the link type
that you want to create.
3. Click Next.
4. Select the server connection profile that you want to use for the connection.
5. Click Next.
6. Select the asset type that you want to connect to and click Display Assets to
show the list of available assets.
7. Click the name of the assets that you want to connect to.
8. Click Finish.

Results
IBM InfoSphere Blueprint Director establishes a connection between the selected
element and the job that you specified.

IBM Cognos Framework Manager linker
You can use this linker to associate an IBM Cognos Framework Manager artifact
with elements in your blueprint. Because IBM Cognos reports are Web enabled,
you can link to elements of a sketch through the Add Asset Link tool.
You must have a valid license for IBM Cognos Framework Manager to use this
linker.

Linking to an existing IBM Cognos Framework Manager model
You can associate existing an IBM Cognos Framework Manager model with an
existing blueprint element by using the Add Asset Link wizard.

Procedure
1. Right-click on the element from which you want to add a metadata link to and
click Add Asset Link.
2. Provide a name for your asset link, and select Cognos Framework Manager
Model for the asset link type that you want to create.
3. Click Next.
4. Click Browse to select the location of the Cognos Framework Manager Model
file that you want to link to.
5. Click Finish.
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Results
IBM InfoSphere Blueprint Director establishes a connection between the selected
element and the Cognos Framework Manager Model that you specified.

Generating an IBM Cognos Framework Manager model
You can define a conceptual measure and dimension model by using IBM
InfoSphere Blueprint Director. You can then generate a model for IBM Cognos
Framework Manager to propagate a consistent definition across the entire
information landscape into specialized tools.

Before you begin
You must have an existing blueprint and sub diagram defined to generate a model
and link it to an existing blueprint element. You can use IBM InfoSphere Business
Glossary to define the conceptual entities that are associated with the sub diagram.

About this task
For example, assume that you created a blueprint element called Cubing Services
that has a sub diagram defined with a set of conceptual entities.

If you click the yellow plus icon
, you open the subdiagram for the blueprint
and use IBM InfoSphere Business Glossary to define the conceptual entities that are
associated with the sub diagram. You can then generate a model for the conceptual
sub diagram that you created and link it to your Cubing Services element.

Procedure
1. Open the sub diagram that you want to use as the basis for your model.
2. Set the Measure/Dimension Flag in the Properties pane for each conceptual
entity.
a. For each element that should be translated into a measure, set the
Measure/Dimension Flag to Measure.
b. For each element that should be translated into a dimension, set the
Measure/Dimension Flag to Dimension.
3. Right-click the element that you want to associate the model with and select
Generate > Cognos Framework Manager Generator to link the element to the
model that you created.

Results
IBM InfoSphere Blueprint Director creates a link from the Cubing Services element
to the model that you created. If you click the link, IBM Cognos Framework
Manager opens for the selected model.

Chapter 4. Linking to related artifacts and external tools
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Product accessibility
You can get information about the accessibility status of IBM products.
The IBM InfoSphere Information Server product modules and user interfaces are
not fully accessible. The installation program installs the following product
modules and components:
v IBM InfoSphere Business Glossary
v IBM InfoSphere Business Glossary Anywhere
v IBM InfoSphere DataStage
v IBM InfoSphere FastTrack
v
v
v
v

IBM
IBM
IBM
IBM

InfoSphere
InfoSphere
InfoSphere
InfoSphere

Information Analyzer
Information Services Director
Metadata Workbench
QualityStage

For information about the accessibility status of IBM products, see the IBM product
accessibility information at http://www.ibm.com/able/product_accessibility/
index.html.

Accessible documentation
Accessible documentation for InfoSphere Information Server products is provided
in an information center. The information center presents the documentation in
XHTML 1.0 format, which is viewable in most Web browsers. XHTML allows you
to set display preferences in your browser. It also allows you to use screen readers
and other assistive technologies to access the documentation.
For information about the accessibility features of the information center, see
Accessibility and keyboard shortcuts in the information center.
The documentation that is in the information center is also provided in PDF files,
which are not fully accessible.

IBM and accessibility
See the IBM Human Ability and Accessibility Center for more information about
the commitment that IBM has to accessibility.

© Copyright IBM Corp. 2011
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Accessing product documentation
Documentation is provided in a variety of locations and formats, including in help
that is opened directly from the product client interfaces, in a suite-wide
information center, and in PDF file books.
The information center is installed as a common service with IBM InfoSphere
Information Server. The information center contains help for most of the product
interfaces, as well as complete documentation for all the product modules in the
suite. You can open the information center from the installed product or from a
Web browser.

Accessing the information center
You can use the following methods to open the installed information center.
v Click the Help link in the upper right of the client interface.
Note: From IBM InfoSphere FastTrack and IBM InfoSphere Information Server
Manager, the main Help item opens a local help system. Choose Help > Open
Info Center to open the full suite information center.
v Press the F1 key. The F1 key typically opens the topic that describes the current
context of the client interface.
Note: The F1 key does not work in Web clients.
v Use a Web browser to access the installed information center even when you are
not logged in to the product. Enter the following address in a Web browser:
http://host_name:port_number/infocenter/topic/
com.ibm.swg.im.iis.productization.iisinfsv.home.doc/ic-homepage.html. The
host_name is the name of the services tier computer where the information
center is installed, and port_number is the port number for InfoSphere
Information Server. The default port number is 9080. For example, on a
Microsoft® Windows® Server computer named iisdocs2, the Web address is in
the following format: http://iisdocs2:9080/infocenter/topic/
com.ibm.swg.im.iis.productization.iisinfsv.nav.doc/dochome/
iisinfsrv_home.html.
A subset of the information center is also available on the IBM Web site and
periodically refreshed at http://publib.boulder.ibm.com/infocenter/iisinfsv/v8r5/
index.jsp.

Obtaining PDF and hardcopy documentation
v PDF file books are available through the InfoSphere Information Server software
installer and the distribution media. A subset of the PDF file books is also
available online and periodically refreshed at www.ibm.com/support/
docview.wss?rs=14&uid=swg27016910.
v You can also order IBM publications in hardcopy format online or through your
local IBM representative. To order publications online, go to the IBM
Publications Center at http://www.ibm.com/e-business/linkweb/publications/
servlet/pbi.wss.
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Providing feedback about the documentation
You can send your comments about documentation in the following ways:
v Online reader comment form: www.ibm.com/software/data/rcf/
v E-mail: comments@us.ibm.com
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Links to non-IBM Web sites
This information center may provide links or references to non-IBM Web sites and
resources.
IBM makes no representations, warranties, or other commitments whatsoever
about any non-IBM Web sites or third-party resources (including any Lenovo Web
site) that may be referenced, accessible from, or linked to any IBM site. A link to a
non-IBM Web site does not mean that IBM endorses the content or use of such
Web site or its owner. In addition, IBM is not a party to or responsible for any
transactions you may enter into with third parties, even if you learn of such parties
(or use a link to such parties) from an IBM site. Accordingly, you acknowledge and
agree that IBM is not responsible for the availability of such external sites or
resources, and is not responsible or liable for any content, services, products or
other materials on or available from those sites or resources.
When you access a non-IBM Web site, even one that may contain the IBM-logo,
please understand that it is independent from IBM, and that IBM does not control
the content on that Web site. It is up to you to take precautions to protect yourself
from viruses, worms, trojan horses, and other potentially destructive programs,
and to protect your information as you deem appropriate.

© Copyright IBM Corp. 2011
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Notices and trademarks
This information was developed for products and services offered in the U.S.A.

Notices
IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.
IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:
IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785 U.S.A.
For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:
Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan
The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.
This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
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sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:
IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA 95141-1003 U.S.A.
Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.
The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.
Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.
Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.
All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.
This information is for planning purposes only. The information herein is subject to
change before the products described become available.
This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.
COPYRIGHT LICENSE:
This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
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IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.
Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:
© (your company name) (year). Portions of this code are derived from IBM Corp.
Sample Programs. © Copyright IBM Corp. _enter the year or years_. All rights
reserved.
If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks of International Business
Machines Corp., registered in many jurisdictions worldwide. Other product and
service names might be trademarks of IBM or other companies. A current list of
IBM trademarks is available on the Web at www.ibm.com/legal/copytrade.shtml.
The following terms are trademarks or registered trademarks of other companies:
Adobe is a registered trademark of Adobe Systems Incorporated in the United
States, and/or other countries.
IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.
Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.
Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.
ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office
UNIX is a registered trademark of The Open Group in the United States and other
countries.
Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.
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Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.
The United States Postal Service owns the following trademarks: CASS, CASS
Certified, DPV, LACSLink, ZIP, ZIP + 4, ZIP Code, Post Office, Postal Service, USPS
and United States Postal Service. IBM Corporation is a non-exclusive DPV and
LACSLink licensee of the United States Postal Service.
Other company, product or service names may be trademarks or service marks of
others.
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Contacting IBM
You can contact IBM for customer support, software services, product information,
and general information. You also can provide feedback to IBM about products
and documentation.
The following table lists resources for customer support, software services, training,
and product and solutions information.
Table 2. IBM resources
Resource

Description and location

IBM Support Portal

You can customize support information by
choosing the products and the topics that
interest you at www.ibm.com/support/
entry/portal/Software/
Information_Management/
InfoSphere_Information_Server

Software services

You can find information about software, IT,
and business consulting services, on the
solutions site at www.ibm.com/
businesssolutions/

My IBM

You can manage links to IBM Web sites and
information that meet your specific technical
support needs by creating an account on the
My IBM site at www.ibm.com/account/

Training and certification

You can learn about technical training and
education services designed for individuals,
companies, and public organizations to
acquire, maintain, and optimize their IT
skills at http://www.ibm.com/software/swtraining/

IBM representatives

You can contact an IBM representative to
learn about solutions at
www.ibm.com/connect/ibm/us/en/

Providing feedback
The following table describes how to provide feedback to IBM about products and
product documentation.
Table 3. Providing feedback to IBM

© Copyright IBM Corp. 2011

Type of feedback

Action

Product feedback

You can provide general product feedback
through the Consumability Survey at
www.ibm.com/software/data/info/
consumability-survey
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Table 3. Providing feedback to IBM (continued)
Type of feedback

Action

Documentation feedback

To comment on the information center, click
the Feedback link on the top right side of
any topic in the information center. You can
also send comments about PDF file books,
the information center, or any other
documentation in the following ways:
v Online reader comment form:
www.ibm.com/software/data/rcf/
v E-mail: comments@us.ibm.com
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